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Welcome

Avenza welcomes you to map-making in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of map-making by allowing spatial data
files to be used in a vector graphics application. MAPublisher allows all cartographic tasks to be performed where
they should be done: in a powerful graphics environment.

This user guide assumes that the user is familiar with Adobe Illustrator and has at least a basic understanding of
geographic information systems (GIS) terminology and concepts. Please refer to the Adobe Illustrator user guide for
more information on using Adobe lIllustrator.

This user guide explains the installation process, licensing, and many features of MAPublisher. All MAPublisher
panels, functions and tools are thoroughly detailed together with the related concepts necessary to build map and
perform fundamental cartographic and GIS tasks. Please refer to the Avenza Projections Guide for more information
on the projections supported in MAPublisher.

As a complement to these guides, the MAPublisher software installer includes tutorial documents (MAPublisher
Tutorial Guide, MAPublisher Quick Start Guide and MAPublisher LabelPro Tutorial Guide) and associated GIS datasets.
We encourage all users to go through these guides to gain additional experience with MAPublisher tools and
functions.

MAPublisher and Adobe Illustrator together constitute an integrated cartographic design software system with
state-of-the-art graphics tools and GIS functions.
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Introduction

MAPublisher 9.6 is the newest version of a powerful suite of plug-ins for Adobe Illustrator CS6 / CC/ CC 2014 that
bridges the gap between geographic information systems (GIS) and high-end graphic design software in order
to facilitate the map creation process. MAPublisher offers additional panels, functions, tools and functions to the
powerful Adobe lllustrator design environment that enable GIS data files to be used as a base for cartographic
production destined for print or Web contents.

Working from a traditional Adobe lllustrator document, users create and edit their data organized through layers
(either new or imported with MAPublisher). Users benefit from the Adobe Illustrator graphic tools as well as
additional custom MAPublisher functions and panels to create, edit and query the map data.

MAPublisher Import and Multiple Data Import functions allow the import of major GIS and CAD formats (ArcGlS,
Maplinfo, AutoCAD, MicroStation, KLM and more) into Adobe Illustrator, while retaining their native geometry
(Point, Line, Text, Area), layer structure, geographic location and attribute data.

The cartographic workspace is managed through MAP Views that control the geospatial parameters: coordinate
system, map anchor, map scale and rotation. Layers organized under the same MAP View share the same
geographic frame of reference. A layer must reside within a MAP View to be managed by MAPublisher functions
and keep its spatial and attribute information; however layers not related to a MAP View may still be used for
presentation purposes (such as title, scale and legend). An Adobe Illustrator document may contain more than one
MAP View. For example, a map with an inset map at a larger scale to represent a zoomed-in area of interest.

The MAP Attributes panel allows for creating, editing and querying attribute information. For example, for a line layer
containing street data, each line segment may be linked to a table with information relative to the street name
and street category. Using the MAP Attributes panel, this information can be viewed, queried, edited or additional
columns of data may be appended.

MAP Themes make use of the attribute data to apply Adobe lllustrator graphic styles, symbols or character styles to
map features based on an object’s attribute values. Choose from Stylesheet, Charts, and Dot Density themes.

MAPublisher also offers many functions and tools to manage GIS data from within Adobe lllustrator:
« Import major GIS and CAD formats (MAPublisher Import and Multiple Data Import)
« Export to Geospatial PDF (Export Document to Geospatial PDF)
« Export a map to Flash with populated Web tags (MAP Web Author)
- Export layers to major GIS and CAD formats (Export MAP Layers, MAP Views panel)
- Export geographically referenced images (Export Selected Image, Export Document to Image)
« Plot a symbol by typing in its world coordinates (MAP Point Plotter)
- Georeference data (MAP Locations, Georeferencer)
- Trim the geographic extents of the map (Vector Crop, Crop to Shape)
- Join lines or points that share a same attribute value, simplify lines, create a buffer area around a line (Buffer
Art, Flip Lines, Join Areas, Join Lines, Join Points, Line Plotter, Simplify Art)
- Automatically label features based on attribute data (MAP LabelPro, Label Features and MAP Tagger Tool)
- Select features based on attributes (MAP Selections)
- Draw objects with geographic dimensions (MAP Area Tools)
- Create grids and indexes (Grids and Graticules)
- Create scale bars and north arrows (Scale Bar, Create North Arrow)
+ And much more...
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MAPublisher Features

Import and Export Data

Import data from mapping applications such as ArcGIS, MaplInfo, MicroStation, Google Earth and other sources
with all attributes and georeferencing intact. Make vector and database edits, data edits, additions and save your
changes to a variety of GIS data formats. Newly supported formats are KMZ, GML and S-57 (import only).

MAP Views

The MAP Views panel controls the Adobe lllustrator layers organization into geographically referenced entities. It
offers many ancillary tools: export to GIS format, layer lock and display control, Switch to MAP View, exchange MAP
Objects between Adobe lllustrator documents.

Several geographical references can be maintained per document (e.g. main map and inset maps), stored as MAP
Views. Each MAP View scale, transformation, position on the artboard is configured through the MAP View Editor —
with many option for display, zoom, rescale, rotation, and so on.

MAP Attributes

The attribute table holds map attribute information for line, area and point data. Add and remove columns, edit
schemas, join tables, calculate and apply expressions to customize map attributes. MAP Attributes are the base
to many other MAPublisher tools (such as line functions, MAP Themes, and MAP Web Author). They can also be
exported to text file for further usage.

MAP Themes

MAPublisher quickly and easily styles map features using Stylesheets, Charts and Dot Density themes. Specify
rules and expressions to apply preset or custom symbols, graphic styles and character styles to artwork based on
existing map attributes. Use various classification methods to easily create data classes. In addition, create highly
customizable MAP Theme Legends.

MAPublisher Panels

MAPublisher panels seamlessly integrate into the user interface and can be resized, moved, and docked just like
native Adobe lllustrator panels.

MAPublisher Toolbar

The MAPublisher Toolbar allows you to easily launch all the main MAPublisher tools with a single click.

MAPublisher LabelPro™ 2.0

MAPublisher LabelPro™ revolutionizes the way users can label map data, including using symbols as labels and

label conflict resolution with a high degree of customizable rule-based labeling options. The MAPublisher LabelPro
engine uses your map data attributes for labeling with styles, rules and controls. The interface was redesigned for and
includes more settings such as label filters and expressions.
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MAP Web Author HTML5 export

Export Adobe lllustrator documents with GIS data to interactive HTML5 web maps complete with callout bubbles,
rollovers, layer control, pan and zoom controls, and with all the underlying GIS attributes intact. HTML5 web maps
can be created without the need for browser plug-ins. HTML5 web maps are suitable for mobile use on tablets and
smartphones. MAP Web Author export settings include recommended sizes for display on mobile devices.

MAP Vector Crop Tool

Crop map documents by exact locations (including MAP Locations) and dimensions. Easily remove unwanted data
while preserving attributes and styles. Perfect for creating inset maps. Crop To Shape tool can use any shape to crop.

MAP Point Plotter Panel

MAP Point Plotter places points (e.g. locations of towns or cities) based on user input locations onto any projected
map in projected units or lat/long format (decimal degrees, or Degrees Minutes Seconds). MAP Point Plotter also
offers the option to instantly plot centroids for line or area features.

Area Plotter

The Area Plotter tool creates new rectangle or ellipse polygons on MAP Area layers by using page or world
coordinates, and by location type (using either a bounding box or by a single coordinate position). Use it to create
precise area shapes based on coordinate locations.

Geospatial PDF Import and Export

Ability to import geospatial PDF documents quickly and easily using MAPublisher. This import method can
automatically assign the content in a geospatial PDF to appropriate MAP Layers and a MAP View. Export map
data to a geospatially enabled PDF. In this process, all objects and associated MAP Attributes information (when
available) are ported to PDF, while also maintaining the map coordinate system. When a geospatial PDF is opened
with Adobe Acrobat Reader 9, one can find locations, measure distances, add location markers as well as copy
coordinates to the clipboard. Additionally, objects can be selected and queried and their MAP Attributes can be
viewed in the Adobe Acrobat Model Tree.

MAPublisher Spatial Database import

Import spatial data from Esri Personal Geodatabase (.mdb), File Geodatabase (.gdb), and ArcSDE servers. This
function requires Esri software and a valid license installed on the computer and consequently it is only available on
Windows operating systems. Supported feature types are Point, Polyline, Polygon, Circular Arc, Eliptical Arc, Bezier
Curve, Annotations (text). The MAPublisher Spatial Database import allows for SQL queries and spatial filters.

MAP Measurement Tool

The MAP Measurement Tool measures straight distances (between two points), path distances (multiple points),
azimuths, and the perimeter and area of closed paths — in page or map unit (real world distances). Furthermore,
the measuring path can be converted to a line or area in the currently selected layer.

X MAPublisher Features



MAP Selections

Build, edit and apply multiple selection criteria based on the attributes and properties contained in MAP Layers
using MAP Selections. Selection criteria are created in an expression builder and can be applied to any MAP layer,
and can be saved so they can be edited or applied later.

Geometry Operations

Join areas, lines or points and flip lines while keeping attributes intact. Use Simplify Line to reduce the number of
vertices in a point (with preview and information on the number of filtered points). Create lines based on a series
of point locations. Use Buffer Art to create buffer areas around line, area or point features. Join Areas can dissolve
multiple areas into a larger area and still retain attributes.

Labeling

Create labels for map objects using values from the MAP Attributes panel. MAPublisher provides two methods of
adding labels to your map: Label Features labels specified layers automatically; and MAP Tagger Tool labels features
individually through user selection.

Register Image

Register images accurately to your vector data. MAPublisher determines the parameters of the raster image and the
coordinate system of a selected MAP Layer in the registration process. A MAP Layer feature type called Image allows
georeferenced images to be placed accurately. In addition, Import and Multiple Data Import now supports image
formats which simplifies the process of importing them into an Adobe Illustrator document.

MAP Elements

Easily add customizable map elements such as scale bars, north arrows and map legends. Choose from preset
designs or edit an existing one.

Merge Layers

The new Merge Layers tool combines at least two MAP Layers of the same feature type into a new MAP layer based
on its attribute values. The art from the source layers can either be copied or completely moved to the new layer
(including its attributes).

Split Layer

The Split Layer function splits a layer into new layers based on an expression or by unique attribute value. The
qualifying features can either be copied or moved to a new layer, while maintaining all their attribute data.
MAPublisher Log

The MAPublisher Log records information about which MAPublisher tools were used and when they were used.
View detailed information about successful operations, warnings and errors.
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MAPublisher License Management

The MAPublisher License Management system helps users manage their licensing in a more streamlined and user-
friendly manner. Users can now evaluate the product, register, retrieve their licenses and checkout a floating license,
allin a single dialog box. Additionally, MAPublisher panels are now marked with a lock icon when the software is
not licensed.

MAPublisher Preferences

The MAPublisher Preferences allow users to fully customize their MAPublisher experience. Control everything
from the way layers are sorted to the font used to display attribute data or style of the MAP Selections panel. This
includes several previously hidden options that used to be the domain of advanced users.

Web Feature Service and Web Map Service

Two import features: Web Feature Service (WFS) and Web Map Service (WMS). Access these features through Import
or Multiple Data Import. WFS accesses web servers that deliver vector content in GML format. WMS access web
servers that deliver raster content in a variety of formats.

Create Halo

The Create Halo tool produces halo graphic styles and applies halos to features on MAP layers. Halos can be
independently created as a graphic style without having them applied or they can be directly applied to a MAP
layer without having to create a graphic style.

Scale and Rotate By Attribute

The Scale & Rotate By Attribute tool provides options to scale and rotate art objects using specified values or the
target MAP layer's attributes.

Document Operations

Text Utilities performs many text actions such as correcting upside down text, separating multiline text into single
line and cropping text path to text length. These actions can be applied to either all text layers or specific text on a
layer. Right-to-Left Text is used to apply proper formatting to right-to-left languages such as Arabic and Hebrew.

MAP Locations

The MAP Locations are used as annotation to identify map world or map page locations. These locations can then
be used in other MAPublisher functions when specifying map or page anchors and in tools such as Specify Anchors,
Area Plotter, Line Plotter and Point Plotter.

MAPublisher FME Auto

With the add-on MAPublisher FME Auto license comes the ability to import FME FFS files. Use FME Desktop tools to
translate GIS data to work with MAPublisher for a true automated workflow.

Xii | MAPublisher Features



What’s New in MAPublisher 9.6

Adobe lllustrator Creative Cloud (2015)
Fully compatible with Adobe lllustrator Creative Cloud 2015 on both Windows (32-bit and 64-bit) and Mac.

Export PDF Maps Package and Upload to PDF Maps Store

New ability to export a map package compatible with the PDF Maps app. Map publishers can upload map packages
directly to the PDF Maps Store.

Export Document to Web Tiles

Optimized for faster tile export.

Text Utilities

New text utility that curves text to lines of latitude.

MAPublisher FME Auto
Compatible with FME Desktop 2015.

And more...

A number of user interface and usability enhancements.

What's New in MAPublisher | Xiii
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System Requirements

Before installing MAPublisher, please ensure that these minimum system requirements are met (recommended
requirements are mentioned as necessary):

WINDOWS

MAC

Notes:

16

. Adobe lllustrator CS6/CC 2014/ CC 2015 (64-bit recommended)
. 1 GHz or faster (multi-core processor recommended)

. Windows 7 / 8 (compatible with 64-bit versions)

. 4 GB RAM minimum (8 GB RAM or higher recommended)

. 1 GB of available hard-disk space

- Display resolution of 1280 by 800 pixels

+  Adobe lllustrator CS6 / CC 2014/ CC 2015

»  Intel Core 2 Duo (Core i3 or higher recommended)

+ MacOS X 10.9 or higher

. 4 GB RAM minimum (8 GB RAM or higher recommended)
. 1 GB of available hard-disk space

- Display resolution of 1280 by 800 pixels

Adobe lllustrator CC and Mac OS X 10.8 are both deprecated in MAPublisher 9.6.

Windows XP/Vista and Adobe lllustrator CS5/5.1 are unsupported in MAPublisher 9.6. We recommend
upgrading to newer versions to continue receiving MAPublisher updates.

Not all foreign language versions of Adobe Illustrator may be supported. Contact support@avenza.com for
more information.

Installing MAPublisher on a system that does not meet the minimum requirements may produce unexpected
results or errors. These issues may not be supported by Avenza Technical Support.

Chapter 1: Getting Started
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Installation Instructions

MAPublisher is licensed for use on a single computer and, once activated, will be node-locked and will only function
on that computer. Therefore, before proceeding with installation and activation, please ensure that MAPublisher is
installed on the appropriate computer.

Different MAPublisher versions can be installed on the same computer if different Adobe Illustrator versions are
installed. For example, MAPublisher 7.6 for Adobe lllustrator CS2 and MAPublisher 9.6 for Adobe Illustrator CC 2015
can be installed at the same time.

It is not recommended, but different MAPublisher point releases can be installed on the same machine. For
example, MAPublisher 9.0 for Adobe lllustrator CS5 and MAPublisher 9.6 for Adobe lllustrator CC 2015. It is
recommended to uninstall older versions of MAPublisher before installing the latest release. During the uninstall
process, an option will be given to backup custom coordinates systems and MAPublisher LabelPro rules.

For users intending to use MAPublisher LabelPro, a system restart is recommended after installing MAPublisher. This
ensures that included fonts are installed correctly.

WINDOWS

«  Make sure that a compatible version of Adobe lllustrator is installed on the computer. If Adobe
Illustrator is running, exit the program.

«  DVDversion: Insert the MAPublisher 9.6 DVD. If Autorun is disabled on the system, navigate to the
MAPublisher 9.6 directory on the DVD, and double-click Setup.exe.

«  Downloaded version: Extract mp96wi-e.zip to a temporary location. When the files are unzipped, proceed to
the MAPublisher directory and double-click Setup.exe.

«  Proceed through the installation screens as instructed. Options are given to install documentation and
tutorial data. If these components are selected, the files will be installed to Users\Public\Documents\
Avenza\MAPublisher 9.6.

«  Launch Adobe lllustrator. See the MAPublisher License Management section.

MAC

«  Make sure that a compatible version of Adobe lllustrator is installed on the computer. If Adobe
Illustrator is running, exit the program.

+  DVDversion: Insert the MAPublisher 9.6 DVD. Navigate to the MAPublisher 9.6 directory on the DVD and
double-click Install MAPublisher 9.6.

»  Downloaded version: Extract mp96mi-e.dmg to a temporary location. Then proceed to the MAPublisher 9.6
folder and double-click Install MAPublisher 9.6.

+  Proceed through the installation screens as instructed. Documentation and tutorial data will be
installed to Applications\Avenza\MAPublisher 9.6\MAPublisher Tutorials . An Alias to this folder will be
created and placed on the desktop when installation completes.

«  Launch Adobe lllustrator. See the MAPublisher License Management section.

Chapter 1: Getting Started | 17
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MAPublisher Compatibility Notes

The following provides compatibility information with legacy MAPublisher and Adobe Illustrator documents,
third-party plug-ins, and other compatibility issues.

BACKWARDS COMPATIBILITY

All MAPublisher documents are not backwards compatible with previous versions of MAPublisher.

Saving an Adobe Illustrator document to a legacy format (e.g. saving a CC document as CS5) may have unexpected
results, such as loss of data attributes. It is recommended to save a copy of the file in the current Adobe lllustrator
version before attempting to save to a legacy format.

MAPUBLISHER 5 (OR EARLIER) DOCUMENTS

Point Data

MAPublisher introduced new standards on dealing with point data in MAPublisher 6. Pre-MAPublisher 6 documents
will have font based points converted to symbols on opening of the document.

MAPUBLISHER 6 (OR EARLIER) DOCUMENTS

Grids and Graticules

Please note that grids created in MAPublisher 6.x and earlier will need to be recreated with the new tool if the
generation of an index is required.

Legend to Stylesheet Conversion

Legend functionality (Assign Legend Info, Draw Legend etc) was ported into MAP Stylesheets in MAPublisher 7.
Legend information held in legacy MAPublisher documents (6.x and earlier) will be converted into stylesheets on
document open. Subsequently Graphic Styles (for line and area legends), Character Styles (for text legends) and
Symbols (for point legends) will automatically be generated and added to the respective Adobe lllustrator panels.

To qualify for legend conversion, legend art in legacy documents must contain the following properties:
- Beofavalid art type:i.e. polygon, path, symbol or text
«  Have a legend expression assigned (via Assign Legend Info or Auto Assign Legend Info)
+  Have a target MAP Layer

During the conversion process you will be asked to set additional conversion preferences:

- Determine if target MAP Layers should be immediately assigned to the applicable stylesheet. Checking
this option will immediately apply the new stylesheets to map art on target layers, whereas unchecking
this option means the new stylesheets will not be applied on document open, allowing you to manually
drag target layers into the applicable stylesheet later. Note auto assignment conversions are slower.

«  Determine if you wish to merge similar converted stylesheets (i.e. stylesheets with a matching feature
type and original map layer) into a single stylesheet. Note: option will be disabled if it is not applicable.

Tables
Table information held on table layers (i.e. MPTables layers) will be removed on document open. Therefore ensure
that all tables have been joined to the vector art prior to opening the document in MAPublisher.

18 | Chapter 1: Getting Started
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ALL MAPUBLISHER DOCUMENTS IN ADOBE ILLUSTRATOR 10 (OR EARLIER) FORMAT

Legacy Text Conversion

Adobe introduced new methods for dealing with text art in Adobe lllustrator CS. Therefore files containing
MAPublisher text objects must be converted using Adobe Illustrator and MAPublisher text conversion utilities.

If the Adobe lllustrator legacy text conversion message appears when opening a legacy document, click OK. This
will allow MAPublisher to use its own conversion utility to update text items while maintain the text attributes. If
you click Update, the document will be opened, however all attributes associated with this text will be lost.

At the MAPublisher Legacy Text Conversion dialog box, choose one of the following:

All text art

MAPublisher text art only

To convert both MAPublisher text and regular Adobe
Illustrator text to the new Adobe lllustrator text format

To convert only MAPublisher text to the new Adobe
lllustrator text format

Nothing | To open the file but lose attribute information
associated with MAPublisher text elements
Legacy Text Conversion MAPublisher Log
oot i ot ottt o v ooy, AP R il i LS ¥ [

for legacy textart.

art.

Update

@) Al textart

©) MaPublisher text art only
() Nothing

If you dedide not to convert the text at this time and instead opt to convert it manually at a later tme, be
aware that Ilustrator's legacy text conversion process does NOT preserve attributes for converted text

When Layer Message Clear
4 i minutes age! 1% Loading document
ScaleBar text  Converted & piece(s) of legacy text art,
] MPTables Dropped 1 MAP table(s).
> ScaleBar_area 5 attributes converted on 5 piecels) of art Export
Parcel Data_area 11 attributes converted on 1,006 piece(s) of art
Land Use area 8 attributes converted on 80 piece(s) of art
Boundary_area 5 attributes converted on 1 piecels) of art

Deselect All

swow: (@) (2]

COMPATIBILITY WITH THIRD-PARTY PLUG-INS

All efforts have been made to develop MAPublisher in accordance with the Adobe Illustrator SDK and third-party
development schema. However, Avenza cannot verify and validate compliance and compatibility with other

third-party plug-ins that may be installed on your system and cannot guarantee that MAPublisher will perform as

expected in such configurations. If you believe that a third-party plug-in is conflicting with MAPublisher, please

contact support@avenza.com.

COMPATIBILITY WITH ADBOE ILLUSTRATOR CC 2015 DATA RECOVERY

Adobe lllustrator CC 2015 introduced the Data Recovery feature which takes a snapshot of the working file at

specified intervals. A confirmed issue is that recovered files will have incorrect georeferencing. This issue has been

reported to Adobe for further investigation. It is not recommended to use any auto-recovered Adobe lllustrator
files. We suggest to save your working files frequently.
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MAPublisher License Management

MAPublisher will not function until it is activated. MAPublisher is available in both single-user and floating license
configurations. Floating licenses are designed to allow an organization to deploy a specific number of licenses
that can be used and shared on any number of computers over a network. If you have purchased a floating license
please refer to the floating license installation guide provided with your purchase. The instructions in this user
guide are for the activation of single-user licenses of MAPublisher only.

IMPORTANT: Some peripheral components might interfere with the activation process. Before activating
MAPublisher, users must temporarily unplug or disable: mobile phone, blue tooth, wireless or GPS systems.
Laptop users with a docking station must activate MAPublisher in the undocked state.

After installing MAPublisher, launch Adobe lllustrator. The Welcome to MAPublisher dialog box will appear. When
an Internet connection is enabled and the latest license is valid, MAPublisher will automatically activate from
information provided by Avenza license servers.

This screen also provides several licensing options: Evaluate, Register, Retrieve and Floating.

Note: To continue to use Adobe lllustrator without MAPublisher, cancel this dialog box and activate MAPublisher
license later by navigating to the Help menu in Adobe Illustrator and then to MAPublisher Licensing > License
Management. MAPublisher panels are marked with a lock icon when the software is not licensed.

Welcome to MAPublisher

B ]
i il L Close

MAPublisher° 96

for Adobe’ lllustrator

When Map Quality Matfers'
I Michae Braneati, Tara Dennis, Nicokss Di Noia, Kate Epstain Machine ID - When moving or activating
o %, MarcGraham, Dmitry Guglya, Josh Knausr, Kaitlin Kurysko, i th h the Int: t or b
© Avenza [ s s e Ve Nascls stephen ol alicense through the Internet or by
"2 Al atter 2 o Wat; A ! i
QU SYSTENS RE MichaVakubensky eter Zhing uchen Zhong & Evan Zhou e-mail, the computer's Machine ID can

be found here.

License Management

) Evaluate . Register || Retrieve | Floating
License status: Licensed from server ] Chedkin ) Evabiate | | P Register | | § Retieve | | gl Fisating Close
Checkout floating licenses automatically Feature Version Type Status License Key Log
[ Don't show again 4 MAPublisher 9.6 Floating Licensed from server| Floating

MAPublisher LabelPro 2.0 Floating Licensed from server| Floating
MAPublisher FME Aute 1.0 Floating Unlicensed

MAPublisher welcome screen

Automatically checkout license Machine ID: (0022222c1111

Use roaming license [Roaming is unavailable]

Duration of borrow: 1 day(s) -

MAPublisher License Management
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ACTIVATE AN EVALUATION VERSION OF MAPUBLISHER

1. Afterinstallation of MAPublisher, click the Evaluate button on the Welcome to MAPublisher or License Management
dialog box. Complete the form and click Evaluate.

2. When you are ready to purchase the software you can open the MAPublisher License Management dialog box
from Adobe Illustrator Help menu at MAPublisher Licensing > License Management, click Register button and
follow the instructions in the next paragraph.

Note: A MAPublisher evaluation is fully functional. There are no limitations except that an evaluation license is only
valid for 14 days from the day of activation.

REGISTER A PURCHASED COPY OF MAPUBLISHER

1. Toregister a purchased copy of MAPublisher, click the Register button in either the MAPublisher Welcome Screen
or MAPublisher License Management dialog box. Enter the license key that was provided when the product was
purchased. Complete the form and click Register.

Note: The license key for MAPublisher 9.6 starts with "MP9-".

RETRIEVE YOUR MAPUBLISHER LICENSE

To retrieve an activated MAPublisher license, click the Retrieve button in either the License Management dialog box
or Welcome Screen. The license file will be downloaded from the Avenza Systems licensing server.

CHECKOUT A FLOATING LICENSE

If you have purchased a floating license, please refer to the floating license installation guide provided with your
purchase. Once the server license is fully operational, follow these instructions to checkout a license from the client
machine (the computer running the actual MAPublisher application).

1. After installation of MAPublisher, click the Floating button of the MAPublisher Welcome Screen or MAPublisher
License Management dialog box.
2. Enter the name or IP address of the server where the license manager resides.

3. Click the Checkout button to retrieve the one of the licenses from the server.

Notes: If you wish to use Adobe Illustrator without MAPublisher, then click the Checkin button from the MAPublisher
License Management dialog box (at Help > MAPublisher Licensing > License Management). This releases the
license, so other users can use it.

The link to the server is set once. The next time Adobe Illustrator is started, just click the Checkout button on

the MAPublisher Welcome Screen or License Management dialog box.
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MAPUBLISHER LABELPRO LICENSING

MAPublisher LabelPro is an optional add-on to MAPublisher. Purchased MAPublisher LabelPro licenses are added
to the main MAPublisher license. During the registration process described earlier in this chapter, all valid licenses
will be imported. When purchasing a new MAPublisher LabelPro license on top of an existing MAPublisher license,
the existing license key will be tagged to support MAPublisher LabelPro and the new license must be retrieved (see
instructions earlier).

To evaluate MAPublisher LabelPro, open the MAPublisher License Management dialog box from the Adobe lllustrator
menu (Help > MAPublisher Licensing > MAPublisher License Management). Click the MAPublisher LabelPro branch and

then click the Evaluate button as previously explained.

Click the Log button to see more system information about the license status.

License Management

(o) Evaluate | | . Register | | || Retrieve | | 4 Floating Close
Feature Version Type Status License Key Lag
4 MAPublisher 9.6 Floating Licensed from server Fleating

MAPublisher LabelPre 2.0 Floating Licensed from server Fleating
MAPublisher FME Auto 1.0 Floating Unlicensed

The evaluation version of MAPublisher LabelPro scrambles the text of placed labels but preserves the case, spacing
and punctuation. The results give a sense of how actual labels would be placed based on the rule settings. See
chapter 17 for more details on MAP LabelPro functionality and usage.

Note: MAPublisher and MAPublisher LabelPro can only be both floating licenses or both local licenses (fixed or
evaluation). A user on a floating license wishing to evaluate MAPublisher LabelPro will have their main
MAPublisher and MAPublisher LabelPro licenses switched to a local evaluation license. At the end of the
evaluation period, the settings for floating license can be reset as described above.

MAPUBLISHER FME AUTO LICENSING

MAPublisher FME Auto is an optional add-on to MAPublisher (8.6 and newer). It is used in conjunction with

FME software to import data (see chapter 3). Purchased MAPublisher FME Auto licenses are added to the main
MAPublisher license. During the registration process described earlier in this chapter, all valid licenses will be
imported. When purchasing a new MAPublisher FME Auto license on top of an existing MAPublisher license, the
existing license key will be tagged to support MAPublisher FME Auto and the new license must be retrieved (see
instructions earlier).

To evaluate MAPublisher FME Auto, open the MAPublisher License Management dialog box from the Adobe
lllustrator menu (Help > MAPublisher Licensing > MAPublisher License Management). Click the MAPublisher FME Auto
branch and then click the Evaluate button.
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MOVE A LICENSE

To move a previously activated license to a new computer, use the following steps:

1. Uninstall MAPublisher from the current computer.

2. Install MAPublisher on the new computer.

3. Obtain the machine ID for the new computer (as found in the MAPublisher License Management dialog box

started from the Adobe Illustrator Help menu at MAPublisher Licensing > License Management.)

4. Complete the on-line form at http://www.avenza.com/support/rehost-license. For offline users, call tech support.

LICENSE TROUBLESHOOTING

If you cannot register or retrieve an evaluation or purchased license from within MAPublisher (e.g. firewall
limitations), visit the Avenza Systems website (www.avenza.com/activation) and provide the Machine ID displayed in
the License Management dialog box. A zipped license file attachment will be sent to the registered e-mail address

on record. Unzip this attachment and save the .lic file to the appropriate folder:

Windows 7/8: C:\ProgramData\Avenza\MAPublisher 9

Mac OS X: Applications/Avenza/MAPublisher 9.6/MAPublisher Plug-In

To quickly access the MAPublisher license file directory, right-click a row in the License Management dialog box and
click Browse to license folder. Copy or move MAPublisher license files directly into this location.

o) Evaluate | | /.~ Register

License Management

| Retrieve | | 4| Floating

Feature

Version Type Status

4 [MAPublisher

9.6 Floating Licensed fro

MAPublisher LabelPre 2.0 Floating Licensed fro
MAPublisher FME Aute 1.0 Floating Unlicensed

|

&
/_)
(c]
1

)

Check-in license

Check license usage

Register product...
Evaluate...

Retrieve licenses

Browse to license folder...

Durat

The bo:

ﬁ_] Chedk-in Automatically chedkout license

Use roaming license [Roaming is unavailable]

ion of borr

: 1lday(s)

owing period begins when you disconnect fr

Machine ID: |0022222¢1111

Chapter 1: Getting Started
MAPublisher License Management

23



MAPublisher Tools in Menus and Panels

MAPublisher tools can be found in a number of locations in Adobe lllustrator®.

MAPublisher Import Map Data can be MAPublisher Preferences can be
found in the File menu found in the Edit menu.

Ai [File] edit Object Type Select Effect View Window Help Al File [EE] Object Type Select Effect View Window Help

New. ctiN Undo ez
New from Template. Shift CtrleN Redo Shift-CtrleZ
Tz Siis® cu Cl+X
Open Recent Files » o e
Browse in Bridge. Al Ctt+ 0 e -
Import Mzp Data Import Paste in Front ctiisF
Close W L T U st Paste in Back Ctl+B
Save Ctriss Paste in Place Shift+CtrlsV
Save As. Shift-Ctrle. Paste on Al Artbosrds Al Shife-CarleV.
Savea Copy. AlteCries Clear

Save as Template.

Save for Web... AltwShifteCtri+S

Findl and Replace.

Find Next
Save Selected Slices, Check Spelling... Ctrl+l
Revert Fl2 Edit Custom Dictionary..

Place.. Shifts Ctrl+P Edit Colors 3
Save for Microsoft Office... Edit Original

Export.
Share on Behance. Transparency Flattener Presets.
Print Presets.

Package.. Alt+Shift-Ctrl-P pe—

Seripts > SWF Presets..

Document Setup. Al Ctrlep Perspective Grid Presets..

Document Color hode e Color Settings.. Shift+CtrleK

File Info. AltsShifteCtr| pra——

(Rt S MAPublisher Preferences

Bt cti-Q Keybosrd Shortcuts AlteShiftCtrleK
My Settings »
MLAW@AVENZA.COM ,
Preferences ,

MAPublisher tools can be found in the Object > MAPublisher menu.

Al File Edit [OBEE] Type Select Effect View Window Help [ [Elv 4G

Transform ,
Armange »
MAPublisher 3
Automation.

Group. Ctr+G Copy MAP Objects From...
gy Shift+CtieG Export Document to Geospatial PDF..
Lok K Export Document to Image.
o Export Document to Web Tiles...
Unlock All Al Ctrl+2 Export MAP Layers.
. 5 Export Selected Image..

X . . Export to PDF Maps Package.
Show All Alt+Ctri+3 e e
Cpand Upload to PDF Maps Store...

Expand Appearance my
Rasterize.. ublisher Log..
Create Gradient Mesh,

Create Object Mossic Add Calculated Data...

Area Plotter.
Flatten Transparency Find Places
Georeferencer..
S 4 Line Plotter.
Create Trim Marks
Path »|  BufferArt
Crop To Shape..
Shape " Fiplines
Pattern | Join Areas.
Blend »|  Join Lines.
Jain Paints..
Byl ' Path Uilites..
Perspective | Simpify Ar.
Live Paint (Y MR cc s 2
Image Trace »
Text Wrap , | Mergelayers.
Split Layer...
Sketch and Line Art »
Clipping Mask 0 Create Halo.
Compound Path , Dash Offset.
Artboards , | Scale & Rotate By Attibute.
Graph ,

Create Knockouts.
Label Features.,
MAP LabelPro..
Right-To-Left Test..
Text Utilties..

Create North Arrow,
Grids & Graticules.
Make Index.

Scale Bar...

* Menus reflect Adobe lllustrator Creative Cloud 2015.
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MAPublisher panels can be accessed through the Window > MAPublisher menu.
fect View (S -

New Window

Amange »
Workspace »

Extensions »

[v] control
Tools ,
Actions
Align ShifteF7
Appearance ShifteFs
Artboards
Atrbutes CueF11
Brushes F5
Color 5
Color Guide ShifteF3
S5 Propertes
Document nfo
Flattenes Preview
Gradient CuleFs
Graphic Styles ShifteFS
Image Trace
Info CuleFs
Kuler

e "
Links
Magic Wand
VaPubisher (7] e oot
Navigator MAP Attributes
Pathfinder ShifteCtrl+FO MAP Themes
Pattern Optons ] Mo views
Separations Preview MAP Point Ploter
Stroke CuleF10 MAP Selections
SVG Interactivty MAP Info
Swatches MAP Web Author
Symbols ShifteCtl+F11
Transform ShifteF
Transparency ShiftCtrl+F10

Type »

MAPublisher tools can be found in the main Adobe Illustrator Tools panel.

o

: .

WO =9D

».

Click and hold tool icon to open context
menu to choose the related tool.

.
.

o

4 MAP Area Tool (box) MAP Area Tool (ellipse)
MAP Vector MAP Vector Ellipse Crop Tool

Rectangle Crop Tool

DR ONNNE

E&MF T

e

¢

=

AP Measurement Tool

T

AP Tagger Tool MAP Contour Tagger Tool

2.

. MAP Page Location Tool MAP World Location Tool

&

o
=gl

Bé
&l

u

.

&

1P N

ﬂ
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MAPublisher Toolbar

Window > MAPublisher > MAP Toolbar

The MAPublisher Toolbar provides easy access to launch the MAPublisher tools and panels. It is compatible with the
light and dark user interface of Adobe lllustrator CS6 and CC. The MAPublisher toolbar is divided into eight sections:
Import/Export, Properties, Data Creation, Geoprocessing, Organization, Thematic Tools, Labels and Layout Tools.

Import/Expart Properties Data Creation Geoprocessing Organization Thematic Taols Labels Layout Tools

HESsEEEEs EERE B EE < Hane B4V Teoefmw @Ol Ve Eale i

The MAPublisher Toolbar can be saved in a workspace (Adobe lllustrator main menu Window > Workspace).

Register Image Export
Copy MAP Objects From PDF Maps
Multiple Data Import MAP Web Author (panel)
P P [mp-urtJFx:puth P
Import [ & (] & D E @J Lz Automation

Export MAP Layers... [ Export to PDF Maps Package...
Export Selected Image... @ Uplead to PDF Maps Store...
Export Document To Image...

Export Document To Web Tiles...

y: RUER WU

Export Documnent to Geospatial PDF...

Properties

MAP Views (panel) ——— (| . Eig |E| MAPublisher Log
MAP Attributes (panel) ;

MAP Locations (panel)

MAP Info (panel)

MAP Point Plotter (panel) Find Places
E+mun l
Plot ﬁ e @ ~— Georeference Data
2 Line Plotter. L hdd Galculated Data

] Area Plotter...
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Crop

Buffer Art
Simplify Lines Flip Lines
N ooy ||
Join .f':’ F" |_EI_|‘ @ &= (5] ——Path Utilities
B Join Areas... &) Crop To Shape...
lif': Jzin Lines... @ Vector Crop...
%.® Jain Points...
Organization
MAP Selections (panel) [] M ‘#‘-— Split Layers
Merge Layers |
Thematic Tools
MAP Themes (panel) T e &= % Dash Offset
Create Halo l l Scale & Rotate By Attribute
Labels
&
MAPLabelpro . Gl U &[0 4 & Right-to-Left Text
Label Features | | Create Knockouts
Text Utilities
Layout Tools
Gridsand Graticules . Fff A1 e [y Create North Arrow
Make Index | Scale Bar
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MAPublisher Preferences
Edit > MAPublisher Preferences (Windows)
Hlustrator > MAPublisher Preferences (Mac)

MAPublisher Preferences are options that allow users to customize MAPublisher panels and editors, including those
for layer ordering, font for attribute data display and panel style. Settings are available for the following categories:

« Expression Builder « MAP Info Panel « Online Maps

« Find Places « MAP LabelPro - Spatial Database (Basic Esri

« FME Auto (Windows only) « MAP Locations (panel) ArcSDE Server Editor, Esri

« General « MAP Measurement Geodatabase Editor and

« Import Map Data « MAP Selections (panel) General Spatial Database Editor
« MAP Attributes (panel) « MAP Themes (panel and editor) - Windows only)

« MAP Crop Tool « MAP Views (panel and editor) - Raster Georeferencing

MAPublisher Preferences are saved in an Adobe lllustrator preference file called AlPrefs (Windows) or Adobe
Illustrator Prefs (CC and Mac), which is launched each time Adobe lllustrator is started. Therefore, MAPublisher
Preferences are not file dependent. The Adobe lllustrator preference file is located in following directory:

Windows base folder: C:\Users\[user]\AppData\Roaming\Adobe
For CS6: \Adobe lllustrator CS6 Settings\AlPrefs
For CC/CC 2014: \Adobe lllustrator 17/18 Settings\[en_US]\[x64\x86]\Adobe lllustrator Prefs

Mac base folder: Users/[username]/Library/Preferences
For CS6: /Adobe lllustrator CS6 Settings/Adobe lllustrator Prefs
For CC/CC 2014: /Adobe lllustrator 17/18 Settings/ [en_US]/Adobe lllustrator Prefs

OPEN MAPUBLISHER PREFERENCES

MAPublisher Preferences can be opened from the Adobe Illlustrator main menu, Edit > MAPublisher Preferences
(Windows) or lllustrator > MAPublisher Preferences (Mac), from the panel options menu of the following MAPublisher
panels: MAP Attributes, MAP Selections, MAP Themes and MAP Views, and by double-clicking the tools buttons: MAP
Location and MAP Measurement. All preferences shown here are the default settings.

MAPUBLISHER PREFERENCES SETTINGS

Clicking one of the MAPublisher category or sub-categories on the left hand list displays the corresponding
property sheet displayed on the right.

Expression Builder Preferences

The Expression Builder property sheet shows the settings relative to the Expression Builder dialog box used with
the MAP Attributes, MAP Themes and MAP Selections panels (see chapter 5 for more information).

unique values - Set the
Expression Builder maximum number of unique
values visible in the Expression
Builder (Expression Components >

Maximum unique values: 1000 [2 Cancel

‘ > L2 General Maximum recent expressions: P

[# Import Map Data I Description).
Maximum recent expressions: - Set the maximum number The default value is 1000, users with
recent expressions displayed in the Expression Library high performance computers can
(Expression Components > Description). increase this number.
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FME Auto Preferences

The MAPublisher FME Auto preference category can be viewed in Chapter 3. Windows only.

Find Places Preferences

0 Expression Builder
= FME Auto
@, Find Places
> Lk General
Import Map Data
AP Attributes

General Preferences

MAPublisher Preferences
Find Places

Find places HTML fle:

Find places HTML file

Choose a new HTML file to specify a
different online map service. Leaving
this blank will use the default online
map service. Customization of the
HTML file is required, please contact
Avenza Support.

The General property sheet is used to change the layer ordering rule for all MAPublisher panels. By default, layers
are sorted alphabetically only. The other option is to first group layers by data type first (Legend, Text, Point, Line

and Area) and subsequently in alphabetical order for each group.

0 Expression Builder
= FME Auto
@, Find Places
[#] Import Map Data
> [E MAP Attributes
[E MAP Crop Tool
il MAP Info Panel
@ MAP LabelPro
> [F9] MAP Locations
% MAP Measurement
> [ MAP Selections
Y& MAP Tagger Tool
T MAP Themes

Log notification level - What is recorded by
the log. By default, Warnings & critical
messages is chosen. If needed, choose

MAPublisher Preferences

General
Log notification level: | Warnings & critical messages -
Locale: (®) Use system locale: English, UnitedStates

Q Language: English

Country:  United States

Locale - These options affects how
MAPublisher formats numbers

(i.e. use comma or point as decimal
separator). Use the operating system
local settings or specify a different
language and country.

and

Format numbers for display purposes and other operations based on locale
heck for MAPLbiisher updates
‘Add notes for lagers created by MAPublisher operations

Sorting style: Type, then name -

Preview quality: Medim -

Add notes for layers created by MAPublisher
operations - Enable to automatically create
layer notes for MAPublisher operations

No notification or Critical messages only.

General > Transformation and General > Units

0 Expression Builder ~
= FME Auto
@, Find Places
4 b General
¢ Units
[#] import Map Data
> [E MAP Attributes

0 Expression Builder ~
= FME Auto
@, Find Places
& General
% Transformation
¢ Units
[#] Import Map Data
b MAP Attributes
[ maP Crop Tool
[ MAP Info Panel
& MAP LabelPro
> [Fs] MAP Locations
@ MAP Measurement
> [ MAP Selections
@ MAP Tagger Tool
T MAP Themes

N

MAPublisher Preferences

L

Preview quality - Adjust the
preview quality within various
MAPublisher dialog boxes

Format for labeling op
display purposes based on locale
Change number labels based on
country (e.g. 400.00 in USA compared
t0 400,00 in Norway)

Sorting style - Set to Name, then type
for an alphabetical sorting. Set to
Type, then name to first sort the layers
per data type (Legend, Text, Point,
Line or Area)

in point size/stroke weight/

General > Transformation =
Maintain point size when rescaling Cancel
lintain stroke weight when rescaling
Maintain text size when rescaling
[ Maintain point rotation when rotating
[ Maintain point text rotation when rotating
MAPublisher Preferences

General > Units
Pinned map units: [ 1/10Foot ~ || cancel

[ 1/10 US Survey Foot

[] ArcMinute

[] ArcSecond

[] Benoit's Chain

] Benoit's Link

[ Bin width 12.5 Meter

[ Bin width 165 US Survey Foot
[ Bin width 25 Meter

[ Bin width 3.125 Meter

[] Bin width 330 US Survey Foot

Max recent map units: 512

Page units: Pixels (px) M

.
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rotation/text size when rescaling/
rotating - Scale changes (made in
the MAP View Editor) that affect
stroke, point and text sizes and
rotation.

Pinned map units - The selected
map units are listed first in
the unit drop-down lists of
MAPublisher (e.g. in Scale Bar
or Buffer Lines dialog boxes)

Max recent map units - Maximum
number of map units
memorized by MAPublisher

— Page units - Choose how page

units are displayed: pixels,
points, inches, centimeters,
millimeters, picas or use
document units.
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Import Map Data Preferences

The Import Map Data preference category allows users to sort the order of the attributes columns upon import.
By default, attributes are imported in the same order as in the source GIS data file and the MAPublisher #Property
attributes are created in front of the imported attributes (see chapter 5 for additional information).

M. Pr

Import Map Data

Cancel

oo Expression Builder
= FME Auto
©o Find Places
b 48 General
] import Map Data
» [E MAP Attributes
[l MAP Crop Tool
[ MAP Info Panel
& MAP LabelPro
> [F#] MAP Locations
< MAP Measurement

|

Attribute sort on import: Da not sort

Path comers: Round Join

L

Path endings Round cap

Property disposition on import:  Move properties to start
] Show full filename in Multiple Data Import data list

[] show extents in Multile Data Import data st

Append feature type as suffix on imported layer names

sort on import - Set to Do not
Sort to maintain the attributes order
of the source GIS file. Set to Order
attributes alphabetically to apply this
new ordering.

Path corners - Set to Miter, Round or
Bevel join

Path endings - Set to Butt, Round or
Projecting cap

Property disg onimport - Set to

AP Selections
] MAP Tagger Tool
T MAP Themes
> @ MAP Views
@ Online Maps
O Raster Georeferencing
» [ Spatial Database

nsure imported layer names are unique

how extensions in Format drop-down list

Import Geospatial POFs

Show full file name in Multiple Show extents in Multiple Import ial PDFs  Show in Format drop-down list
Data Import data list Data Import data list Check this option By default, the Format drop-down
The Multiple Data Import Check this option enable the ability to listin the Import and Multiple Data
data list shows the list of to display the data import geospatial  Import dialog boxes shows the

extents (lower left and PDF documents
upper right corners

coordinates)

format extensions (e.g. [*.shp]).
Clear this check box not to display
format extensions.

selected files for import. By
default, only the file name is
displayed. Check this option
to display the full path.

MAP Attributes Preferences

Pre nces

Move properties to start or Move
properties to end

Append feature type as suffix on imported
layer names - By default, the feature
type is appended to the layer name
(e.g."_area' or'_point'). Clear this
check box to prevent this behaviour.
Ensure imported layer names are unique
By default, MAPublisher appends
anumber 1, 2 etc... to an imported
layer name if the layer name already
exists. Clear this check box to
prevent this behaviour.

MAP Attributes

Cancel

0 Expression Builder
= FMEAuto
§, Find Places
b L General
[# Import Map Data
b MAP Attributes
[E MAP Crop Tool
[El MAP Info Panel

[] Replicate attribute data to compound path sub-components

Default string size: 5%

[ count: HE

Default decimal count - Specify the default
number of decimals applied when
creating a new attribute of type Real

Default string size - Specify the default
string size applied when creating a
new attribute of type String

MAP Attributes > Panel

MAPublisher Preferences

fio Expression Builder MAP Attributes > Panel

= FME Auto

: (@ Use default font
@, Find Places RS
> L General ) |5 shellDig 2
B import Map Date Table font size: | Defaut 1= =

4 [ MAP Attributes

Show icons in column headers

Show display names in column headers
L1 show recor
[] 5ort string attributes using Natural Comparison,

[ MAP Crop Tool

[ MAP Info Panel

& MAP LabelPro
> % MAP | ncations

Show recordset navigation - Enable this optionto  Sort string attributes using Natural

show navigation buttons in the MAP Attributes Comparison - Enable this option use an
panel as well as any Tear-off panels. Use them  alphanumerical sort which is more
to scroll through attribute records. natural to humans.

Show display names in column headers
Enable this option to show the
display name of a column header
instead of the actual column name
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p datato d path
sub-components - Enable this option
before editing the attribute schema
so that the attributes do not get
broken when releasing a compound
path (see chapter 5)

Table font - Set the text font for
headers and attribute values

Table font size - Set the text font size
Show icons in column headers - Enable
this option to display the data type in
front of the attribute column name:
IE Boolean, [12] Integer, Double,
[ String, and IE‘ Image



MAP Crop Tool Preferences

The MAP Crop Tool preference category contains point text and path text crop type and crop method settings.

o Expression Builder
= FME Auto
@, Find Places
> L% General
[#] Impert Map Data
> [ MAP Attributes

B MAP Info Panel
& MAP LabelPro
> [Fol MAP Locations
@ MAP Messurement
> i MAP Selections
@ MAP Tagger Tool
T MAP Themes
> @ MAP Views
(@ Online Maps
% Raster Georeferencing
» [ Spatial Database

MAP Crop Tool
Point Text:
©) Vectorize and crop

(® Crop textbased on:

) Origin of first character

MAPublisher Preferences

Points:
[ vectorze and crop

Cropping Boundary:

Accuracy for bezier cropping boundaries:

[ MAP Crop Tool

() Text bounds

T More accurate

O Vectorize and crop

O Croppath only
(@) Crop textbased on:

®) Origin of first character
() Text bounds

[ crop path

Reset Do not show sgain preferences

Note: Attrbutes and fezture type support wil be lost when vectorizing points or text.

Cancel

Less accurate

Point Text - Choose how
point text is handled
when intersected by a
crop boundary

Points - Choose how points are

handled when intersected by
a crop boundary

Path Text - Choose how

point text is handled

when intersected by a

crop boundary

Cropping Boundary - Adjust
accuracy for vectorizing a
bezier path when intersected
by a crop boundary

Note: For Spatial Database spatial filter (crop on import option), there will be no point vectorizing and text will be

cropped based on whether its bounding box touches the crop area.

MAP Info Panel

The MAP Info panel preference category contains general settings (see chapter 4).

fo Expression Builder
= FME Auto
@, Find Places

b 4 General
[# Import Map Data

> [E MAP Attributes
[ MAP Crop Tool
Y I
& MAP LabelPro

» ol MAP Locations
@ MAP Measurement

v 1 MAP Selections
] MAP Tagger Tool

T MAP Themes

MAPublisher Preferences

MAP Info Panel

LatfLong display format: |Decimal degrees (D+[.d*])

Display precision: 35

Cancel

Lat/Long display format- Set the latitude

and longitude display format:

« Decimal degrees

« Delimited Degrees Minutes Seconds
« DegreesMinutes

+ Degrees.MinutesSeconds

« Packed DMS with decimal point

« Packed DMS

Display precision - Set the number of

decimals shown on the MAP Info panel
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MAP LabelPro Preferences

The MAP LabelPro preference category contains general settings to save the path access to saved rules, styles and

symbol folders (see chapter 17 for more information on MAP LabelPro).

MAPublisher Preferences

MAP LabelPro

o Expression Builder
=, FME Auto
o Base rule folder: : D: X
§, Find Pioces ase rule folder: cip 9.4\
+ L Genersl Base style folder: C:\ProgramD: 5.4
[ Import Map Data Symbol folder Ci\Program Fles\AvenzaWaPublsher .4 abelPro\symbals\

» [E MAP Attributes

MAP Crop Tool Placement warning threshold: 50% &
Bl MAP info Panel Ionore invisble artwork
MAP LabelPro
] M tiline text
> o] MAP Locations S
€ MAP Messurement Leader line cap style: Rounded ~

> @ MAP Selections

] MAP Tagger Tool

T MAP Themes
@ MAP Views

@ Online Maps

¥, Raster Georeferencing
» | Spatial Database

Ignore invisible artwork - This option
ignores individual invisible artwork. If
disabled, individual invisible artwork
will be taken into account as labeling
source and obstacle.

Merge multiline text
Merges multiple
lines of text into a
single line

Leader line cap style
Change the leader
line cap style for
enabled lines

Reset Do not show again preferences

Note: The default directories for the rule, style and symbol folders:

Base rule folder - Directory path to the
rule folder. Click the browse button
to change the path.

&~ Base style folder - Directory path to the

L— Symbol folder - Directory path to the

style folder. Click the browse button
to change the path.

symbol folder. Click the browse
button to change the path.

- Default rules and styles folders—respectively Rules and Styles subfolders in the directory:

Windows 7/8: C:\ProgramData\Avenza\MAPublisher 9\LabelPro\

Mac OS X: Applications/Avenza/MAPublisher 9.6/MAPublisher Plug-In/LabelPro/

- Default symbol folder:

Windows 7/8: C:\Program Files\Avenza\MAPublisher 9\LabelPro\Symbols

Mac OS X: Applications/Avenza/MAPublisher 9.6/MAPublisher Plug-In/LabelPro/Symbols

MAP Locations Preferences

The MAP Locations preference to control MAP Location labels, lat/long format and precision.

MAP Locations Preferences

MAPublisher Preferences

Default colours - Change the default

#¢9 Expression Builder MAP Locations

= FME Auto

o Default MAP World Locatien colour:

§, Find Places ]
> i General Default MAP Page Location colour: I

[# import Map Data

MAP Lacation label size: smal -

Cancel

colours of MAP Page and MAP World
Locations

MAP Location label size - Control label
|— size for each MAP Location

3 MAP Attributes

MAP Location label policy - Control how

MAP Crop Tool
[El MAP Info Panel

MAP Location label policy: Show when tool cursor is nearby v

Auto-show label proximity: spx[E

the labels appear or disappear

T MAP LabelPro

> [["9 MAP Locations
< MAP Measurement
» T MAP Selections

MAP Locations > Clipboard MAP Locations > Panel

LI TG e R T MAP Locations > Panel
Alternate dinate:  Geodetic b: -
T cooranate: St Lat/Long display format: | Decmal degrees (0+[.d%])
Lat/long format: | Decimal degrees (D+[.d*]) e
- Predision: 4=
Presson: e

Use locale setting to format copied values.
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Auto-show label proximity - Control how
close the mouse cursor has to be
before a label appears



MAP Measurement Preferences

The MAP Measurement category contains display settings for the MAP Measurement Tool (see chapter 7 for details).

[#] import Map Data

fiu Expression Builder MAP Measurement
= MEAuto Units: Use current layer's units
©, Find Places

¥ L General Calauiation method: | Geodesic

Cancel

Units - Choose to use the current
layer's units or select a specific unit in
the drop-down list

— C ion Method - Choose to calculate

distance based on datum (geodesic)

Display precision: 6=
> [E MAP Attributes
(3 MAP Crop Tool Line colour: [ ]
Bl MAP info Pand New e colour: =0

& MAP LabelPro
» [4] M4P Locations
[ MAP Measurement
> 1@ MAP Selections
] MAP Tagger Tool
T MAP Themes

—® ] Show azimuths

Positive angle direction: | Counter-dockwise

Show azimuths - Display forward
and reverse azimuth when using
the MAP Measurement tool

MAP Selections Preferences

Positive angle direction - Set the
positive angle direction as either
counter-clockwise or clockwise

or map projection (Cartesian)
Display precision - Set the number
of decimals shown on the MAP
Measurement annotations

Line colour - Set the color of the
digitized measurement path

New line colour - Set the color of
the current segment (between
last digitized point and current
mouse position)

The MAP Selections preference category does not contain general settings but has a sub-category for the MAP
Selections panel (see chapter 11 for a full description of the MAP Selections panel).

MAPublisher Preferences

0 Expression Builder ~ | MAP Selections > Panel

= FMEAuto

§ Find Places
b ¢ General

[# Import Map Data

Show selections on two lines

Cancel

Show selections on two lines - Enable

> [ MAP Attributes
[ MAP Crop Tool
Il MAP Info Panel
% MAP LabelPro
> [P MAP Locations
& MAP Measurement
4 {@ MAP Selections

T MAP Tanaer Tonl

MAP Tagger Tool Preferences

this option to display the selection
filter name and its expression on two
separate lines.

The MAP Tagger Tool preference contains general setting for leader lines (see chapter 10).

MAPublisher Preferences

0 Expression Builder MAP Tagger Tool
= FME Auto
o Find Places
> L} General
[# Impert Map Data
> [E MAP Attributes
[E MAP Crop Tool
B MAP Info Panel
B8 MAP LabelPro
> [F9] MAP Locations
< MAP Measurement
> (£ MAP Selections

] MAP Tagger Tool

T MAP Themes

Leader lne attaches: |Side of text

Cancel

Leader line attaches - Choose how the

leader line attaches to the label: side
of text or center of text

Note: The Center of text setting does not work when labels are curved with lines of latitude.
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MAP Themes Preferences

The MAP Themes preference sets maximum features to use and maximum data classes (see chapter 9).

o0 Expression Builder
= FMEAute
o Find Places
> L} General
[# Impert Map Data
> [E MAP Attributes
(= MAP Crop Tool
B MAP Info Panel
B8 MAP LabelPro
> [F9] MAP Locations
< MAP Measurement
> [ MAP Selections
@ MAP Tagger Tool
T_MAP Themes
> @ MAP Views

features to use in Rule Generator
This option specifies the maximum
number of unique values that can be
generated by the Rule Generator

MAP Views Preferences

MAP Views > Editor

= FME Auto ~
o Find Places
> 4 General
[#] Import Map Dsta
> [ MAP Attributes
[E MAP Crop Tool
[l MAP Info Panel
@ MAP LabelPro
> [F4] MAP Locations
- MAP Measurement
> & MAP Selections
6 MAP Tagger Tool
T MAP Themes
s @ MAP Views
(@ Online Maps
% Raster Georeferencing

data dasses

This option specifies the maximum
number of data classes when that
can be used with the Rule Generator

Start centered on - By default, the
current artboard is centered in the
preview area of the MAP Views dialog
box. Change the option to have it
centered on the current MAP View.

Online Maps Preferences

0 Expression Builder
= FME Auto

AP Themes
Maximum features to use in Rule Generator: 000 '+ Cancel
Maximum data dasses: 1000 &
1
The MAP Views preference for the MAP Views editor (see chapter 4).
u o
MAP Views > Editor
Start centered on: | Current artboard Cancel
[] Show Latitude /Longitude ordering option
MAPublisher Preferences
Ontns Hoge
Online maps are used in Georeferencer and in MAP Locations. Cancel
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@, Find Places
> L General
[#] Import Map Data
> [E MAP Attributes
(3 MAP Crop Tool
Bl MAP Info Panel
G MAP LabelPro
> [F4] MAP Locations
@ MAP Measurement
¢ & MAP Selections
] MAP Tagger Tool
T MAP Themes
> @ MAP Views
(@ Online Maps
“ Raster Georeferencing
> [ Spatial Database

Oriine map HTM. file:
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Show Latitude/Longitude ordering option
Enable this option to show the
Latitude/Longitude ordering
drop-down menu in the MAP Views
dialog box. This effectively swaps the
order of how latitude and longitude
values are shown.

Online map HTML file

Choose a new HTML file to specify a
different online map service. Leaving
this blank will use the default online
map service

Customization of the HTML file is
required. Please contact Avenza
Support for more information



Spatial Database Preferences

For Windows only. The MAPublisher Spatial Database preference category does not contain general settings but has
three sub-categories: Basic Esri ArcSDE Server Editor, Esri Geodatabase Editor and General Spatial Database Editor (see
chapter 3 for a full description of the MAPublisher Spatial Database).

Spatial Database > Esri Geodatabase Editor

MAPublisher Preferences

> 4% General
[#] Import Map Data
» [ MAP Attributes
[ MAP Crop Tool
[l MAP Info Panel
T MAP LabelPro
> [F#] MAP Locations
% MAP Measurement
> H MAP Selections
@ MAP Tagger Tool
T MAP Themes
b @ MAP Views
@ Online Maps
¥ Raster Georeferencing
4 () Spatial Database
[ Basic Esri ArcSDE Server Editor

[-] General Spatial Database Editor

9 Find Places | spatial Database > Esri Geodatabase Editor

Use alias as layer name - Enable this
option to use feature class' alias

Use alias as layer name

[] Use abbreviated table name for layer name
Display eoded domain/subtype description: Instead
1] Load subtypes as separate ayers

[] sort feature datasets alphabetically when selecting for import

—® | Sort feature dasses alphabetically when selecting for impart

[ Sort attributes alphabetically when selecting for import

[ Automatically connect to:

Load subtypes as separate layers —
Enable this option to use
create new layers per subtype

Sort feature datasets alphabetically —
when selecting forimport - Enable
this option to sort feature

+— Sort attributes alphabetically when selecting for
import - Check this option to sort attributes
alphabetically in the import dialog boxes

+— Sort feature dasses alphabetically when
selecting for import - Enable this option
to sort feature classes alphabetically

Number of points to use to specify  spatisl fiter bounding box: |Twa (opposite comers)

name rather than its true name
Cancel
Use iated table name for layer name
- ArcSDE geodatabases' tables

are identified as databaseName.
userName.tableName. The
abbreviated version uses only the
table name as layer name.

If this option is used in combination
with the "use alias" option, the alias is
applied first.

Display coded domain/subtype description
Option to import attributes with
coded values from subtypes and
attribute domains as follow:

Number of points to use to specify a spatial filter
bounding box - Choose either two opposite
corner points or four sequential points

« Instead: replace the codes by their
description (text)

« Never:import actual values—codes

« In Addition: create two attribute
columns, one with coded values
and one with descriptions

datasets alphabetically in the in the import dialog boxes

import dialog boxes

— Automatically connect to - Check this
option to automatically connect to a
specific server connection, selected
in the drop-down list

Spatial Database > Basic Esri ArcSDE Server Editor

Spatial Database > Basic Esri ArcSDE Server Editor

..&————— ArcGIS Bin directory - Specify the
location where the ArcGIS Bin
directory is installed. Click the Browse
button to open a folder browser and
change the path.

ically connect to - Check this
option to automatically connect to a
specific server connection, selected
in the drop-down list

ArcGIS Bin directory: |t Program Fles\ArcGIStBin|

[] Automatically connect to:

Spatial Database > General Spatial Database Editor

‘Spatial Database > General Spatial Database Editor

Number of SQL queries to remember: 5

Number of default datasets to remember: 30

F

Number of SQL queries to remember
Select the number of queries
memorized in the Recent category

Number of default datasets to remember
Select the number of default datasets
saved in memory for later use
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Raster Georeferencing Preferences

The Raster Georeferencing preference category sets the default external reference format as well as override
options when opening a raster.

MAPublisher Preferences

F¥0 Expression Builder Raster Georeferencing
Find Pl
® i Defauit extemal reference format: [ Workd = Default external reference format
[# Import Map Data Open/New: use internal format f available Choose a default external
> [ MaP Attriutes reference format that MAPublisher
[E MAP Crop Teol il F ts include: Bl
£ MAP Info Panel will use. Formats include: Blue
&% MAP LabelPro Marble Reference, ERS, MapInfo
> [F4] MAP Locations TAB, and World.

S MAP Measurement
> [@ MAP Selections

T MAP Tagger Tool Open/New: use internal format if available

T MAP Themes This option overrides the chosen default
> @ MAP Views external reference format when any
(@ Online Maps . .
B = internal reference is detected
g aster Gemefevencmé

» [ Spatial Database

Reset Do not show again preferences

RESET MAPUBLISHER PREFERENCES TO DEFAULT SETTINGS

MAPublisher Preferences can be reset directly from the MAPublisher Preferences dialog box. Right-click a category to
display the choice to reset the preference setting of the category or the entire MAPublisher Preferences.

%, Reset 'MAP Views' and sub-preferences

“%,  Reset all preferences

MAPublisher Preferences will also be reset if the Adobe lllustrator preferences are reset or deleted. Adobe often
recommends this to solve some problems with the application. Adobe lllustrator preferences are reset by doing one
of the following:
«  Press and hold Alt+Control+Shift (Windows) or Option+Command-+Shift (Mac) as Adobe lllustrator is starting.
The current settings are deleted.

«  Remove or rename the AlPrefs file (Windows) or Adobe lllustrator Prefs file (Mac). New preferences files
are created the next time Adobe Illustrator is restarted.
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MAPublisher Log

MAPublisher Log —— Zoom to/Clear Selection/Add To Selection/
I Remove From Selection - Controls to
H 2] [ view art objects and layers
When Layer Message Clear
({7 seconds ago | @ Layer Transformation
17 seconds ago w2 Writing out transformed features to art Desclect Al
. CityBoundary_area 1 Layer transformed.
Log items - Messages about used 1 layeris) were transformed from 'CityBoun| | Export e——— Export- Export the list to a text file
MAPublisher tools are |°gged 4 26 seconds ago ¢ Autornated Map Theme application
here. Scroll to the right to view Mone of the imported MAP layers were affe]
details about each tool. 4 26 seconds ago Simple Import
39 seconds ago 1 Reading data from 'CityBoundary’
26 seconds ago 2 Creating lllustrator artwork
4 1 minute ago reate Grid Collection
EH Scale_bar_legend A grid collection was created.
17 minutes ago % Loading document
Show information/warning/citical < i
messages - Toggle the filters to e Show:
show different message types

FUNCTIONALITY

The MAPublisher Log records information about which MAPublisher tools are used, when they were used, and on
which MAP layers.

USING MAPUBLISHER LOG

To view the MAPublisher Log dialog box, click the MAPublisher Log button on the MAPublisher Toolbar or click
Object > MAPublisher > MAPublisher Log.

When a MAPublisher tool is used, information such as the tool used, inputs, outputs, warnings and errors are
recorded into the log. The log also displays when tools were executed and which layers were involved. However,
not all MAPublisher tools are recorded as a log entry (such as MAP Tagger Tool, MAP Locations, MAP Selections,
and MAP Web Author). Certain MAPublisher tools may yield warning messages after completing a process (e.g.
MAPublisher LabelPro).

Use the Show toggles to filter information, warning and critical messages.
Click the Export button to export the entire log to a text file.

A maximum of 10,000 messages can be logged. Click the Clear button to remove all messages from the log. This is
permanent and cannot be undone.
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Preparing the Workspace

Before using MAPublisher, you must first set up your Adobe lllustrator document. It is at this point that you define
your page size and units, set your print orientation and generally prepare your Adobe lllustrator workspace.

Establish the desired page size and orientation before importing map data as MAPublisher will establish
georeferencing based on the current page. However editing page dimensions after import will maintain correct
georeferencing based on the new page dimensions.

Note: If no document is open, click MAPublisher Import or Multiple Data Import to initiate the New Document
dialog box.

SETTING UP A DOCUMENT

1. Create a new Adobe lllustrator document by selecting File > New, or Select File > Document Setup if you already
have a blank document open - The Adobe lllustrator Document Setup dialog box appears.

2. Select the size to use for your page. Letter (8.5"x 11”) is the default size*. You may wish to change the
orientation to landscape for some files. For example, a map of Chile may be best displayed in portrait but a
map of Indonesia may be best displayed in landscape.

Select your desired page units. The default unit type is Points.

4. Ensure the page origin is at 0,0. To do this, select View > Show Rulers. Double-click the top left corner of the
rulers where the vertical and horizontal rulers intersect.

For more information and details regarding these operations please refer to your Adobe lllustrator User Guide.

*In step 2 the default page size of 8.5” x 11”is for North American versions of Adobe lllustrator. Other language versions
of Adobe lllustrator may have different default page sizes. Consult your Adobe lllustrator User Guide for more information.

Notes: Note that the maximum length and width dimension for an Adobe lllustrator document is 227.54 inches.
The Duplicate Artboard function should be used with caution because it also duplicates art and moves it on

the page. However, the duplicated art reference is the same geographic frame as the original art (they are
contained in the same layer). Therefore the geographic position of the duplicated art will not be correct.
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Map Data File
Formats

MAPublisher imports and exports many of the leading GIS
industry file formats.

Import Formats

Adobe Geospatial PDF (pdf)

AutoCAD Drawing/Exchange (dxf, dwg)
Delimited XY Text Data (csv, tsv, txt)

Digital Line Graph (opt, dlg)

Esri ArcInfo Generate (gen)

Esri Interchange File (e00)

Esri Shapefile (shp)

Esri ArcMap Document (mxd)

FME Feature Store (ffs)

Geography Markup Language (gml, xml)
GPS Exchange Format (gpx)

Google Earth (kml, kmz)

Image (multiple formats)

International Hydographic Office S-57 (000)
Maplinfo Interchange Format (mif)

Maplnfo Table (tab)

MicroStation Design (dgn)

Microsoft Excel (xls)

Spatial Data Transfer Standard (SDTS) (catd.ddf)
TIGER/Line (rt1, r*1, bw1)

Web Feature Service

Web Map Service

Basic Esri ArcSDE Server

Basic Personal Geodatabase Reader (mdb)
Esri ArcSDE Geodatabase

Esri Basic Personal (mdb) and Basic File (gdb) Database Reader
Esri File Geodatabase (gdb)

Esri Personal Geodatabase (mdb)

Export Formats

Adobe Geospatial PDF (pdf)

AutoCAD Drawing/Exchange (dxf, dwg)
Delimited XY Text Data (csv, tsv, txt)

Esri Interchange File (e00)

Esri ArcInfo Generate (gen)

Esri Shapefile (shp)

Geography Markup Language (gml, xml)
Google Earth (kml, kmz)

Maplinfo Interchange Format (mif)
Maplnfo Table (tab)

Microsoft Excel (xls)

MicroStation Design (dgn)
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Import and Export Supported Data Formats

This section provides an overview of the supported formats. For an in-depth analysis of further considerations when
using these formats during Import, please see appendix AT.

DATA FORMAT DESCRIPTIONS

Adobe Geospatial Portable Document Format (pdf)

Import and Export

The geospatial PDF is considered an Adobe Acrobat Portable Document Format (following the PDF 1.7 specification)
that contains information that is required to georeference location data. It is an open specification developed and
maintained by Adobe Systems. See detailed specifications in Section 8.3 at http.//www.adobe.com/devnet/acrobat/
pdfs/PDF32000_2008.pdf.

AutoCAD Drawing (dwg) and Drawing Exchange (dxf)

Import and Export

These file types are most commonly created by Autodesk AutoCAD product, though other computer-aided design
(CAD) programs such as Bentley MicroStation capable of creating them. Two formats are used by AutoCAD: DXF
(drawing exchange format) files and ASCII representations of the binary DWG (drawing) files. Logically, both files are
identical and MAPublisher treats both file types in the same manner. AutoCAD files consist of drawing settings and
configurations, as well as a series of entities, or graphic elements, organized into layers. MAPublisher provides broad
support for many AutoCAD entity types and options. Prior to import, set the colour mode of the Adobe Illustrator
document to the same scheme used in the colour table of the CAD file (RGB or CMYK) to ensure colours are
imported correctly. Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point,
then line, then area layers. Annotation objects are converted to a point containing attribute information including
the text value to be labeled and its angle. Certain symbols may import as "exploded" objects in MAPublisher.

Delimited XY Text Data (csv, tsv, txt)

Import and Export

MAPublisher also supports the import of Delimited Text Data held in a variety of tabular file formats, as long as the
data contains coordinate values. File types supported are Text (txt), Tab Separated (tsv) and Comma Separated (csv)
files. Import Settings dialog box: In order to import point data with MAPublisher the parameters must be set by
clicking the Settings’ button. This operation is required to choose the columns of the selected attribute file that will
be used to derive the X and Y coordinates of the data, and ensure correct georeferencing. These and further settings
are discussed in chapter 6 and in the Delimited Text Data Settings section in appendix A1.

Digital Line Graph (opt, dig)

Import only

The USGS (United States Geological Survey) DLG file structure is designed to accommodate categories of spatial
data represented on a conventional line map. Node (point), line, and area data types are accepted. The attribute
coding scheme is designed to accommodate basic cartographic data categories such as hypsography, hydrography,
or political and cultural features, as well as additional thematic data categories.

40 Chapter 2: Map Data File Formats
Import and Export Supported Data Formats



Esri Arcinfo Generate (gen)

Import and Export

Arcinfo Generate files are created by Esri Arcinfo product, and have a simple ASCII from x-y to x-y format. Due to its
simplicity you can also use a text editor such as Notepad to create text files and save them with a GEN extension,
which can then be imported with MAPublisher.

Esri Interchange File (e00)

Import and Export

Esri Interchange File files are created by Esri ArcInfo product. A single EQO file describes a complete Arcinfo
coverage. The file itself is actually an archive of several smaller files, or sub files, which will have fixed names and
follow a predefined data format. MAPublisher will reproduce these sub files as distinct Adobe Illustrator layers on
import. Therefore importing a single e00 import can result in the generation of point, area, line and text layers.

Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point, then line, then area layers.

Esri Shapefile (shp)

Import and Export

Shapefiles are most commonly created by Esri ArcGIS or ArcView. Shapefiles store both geometry and attributes for
features, and a single shapefile will consist of at least three physical files: the SHP portion contains the geometric
data, the DBF contains attributes for the geometric data, and the SHX contains the index information. There is often
a PRI file, which stores coordinate system information and is automatically read by MAPublisher on import. If a
shapefile folder does not contain a PRJ file, a coordinate system should be specified in MAPublisher. The important
things to remember when importing shapefiles are that the SHP file must be the one that is selected through

the MAPublisher import filter and that all its component files must be in the same folder. You may also find that

a shapefile directory includes two extra files, a SBN and a SBX, which hold the spatial index for the geometric

data. These two files will not exist unless the shapefile was created with an Esri product, and are not necessary for
successful import with MAPublisher.

Esri ArcMap Document (mxd)

Import only

ArcMap Documents (MXD files) contain information describing the map, page layout, layers associated with it, and
any objects inserted into the map. ArcMap documents can be imported using MAPublisher Import and Multiple
Data Import. Due to certain limitations, only the coordinate system, layer order and map data are retained when
importing an ArcMap Document. Any styles, such as strokes, fills and patterns are not preserved. In addition, to
import ArcMap documents, at least ArcGIS 9.x must be installed.

FME Feature Store (ffs)

Import only

FFS stands for FME Feature Store. This format is a memory dump of FME features; so it supports the complete FME
data model and can hold anything that FME features carry. This makes the format attractive as a holding spot for
data that should persist between FME runs.

MAPublisher-FME Auto is a plugin for MAPublisher. It is already installed with MAPublisher and requires activation
through MAPublisher Licensing. See chapter 3 for more information about FFS import and MAPublisher-FME Auto.
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Geography Markup Language (gml, xml)

Import and Export

The Geography Markup Language (GML) was designed as a geographic interface language for the Geo-Web. It is
currently in draft as an ISO standard (ISO 19136). The goal of the format is to provide users with a set of abstract
base objects that can be built into working real world dataset. It uses an XML base to store geometry and feature
information that can easily be transported across the Internet.

The GML Simple Feature Profile was created by the Open Geospatial Consortium (OGC) as a restricted but useful
subset of the GML specification. It provides a reduced geometry and metadata profile that can be shared across
many GIS tasks. This simple feature model can be used as a base to generate local application profiles for a specific
work area. Since the GML models base abstract classes, these application profiles (schemas) are required for
accessing and processing any GML datasets. GML data has a GML extension, and requires a attributes schema file XSD.
Some GML files may have their XSD file referenced to a URL path, we recommend to copy the XSD files locally, to
avoid error messages upon import when no internet connection is available. Users have two options to store their
GML and XSD files: they can be both located in a same directory or the XSD files can be kept in the MAPublisher
GML Schema directory found here:

Windows 7/8: C:\Program Files\Avenza\MAPublisher 9\Data Source Files\GMLSchema
Mac OS X: /Applications/Avenza/MAPublisher 9.5/MAPublisher Plug-In/Data Source Files/GMLSchema

The second option is the most practical if all the GML files are using a same schema (only one instance of the XSD
file needs to be saved). Installed with MAPublisher are three default XSD files:
«  xmlxsd, generic GML attribute schema.
+  nen3610.xsd and top10nl.xsd, models standardized in the Netherlands (maintained by the Dutch
topographic office Kadaster).

GML files with a missing XSD file or with an invalid attribute schema will cause a GML validation error upon import
(see chapter 3). Users have the option to find the appropriate XSD file and copy it to the GML Schema directory or
to the GML file directory. This option will assign a type string to all attributes. See chapter 3 Importing Map Data for
more details on these settings.

MAPublisher supports the import of simple features (points, lines, polygons, donuts, and aggregates) in GML 2.0
and later versions. MAPublisher supports export to GML 3.1.1.

Google Earth (kml, kmz)

Import and Export

Keyhole Markup Language (KML), is an XML-based language for managing the display of three-dimensional
geospatial data in the programs Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies
a set of features for display. Each feature always has a longitude and a latitude and can have other data, such as tilt,
heading, and altitude. KML shares some of the same structural grammar as GML. KML files are very often distributed
as KMZ files, which are zipped KML files with a KMZ extension. MAPublisher imports and exports both file type
based on the KML version 2.2 specifications. KML track and linestring import is supported. KML image import to
attributes is supported. When importing and exporting data that includes images, the KMZ format should be used.

Note: Picklist attributes exported from the Avenza PDF Maps app as KML are currently not supported in MAPublisher.
Importing just a schema (without data) from Avenza PDF Maps into MAPublisher is not supported.
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GPS Exchange Format (gpx)

Import only
GPS Exchange Format (GPX for short) is a light-weight XML-based data format designed for the interchange of GPS
data. MAPublisher supports GPX schema version 1.1.

Image (png, jpeg, jpg, jpe, tif, tiff, gif, jp2, jpf, jpx, j2k, j2¢, jpc, psd, pdd, bmp)

Import and Export (tif, png, jpg)

Referenced raster files of the above mentioned formats can be imported and placed directly into a MAPublisher
MAP View using Import and Multiple Data Import. These images have the option to be linked or embedded into
Adobe lllustrator upon import. Images cannot be reprojected by MAPublisher in Adobe Illustrator. Use Geographic
Imager or another third-party software to properly reproject geospatial images.

International Hydrographic Office S-57 (000, 030)

Import only

S-57 is referring to the IHO (International Hydrographic Office) Special Publication number 57 related to the IHO
transfer standard for Digital Hydrographic Data . Maintained by the IHO, S-57 format is intended for the exchange of
digital hydrographic data between national hydrographic offices and for its distribution to manufacturers, mariners
and other data users. It is used for the supply of ENC cells (Electronic Navigational Charts) to ECDIS (Electronic Chart
Display and Information System). The objects spatial geometry can be of Point, Line or Area geometry, while object
descriptions are categorized in object classes, organized in specific attributes schemas. To make full use of this
format, refer to the online object catalog available on www.s-57.com.

MAPublisher imports non-encrypted S-57 data into MAP layers named per S-57 object acronym, of type Area, Line
or Points. All S-57 Attributes are converted into MAP Attributes.

An Adobe lllustrator template is supplied to automatically style the map after import. The template contains a series
of MAPublisher stylesheets linking S-57 imported features to nautical symbols and graphic styles (libraries provided
by Avenza). This representation is non-exhaustive and meant to assist users with limited knowledge of the S-57
format to interpret the data contents more easily. The S-57 template and the symbols and graphic styles libraries
can be found in the MAPublisher Helpful Styles & Symbols folder (see Appendix 4).

Maplnfo Interchange Format (mif)

Import and Export

Files of this type are most commonly created by the Maplinfo product, though other products, including
MAPublisher, are also capable of generating files in this format. These files exist in pairs where each file has the same
name but ends in either a MIF or MID file extension. The MIF portion contains the vector geometric data, and the
MID contains the associated attributes. Both files are required in order to successfully import a file of this format to
Adobe lllustrator using MAPublisher. The important things to remember when importing Maplinfo files are that the
MIF file must be the one that is selected through the MAPublisher import filter and that both files must be in the
same folder. MAPublisher will automatically locate and deal with the MID file.
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Maplinfo Table (tab)

Import and Export
The TAB format is a simple, non-topological format for storing the geometric location and attribute information
of geographic features, and is an integral part of the Mapinfo product. The TAB format defines the geometry and
attributes of geographically-referenced features in several files with specific file extensions that are stored in the
same folder on disk:

«  .tab: main file, table structure in ASCIl format.

- .map: the file that stores the feature geometry.

« .id:the file that stores the index of the feature geometry.
- .dat: the dBASE file that stores the attribute information of features.
«  .ind: table field indexes (if necessary)

The geometry of each feature is stored as a shape that comprises a set of vector coordinates. The attributes for each
feature are stored as a record in a dBASE table (dat) associated with the shapefile (map). There is one record in the
dBASE table for each feature in the map file. Raster TAB files cannot be imported in MAPublisher.

To ensure successful import, select the TAB component in the MAPublisher importers.

Microsoft Excel (xls)

Import and Export

Import geographic point data from an Excel spreadsheet (version 2007 and earlier only; XLSX is not supported)
that contains latitude and longitude entries for each row. In order to import point data, click the Settings button in
the Import dialog box to choose which columns will be used to as the X and Y coordinates of the data, and ensure
correct georeferencing. Further settings including other types of are discussed in Appendix A1.

MicroStation Design (dgn)

Import and Export

MicroStation Design files (dgn) are the native files created by Bentley Systems Inc. (and formerly Intergraph)
MicroStation product. Design Files consist of a header, followed by a series of elements. The header contains global
information including the transformation equation from design units to user coordinates, as well as the dimension
of the elements in the file. Each element contains standard display information, such as its colour, level, class, and
style, as well as a number of attributes specific to its element type. During the import process, MAPublisher will
produce one layer for each Level that exists in the MicroStation Design File. Annotation objects are converted to a
point containing attribute information including the text value to be labeled and its angle.

MAPublisher supports the import of MicroStation J (version 7 and 8) files, however attached raster file will not
be imported (ignored). Prior to import, the colour mode of the Adobe Illustrator document should be the same
scheme used in the colour table of the original file to ensure that the colours are interpreted correctly.

The hierarchy of layers in multi-feature imports is by feature type in the following order: text layers, then point
layers, then line layers, then area layers. Raster files attached to DGN files are ignored during the import process.
Files are exported from MAPublisher as MicroStation J files. Upon export, users may select a DGN seed file. All
information in the seed file gets carried over to the output file, such as level (layer) definitions, units, colors, line
styles definitions, etc. If an exported layer name matches a level name in the seed file, the data of that layer is
appended to the existing level, if not, a new level is created.
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Spatial Data Transfer Standard (SDTS) (catd.ddf)

Import only

Digital cartographic products of the USGS are available in the Spatial Data Transfer Standard format, and are
generally distributed over the Internet as a means of promoting the standard. For SDTS import, select the catd file
(xxxxcatd.ddf), which is the index file that contains a description of the other files in the SDTS transfer. Individual
DDF files cannot be imported. Generally all SDTS downloads will contain the CATD file.

TIGER/Line (rt1, r*1, bw1)

Import only

TIGER is an abbreviation of Topologically Integrated Geographic Encoding and Reference System, and was developed
by the U.S. Census Bureau. TIGER/Line files are a digital database of geographic features, such as roads, railroads,
rivers, lakes, political boundaries, census statistical boundaries, etc., that cover the entire United States. The
database contains information about these features such as their location in latitude and longitude, the name, the
type of feature, address ranges for most streets, the geographic relationship to other features, and other related
information. TIGER/Line files are the public product created from the Census Bureau TIGER database of geographic
formation. TIGER was developed in order to support the mapping and related geographic activities required by the
census and sample survey programs. More information on the TIGER/Line file format and data product can be found
on the US Census web page at: http://www.census.gov/geo/www/tiger/

MAPublisher considers the RT1 or BW1 file as the TIGER dataset. Even though each county will consist of a series
of files with a common base name, there may be a number of different extensions. Remember to select the RT1 or
BW1 file when importing TIGER data.

Web Feature Service

Import only

Web Feature Service is an interface standard designed by the Open Geospatial Consortium (OGC) for GIS vector
data transactions across the Web. The MAPublisher WFS import connects to servers that use versions 1.0.0 and 1.1.0
of the OGC standard. WFS servers provide GML files, which are read using the MAPublisher GML importer. The GML
importer supports the GML simple features 2.0+ profile.

As the WFS importer is read-only, WFS-T is not supported. See Web Feature Service in Chapter 3 "Importing Map
Data" for information on WFS parameters.

Web Map Service

Import only

Web Map Service is an interface standard designed by the Open Geospatial Consortium (OGC) for GIS raster data
transactions through http protocol. The MAPublisher WMS import connects to servers that use version 1.1.1 of the
OGC standard. WMS data formats include PNG, JPG, TIF and GeoTIFF. See Web Map Service in Chapter 3 "Importing
Map Data" for information on WFS parameters.
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Basic Esri ArcSDE Server’

Import only

ArcSDE geodatabases are multi-user Esri spatial databases, that allow users to store, use, and manage their GIS

data in one of the following commercial database management systems (DBMS): IBM DB2, IBM Informix, Microsoft
SQL Server, or Oracle. They are available in three levels of flexibility: desktop, workgroup and enterprise. The Basic
Esri ArcSDE Server import option allows users who have a free Esri desktop application called ArcReader to import
feature classes from ArcSDE geodatabases, but with some limitations on the selection functions — see chapter 3 for
more information on spatial databases.

1 Basic Esri ArcSDE Servers are not supported on Mac due to limitations of the related Esri libraries.

Basic Personal (mdb) and Basic File (gdb) Database Reader (Mac supported)

Import only

The basic personal and basic file geodatabase reader can import basic feature class geometries and attributes on
systems that do not have an Esri license. This makes it possible, for the first time, to open .mdb or .gdb on Mac
systems. The basic reader provides limited import capabilites supporting geometries and attributes not annotations
or subtypes. Spatial Filters can be specified and SQL queries are supported on Windows only. Basic File (gdb)
Database Reader is supported on Adobe Illustrator CS6 and higher (Mac and Windows) 64-bit installations only.

Esri file geodatabase libraries used in MAPublisher are only available in 64-bit.

Esri ArcSDE Geodatabase’

Import only

ArcSDE geodatabases are multi-user Esri spatial databases, that allow users to store, use, and manage their GIS
data in one of the following commercial database management systems (DBMS): IBM DB2, IBM Informix, Microsoft
SQL Server, or Oracle. They are available in three levels of flexibility: desktop, workgroup and enterprise. The Esri
ArcSDE geodatabase import option allows users who have ArcGIS software and a valid license to import all ArcSDE
geodatabase types with advanced options for the selection — see chapter 3 for more information on spatial
databases.

1 Esri ArcSDE geodatabases are not supported on Mac due to limitations of the related Esri libraries.

Esri File Geodatabase’ (gdb)

Import only

A File geodatabase is a native Esri single-user spatial database. It is a collection of various types of GIS datasets held
in a file system folder. This is the recommended native data format for ArcGIS. Importing this format requires ArcGIS
software and a valid license — see chapter 3 for more information on spatial databases.

1 Esri File geodatabases are not supported on Mac due to limitations of the related Esri libraries.

Esri Personal Geodatabase (mdb)

Import only

A Personal geodatabase is a native Esri single-user spatial database. This is the original data format for ArcGIS
geodatabases stored and managed in Microsoft Access data files. Importing this format requires ArcGIS software
and a valid license — see chapter 3 for more information on spatial databases.

1 Esri Personal geodatabases are not supported on Mac due to limitations of the related Esri libraries.
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OTHER SUPPORTED FILES

MAPublisher also supports Adobe lllustrator (ai) files created by Cartographica, a third-party GIS software.
Cartographica users who wish to use files in MAPublisher must check the Include data in export option during export.

lllustrator Export Options
[ Label all line segments
= Polygon labels appear inside
O Polygon labels appear astride

@ Include data in export

MAPublisher reads Adobe lllustrator files exported by Cartographica and extracts the geospatial information to
convert it into layers and MAP Views—including projection, map scale and page position. However, there may be
limitations when working with these files and it is recommended that they be saved as the latest version of Adobe
lllustrator files compatible with your system (this is required before exporting to geospatial PDF).

DATA CONSIDERATIONS

When obtaining GIS data for use with MAPublisher, whether from an online source, commercial vendor,
government office or from a source within your organization, there are a number of important considerations to
keep in mind.

First and foremost, obtain data in one of the formats supported by the MAPublisher. In cases where the file format
native to a particular mapping application is not supported by MAPublisher, you can often request the data
provider to export a file in one of the supported formats.

When obtaining data you should acquire as much metadata about the files as possible. MAPublisher deals with
data in the following manner: Unprojected data will be imported by MAPublisher with latitude and longitude map
anchors, which will therefore range from (x) -180 to 180, (y) -90 to 90.

If you receive projected data you should be aware of the following. MAPublisher will import projected data
with a true scale and appropriate map anchors. Unlike unprojected data, these map anchors will not be in lat/
long, but rather in a coordinate system appropriate for the particular projection. For most file formats the name
of the projection, datum, and units will be recognized by MAPublisher. However if the program cannot find this
information in the data, and you wish to subsequently reproject your data, you will be required to specify the
coordinate system.

In addition, MAPublisher is a two dimensional mapping program. If you attempt to import 3D data with
MAPublisher it will be converted to two dimensional artwork by the importers. Data provided in a generic latitude
and longitude (unprojected) coordinate system will usually be recognized as a WGS 84 (World Geodetic System
1984 - EPSG = 4326) coordinate system by the MAPublisher importers.
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ADOBE ILLUSTRATOR 64-BIT DATA IMPORT LIMITATIONS

On MAPublisher 9.x for Adobe lllustrator CS6/CC 64-bit, the following data formats are not supported:
«  Esri ArcMap Document (mxd)
«  Basic Esri ArcSDE Server, (connection to arcServer with only Arcinfo installed libraries)
«  Esri ArcSDE Geodatabase
«  Esri File Geodatabase (gdb)

The suggested workaround is to run MAPublisher 9.x for Adobe Illustrator CS6/CC 32-bit and import any of the
above formats, then save and close the Adobe lllustrator file. Re-open the Adobe lllustrator file with MAPublisher
9.x for Adobe lllustrator CS6/CC 64-bit, and then save it. This will ensure that a 64-bit workflow is used while working
with the document.

Esri Personal Geodatabase (mdb) is supported only if the Microsoft Access Database Engine 2010 Redistributable is
installed. Download the redistributable at http://www.microsoft.com/en-us/download/details.aspx?id=13255.

Note: This only affects Windows 64-bit operating systems.
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' Importing
. Map Data

The Import functions are the starting point for most users
wanting to work with GIS map data in Adobe lllustrator. These
functions are used to import GIS data, set the initial map scale
and define your cartographic workspace to start making maps.

The topics covered in this section:

Import

Multiple data import

Web Feature/Map Service

Spatial Databases

Geospatial PDF Import

MAPublisher FME Auto and FME FFS Import
Automation

See chapter 2 for detailed descriptions of formats that
MAPublisher can import.
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Format - Choose the data format
type to import. This shows all
MAPublisher supported data types.

Filename - Displays the directory path and
file name for the currently selected file(s).
Click Browse to select files for import.

Path and file name can also be entered
manually. A status displays whether or not
the data loaded sucecssfully or needs to
be reloaded.

Coordinate System - The detected coordinate
system of the data source. If the coordinate
system of the selected file is known, but
was not automatically detected, click the
hyperlink to choose an appropriate one.
This will open the Specify Source Coordinate
System dialog box (below). Alternatively,
click the From File button to choose a
coordinate sysem from another source

file. Click the Clear button to clear the
existing source coordinate system. Click
View Coordinate System Information to
view more information about the source
coordinate system.

RELATED TOOLS

Import

File > Import Map Data > Import and MAP Toolbar

e Format:

Import

Maplnfo Interchange Format [<.mif] -

Filename: Jtorial Guide & Data\{Tutorial Data\world.mif

« Data loaded successfully.

Simple Mode

Encoding: |Default System Encoding -

—e WGS 84

[] same as:

Import

Format: | MapInfo Interchange Format [*.mif] -

Filename: itorial Guide & Data\Tutorial Data\world.mif

« Data loaded successfully.

Browse.

Format Import Settings - Opens Format Import
Settings dialog box. Format specific settings

—e—— affect how MAPublisher and Adobe

lllustrator reads the data (see Format Import
Cancel . .
Settings section).
=) Advanced s———— Simple/Advanced Mode - Toggle

between Simple and Advanced
mode (also see below)

o) oK

= Cancel

Encoding - Choose a different character
encoding if the attribute data uses a
different character set

Coordinate System:

@ Chicagoland

Advanced Mode

Specify Source Coordinate System
Click the source coordinate system hyperlink in the Import dialog box.

Same as - Enable this option to assign a
coordinate system that matches that of
an existing MAP View in the document.

— It is available when another MAP View is

present in the working document.

@

Coordinate Systems - Choose a
category appropriate to the
data to be imported. To view
all of the coordinate systems
select *All*. For a list of the
last 10 coordinate systems
used, select *Recent*.

b UTM Winkel-Tripel, Central Meridian Greenwich Winkel-Tripel, Cer
> World P nre s o it et et e
vl|<
Search - Specify a text string +| @ + @ /@3
to search the database
N Search
for coordinate systems. —+—e
Folder: World

Results are displayed in the

*Search* category. Fnd

in [Name -

Specify Source Coordinate System
Datasource: ~ €:\Program Files\Avenza\MAPublisher 8. 4\Data Source Files\geodata, xml
Custom Data:  C:\Pr IDi 9. | Close
Folder ~l|@ & Display Name - Name ~

Arctic ) Two Point Equidistant Two Point Equidis
> Asia 4 Van der Grinten Van der Grinten £350
> Europe A WGS 84/ NSIDC EASE-Grid Global WGSB4/NSIDCE | | gave ps...

Example Systems-NOT FO.. ) WGS 84/ PDC Mercator WGS 84/ PDC Me . " : ;
> Morth America WG5 84 / Pseudo-Mercator WGS 84 Pseudo- « Sys.tem n ~This
> Oceania 4 WGS 84/ World Equidistant Cylindrical WGS 84/ Werld E area shows information about the
> Other ) WGS 84/ World Mercator WGS 84/ World | coordinate systems. (i.e. Name,

Outdated (Deprecated) A Winkel | Winkel | P !
> South America A Winkel Il Winkel I Type, Envelope, EPSG Code). To

choose a known source coordinate
system select it from this list.

Dataset Coordinate Systems
Automatically opens if multiple datasets have been selected and do not have a matching coordinate system.

Dataset - List of all the datasets
selected for import
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Dataset Coordinate Systems

find a st of your selected datasets and their assodiated coordate system,

You cannot select multiple datasets with different coordinate systems. Below you wil

Dstaset Coordinate System

canada MAD2T
ukpoly WES &4

Update @

Close

Remove &——

Remove and Update - Remove datasets
that do not have a matching
coordinate system and click Update

Coordinate System - List of the
coordinate system for each
individual dataset



Matching MAP View

Automatically opens if there is an existing coordinate system in the document that matches imported data.

Add to - Add the incoming data file to a
matching MAP View

Fit to page based on new MAP View - Create a
new MAP View for the imported data.
Existing data and incoming data will be
treated separately in terms of page scaling
and position

Matching MAP View Found

Your data matches one or more MAP Views found in the
document. Please select a destination MAP View.

Destination MAP View:

= (@) Add to:

@ worldwest - -—J

[] Resize MAP view to fit
—* () Fit to page based on new MAP View

MAP View list - Select the matching coordinate
system that you wish to align the incoming
data to.

Resize MAP View to fit - Check this box to scale the
matching data so that both the selected layer and
the incoming data fit inside the page extents.

FORMAT IMPORT SETTINGS &

These settings affect how MAPublisher and Adobe lllustrator handle the data during import.

AutoCAD Drawing/Exchange

AutoCAD Drawing/Exchange Settings

Group entities: |By layer
Read hatches
Read block references as points

White lines/fls: | Change white lnes/fil to black ~

Group entities - Group entities by
layer name or geometry

White lines/fills - Options:

Read hatches - Read the hatch
pattern on import

the file

Read block references as points
Blocks are not expanded and
read as points on import

white lines

Geography Markup Language

« Importas is:import data true to the
original colour settings contained in

« Change white lines/fills to black: import
black lines instead of the files native

« Create black background: incorporate a
layer containing a black background,
to mimic the AutoCAD environment

Geography Markup Language Import Settings

Delimited XY Text Data

Delimited XY Text Data Settings

Encoding: | Default System Encoding -
Format: Dedmal degrees (D+[.d*]) A Cancel

Dedmal degrees, with optional direction indicator.
Examples:
7.5449W, 54,9777 | -79,44

Motation: items in [] are optional, "* means zero or more digits and
'+ means one or more digits. Direction can be indicated with -, 'N',
or "W

Coordinate Columns:

Longitude: |LONGITUDE: -86.3000 b

Latitude: | LATITUDE: 32,3670 =
Use first line as a header (detected)

Specify Schema

«# Settings are valid.

Display Options:

Symbol: | @ [MAPublisher Default Symbol] ~

Format - Select the coordinate format of the data to be imported

(e.g. Decimal Degrees, Packed DMS. See chapter 6)

Coordinate Columns - These drop-down lists contain the names of

Reverse X-Y coordinates: | Only for geodetic systems [Defaul] =

[ Copy your frequently used XSD files to the GMLSchema folder
to avoid having to keep them with your GML files.

Cancel

Web Feature Service

Web Feature Service Import Settings

Reverse X coordnates: | Only for geodetic systems Defauit] v

(@ Copy your frequently used XSD fles to the GiLschema folder | Cancel
£ avoid having to keep them with your GML fles.

(@ VIFS 1.0.0: Default vl everse for geodeticsystams.
WS 1.1.0: Default wil not reverse for gedetic systems.

Reverse X-Y coordinates - Change the order of Xand Y
coordinates. This may help when an external program
exports X-Y coordinates in reverse. Options:

« Only for geodetic systems [Default]

« Always

« Never

all the numeric columns in the selected file. Choose the columns
containing the coordinate information. Enable Use first line as a
header if the first line of the text file contains column headings.

Specify Schema - Click the link to change the data schema type for
attributes in the delimited text data set (see below)

Specify Schema
Attribute Type ~ oK
D Integer Cancel
PlaceName [#] String
Web [ string
image [ String
lego_image [ String o

Display Options - Choose a default symbol to to be applied on import
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Esri Interchange File

EQO Import Settings

Ignare TIC layer _

Cancel

Ignore TIC Layer - Enable

this to suppress creating

of _tic_point layer. Disable
to create a layer holding the
registration control points.

Google Earth

Google Earth Settings

Allow random colour mode
[] Expand network links

Cancel
[] Automatically apply Symbols when possible

KML Properties: |Import & visble =

Allow random colour mode
Enable this option to
generate random colour
settings for the data

Expand network links

Enable this option to use of
network linked KML files

KML Properties - Options:

« Import &visible: import KML
properties and make them visible
in the MAP Attributes table

« Import & hidden: import MIF
properties and make them hidden
in the attribute table

« Not imported: do not import MIF

Automatically apply Symbols properties

when possible

This setting automatically
applies symbols to map
features during import

Click the info button to view available KML
properties.

International Hydrographic Office

Adobe lllustrator Options for International Hydrographic Office...

Automatically apply Graphic Styles and Symbols when possible oK

Cancel

Automatically apply Graphic Styles and Symbols when possible
This setting automatically applies graphic styles
symbols to map features during import

Image Settings
Reference file: VancouverDowntown. tif
Image size: 1,260 x 907 pixels
World extents: 4,666.034793031692971 x 4,665,0347. Cancel
Units: Meter

Coordinate system: NADS83 /UTM zone 10N
+ Georeferencing is valid.

Image placement: |Embed -

@ Embedding TIFF image that contains transparency may
cause referencing and export issues. Choose “Flatten
Layers to a Single Image" when the TIFF Import Options
appear.

Reference file - Click the reference file link
to open the Edit Image Registration
dialog box (see chapter 12)

Image placement - Embed the image
into the document or Link to it.
Please see note about transparency.
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Mapinfo Interchange Format

Adobe lllustrator Options for Maplnfo Interchange Fo...

Automatically apply Graphic Styles when passible _
(1]

MIF Properties: Import & visible

Cancel

Automatically apply Graphic Styles when possible
This setting automatically applies graphic styles to map
features during import
MIF Properties - Options:
« Import & visible: import MIF properties and make
them visible in the MAP Attributes table
« Import & hidden: import MIF properties and make
them hidden in the MAP Attributes table
« Notimported: do not import MIF properties

Click the info button to view available MIF properties.

Mapinfo Table

Adobe lllustrator Options for Maplinfo Table

°

Cancel

TAB Properties: | Import & visble +

TAB Properties - Options:
« Import & visible: import TAB properties and make
them visible in the MAP Attributes table
« Import & hidden: import TAB properties and make
them hidden in the MAP Attributes table
« Notimported: do not import TAB properties

Click the info button to view available TAB properties.

g

MicroStation Design

MicroStation Design Settings

Group elements: By geometry -

Coordinate units: | Master -

Cancel

[] orop comples chains

[ 1anore tags on import
white lines/fils: |Change white linesfill to black
[] create groups for like text

Group elements

Choose how to group the
elements: By geometry or By level.
If elements are grouped by level,
it may result in a large number of
output files.

Coordinate units

Specify how feature coordinates
will be interpreted and converted:
Master or UOR

Drop complex chains

Component of a complex chain
returned as its own feature.
Otherwise all elements of the
complex chain will be merged
into a single linear feature.

Ignore tags on import
Ignore any tags on import so that it
does not affect spatial extent

White lines/fills - Options:

« Importas is: import data true to the
original colour settings contained in
the file

« Change white lines/fills to black: import
black lines instead of the files native
white lines

« Create black background: incorporate a
layer containing a black background,
to mimic the AutoCAD environment

Create groups for like text

Text in the same graphic group or
the same text node will be grouped
in Illustrator



Microsoft Excel

Microsoft Excel Settings

Vierksheet: [isdbes -
Format: | Projected units - Cancel

Projected units (meters, feet, etc.)
Examples:
5293.07, 24539454 | -839843.7139, 7322535.5729

Notation: items in [] are optional, " means zero or more digits and '+
means one or more digits. Direction can be indicated with -, 'N', or "W".

Coordinate Columns:

X: #MapX: 5079532.31638958 -

i #MapY: 634767.951573596 &
Use first line as a header (detected)

Spedify Schema

" Settings are valid.

Display Options:

Symbol: | @ [MAPublisher Default Symbol]

Worksheet - Choose the appropriate Excel worksheet to import data
values from

Format - Choose the coordinate format of the data to be imported
(e.g. Decimal Degrees, Packed DMS. See chapter 6).

Coordinate Columns - These drop-down lists contain the names of

all the numeric columns in the selected file. Choose the columns
containing the coordinate information. Enable Use first line as a
header if the first line of the text file contains column headings.

Specify Schema - Click the link to change the data schema type for
attributes in the delimited text data set)

Display Options - Choose a default symbol to to be applied on import

FME Feature Store

FME Feature Store Settings

Password:

[[] Show password

@ You do notneed to enter a password
unless the dataset you are importing
requires it,

Cancel

Password - Enter a password to unlock the FME file, if required

Note:

Esri ArcSDE Geodatabase,
Esri File Geodatabase and
Esri Personal Geodatabase

Esri File Geodatabase Settings

Unicode database Cancel

Prepend feature dataset name to layer name

) Use locale to decode:
Locale:

Ifno value is entered, the locale of the
current machine will be used.

Prepend feature dataset name to layer name Enable this to
prepend feature dataset names to layer names.

Unicode database - Unless specific issues importing
converted geodatabases, keep this option as default.

Use locale to decode - This option might be required if
the geodatabase was created by converting a filein a
format not supporting unicode (e.g. Esri shapefile) and
if it contains non-ASClI characters. Specify the locale
name (e.g. en-US), leave it as 0 to use the locale of the
current machine.

These are advanced settings. Contact Avenza Technical
Support (support@avenza.com) for assistance.
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IMPORT FUNCTIONALITY

Import provides a method of importing map data into Adobe lllustrator. Its purpose is to import either a single data
file or several files of the same format and coordinate system. The Import dialog box has a Simple and Advanced
mode. The latter includes additional options and coordinate system settings.

PREREQUISITES

Use Import either before or after an Adobe lllustrator document is created. If no document is open, Import will open
the New Document dialog box.

MAPublisher will interpret the artboard dimensions during the import process and calculate a map scale for the
document accordingly. If the document size is changed in the Adobe Illustrator document settings, the scale will
have to be recalculated using the MAP View Editor (see chapter 4 for more information).

Additional import options can be specified in the MAPublisher Preferences dialog box (see chapter 1) Import Map
Data category, such as attribute order, layer naming convention or display of extents in the import dialogs.

USING IMPORT

Click the Import button on the MAPublisher toolbar or from the Adobe Illustrator menu File > Import Map Data >
Import.

Overview

The Import dialog box has two modes: Simple and Advanced. In Simple mode, a file format drop-down list, a format
import settings button, and a Filename path box and Browse button are available. In Advanced mode, several
additional controls are available. The coordinate system section displays which coordinate system the data has (if
applicable) and provides an option to edit it. In both Simple and Advanced modes, a status displays information
such as data being loaded successfully or if further settings are required.

Adding Files

To specify the format to be imported, click the Format drop-down list and choose <Auto detect format> or another
specific format. The <Auto detect format> option allows all supported GIS files to be displayed in the file browser.
Choosing a specific format is recommended to ease navigation.

Once a format has been selected, click the Browse button to select the file(s) to be imported and click Open.
Alternatively type in the full path of the file(s) in the Filename box. Multiple files of the same format and the same
coordinate system can be imported at the same time (see Multiple Data Import to import files of different formats
and coordinate systems).

A status displays whether or not the data was loaded successfully. In some cases, it may be necessary to click the
status to reload the data again. Click the Log button to view more information about the chosen data file.
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Format Import Settings

Certain file formats have additional configuration parameters which can be accessed by clicking the Settings button
(listed in the Format Import Settings section above). These settings affect how MAPublisher and Adobe Illustrator
handle the data during import. The Settings button is enabled when additional format import settings are available.

Note: Settings are mandatory only when importing Delimited XY Text Data or Microsoft Excel formats.

Delimited XY Text Data Settings

Delimited text files can be imported as point data provided they contain coordinate values. MAPublisher supports
the following delimiters between data values: comma, return, end-of-line and tab. When importing delimited

text data, specify the character encoding and format: Projected Units, Decimal Degrees, Delimited Degrees Minutes
Seconds, Degrees.Minutes, Degrees.MinutesSeconds, Packed DMS with decimals and Packed DMS (see chapter 6 for
more details). In the Coordinate Columns section, specify the fields in the source file that contain the appropriate
coordinate values. The drop-down list labels display Longitude and Latitude or X and Y, depending on the selected
format. If the first line of the text file contains column headings, enable the Use first line as a header check box
(MAPublisher generally detects it automatically). If the file does not appear to contain column headers, MAPublisher
will assign default header names (Column1 and Column?2) to the chosen fields on import. Assign data schema types
to attribute columns in the Select Schema frame.

Encoding (Advanced Mode)

Most formats have a character encoding setting. Extended and international character sets are supported as
attributes on import. To assign a character codec suitable for your selected dataset, choose the appropriate value
from the Encoding drop-down list (the first column displays the name and the second column displays the code or
alternate name, if available).

Source Coordinate System (Advanced Mode)

When the Filename text box has been populated with a valid path, MAPublisher will load the file(s) to determine if a
valid coordinate system can be found and will display it in the Source Coordinate System section.

When [No Coordinate System Specified] is shown, no coordinate system was detected. If necessary, click the
hyperlink to specify one. In the Specify Source Coordinate System dialog box, coordinate systems are separated into
categories (geodetic or projected) to ease the process of choosing a coordinate system: under the Coordinate
System category *All* will list all the coordinate systems in the database. For an overview of Geodetic and Projected
systems and Datums see appendix A2.To view the parameters of a certain coordinate system, click the Info button.

To change the coordinate system of a chosen dataset to match the coordinate system of an existing MAP View
(see chapter 4 for more information) in the document, enable the Same as check box and choose a MAP View. See
Importing Data (next page) for available options when the coordinate system of imported data matches that of an
existing MAP View.
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Importing Data

When format and dataset file(s) are chosen (with settings specified), click OK to start the import process.

If the coordinate system of the imported data matches the coordinate system of an existing MAP View, the Matching
MAP View dialog box will automatically open with the following available options:

+  Addto: choose the MAP View from the drop-down list in which to add the imported data. Enable the Resize
MAP View to fit check box to scale all the data (existing and incoming) to fit the artboard extents. If this
option is not checked, the imported data may fall outside the artboard extents

«  Fittopage based on new MAP View: the imported data will be treated separately from the matching data
and a new MAP View will be created (based on the same coordinate system). The imported data may
overlap with existing data. Use the MAP View Editor to scale and move the data on the artboard (see
chapter 4).

RESULTS

Data is imported as an individual Adobe lllustrator layer (or layers if multiple dataset files were chosen) with an
assigned feature type (point, line, area, orimage — see chapter 4) that matches the source data type. It is also now
considered a MAP Layer. All MAP Layers are contained in a MAP View (existing or new) that designate how the data
is displayed on the artboard (based on coordinate system, map scale, and artboard extents — see chapter 4).

MAP Layers are named based on the file name or on the layer name in the source file. By default, the assigned
feature type extension is used as a suffix (e.g. name_area) and when a layer name already exists, a suffix with a
number (e.g. name_area 1) will be used — this may be disabled in MAPublisher Preferences > Import MAP Data
property sheet (see chapter 1).

Notes: When importing data exceeding the allowable 32,000 points per path in Adobe Illustrator, MAPublisher
automatically simplifies the imported object and shows a warning message.

The simplification algorithm compares points in a line or polygon in groups of three. When the shortest
segment is found, the center point is removed, and the total segment distances are recalculated. This
removal process continues until the maximum allowable number of points is reached.

When attempting to import a 16 bits/pixel raster or 16 bits/pixel FME raster file, MAPublisher will convert it to
8 bits/pixel.
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Multiple Data Import

File > Import Map Data > Multiple Data Import and MAP Toolbar

Multiple Data Import

Cancel

Coordinate System  Data Source Features
Data List - This is a table — |1 W5 24 Parks 16
where all data selected for _
import are listed 2 NADS3/ UTM zone 10N Hotels 10
3 NAD2T canada 13
Destination MAP View
Add... Remove Edit...

New based on - Import all of the
data to one of the coordinate

systems in the Data List Destination MAP View:

canada

@ San Frandisco Downtown

— (@ .
Use existing - Import all of ®) New based on:

the data to an existing
coordinate system
associated with a MAP View J

() Use existing:

[ Auto-scale

in the document

() Create new: Editor...

Auto scale - If multiple datasets
are present in the Data List,
and New Based On or

Coordinate system: NAD27

Page anchors: {(0in,-0in)

Wisual scale: 1:17533945.821581
Map anchors: (-141.0153, 41.7110)
Map unit: Degree

Map angle: 0

Use Existing is selected,
check this box to ensure the
imported artwork fits inside

the page extents

Create new - Allows users to import all
data into a new coordinate system.
Click the Editor button to open the MAP
View Editor (see chapter 4).

RELATED TOOLS
Multiple Data Import - Add

Details - Displays details of the selected
data source: coordinate system, page
anchors, visual scale, map anchors,
map unit, and map angle.

Click the Add or Edit button in Multiple Data Import dialog box.
It functions the same as the Import dialog box. See Import section.

Add

Format: |Esri Shapefile [*.shp]

+ Data loaded successfully.

Enceding: | Default System Encoding

Coordinate System:
WGS 84
[] same as: e VancouverDowntown

Filename: de & Data\Tutorial Data\southchinasea.shp

Cancel

8 8 =

+ (%) Simple

Format Import Settings

See Import section for various Format Import Settings dialog boxes and settings.

Coordinate System - Coordinate
system of the data source

Data Source - Map data chosen
for import (full path or just
file name depending on
MAPublisher Preferences - see
chapter 1). Icon identifies data
as vector or raster.

Features - Number of art
objects to be imported

(Enable show extent in
MAPublisher Preferences).
Extent displays the lower
left (LL) and upper right
(UR) coordinates (XY) of the

dataset extents.

Nidd - Add data to the Data List
using the Add dialog box (see
below).

Remove - Remove selected data
sources from the list

Edit - Allow editing of the
selected data by re-opening
the Add dialog box

(see below)

Chapter 3: Importing Map Data | 57

Multiple Data Import



MULTIPLE DATA IMPORT FUNCTIONALITY

Multiple Data Import provides another method of importing map data into Adobe Illustrator. Its advantage over
Import is that it can import data in multiple formats and coordinate systems. All data listed for import are displayed
in the dialog box with information relative to their coordinate system. All imported files are reprojected to match a
selected coordinate system.

Note: Multiple Data Import is recommended when importing data that will require a coordinate system
transformation that implies redrawing and path divisions (e.g. world data reprojected from European to
North American aspect). Applying a coordinate system transformation during Multiple Data Import allows
MAPublisher to split paths during transformation, which is not possible at a later stage. Divided paths are
grouped as compound paths.

PREREQUISITES

Use Multiple Data Import either before or after an Adobe lllustrator document is created. If no document is open,
Multiple Data Import will open the New Document dialog box. See the previous Import Prerequisites section.

USING MULTIPLE DATA IMPORT

Click the Multiple Data Import button on the MAPublisher toolbar or from the Adobe lllustrator menu File > Import Map
Data > Multiple Data Import.

Overview

The Multiple Data Import dialog box displays added data, its coordinate system information and the number of
features they contain in a data list. The lower part of the dialog box refers to the Destination MAP View settings.

The Add and Edit buttons open a dialog box similar to the Import dialog box. Please refer to the previous section for
information about character encoding, Format Import Settings and Delimited XY Text Data Settings.

Adding Data

Click the Add button to choose one or more files that share the same format and coordinate system. The Add dialog
box functions the same as the Import dialog box, please refer to previous section for more information. Browse

for data, then click OK to add the files to the data list. To add more datasets to the data list in a different format or
coordinate system, click Add again.

Data List

All added datasets are listed in the Multiple Data Import dialog box. Listed features include the data source file
name, the specified coordinate system and the number of features contained in the dataset.

Click a row in the data list to select a dataset. Click Edit to change the import parameters or click Remove to remove
the dataset. The Edit dialog box provides the same options as the Add dialog box where users can modify the file
name, path, format import settings or source coordinate system.
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Notes: The Multiple Data Import dialog box displays the file name or the full path of the selected files depending on
the settings specified in MAPublisher Preferences > Import MAP Data (see chapter 1). Users can also choose
to display the geographical extents of the data.

It is not possible to import multiple files with a mix of unknown and known coordinate systems. Therefore
the unknown coordinate systems will need to be specified before import.

Destination MAP View

Even though Multiple Data Import allows data with multiple source coordinate systems to be imported, the
destination MAP View can only have a single coordinate system. The Destination MAP View section (for more
information about MAP Views, see chapter 4) has three options to choose the coordinate system:

«  Newbased on: Choose a dataset to base the destination coordinate system on. Coordinate system
information can be seen in the details box.

+  Useexisting: Choose an existing MAP View in the document with the desired coordinate system.
Coordinate system information can be seen in the details box.

For the two options above, the Auto-scale option scales all the data (existing and incoming) to fit the artboard. If this
option is not checked, the imported data may fall outside the artboard extents.

+  (reate new: Specify the parameter for a new MAP View. Click the Editor button to open the MAP View
Editor. In the Destination Coordinate system section, click the coordinate system link to select another
coordinate system from a large list of existing system or to create a custom one. In brief, it allows edits
to be made to map scale, position of the data on the artboard, rotation, and projection or coordinate
system at the same time the data is being imported. The MAP View Editor is explained in depth in
chapter 4.

RESULTS

The data is imported as an individual Adobe Illustrator layer (or layers if multiple files were chosen) with an
assigned feature type (point, line, area, orimage — see chapter 4) that matches the source data type. It is also now
considered a MAP Layer. All MAP Layers are contained in a MAP View (existing or new) that designate how the data
is displayed on the artboard (based on coordinate system, map scale, and artboard extents — see chapter 4).

MAP Layers are named based on the file name or on the layer name in the source file. By default, the assigned
feature type extension is used as a suffix (e.g. name_area) and when a layer name already exists, a suffix with a
number (e.g. name_area 1) will be used — this may be disabled in MAPublisher Preferences > Import MAP Data
property sheet (see chapter 1).
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Web Feature/Map Service

Import or Multiple Data Import (Format drop-down list)
WEB FEATURE SERVICE

Import vector data using the Web Feature Service (WFS). It accesses web servers that deliver vector content in GML
format. To access WFS settings, choose Web Feature Service in the Format drop-down list of the Import or Multiple Data

Import dialog box and click the Service link to choose a web service.

To manage servers used in the WFS, click Browse. The Browse Web Feature Service dialog box maintains a list of
loaded map services. To add a new service click the Add button, then add the service URL and version number.
This list can also be populated with a number of services aggregated by Avenza. To do so, click the Load Services From
Avenza button. To remove a service, select a row, and click the Remove button.

Browse Web Feature Service

Name Connection URL Version ~

Natural Resources Canada Web Feature Serv... http://gecnames.nrcan.gc.ca/wfs/cubeserv.cgi?datast... 1.1.0 Cancel

National Atlas WFS - Congressional Districts ..._hitp://webservices.nationalatlss.gov/arcgis/services/.. 1.1.0
Saved Services Maplinfo Global WFS Services htp: om/mi
WES name and connection GeoServer hitp://webgis.regione.sardegna.it/geoserver/ows? 110
URL and version DM Solutions Sample Server http:/fwww2.dmsolutions.ca/cgi-bin/mswfs_gmap? 100
SCIA IMAP Data Resources httpi//geoservices.knminl/cgi-bin/SCIA_CONSV__I.. 110
Commonwealth of Massachusetts, USA - M... http://giswebservices.massgis.state.ma.us/geoserver/.. 1.0.0
SGS Mineral Resources Texas Geology http://mrdata.usgs.gov/services/t? 100
S . .gov/: J/mt? 04 .
Add/Remove WFS %G?ﬂ‘"f:i‘ ﬁ“””"“ M”,xi”:ﬁ? 'fgy fttps//mdata.sgs. goufsemicesmt 1 ? g v Load Services From Avenza
Add a WFS by entering a Loads an updated list of

name for the service and ——e | ) | @ Load Services From Avenza
the connection URL.

Web Feature Services
from Avenza Systems

In the Select Features dialog box, choose from an available list of feature classes in the Features tree to import.

The feature abstract at the bottom of the dialog box displays a descriptive field about the selected feature and its
bounding box coordinates. Click the Specify Spatial Filter to specify four exact coordinates to limit the area being
imported (see Import Personal and File Geodatabases for more information). Optionally, check the Save file to folder
option and browse to a location to save it locally (not required to use the feature).

Title —eserver Info: Title: Massachusetts Data from MassGIS (GeoServer) @
The title of the current WFS Features: e
Humpback Whale Core Habitat (250-meter grid spacing) -
Humpback Whales in the Southem Gulf of Maine - Interpolation of Sightings per Unit Effort (

Feature Tree

Structured list of available features. It may or
may not show geometry type (Area, Point,
Layer) depending on WFS server settings

Specify Spatial Filter
Define a bounding box to
limit imported features

Additional Server Parameters

Parameters as outlined in WFS abstract
Save file to directory

Check this and browse to a

location to save the selected

map features locally

Feature Abstract
A descriptive field including
layer metadata
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Select Features

Hurricane Tracks for the Atlantic Basin 1831-2008
Hurricanes Making Landfall in New England 1851 - 2008
Hyannis To Nantucket Electric Cable

Hydro Centerline

Hydrography 25k Source

Hydrologic Units
Ice Rinks

Important Fish Resource Areas

Important Fish Resource Areas (250-meter grid spacing)
Inactive Disposal Sites in the Coastal Area
Inactive | andfills

<

e Specify Spatil Filte...
————eAdditional Server Parameters:

———o[¥] save file to folder: ~ers\Mikel \AppData\ ocal{Temp\Ge ographic Imager VAvenzaWFs\

Bromse...

Abstract: Generated from massgs_sde

Keywords: Source, Hycrography, GISDATA.HYDRO25K_SOLRCE,
i=h tech

v-and-

ipport/appl ol

_sde
SRS: EP5G: 26986
Bounding Box: (-73.531010,41, 109615) (-69.826032,43.002376)

hi ¥ html, 25,




WEB MAP SERVICE

Import raster data with the Web Map Service (WMS). It accesses web servers that deliver raster content in a variety
of formats. There are no format specific settings associated with this importer. To access WMS, choose Web Map Service
in the Format drop-down list in the Import or Multiple Data Import dialog box.

To manage web servers used in the WMS, click Browse. The Browse Web Map Service dialog box maintains a list of
loaded services. This list can be populated with a number of services aggregated by Avenza. To add a new service
click the Add button, then add the service URL. MAPublisher WMS importer only supports WMS version 1.1.1.

Saved Services
WMS name and connection —
URL and version

Browse Web Map Service

Neme Connection URL
Atls of Canada hitp://atles.gc.ca/cgibin/atlaswms_en
| JAtias of Canada Maps p: essws.nrcan.ge.c porama_en
British Columbia Base WS p govbe.ca/map: base?
Canadian Network b cgkn.net/cgi-bin/cgknwms
Canadian Geographical Mames WMS hitp://geonames.nrcan.ge.ca/wms/cubeserv.cgi?
CubeWen: WMS http://demo.cubewen.com/demo/cubeserv/cubeserv.cgitdan.
DM Solutions GMap pify a/cg . gmap

Goddard Earth Sciences - AIRS Atmospheric ...

hitp://disc1 sci.gsfc.nasa.gov/daac-bin/wms_airsnrt?

Lizardtech Demo WMS |

National Snow and Ice Data Center

- dtech.c
http://nside.org/cqi-bin/atlas_north?

Version il

111
111
111
111
111
111
111
111
111
111

oK

Cancel

NEXRAD Base Reflectivity p: tate.cdu/cgi cgi 111
Add/Remove WMS Toronto City Geospatial Web Service p toronto.ca/servlet/c Service.. 111 v Load Services from Avenza
Add a WMS by entering a Loads an updated list of
name for the service and the — @ Load Services From Avenza Web Map Services from
connection URL Avenza Systems
Select Web Map Layer — Format
Available output formats
Server Info ——e server Info: Title: CubeSERV Demo WMS Format: | tiff - oK
N . L] _ Style - Choose from
WMS title and map service — - )
yers: Style: Cancel rendering styles available
a Fum:luria: Fijurjty . A | | CubeWerx ¥ e———— forthe selected layer
irport Facility Points
Built-Up Areas Coordinate System:
Layer Tree Coastlines WGS 84 (EPSG:43265) v« Coordinate System
Structured list of layers ‘;Un::\gat\?n Background : adiiond Server Perometore Chon_)se from available
available in the current WMS Gr:ha‘ EDM"‘::Z Hlevations Spatial Reference Systems

Global 30 Second Elevations - it
|nland Water Area v Set Background Transparent 2?('1""“3' sle"’“ Parameters
itional parameters as
. EXP;""/("";"“ Layer ltems —e | Expand Collapse Number of ¥ pixels: |512 : outlined in WMS abstract

xpand or collapse items in Desaription: -
the layer tree - - == Set Back qT
Abstract: VRF Narrative Table for Depth Contours™ A 9 P
Description ———e Specify Spatial Filter... Toggle background

An abstract of the layer that
may include metadata
definitions

Depth contours (BEQ 15) were derived from digital
bathymetric data provided by Defense Mapping Agency.
Depths are expressed in the following intervals: 200, 500, ¥

Show Preview

— 360.00 deg —

Preview

Toggle thumbnail preview
of WMS image. Spatial
extents displayed around it.

Upper Left: (-180.00, 89.92) Lower Right: (180.00, -78. 11)

Image Placement: (®) Embed

Set output folder for image:

[] write reference file:
World

O Lk | @

=i WUsers\Mikel \AppData Lol Temp\Avenzzs\ | |

transparency on import

— Number of X Pixels

Input number of X pixels to
change output image size.
Image is resized proportionally.

Specify Spatial Filter - Import
data based on a specified
geographic bounding box

Set output folder forimage

Image Placement
Choose to have the image embedded
or linked in the document
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Check to enable and
browse to a location to
save the image.
Optionally, check Write
reference file to include a
reference file with the
output image.
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Spatial Databases

A geodatabase is a native Esri ArcGIS data format for storing geographic data. It is a collection of geographic
datasets of various types and managed in either a file folder structure or a relational database, such as:

- Feature classes of points, lines, polygons and annotation for discrete features
- Feature datasets (group of feature classes)

«  Descriptive attributes stored in tables

«  Raster datasets and raster catalogs for imagery

MAPublisher can import several types of Esri geodatabases:

File User Size RDBMS Esri Licensing ~ MAPublisher
extension  access limit Technology (create)* Import access
Arcinfo

Personal geodatabase .mdb Single 2GB Microsoft Access ArcEditor Folder browser
(Jet Engine) ArcView

Arcinfo
File geodatabase .gdb Single 1T8B No RDBMS - uses ArcEditor Folder browser
local file structure

ArcView
ArcSDE Desktop Multiple SQL Server ArcGIS Engine ArcSDE server
geodatabase ) (limited) 4GB Express Arcinfo connection
(called Personal in 9.2) P ArcEditor
ArcSDE Workgroup Multiple SQL Server ArcGlIS Server ArcSDE server
- L 4GB -
geodatabase (limited) Express Workgroup connection
DB2
ArcSDE Enterprise Multiple Depends Informix ArcGIS Server ArcSDE server
eodatabase ) (unlimited) on the Oracle Enterprise connection
9 server PostgreSQL P
SQL server

*For all geodatabases, an ArcEngine license is the minimum requirement for direct read of vector and raster data.

MAPublisher has the capacity to import all types of geodatabases (categorized as Personal, File and ArcSDE
geodatabases). The connection to an ArcSDE server requires server access, user account and versioning information
to be provided by the database administrator. These parameters are exactly the same required to establish a
connection using Esri ArcCatalog—with a small exception for SQL Server Express connections, explained later on in
this chapter.

Once imported into Adobe lllustrator, data does not maintain a link with the original database and database
functions are not valid (topology, table/feature class relationships, subtypes and attributes domains rules). However,
MAPublisher can make use of the geodatabases spatial and non-spatial relationships, subtypes and attribute
domains information during the import process (to populate layer names and attributes).

The following sections include how to:

Import Personal and File Geodatabases

Import Using Basic Personal or Basic File Geodatabase Reader (Mac supported)
Import Esri ArcSDE Geodatabases

Import from Basic Esri ArcSDE server
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SOFTWARE REQUIREMENTS

Esri ArcGIS 9.x or newer must be installed and licensed to be able to fully import Esri geodatabases or to fully access
an ArcSDE server (up to ArcGIS 10.0 only) using MAPublisher Import and Multiple Data Import. At minimum, an
ArcGlIS Engine Runtime must be installed. More commonly, higher licenses that may be used are ArcView, ArcEditor
and Arclnfo.

Only 32-bit applications can use the Esri ArcSDE geodatabase connection. Direct access to feature classes on an
ArcSDE Server requires, at minimum, ArcReader (available for free). However, File and Personal geodatabases cannot
be read using ArcReader. With this license configuration, access to files with a Basic Esri ArcSDE Server connection

is limited compared to a Esri ArcSDE Geodatabase connections (explained further in this chapter). MAPublisher
supports all ArcSDE server connections and SQL queries supported by Esri.

The MAPublisher Basic Personal Geodatabase Reader and Basic File Geodatabase Reader does not require an ArcGIS
licenses for Windows and is compatible with Mac. However, this means that some import functions are limited in
use (explained further in this chapter).

Notes: MAPublisher supports ArcGIS 9.2 and newer geodatabases. However, there are some limitations to the direct
connections from 9.2 clients to the ArcSDE 9.3 geodatabases. Please refer to Esri documentation on software

requirements (service packs) and limitations.

To use ArcGIS 10.0 geodatabases with MAPublisher, a licensed installation of ArcGIS 10.0 is required. Having a
valid installation allows for backwards compatibility with geodatabases created by ArcGIS 9.2 and newer.

Basic File Geodatabase Reader is supported on Adobe lllustrator CS6 and higher (Mac and Windows) 64-bit
installations only. Esri file geodatabase libraries used in MAPublisher are only available in 64-bit.

If ArcReader is not installed on the default installation directory, it might be necessary to edit the binary
location in the MAPublisher Preferences, Basic Esri ArcSDE Server Editor (see chapter 1).

When importing geodatabase features, unicode characters in path names are not supported.

SUPPORTED FEATURES
Data Types
The following is a list of supported and unsupported geodatabase geometry types for import in MAPublisher:
Supported Unsupported
Point Raster
Polyline Grids
* Uponimport, MAPublisher converts an Polygon MultiPatch
arc to aline where a series of vertices will ~ Circular Arc* Dimensions
maintain the geometry. Elliptical Arc*
Bezier Curve
* Uponimport, MAPublisher converts Annotations*

mult_lipa[t annotation into <group> objects . L .
Note: To import a geometry type that requires the use of a Representation in ArcGIS (such as Bezier curves), the

Behavior when Representation Geometry is Edited must be set to Change the geometry of the supporting
feature—option specified when creating a new Representation in ArcGIS.
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Aliases

ArcGlIS users can give the feature classes an alias that acts as an alternate name. Unlike feature class names, aliases
can contain spaces, punctuations, and start with a number. In ArcMap, feature classes are referred to with their alias
name. In ArcCatalog, feature classes are represented by their true names.

Specify to use aliases for layer names in the MAPublisher Preferences for Spatial Database > Esri Geodatabase Editor:

> L General
> [#] Import Map Data
> [E MAP Attributes
MAP Crop Tool
MAP Info Panel
@ MAP LabelPro
> [F] MAP Locations
€ MAP Measurement
> [ MAP Selections
K] MAP Tagger Tool
T MAP Themes
> @ MAP Views
(@ Online Maps

MAPublisher Preferences
Spatial Database > Esri Geodatabase Editor
Use alias as layer name
[] use abbreviated table name for layer name
Display coded domain/subtype description: Instead
[ Load subtypes ac separate layers
[] Sort feature datasets alphabetically when selecting for import
[[] Sort feature dasses alphabetically when selecting for import
[] Sort attributes alphabetically when selecting for import
[ Automatically connect to:

Number of paints to use to spedify a spatial fitter bounding box: | Twa (opposite corners)

Cancel

% Raster Georeferencing
4 [ Spatial Database
7] Basic Esti ArcSDE Server Editor

[ Esri Geodatabase Editor

[=] General Spatial Database Editor .

Reset 'Do not chow agsin' preferences

Note: Aliases for attribute field names are imported as Display Name and true field names as Name of MAP
Attributes columns.

Subtypes and Attribute domains

Subtypes are particular attribute fields made to create groups of records in a feature class that share the same types
of properties. The attribute fields designated as subtype fields contain numerical coded values and have a data type
of short or long integer. Each coded value is associated with a description (textual). In the MAPublisher Preferences
for Spatial Database > Esri Geodatabase Editor, users may choose to load subtypes as separate layers.

Attribute domains are used to constrain the values allowed in any particular attribute of a feature class (or subtypes).
There are two types of attribute domain:

«  Arange domain limits the value of a numerical attribute in between minimum and maximum values —
range domains are not relevant to MAPublisher.

« A coded value domain specifies a valid set of coded values for an attribute (of any type — text, numeric
or date). Both coded values and their meaningful description are stored in the database.

In the MAPublisher Preferences for Spatial Database > Esri Geodatabase Editor, users can set the option to import
attributes with coded values from subtypes and attribute domains as follow:

«  Instead: replace the codes by their description (text)

«  Never:import the actual values (code)

«  InAddition: create two attribute columns, one containing the coded values and one containing the
corresponding descriptions.
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Spatial Filters

During the import process, users can enter two opposite corner coordinate points in any coordinates system unit to
limit the geographic area for the data being imported (see next section).

Note: When importing a feature class that has no art it is considered to have invalid extents and a spatial filter
cannot be created.

SQL Queries

During the import process, users can use SQL queries on feature classes and tables to limit the objects and
attributes to be imported.

Multiple feature classes can be imported using multiple SQL statements as long as all classes share the same source
coordinate system. SQL queries can also be used to import a feature class and the attribute information from a
related non-spatial table. To apply SQL queries on multiple feature classes with different source coordinate systems,
use Multiple Data Import and add the feature classes in several Add sessions (see chapter 3 for more information on
the Multiple Data Import).

MAPublisher uses Esri libraries to run SQL queries. Please refer to Esri documentation for more information on
supported SQL expressions and syntax—it may vary depending on the geodatabase and database server type.

Non-Spatial Relationships

MAPublisher supports non-spatial relationships between feature classes and tables during the import process using
SQL queries. Here are some examples:

Query Result

Import and inner join a feature class to a related table (only

»  SELECT * FROM Feature_Class,Table WHERE FeatureClass.ld=Table.ld . . )
features with entries in the related table are imported)

» SELECT * FROM Feature_Class,Table WHERE FeatureClass.id=Tableld | IMmport and inner join a feature class to a related table and

AND Table.Attribute="ABC' app|y a query
» SELECT * FROM Feature_Class WHERE FeatureClass.Id IN (SELECT Import a feature class without joining to a related table, but
Table.Id FROM Table WHERE Table.Attribute='ABC) use a table value to make a query

Note: SQL syntax may vary depending on the database server type.

Once vector data is imported into Adobe lllustrator, the database relationships rules do not apply anymore. It is
however possible to use the MAP Attributes panel Join Table function to join geodatabase tables with MAPublisher
vector data. For more information, please refer to chapter 5.

Note: When the non-spatial table information is imported together with the feature class using a SQL query, only
the vector features that have a record in the related table are imported. Import first the feature class and use
Join Table in a second step: all vector features are imported and the related table information is added where
a record match is found. This second option might be recommended if the database is not well known.
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IMPORT PERSONAL AND FILE GEODATABASES

Import or Multiple Data Import > Add

Import Browse - Opens a Select dataset
browser. File Geodatabases have

Format -SE|EF; Esri FIIIeGGerc;ta:aSe —e Format: | Esri File Geodatabase [*.gdb] - | | oK the extension gdb and Personal
or Esri Personal Geodatabase.
| Folder: stabase\FileGeodatabases\New York City.gdb | | Browse... Geodatabases have mdb.
<Auto detect format> can only be i e .8 - s
used for Personal Geodatabases. /-] Feature Classes STREET CENTERLINE, SHORELINE Feature Classes - Click to choose which
feature classes will be imported
 Data loaded successflly. O o

FUNCTIONALITY

Esri Personal and File geodatabase feature classes can be imported using Import or Multiple Data Import. The

file selection is done in two steps: 1) select the database (mdb file for Personal geodatabase, a gdb folder for File
geodatabase); 2) select feature classes directly or through an SQL query. Optionally, define a spatial filter to limit the
geographic extents of the data being imported.

When feature datasets are present in the database, MAPublisher uses them to group feature classes per parent
feature dataset to ease the selection process, but feature datasets are not imported as such. The feature dataset
name may be prefixed to the name of the data layer created during import (using an import setting).

For each format, multiple feature classes sharing the same source coordinate system may be selected at once in
the Import or Multiple Data Import > Add dialog box. To import feature classes that do not have matching spatial
reference, use Multiple Data Import and add the feature classes in several Add sessions (see chapter 3 for more
information on Multiple Data Import functionality).

The feature classes (objects and attributes) are imported on separated MAP layers. The layer naming convention is
set in the MAPublisher Preferences for Spatial Databases > Esri Geodatabase Editor.

USING IMPORT ESRI PERSONAL AND FILE GEODATABASES

In the Import or Multiple Data Import > Add dialog box, set the Format drop-down list to Esri Personal Geodatabase or
Esri File Geodatabase. Using <Auto detect format> only works with Personal geodatabases (File geodatabases cannot be
detected because they are directories). The Settings are described in chapter 3. Click the Browse button and select

a file with the extension mdb (Personal geodatabase) or a directory with the extension gdb (File geodatabase)— only
one geodatabase can be accessed at a time. Click Open to open the Select Feature Classes dialog box where specific
feature classes can be imported.
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Select Feature Classes

In the Select Feature Classes dialog box, import one or more feature classes or build SQL queries to select subsets of

feature classes. Click the names of the feature classes to select them for import—selected classes are highlighted. To

deselect a class, click the selected name again.

Select Feature Classes - Click one or more —e @) Select Feature Classes:

Select Feature Classes

feature classes to import, only classes STREET_CENTERLINE

ELEVATION

Cancel

sharing the same original coordinate
HYDRO

system (spatial reference) can be

. OPEN_SPACE
imported together "

PAVEMENT_EDGE

RAILROAD

ROADBED

SHORELINE

building_0609
STREET_CENTERLINE_Clip
STREET_CENTERLINE_ClipAnno

Specify Spatial Filter- Click this button to
open the Specify Spatial Filter dialog box ———eSpedify Spatial Fiter...
O 5QL Query:

SQL Query - Click this option to access —

the Create SQL Select Query dialog box

Create SQL Select Query...

Specify Spatial Filter

A spatial filter consists of a rectangle that defines the extents of imported data. Use extents of an existing MAP
Layer from the drop-down list or enter new coordinates values manually. When setting points manually, enter

two opposite corner coordinates that represent the actual extent of the data. When MAP Locations exist on the
document, it is possible to use them to specify corner coordinates. If required, click the Input Coordinate System

link to use an alternate coordinate system for the inputs.

Relationship - Relationship type affects how the spatial
filter boundary interacts with imported feature classes

Specify Spatial Filter

Use extents of layer - Choose an existing
MAP Layer and click Update to use its
spatial extents as the spatial filter

Relationship: (®) Intersects () Contains (_) Crop to Filter

Set Filter Extent:
Set points manually - Enter two opposite I
corners of the spatial filter boundaries ——e(®) set paints manually

Input Coordinate System - Coordinate ————e Input Coordinate System: MADS3 / New York Lona Island (ftS)
system specified for entering the filter

coordinates (if different from source) C=

o X 912500.000116

Corner - Specify Xand Y ———
coordinates to use as a corner
of the spatial filter

o ¥ 117500,000286

Opposite Corner:
o X: | 1062450.140175

Opposite Corner - Specify X and Y ———
coordinates to use as the opposite
corner of the spatial filter

& Y: | 274322.516365

Cancel

Reset

uft | g MAP Locations - Choose

usft | & predefined MAP
Locations or Artboard
locations (corners)

The Relationship type affects how the spatial filter boundary interacts with imported features:
« Intersects: import objects that intersect the extents of the spatial filter
- Contains: import objects fully contained within the extents of the spatial filter
«  Crop toFilter: includes only features that are cropped to the spatial extent
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Create SQL Select Query

An SQL statement can be built to limit the number of objects and attributes imported from a single feature class.
The SELECT clause should always contain one and one only "Shape" object (actual spatial feature). When possible,
use the operator button to add formatted query statements (including spaces), to limit the typing errors.
For example:
- Infeature class "FC_Point", import all points and the "Valve" attribute (other attributes are not imported).
» SELECT FC_Point.Shape, FC_Point.Valve_ID FROM FC_Point
« Infeature class "FC_Line", import lines (vector only) that have the attribute "Id" equals to 1, 2, 3 or 4.
» SELECT FC_Line.Shape FROM FC_Line WHERE FC_Line.ld IN (1,2,3,4)

It is recommended to use the Validate button to verify the query syntax prior to import.

Multiple feature classes can be imported using multiple SQL statements separated by a semi-colon (;) as long as all
classes share the same source coordinate system. SQL queries can also be used to import a feature class and the
attribute information from a related non-spatial table (see previous section). To perform SQL queries on multiple
feature classes with different source coordinate systems, use the Multiple Data Import and add the feature classes in
several Add sessions (see chapter 3 for more information on the Multiple Data Import).

Recently used SQL queries are saved and accessed by clicking the Recent button. The number of recent queries
saved is set in the MAPublisher Preferences on Spatial Database > General Spatial Database Editor (see chapter 1).

Create-SQL Select Queny 0O

p - Click an operator button to

: + add the corresponding formatted text

SQL Query Editor - Type inan || SELECT | [FROM | [WHERE | [IN | | LIKE e 12 (including spaces) to the query

SQL query. The SQL syntax SELECT Capitals.Shape FROM Capitals WHERE Capitals.CITY_POP > 50000
must be compliant with
the DBMS server in use.

One and one only "Shape" ———

field must be specified in Recent... &pF——
the SELECT clause.

Cancel

Recent - Opens a list of recent SQL
statements (see also MAPublisher
Preferences on Spatial Database > General
Spatial Database Editor - chapter 1)

Validate _e————Validate - Click to verify the query syntax
Selection - Select a feature

class name or attribute Select Feature Class or Attribute name:
and double-click or click > [E Buittup_areas ~| [add to Query
Add to Query to add it 4[] Capitals
to the SQL Qu);ry Editor i Shape e—————————Add to Query - Select a feature class name
above. Attribute alias ——— OBJECTID or attribute and click this button to add
- X [ LOCAL_NAME the item the SQL statement
names are indicated in 5 ENG_NAME
parenthesis. B cAT
[E ciry_pop | v Select recent SQL query
When creating a query, it is necessary to specify a single "SHAPE™ field in the select dause,
Specify Spatial Filter - Opens To specify multiple SQL queries, separate them using a semicolon(:). SELECT Primary_spot_elev_pts.Shape FROM Primary_spot_elev_pts oK
the Spatial Filter dialog box —— specify spatial Fiter... SELECT Capitals.Shape FROM Capitals WHERE Capitals.CITY_POP

¢ Cancel
(see previous page)

< >

Delete - Click to delete———  Delet=
recent SQL queries
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IMPORT USING BASIC PERSONAL OR BASIC FILE GEODATABASE READER

Format - Choose Basic Personal ——
Geodatabase Reader
This works in both Windows and
Mac without an ArcGlIS license.

Import or Multiple Data Import > Add

Import

T~ Format: |Basic Personal Geodatabase Reader [*.mdb] > 1 OK

Filename: se|PersonalGeodatabases\Subdivision.mdb

Cancel

Browse - Opens a Select dataset
browser. Only file geodatabases with
. gdb extension can be chosen.

|7] Feature Classes Click to choose Feature Classes

@ Youmust choose at least one Feature Class. = Advanced

Feature Classes - Click to choose which
feature classes to import

Format - Choose Basic File ——
Geodatabase Reader. This works in
both Windows and Mac without
an ArcGlS license, although only
geodatabases created with ArcGIS
10 or higher are supported.

FUNCTIONALITY

Import

—e Format: | Basic File Geodatabase Reader [*.adb] - oK

. Folder: :e\ArcGIS10'FileGeodatabaseMelbourne.gdb

Browse - Opens a Select dataset
browser. Only file geodatabases with
. gdb extension can be chosen.

Feature Classes - Click to choose which

|| Feature Classes Mountains, Physiography

+” Data loaded successfully, ) Advanced

feature classes to import

Esri Personal and File geodatabase feature classes can be imported using Import or Multiple Data Import. The main

difference between these basic geodatabase readers and the Esri Personal Geodatabase and Esri File Geodatabase

format is that the basic geodatabase readers are available without an installed ArcGIS license and work on both Mac

and Windows.

Both Basic Personal Geodatabase Reader and Basic File Geodatabase Reader can import feature classes. The file

selection is done in two steps: 1) choose the geodatabase (mdb or gdb); 2) select feature classes directly or through

an SQL query. Optionally, define a spatial filter to limit the geographic extents of the data being imported.

Both Basic File Geodatabase Reader and Basic Personal Geodatabase Reader have several limitations:

. Feature datasets are

not supported

- Relationships (intersect/contains) in spatial filters are not supported
« Domain or subtypes are not supported
«  Feature classes that are in coordinate systems with unrecognized EPSG codes are not supported

The Basic File Geodatabase Reader has further limitations:
«  Only ArcGIS 10 and higher file geodatabases are supported
+  Arcs are not supported - arcs will be imported as straight lines based on its vertices
«  SQL queries on unicode tables or attribute names is not supported
«  Bezier curves are not supported - curves will be imported as straight lines based on its vertices.
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USING BASIC PERSONAL OR BASIC FILE GEODATABASE READER

In the Import or the Multiple Data Import > Add dialog box, in the Format drop-down list, choose Basic Personal
Geodatabase Reader or Basic File Geodatabase Reader. Click the Browse button and select a geodatabase file with the
extension mdb (Personal geodatabase) or gdb (File geodatabase)—only one geodatabase can be accessed at a time.
Click the hyperlink to open the Select Feature Classes dialog box to choose specific feature classes for import.

Note: Forward slash "/" in paths are not supported in Windows, but are supported on Mac.

Select Feature Classes

In the Select Feature Classes dialog box, directly import one or more tables or build SQL queries to select attributes of
tables. To directly select tables, click the names of the table to import—selected tables are highlighted. To deselect a
table, click the selected name again.

Note: Text layers in a geodatabase are seen as areas in the Select Tables dialog box, but are imported as text.

Specify Spatial Filter and Create SQL Select Query

The Specify Spatial Filter and Create SQL Query functions similarly to importing an Esri Personal Geodatabase or Esri File
Geodatabase (see previous section, Import Personal and File Geodatabases).
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IMPORT ESRI ARCSDE GEODATABASES

Import or Multiple Data Import > Add

Import

Format - Select Esri ArcSDE Geodatabase. Format: |Esri ArcSDE Geodatsbase v | [ Database - Choose an ArcSDE
<Auto detect format> cannot be used. ) Dateb Connected to UtshGISPortal geodatabase to connect to

Cancel
|=| Feature Classes 5GID10.ECONOMY. TaxEntities2010, SGID10.UTILITI.. e———————— Feature Classes - Choose feature
classes to import

«# Data loaded successfully. =) Advanced

FUNCTIONALITY

Esri ArcSDE geodatabase feature classes can be imported using Import or Multiple Data Import. Importing ArcSDE
geodatabases requires users to create a connection to the database server containing the database. Once a
connection is established, feature class selection is done in the same manner as Personal and File geodatabases—
by direct selection or SQL query (see previous section) and using spatial filters.

The connection parameters to an ArcSDE server are saved with the application. The dataset selections (called MAP
Datasets) are also saved. The maximum number of default MAP Datasets saved is set in the MAPublisher Preferences
for Spatial Database > General Spatial Database Editor. MAP Datasets saved with a specific name (other than the
default one given) are always saved.

Like the other geodatabase formats, multiple feature classes sharing the same source coordinate system may be
selected all at once. To import feature classes that do not have matching spatial reference, use Multiple Data Import
and add the feature classes in several Add sessions (see chapter 3 for more information on Multiple Data Import).

The feature classes (objects and attributes) are imported on separated MAP layers. ArcSDE geodatabase tables
are identified as databaseName.userName.tableName. An abbreviated version using only the table name as layer
name can be applied as a preference. This option and other layer naming conventions are set in the MAPublisher
Preferences for Spatial Databases > Esri geodatabase Editor (see chapter 1 and previous section).

When feature datasets are present in the database, MAPublisher uses them to group feature classes per parent
feature dataset to ease the selection process, but feature datasets as whole cannot be individually imported—only
its individual feature classes can. An import setting allows the feature dataset name to be prepended to the name
of the data layer created during import.
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USING IMPORT ESRI ARCSDE GEODATABASES

In the Import or the Multiple Data Import > Add dialog box, set the Format drop-down list to Esri ArcSDE Geodatabase.
<Auto detect format> does not detect Esri ArcSDE geodatabases. Click the Browse button to open the Browse

ArcSDE Geodatabase dialog box.

The Browse ArcSDE Geodatabase dialog box has options to create, edit and delete connection parameters to ArcSDE

servers. It also stores recently used and saved MAP Datasets.

Connections - List of connections already
created within MAPublisher

Recent/saved MAP Datasets - List of recently
used and saved MAP Datasets

Create new - Opens the Create new ArcSDE ———

Geodatabase Connection dialog box.

Select Connection or MAP Dataset:

Browse ArcSDE Geodatabase

4 Connections

[ArcSDE Connection

Recent/saved MAP Datasets

Edit
« If a connection is selected, it opens
the Edit ArcSDE Geodatabase

Connection dialog box

« If a MAP Dataset is selected, it opens
the Edit ArcSDE Geodatabase MAP
Dataset dialog box

% create New...

Esri ArcSDE Geodatabase Connection

Copy - Copy the selected ArcSDE connection

— Delete - Delete the selected ArcSDE

connection or MAP Dataset

In MAPublisher, apply the same connection parameters as in an Esri application (such as ArcCatalog):

Connection Settings - Specify the
connection settings: Connection Name,
Server, Service and Database Name as i
specified in the database Connection [ | Server:
Properties in Esri ArcCatalog : Service:

See next page for specific details for SQL
Server Express connection (Desktop and
Workgroup Geodatabases)

. ge User name:
Database Authentication - Enter user
name and password provided by the Password: | eees
database administrator [[] Check if you want MAPublisher to remember your password.

Create New ArcSDE Geodatabase Connection

Connection Name: ‘ArcSDE Server Connection

sde.server.com
5151

: Database Mame:  arcsde_db_name

——*®) Database authentication

Operating System Authentication ——s_) Operating system authentication

The server connection uses
Windows authentication. The user
must be logged into Windows
with a login name that is also
valid on the database server.

Transactional Version: | sde.DEFAULT

Test Connection

!

Connection Details - Specify the transactional or historical
version to be accessed. The interface lists the existing
versions for the database.

Information to be provided by the database administrator.

Flease spedify the details of this connection.

@) This connection refers to a transactional version

Version Name Version Description

sde . DEFAULT Instance default version,

(71 This connection refers to a historical version

Connect using a historical marker.
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Important Note for SQL Server Express Users

There is an exception for connections to SQL Server Express servers — ArcSDE Desktop (called Personal in
ArcGIS 9.2) and Workgroup geodatabases. In ArcCatalog, users set a "Database Servers" connection where only
the server name followed by \sglexpress is required to establish a connection. In MAPublisher, there is no specific
interface for SQL Server Express connections, the same interface as for the other types of ArcSDE geodatabases
must be used with specific settings:

Server

Service

Database na

Operating System
Authentication

Select MAP Datasets

me

Name of the server followed by _ SQLEXPRESS

The server name must be preceeded by sde:sqglserver and
followed by \sglexpress (e.g. sde:sqlserver:ServerName\sqlexpress)

The name of the database must be known

Must use this to authenticate SQL Server Express databases

To make a new selection of feature classes from an ArcSDE geodatabase, click a connection name on the Connections
tree of the Browse ArcSDE Geodatabase dialog box and click OK. This opens the Select Feature Classes dialog box. This
dialog box for ArcSDE geodatabases is very similar to the Select Feature Classes dialog box of Personal and File
geodatabases described in the previous section: users can directly select one or more feature classes (provided that
they share the same spatial reference) or build an SQL query to select a subset of some feature classes and apply
spatial filters. The difference with ArcSDE geodatabases is that the feature class selection is saved as a MAP Dataset.
Type in a MAP Dataset name for the selection at the top of the dialog box.

Feature dasses - Click one or more —
feature classes to import - only classes
sharing the same original coordinate
system (spatial reference) can be
imported together

Specify Spatial Filter- Click to open the
Specify Spatial Filter dialog box. See
Import Personal and File Geodatabases.

SQL Query - Click to access the Create SQL —
Select Query dialog box. See
Import Personal and File Geodatabases.

Select Feature Classes

MAP Dataset: | ArcSDE City Data

—e(®) Select Feature Classes:

h— - -

Cancel

sde.SDEMeTwp24Rayna
sde.SDE.CountyRayna

sde.SDE.BuildingPolygonsRayna

sde.SDE.boatinchORayna
sde.SDE.cnty241Rayna
sde.SDE.cnty24pRayna
sde.SDE boatinch4
sde.SDE.HydrographyCopy1
sde.SDE.County
sde.SDE.BuildingPolygons2
sde.SDE.boatinch02
sde.SDE.cnty24118
sde.SDE.cnty2dp25
sde.SDE. Test
sde.SDERETIRED_PRIMARY_CONTROL_POINTS

———e Specify Spatial Filter...
— () SQL Query:

Create SQL Select Query...

— MAP Dataset - Type a name for the selected

dataset (by direct selection or SQL
query). This name will be displayed in
the Recent/saved MAP Dataset list of the
Browse ArcSDE Geodatabase dialog box.

The number of default recent MAP
Datasets saved is set in the MAPublisher
Preferences for Spatial Database > General
Spatial Database Editor.
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In the Browse ArcSDE Geodatabase dialog box, click a MAP Dataset in the Recent/saved MAP Datasets tree. The MAP Dataset
name and connection can be changed in the Edit Ar¢SDE Geodatabase MAP Dataset dialog box.

MAP Dataset - Edit the name of the
MAP Dataset. It will be displayed in
the Recent/Saved MAP Dataset list
of the Browse ArcSDE Geodatabase
dialog box.

Connection - Set the name of the
connection to use to access a dataset

SQL Query - SQL query used to select the
data features (when used) :

Spatial Filter - Spatial filter used to limit ‘_—‘

the import extents (when used)

[T MAP Dataset:

TT® Connection:

Feature Classes:

SQL Query:
Spatial filter:

Edit ArcSDE Geodatabase MAP Dataset

ArcSDE City Data

ArcSDE Connection -

sde.SDEBuildingPolygonsRayna

None
None

Feature Classes - List of
selected feature classes

The maximum number of recent MAP Datasets saved with the default name is set in the MAPublisher Preferences
for Spatial Database > General Spatial Database Editor (user named datasets are saved until deleted).

Settings

Spatial database parameters can by clicking the Settings button in the Import or Multiple Data Import > Add dialog
box. These settings are described in chapter 3. Optionally, prefix the feature dataset names to the layer name

created on import.

Access it by going to MAPublisher Preferences > Spatial Database > Esri Geodatabase Editor

> L General
» [#] Import Map Data
> [E] MAP Attributes
[E MAP Crop Tool
[l MAP Info Panel
& MAP LabelPro
» [F#] MAP Locations.
@ MAP Measurement
> & MAP Selections
@ MAP Tagger Tool
T MAP Themes
> @ MAP Views
@ Online Maps
% Raster Georeferencing
4 () Spatial Database
[ Basic Esri ArcSDE Server Editor

[ Esri Geodatabase Editor

E General Spatial Database Editor

Reset Do not show again’ preferences

MAPublisher Preferences
Spatial Database > Esri Geodatabase Editor

Use alias as layer name

Cancel

[[] use abbreviated table name for layer name
Display coded domain/subtype description: Instead
[] Load subtypes as separate layers

[] sort feature datasets alphabetically when selecting for import

[] sort feature classes alphabetically when selecting for import

[] Sart attributes alphabetically when selecting for impart

[ Automatically connect to:

Mumber of points to use to specify a spatial fiter bounding box: | Two (opposite comers)
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Use iated table name for layer name
ArcSDE Geodatabases' tables

are identified as databaseName.
userName.tableName. The
abbreviated version uses only the
table name as layer name.

If this option is used in combination
with the "use alias" option, the alias is
applied first.



IMPORT FROM BASIC ESRI ARCSDE SERVER

Import or Multiple Data Import > Add

Format - Choose Basic Esri ArcSDE Server
<Auto detect format> cannot be used.

Import

T Format: | Basic Esri ArcSDE Server

Database Connected to ArcSDE Basic Connection

|=| Tables SDE.SDE.SOMERSETCOUMTY

" Data loaded successfully.

- OK
Cancel ) .
Browse - Opens the Browse Basic Esri
ArcSDE Server dialog box

FUNCTIONALITY

Users who do not have an ArcGlIS license can install ArcReader, a free Esri desktop application (www.esri.com). Only

ArcSDE geodatabases can be read, File and Personal geodatabases are not supported using this format. In addition,

file access with a Basic Esri ArcSDE Server connection is limited compared to a Esri ArcSDE Geodatabase connection:
«  Aliases, sub-types and attribute domains are not supported — only true names and actual values

(codes) are imported.

«  Feature datasets are not recognized. Feature classes are all listed on the same level, they are not
grouped by feature dataset.

«  Feature classes are referred to as "tables"

«  Operating System Authentication is not supported.

USING IMPORT BASIC ESRI ARCSDE SERVER

In the Import or the Multiple Data Import > Add dialog box, set the Format drop-down list to Basic Esri ArcSDE Server.
<Auto detect format> does not detect Esri ArcSDE geodatabases. Click the Browse button to open the Browse Basic

ArcSDE Geodatabase dialog box.

The Browse ArcSDE Geodatabase dialog box has options to create, edit and delete connection parameters to ArcSDE
servers. It also stores recently used and saved MAP Datasets.

Connections - List of connections already
created within MAPublisher

Browse Basic ESRI ArcSDE Server

Select Connection or MAP Dataset:

4 Connections

ArcSDE Basic Connection

Recent/saved MAP Datasets - List of recently
used and saved MAP Datasets

Create new - Opens the Create new Basic—— Create New...

ArcSDE Server Connection dialog box.

Recent/saved MAP Datasets

Copy... Delete

OK

Cancel

« If a connection is selected, it opens
the Edit Basic Esri ArcSDE Server
Connection dialog box

« If a MAP Dataset is selected, it opens
the Edit Basic Esri ArcSDE Server MAP
Dataset dialog box

Copy - Copy the selected ArcSDE connection

i Delete - Delete the selected ArcSDE
: connection or MAP Dataset
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Basic Esri ArcSDE Server Connection

In MAPublisher, apply the same connection parameters as in an Esri application (such as ArcCatalog):

Connection Settings Create New Basic ESRI ArcSDE Server Connection
Connection Name, Server, Service and
Database Name as specified in the database : Connection Name: | ArcSDE Basic Connection
Connection Properties in ArcCatalog g )
: Server: sde.server.com E=
See next page for specific details for SQL Service: 5151
Server Express connection (Desktop and H . . .
P ( P : Database Name: | arcsde_db_name Version - Enter the transaction
Workgroup Geodatabases) L N .
Version: e———————— version information provided by
the database administrator.
3 ¢ User Name: user
User Name / Password - Specify
authentication information provided by : Password: el Unlike ArcSDE Geodatabases, the
the database administrator [] Check if you want MAPubisher to remember your password. ArcSDE server interface does not list
the versions existing in the database.
Test Connection Test Connection - Tests the connection
parameters prior to accessing datasets.

Note: If ArcReader is not installed in the default installation directory, it may be necessary to edit the binary
location in the MAPublisher Preferences > Basic Esri ArcSDE Server Editor (see chapter 1).

Important Note For SQL Server Express Users

Some specific settings are required for SQL Server Express connections. See Esri ArcSDE geodatabase connection.

Select Tables

Feature classes are referred to as tables using the Basic Esri ArcSDE Server. In the Select Tables dialog box, directly
import one or more tables or build SQL queries to select attributes of tables. To directly select tables, click the names
of the table to import—selected tables are highlighted. To deselect a table, click the selected name again.

Note: Text layers in a geodatabase are seen as areas in the Select Tables dialog box, but are imported as text.

Select Tables

MAP Dataset: | County Data 0—@—— MAP Dataset - Type a name for the selected

Select Tables - Click one or more tables to —— @ select Tables: dataset (by direct selection or SQL

Cancel ; i i i
import. Only tables sharing the same SDESDE HANCOCKCOUNTY 2 Recent soved MAP Datases 1k o she ronse
original coordinate system (spatial SDE.SDELINCOLNCOUNTY N >

reference) can be imported together. SDESDE OXFORDCOUNTY Basic ArcSDE Geodatabase dialog box.
SDE.SDE.PENOBSCOTCOUNTY
SDE.SDE.PISCATAQUISCOUNTY The number of default recent MAP Datasets
SDE.SDE.SAGADAHOCCOUNTY saved is set in the MAPublisher Preferences
SDE.SDE.SOMERSETCOUNTY for Spatial Database > General Spatial
SDE.SDE.WALDOCOUNTY Database Editor.

SDE.SDEWASHINGTONCOUNTY
SDE.SDE.YORKCOUNTY
SDE.SDE.AROOSTOOKCOUNTY

Specify Spatial Filter- Click to open the SDE.SDE.METWP24

Specify Spatial Filter dialog box. See SDE.SDE FMEPERFS

Import Personal and File Geodatabases. SDE.SDE.FMEPERFS
SDE.SDE.CANADA v

e |Specify Spatial Filter...

SQL Query - Click to access the Create SQL —* () 5QL Query:
Select Query dialog box. See Create SQL Select Guery...
Import Personal and File Geodatabases.
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Geospatial PDF Import

FUNCTIONALITY

Geospatial PDF Import is an easy way to import a geospatial PDF into Adobe lllustrator using MAPublisher. Its
purpose is to import map data and organize information into MAP Layers in a MAP View.

PREREQUISITES

MAPublisher supports geospatial PDF documents generated from MAPublisher and Geographic Imager. It also
supports third-party georeferenced PDF documents (e.g. from ArcGIS and TerraGo).

USING GEOSPATIAL PDF IMPORT
Begin to import a geospatial PDF from the File > Open menu. Browse for a geospatial PDF document and click Open.

The Select PDF Import Method dialog box will open.

Select PDF Import Method

The Select PDF Import Method contains two options for import: Simple and Advanced.

Select PDF Import Method

(@ Import to a single layer (Simple PDF Import):

The PDF will be imparted to a single layer maintaining
referencing, however attributes will be lost. Use this
method if you are experiencing incorrect layer order using
the advanced method.

(C) Import and split into layers (Advanced PDF Import):
The PDF will be imported and MAPublisher will separate art
to its respective layer, maintaining attributes and
referencing. If you experience any issues with layer order
please use the simple method.

==

The Advanced PDF Import method is used to separate art to its respective layer. This method maintains attributes
and referencing. It will open the Layer Assignment dialog box so that layers in the PDF can be assigned a
MAPublisher feature type and a MAP View. In most cases, it is recommended to use Advanced PDF Import.

The Simple PDF Import method should be used if any layer order issues are caused by the Multiple Data Import.
This method imports features to a single MAP View and Adobe lllustrator layer. This method maintains referencing,
however all attribute information will be lost.
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Layer Assignment

When Advanced PDF Import is used, it will open the Layer Assignment dialog box. It is used to assign the data
structure found in a geospatial PDF to the appropriate Feature Type and a MAP View. It contains three columns:
Layer, Feature Type and MAP View. In the Feature Type column, the <Auto-detect> option automatically chooses
the appropriate feature type (Area, Point, Line, Image, Text or Legend) to assign each layer. Alternatively, click a
Feature Type cell to assign a layer to the appropriate feature type (or to None for no feature type). Layers can be
assigned to the Layers MAP View or to a Non-MAP Layer. Click OK to accept the layer assignments.

To assign the default layer assignments, click the Use Default button. Any changes made to the Feature Type and
MAP View will not be used—it will use <Auto-detect> and the default MAP View.

Layer Assignment
Layer Feature Type MAP View
+ Layers L <Auto-detect> @ Layers Use Default
+# Toronto boundary Line @ Layers
« Expressway - 400s 4 <Auto-detect> @ Layers
 lines_Expressway Ramp L <Auto-detect> @ Layers
« Expressway - string Huys 4 <Auto-detect> @ Layers
& Expressway - Gardiner L <Auto-detect> @ Layers
« Expressway - DVP 4 <Auto-detect> @ Layers
+ Other U <Auto-detect> [A](Non-MAP Layers]  ~
+ Graticule HH Legend @ Layers
+ lines_Major Shoreline L <Auto-detect> @ Layers
« lines_CreekTributary L <Auto-detect> @ Layers
- v

Note: During import, MAPublisher is unable to assign layers to a MAP View when a geospatial PDF does not have
any layer structure to begin with.

NOTES ABOUT GEOSPATIAL PDF IMPORT

Adobe lllustrator does not import layers set to invisible in a PDF document. This situation may happen if layers in
MAPublisher are set to invisible and then exported to PDF. To prevent this from happening, ensure that all layers are
made visible before export to PDF.

In certain cases, point objects may be imported as areas. Depending on how the authoring program created the
PDF will determine how MAPublisher imports point objects. A possible workaround to this is to recreate point
objects or create centroids using the existing areas in MAPublisher. Alternatively, try a different authoring program
to export to PDF.

In certain cases, text objects are imported but every word is broken into independent characters. Resolving this
issue is dependent on how the authoring program creates the PDF.

There are several TerraGo PDF export settings to be aware of. The Layer Menus export option provides a way to
organize a layer listing in a PDF document but has no affect on layer structure. MAPublisher does not use this
option during import. Also, the initial visibility for all layers you wish to import must be set to visible. MAPublisher is
unable to import layers set to invisible by the TerraGo PDF exporter.
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MAPublisher FME Auto and FME FFS Import

FUNCTIONALITY

MAPublisher has two main functions that support FME Desktop:

1. In FME Workbench and FME Universal Viewer, the Adobe lllustrator - Avenza MAPublisher writer provides
export options to convert GIS data into an Adobe Illustrator document, complete with a MAP View and MAP
layers (see next page).

2. In MAPublisher, FME Auto gives the ability to import FME Feature Store (ffs) files.

The combination of MAPublisher FME Auto and the Adobe Illustrator - Avenza MAPublisher writer in FME Desktop
creates a full featured GIS processing and design environment. Use Adobe Illustrator templates with FME Auto

to create an automated workflow from FME Desktop to MAPublisher seamlessly. Use the MAP Theme stylesheet
Auto-Assign option to automatically have your custom styles applied as data is imported into Adobe Illustrator.
Templates and MAPublisher MAP Themes and styles can be prepared in advance.

PREREQUISITES

MAPublisher FME Auto is a separate license that must be activated in MAPublisher License Management dialog box
before use (see chapter 1).

MAPublisher FFS import is available through Import and Multiple Data Import when FME Desktop is installed.
For Adobe lllustrator and MAPublisher 64-bit users, install FME Desktop 64-bit. For Adobe lllustrator and
MAPublisher 32-bit users, install FME Desktop 32-bit. FME Desktop 2014 SP2 is supported.

IMPORTING FME FFS FILES

This is similar to importing other formats (See Import and Multiple Data Import). In Import or Multiple Data Import,
choose FME Feature Store [*.ffs] from the Format drop-down list. Click Browse to select the file(s) to be imported and
then click Open.

Import
Format: |FME Feature Store [=.ff] ~ | & oK.
Filename: |\MAPublisher 9.4\Data\Geometry_Area. ffs Browse... Cancel
¥ Data loaded successfully.
Encoding: |Default System Encoding -
Coordinate System:
VGS 84 8 8 &
Same as:

FFS files can have password protection. To import an FFS file protected by a password, click the Settings button and
enter the password. A warning dialog box will appear if the password is incorrect and a notification that says Unable
to read datasource displays in the import dialog box.
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USING MAPUBLISHER FME AUTO IN FME WORKBENCH AND FME UNIVERSAL VIEWER

FME Workbench is a visual workflow editor used for developing data transformation tools. It is commonly used for
translations between various GIS data types. FME Universal Viewer is a utility that allows you to view data in any
FME-supported format. The Adobe lllustrator - Avenza MAPublisher writer provides export options to convert GIS
data into a new Adobe lllustrator document, complete with a MAP View and MAP layers.

To access the MAPublisher writer in the FME Workbench main window, go to Writers > Add Writer. To access the
MAPublisher writer in FME Universal Viewer, click File > Save Data As. In the Add Writer dialog box, browse for the
Adobe lllustrator - Avenza MAPublisher format.

FME Workbench FME Universal Viewer
. = T
Format - Browse the Writer Gallery to Add Writer - & Select Destination Format and Dataset
select the Adobe lllustrator - Avenza \riter Writer
MAPublisher writer ———eFormat: | Adobe Tiustrator - Avenza MAPUblisher v | Format: | Adobe Ilustrator - Avenza MAPublisher v

Dataset - Browse for the intermediate ———epataset: inza|MaPUbisher 3. 4\Data\Geometry_area. | [.| (0

Dataset: juments\Avenza\MAPUblsher 8.4\Data\Geometry. ffs” | ...
file (ffs) to be translated

Parameters... | Coord. System: | Same as source v [ Parameters... | Coord. System: | Same as source v
Parameters - Specify the destination Adobe
Illustrator file and advanced settings

for MAPublisher FME Auto. Detailed
information about the parameters below.

Workflow Options Help oK Cancel

(®) Static Schema (7) Dynamic Schema

Help oK Cancel

Click the Parameters button to access the Adobe Illustrator - Avenza MAPublisher Parameters dialog box:

+ Adobe lllustrator - Avenza MAPublisher Parameters “
Adobe Illustrator Parameters

Destination: Use FFS Folder

Adobe lllustrator Parameters

Specify initial Adobe Illustrator file
or template to import GIS data to,
the destination Adobe Illustrator
file /folder (where it is saved to) and
how the document behaves (leave
open, save, save and close, or close
without save)

Initial AL File/Template:

Destination AI File/Folder: | <Unused:>

Document Disposition: |Leave open -

Existing Document MAP View .
o——— Existing Document MAP View - Use these

options to fit data to the page and
choose the appropriate setting if a
matching MAP View is found.

Fit to Page After Adding Data

If Matching MAP View Found: | Create new MAP View -

New MAP View Properties (optional)
o———— New MAP View Properties - Optionally,

Other Parameters

Additional options to strip format
attributes, wait for results (stops
on errors), quit Adobe lllustrator

if launched using FME, choose a
different character encoding, and
choose a FFS file compression level
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Load from feature attributes if available
Coordinate System File:
Scale:

Origin: |Lower-eft corner

Other Parameters
Strip Format Attributes
[[] wait For Result from MAPublisher
[[] Quit Launched Tlustrator If Unused
Character Encoding:

FFS File Compression Level: |Mone

use these settings to set a coordinate
system file, set a map scale and the
point of origin (lower-left corner or
center) for the MAP View
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Adobe Illustrator - Avenza MAPublisher Parameters

Initial Al File/Template

Translate data from FME to Adobe Illustrator by using existing Adobe Illustrator file (ai) or Adobe lllustrator Template
file (ait). If no file is set for this option, a prompt will appear to create a new document when the import process
starts in Adobe lllustrator.

Destination Al File/Folder and Document Disposition
After GIS data is successfully imported into Adobe Illustrator, there are several options to handle the document
using the Document Disposition drop-down options:
«  Leave open: After the import process is complete, the Adobe Illustrator document will be kept open
«  Save: After the import process is complete, the Adobe Illustrator document will be saved, but will
remain open.
- Saveand close: After the import process is complete, the document will be saved and then closed.
«  (Close w/o save: Close the document without saving. Recommended use with Fanout Dataset in FME.

To save a document using a specified name, enter it into the Destination Al File/Folder box and set the document
disposition to Save or Save and Close. Alternatively, you can specify only the Initial Al File, in which case it will be
overwritten in the process. When no Destination Al file name or folder is set and the Initial Al file is either a new
document or a template, a prompt at the end of the automation process to specify a file name or folder will appear.

Existing Document MAP View

Fit to Page After Adding Data
Enable this option to scale the data (existing and incoming) to fit to the extent of the art board.

When an existing Adobe lllustrator file contains a MAP View with the same coordinate system as the data being
imported with MAPublisher FME Auto, the If Matching Existing MAP View Found option contains several options to
handle the imported datasets:

«  (Create New MAP View: The datasets will be imported to a new MAP View.

«  Promptthe User: A prompt will appear during the automation whether or not the GIS data should be
imported to an existing MAP View. With this option, user can specify which MAP View to use. This
option is useful when there are multiple MAP Views with the same coordinate system available in the
specified Adobe lllustrator file.

Al data to first matching MAP View: If the specified Adobe Illustrator file has multiple MAP Views with the
same coordinate system, GIS data via FME Automation will be brought to the first MAP View with the
same coordinate system as the one with the GIS dataset being imported.

New MAP View Properties (optional)

Coordinate System File
Choose a coordinate system file (wkt, prj, tab) for the new MAP View.

Scale
Set an initial map scale for the new MAP View.

Origin
Choose a point of origin (lower-left corner or center) for the new MAP View.
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Other Parameters

Strip Format Attributes

When GIS data is converted to FME Feature Store (ffs) format, the FFS file may contain extra attributes to preserve
information of the original data format such as dimension, geometry type, and feature type information. Enable
this option to prevent these attributes from being imported into the Adobe Illustrator document.

Note that FFS retains all the attribute data from its initial sources, which may include source format-specific
attributes, source user attributes, etc. While disabling this option minimizes the amount of data imported, enabling
it may result in better rendering of the original dataset features and allow you to perform stylization in MAPublisher
based on the original source attributes.

Wait For Result from MAPublisher

By default, after sending a request to MAPublisher to perform an import operation, FME does not wait for the
application to complete it and immediately proceeds to the next item. When this option is enabled, the format
writer will wait for MAPublisher to finish its work and report the results to the FME log, rather than having it
displayed in MAPublisher.

Quit Launched Illustrator If Unused

MAPublisher FME Auto starts Adobe Illustrator if it is not running. Enable this option to quit Adobe Illustrator after
the import process if it was launched by FME and it has no other pending requests. If Adobe Illustrator is already
running when MAPublisher FME Auto begins, this option will be ignored. Please also note that all the writers in the
workspace should have this option enabled for Al to Adobe Illustrator to quit. Please also note that depending on
timing Adobe Illustrator may quit and launch multiple times if this option is set, since it makes the decision about
quitting only based on the requests that have arrived so far.

Character Encoding
By default, the current system locale is used to decode language-specific data for attribute definitions and values.
This option is the way to specify what encoding should be used to interpret the attribute data in MAPublisher.

FFS File Compression Level
This option is inherited from FME FFS writer option and has three settings: None, Medium, and High. A lower
compression level will result in faster operation while a higher compression level will result in smaller file sizes.

FME Workbench Navigator
All the parameters for the Adobe lllustrator - Avenza MAPublisher writer are available in the FME Workbench
Navigator. Use this panel to adjust parameters before importing GIS data to Adobe lllustrator.

The Adobe lllustrator - Avenza MAPublisher Parameters dialog box is only accessible once. After it is closed, it
cannot be accessed again. All the parameters in that dialog box are available in the Navigator panel.
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MAPublisher Preference Settings for FME Auto

FME Auto preference settings are in MAPublisher Preferences (chapter 1).

Run this version of lllustrator when using FME Auto

Navigator

-x  Enable this option to set a specific version of Adobe lllustrator to be used as

4 5] Geometry_Area [MAPUBLISHER]
@ Coordinate System: <not set>
4 .£35 Parameters

-3 Initial AL Fle/Template: <not set>
~83 Document Disposition: Leave open

~53 Fit to Page After Adding Data: Yes
§5% Wait for Result: No
83 Strip Format Attributes: Yes
£5% Quit Application If launched: No
83 FFS File Compression Level: None
{53 Enforce Strict Schema: No
> 63 Advanced
Feature Types
'S Transformers
E Il ——

453 Destination AI File: C:\Users\nlaw\Desktop'canada.ai

7| the default when multiple versions of Adobe Illustrator (which are compatible

£ Destnaton FME Feature Store (FFS) Fle: lach HPIQA with MAPublisher 8.6 and newer) are installed.

£51 If Matching MAPView Found: Create new MARYw If this preference is not enabled in any of the Adobe lllustrator versions

— installed, the most recent version will be launched when MAPublisher FME
Auto starts. For example, if a machine has Adobe lllustrator 5 and CS6 installed
with MAPublisher 9, the CS6 version will be launched.

' When Adobe lllustrator is already running before MAPublisher FME Auto starts,

Seconds before timeout

f_Expression Builder

[= FME Auto

@ Find Places

> L General

> [# import Map Data

> MAP Attributes.
[E MAP Crop Tool
[l MAP Info Panel
G MAP LabelPro

> [Fe] MAP Locations

it will be used for MAPublisher FME Auto regardless of the option selected in
MAPublisher Preferences.

e Auto This option specifies the number of seconds FME Desktop
[ R tis version f Thstator when using 4 At will try for when attempting to open Adobe lllustrator. If
Seconds before timeout: 60s |+

FME Desktop can not open Adobe lllustrator, a message
will appear in the FME Log.

KNOWN LIMITATIONS

«  Multipoint geometry cannot be imported.
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Automation

Object > MAPublisher > Automation and MAP Toolbar @
FUNCTIONALITY

Automation combines several MAPublisher tools and features to automate some of the common map and output
related workflows. Automation is run when data is imported into the document. For example, you can automate
the creation of a map through a combination of settings for MAP Views, MAP Stylesheets, Grids & Graticules, MAP
LabelPro and Export to PDF. All or a combination of some of the automation settings can be used.

Note: Adobe lllustrator documents saved with Automation settings on Windows are not compatible with Mac.
Likewise, documents saved with Automation settings on Mac are not compatible with Windows.

PREREQUISITES

Automation is only compatible with MAP Views, MAP Stylesheets, Grids & Graticules, MAP LabelPro and Export to
geospatial PDF. A document must be active before Automation can be used.

Automation can be used in conjunction with the MAPublisher FME Auto add-on.

USING AUTOMATED SETTINGS

Click the Automation button on the MAPublisher toolbar or from the Adobe lllustrator menu Object > MAPublisher

> Automation. In the Automation Settings dialog box, options for five features are available: MAP Views, MAP
Stylesheets, Grids & Graticules, MAP LabelPro and Export to PDF. On data import, automation is only run on settings
that are enabled in each tab and is applied in the tab order from left to right.

MAP Views tab

Enable the MAP Views option to include the If there is a matching MAP View setting in automation.

Automation Settings

When MAP data is imported into this document, the following operations will be applied automatically if checked,
in the order shown below from left to right.

Cancel
MAP Views MAP Stylesheets Grids & Graticules Labeling Export to PDF

MAP Views:
If there is a matching MAP View: Prompt the user -
If specified in FME Auto, this choice will be ignored.

This setting affects data when it is imported. When the coordinate system of data being imported matches a
coordinate system of an existing MAP View in the document, several actions can be performed:
«  Prompt the user: prompt the user to add to existing MAP View (and resize) or create a new one.
«  (Create new MAP View: no prompt, create a new MAP View every time.
«  Add data to first matching MAP View, do not resize: add imported data to the first matching MAP View, but does
not resize it to match the map scale.
«  Add data to first matching MAP View, resize to fit: add imported data to the first matching MAP View, resize it to
match the map scale.
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MAP Stylesheets tab

Enable the Apply applicable MAP Stylesheets option to include it in automation. This option applies any MAP Themes
Stylesheets that can apply to the imported data.

Automation Settings

When MAP data is imported into this document, the following operations will be applied automatically if checked,
in the order shown below from left to right.

Cancel
MAP Views MAP Stylesheets Grids & Graticules Labeling Export to PDF

Apply applicable MAP Stylesheets

Grids & Graticules tab

Enable the Create MAP Grid option to include it in automation.

Automation Settings

When MAP data is imported into this document, the following operations will be applied automatically if checked,
in the order shown below from left to right.

Cancel
MAP Views | MAP Stylesheets | Grids & Graticles | Labeling | Export to PDF

Create MAP Grid:
Extents for grid bounds:
(®) Use MAP View extents
() Use extents of this layer:
| Ignore automatic import suffix when comparing
‘Grid configuration files:
() All configuration files in this folder: Browse...
(@ Only these configuration files:

Grids: ]

Under the Extents for grid bounds section, choose the Use MAP View extents option to create a grid based on the
geographic extent of the MAP View or choose the Use extents of this layer option and enter a layer name in the text
box. The layer name needs to match exactly (case-sensitive), although the suffix can be ignored if that option is
enabled (default).

Under the Grid configuration files section, choose the All configuration files in this folder option to use all configuration
files stored in a specified folder. The files in the folder are applied in alphabetical order. Choose the Only these
configuration files option when there is a need to use only certain grid configuration files. Click the Add button to add
configuration files to the list and use the Up and Down arrow buttons to reorder them. Configurations are applied
from top to bottom in the list. Click the Remove button to remove files from the list.
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Labeling tab

Enable the Apply Labeling option to include it in automation. Use this option to setup automated labeling for
imported data.

To add layers, click the Add Layers button. Added layers are listed with <Empty name>. Enter the name of the source
layer with features to label into the Source layer box (this name will replace <Empty name> in the list). Enter the name
of the target MAP Text layer into the Target layer box. Enter the name of the attribute to be used for lables into the
Attribute box. Choose a style from the Style drop-down box. Styles are sourced from the Styles panel.

Automation Settings

When MAP data is imported into this document, the following operations will be applied automatically if checked,
in the order shown below from left to right.

Cancel
MAP Views MAP Stylesheets Grids & Graticules Labeling Export to PDF

Apply Labeling:

Layers Q| @

A <Empty name> \ Source layer: |Name of layer with features to label
Target layer: |Mame of layer on which to create labels
Attribute: Name of attribute to use for labels
Style: Use current settings -

["] Apply LabelPro:

Settings file: Browse...

Enable the Apply LabelPro option to include it in automation. This option applies any MAP LabelPro settings file. See
chapter 17 for more information about MAP LabelPro settings.

Note: The MAP LabelPro add-on requires a separate license. See chapter 1 for more information about licensing.

Export to PDF tab

Enable the Export to geospatial PDF option to include it in automation. Specify or browse to a folder in the Save as
text box. If required, specify or browse for an export PDF settings file. See chapter 16 for more information about
geospatial PDF export settings.

Automation Settings

When MAP data is imported into this document, the following operations will be applied automatically if checked,
in the order shown below from left to right.

Cancel
MAP Views MAP Stylesheets Grids & Graticules Labeling Export to PDF

Export to geospatial PDF:
Save asi Browse...
If Fanout Dataset is spedified in FME Auto, this option will be ignored. If use FFS folder is

specified in FME Auto, that lacation wil take precedence and the output POF will have the
same name as the FF5 file.

Settings file: Browse...
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MAP Layers and
MAP Views

The MAP Views panel is the hub from which many additional
MAPublisher features may be accessed. It organizes MAP
layers into based on distinct coordinate systems known as
MAP Views. Use this panel to specify coordinate systems

for MAP Views, perform coordinate transformations, adjust
scale, change data alignment and placement, and export to
industry standard GIS formats.

When importing data, an Adobe lllustrator layer is created for
each feature type, and is by default appended with a _point,
_line, _area, or _text suffix in the Adobe Illustrator Layers
panel. Certain file types generate multiple layers, such as
DGN or DXEF, but are similarly split up by feature type. A single
import of such files produces a single MAP View as an import
can only take place into a single coordinate system. Custom
MAP Views may be created in order to georeference existing
Adobe lllustrator artwork.

The following pages deal with the creation and management
of MAP Views, specifying and transforming a coordinate
system, editing scale and data placement on the page,
merging Adobe lllustrator layers, and exporting to GIS formats.

Topics covered in this section:

MAP Views Panel

MAP View Editor

Export MAP Layers and MAP Views
MAP Info Panel

Copy MAP Objects From
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MAP Views - Each contains

MAP Views Panel

Window> MAPublisher > MAP Views and MAP Toolba

MAP Views

distinct configurations of
geospatial parameters

MAP Layers - An alphabetical

list of the layers that comprise
each MAP View, symbolized by
feature type.

Lock button - Click box to lock

or unlock a MAP Layer (lock

check box is mirrored in the

Adobe lllustrator Layers panel)
Non-MAP layers - Lists the Adobe
lllustrator layers that are not part of
a specified MAP View, and do not
contain georeferenced information
Layer Note - Click this button to

add a layer note. A note with no

+ symbol already contains a note.

+ (& Land Image
) i || Land_image
+ @ ukpoly
: - ;:::a Switch MAP View - Click this button to
switch the selected layer from one
< wili=izs MAP view to another. Remove MAP
® 0O | ke e data moves the selected layer to
® m] 5] uipoly_area the [Non-MAP layers] section and
> & world removes the georeferencing and
i Airports_point attributes in the process.
a 0 world_area
- ZNNHV!AP Layers
® @ [ALayer 1 Add MAP Layer - Creates a new MAP
layer (in both the MAP Views panel
and the Adobe Illustrator Layers
panel). Opens the Add MAP Layer
3MAP Views L S a dialog box.
Delete selection button - Delete the
currently selected MAP Layer or
Export MAP View / Export MAP Layer MAP View
Export the selected MAP View or . . .
MAP Layer to various GIS formats an Zoomtoukeail lind
Lock "ukrail_line”
Unlock "ukrail_line" «——— Layer Operations - Zoom, toggle lock,

and toggle visibility of MAP Views
and MAP layers.

Hide "wkrail_line"

Show “ukrail_ling"

Lock all layers except "ukrail_line"
Unlock all layers except "ukrail_line"

Hide all layers except "ukrail_ling"

Show all layers except "ukrail_line"

MAP Views Panel Options Menu

MNew MAP View...

New MAP View For Photashop Paths...

Duplicate "Chicagoland”
Edit "Chicagoland"...

Delete Selection
Add MAP Layer...

Specify Anchors...
Export Coordinate System to File...

Export "Chicagoland”...
Layer Name Search & Replace...
Sort Art on Layer..

Edit Layer Note...

Load Custom Coordinate Systems...
Edit Custom Coordinate Systems...

Document Summary...

Specify Alternate Coordinate System...

Copy MAP Objects From...

Preferences...
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New MAP View - Create a new MAP View and specify its name and coordinate information.

New MAP View For Photoshop Paths- Specify a new MAP View based on paths exported from Geographic Imager/Adobe Photoshop.
Duplicate Selection - Create a duplicate of the currently selected MAP View.

Edit Selection - Open the MAP View Editor to edit the name and coordinate system of the currently selected MAP View.

Delete Selection - Delete the currently selected MAP View or MAP Layer provided it does not contain any Adobe lllustrator layers.
Add MAP Layer - Create a new MAP Layer through Add MAP Layer dialog box.

Specify Anchors - Manually establish the tie-in point between Map and Page Anchors (should only be used for new MAP Views or
for the correction of georeferencing errors).

Export Coordinate System to File - Exports the selected MAP View coordinate system to a WKT definition (wkt) (see Appendix A2).
Export Selection - Enable the export of the selected MAP View or MAP Layer to various GIS formats.

Layer Name Search & Replace - Search for text within layer names and specify an alternative. Useful for multi-layer imports.

Sort Art on Layer - Sort art in ascending or descending order based on attribute.

Edit Layer Note - Add or edit the selected layer's note.

Load Custom Coordinate Systems - Load external coordinate systems in XML format (see Appendix A2).
Document Summary - View a summary of all features and other art on both MAP layers and non-MAP layers.

Specify Alternate Coordinate System - Choose a coordinate system that appears as an alternate option on many MAPublisher tools.

Edit Custom Coordinate Systems - Open the custom coordinate system editor to create new coordinate systems and edit the
parameters of existing ones in the data source (see Appendix A2).

Copy MAP Objects From - Copy MAP Views, MAP layers, MAP Themes (including Stylesheets), and MAP Selection Filters from other
open documents.

Preferences - Opens MAPublisher Preferences on the MAP Views Panel property sheet (see chapter 1).
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RELATED TOOLS

%]

Layer name - Type the name of the new
layer (it will appear in both MAP Views
and Adobe lllustrator Layers panels)

Feature type - Choose the type of feature
of the new layer. This drop-down list
presents a choice of Area, Line, Point,
Image, Text or Legend layer types.

Feature type - Choose the type of feature
that exists for the layer being switched
to the MAP View. This drop-down list
presents a choice of Area, Line, Point,
Image, Text or Legend layer types.

Add MAP Layer

Base attribute schema on - Check this option to
copy the attribute schema from the existing
MAP Layer selected in the drop-down list

Add MAP Layer
Layer name: Layer 1
j" Feature type: Area - Cancel
Advanced:
[] Base attribute schema on: Land_area -
‘Check this option to inherit the attribute structure from the specified layern

Plot Centroids, Label Features, MAP Tagger
Tool and MAP LabelPro tools make use of this

option, see specific chapters.

Undefined Layer

Automatically opens when switching a Non-MAP layer to a specified MAP View.

Undefined Layer - Layer 2

Paint

=

Feature type:

Advanced:

-

Base attribute schema on - Check this option to
copy the attribute schema from the existing
MAP Layer selected in the drop-down list

Plot Centroids, Label Features, MAP Tagger
Tool and MAP LabelPro tools make use of this
option, see specific chapters.

Specify coordinate system Choose this option
and then click the Select button to specify
the coordinate system of the named

MAP View via the Select Coordinate
System dialog box (see Appendix 2). Once
selected, the coordinate system will be
displayed below it.

[] Base attribute schema on:
Check this option 1o inherit the swibute strucmrs from the specfisd layer,

Hotels_point

Cancel

Apply to all

Apply to all - When multiple layers
are switched at once to a specified
MAP View, check this box to apply

the same feature type to all

Missing Coordinate System
Automatically opens when dragging a MAP Layer to an alternate MAP View, and
either the source or destination MAP View has an unspecified coordinate system.

Missing Coordinate System

The 'County’ MAP View does not contain any coordinate system information.

(") Specify coordinate system: Select...
Coordinate system:

@ city

Coordinate system: Ilinois Eastern Zone

(®) Same as:

Same as - Choose this option in
order to assign a coordinate
system to the named MAP View
that matches that of an existing
MAP View. The coordinate
system of the selected MAP
View will be displayed below.

Layer Name Search & Replace

Layer Name Search & Replace

Input Coordinate System - Specify the
coordinate system in which the

Find what: _area

Replace with: ‘jeamre ‘

anchor position is entered. Use

Specify Anchors
Should only be accessed when creating a new MAP View
or correcting inaccurate georeferencing information.
Caution: editing anchors can damage the accuracy of the data.

the current MAP View's coordinate

Specify Anchors

Replace with - Type in the Find what -
variable you wish to change

the layer names to

variable contained in the
current layer names on
which you wish to search

Cancel system or specify a different one
(by default, the geodetic system ——e Input Coordinate System:
base of the projection or WGS84, in
Type in the latitude-longitude format).

Page Anchors in the units of the
current document. Click the MAP
Location button to choose a MAP

Page Location as a page anchor.

Map Anchor - The location of the Map
Anchors in the units of the selected —
coordinate system. Click the MAP
Location button to choose a MAP
World Location as a page anchor.

Page Anchor - The location of the —— page Anchor:

—e Map Anchor:
o X |-1978778.032844 m '
« i 475160562751 m| -

Cancel

(®) Use MAP View's coordinate system

O Use: Was a4

o X
LY 4

Make sure you have set rulers to Global Rulers when
reading the page location with any Tlustrator tools.

0.000000 px '
792.000000 px | w

You can find the option at View > Rulers > Change to Giobal Rulers
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OVERVIEW

The MAP Views panel displays a list of all the Adobe lllustrator layers in the current document and all MAP Views—
defined configurations for geospatial parameters (coordinate system, anchors, map scale and rotation). Every
MAP Layer is shown in this panel as belonging to a particular MAP View. Adobe lllustrator layers that do not have
georeferencing information (e.g. non-map objects such as diagrams and supplemental art) are placed in the
[Non-MAP layers] category.

Categories are symbolized in the following manner:
@ MAP View Contains layers with georeferenced and attribute information.

E Non-MAP layers ~ Contains layers with no georeferenced or attribute information.

Each layer that belongs to a MAP View is symbolized in MAPublisher panels and dialog boxes with an icon
identifying its feature type:

Area layer (e.g. county boundaries, urban areas, country outlines etc.)

Line layer (e.g. rivers, roads, railways etc.)

Point layer (e.g. town and city symbols, railway stations etc.)

Text layer (e.g. text labels)
EE Legend layer (for MAPublisher Legend items: North Arrows, Scale Bars, Grids)

@ Image layer  (for referenced images)

Note: Layers are sorted alphabetically or by data type, as specified in the MAP Views category in the MAPublisher
Preferences (see chapter 1).

FUNCTIONALITY

MAP Views are designed to give easy access to settings for specifying and transforming coordinate systems, for
editing scale and data placement on the page and for exporting to GIS formats. The MAP Views panel allows
toggling Adobe lllustrator layers accessibility, georeferencing existing Adobe lllustrator artwork, changing multiple
layer names and projecting data on the fly.

USING THE MAP VIEWS PANEL

Creating New MAP Views

To create a new MAP View, click New MAP View in the panel options menu. This opens the MAP View Editor (discussed in
MAP View Editor section). Specify a coordinate system and enter values for scale, rotation, and page anchors. After
creating a new MAP View, the Specify Anchors item from the MAP Views panel options menu must be used to define
the tie-in point between Map Anchors and Page Anchors.

Note: Creating a new MAP View is only recommended when registering a non-referenced Adobe lllustrator
document. To transform an existing MAP View to a new coordinate system and scale (e.g. to create an inset
map), use the duplicate MAP View function and transform or rescale the copied MAP View.
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Duplicate And Delete MAP Views

MAP Views can be duplicated. For example, to create inset maps make a duplicate and drag MAP Layers into the
new MAP View. Then use the MAP View Editor to edit the placement, scale or coordinate system of the duplicate.
Note that MAP Layers can only be duplicated in the Adobe lllustrator Layers panel.

Delete a MAP View or MAP Layer using the Delete button at the base of the panel or through the MAP Views panel
options menu. When deleting a MAP View, any MAP layers (and sublayers) within it are also deleted.

Create New MAP Layers

Create new MAP Layers to hold geospatial data or to generate artwork using MAPublisher tools (plot points, labels,
legends, grids, scale bars and north arrows). Click the Add MAP Layer button to create a new Adobe Illustrator layer
which simultaneously places it into a selected MAP View. Specify the appropriate Layer name and Feature type for the
new layer. Below are examples of the types of MAPublisher tools that require a specific MAP Layer type:

Area layer Buffer Art, Join Areas, Line Plotter (see chapter 8)

Line layer Buffer Art, Join Lines, Line Plotter (see chapter 8)

MAP Point Plotter (see chapter 6)
Join Points (see chapter 8)

Label Features, MAP Tagger (see chapter 10)
Text layer MAPublisher LabelPro (see chapter 17)

Grids and Graticules (see chapter 13)
Scale Bars, North Arrows (see chapter 14)

Point layer

EE Legend layer

@ Image layer Import Image, Register Image (see chapter 3 and 12)

Note: The Advanced option Base attribute schema on will copy the attribute schema from an existing MAP Layer (see
chapter 5 for details). This option is required to enable the copying of attributes from source to destination
layers in the MAPublisher labelling tools and Plot Centroids function. See respective chapters.

Transform MAP Layer Coordinate System using the MAP Views Panel

The MAP Views panel can be used to move MAP layers from one MAP View to another, also known as projecting
vector data-on-the fly (raster images cannot be reprojected or transformed with MAPublisher). To move a MAP layer
to another MAP view, dlick and drag or use the Switch MAP View button. For example, to reproject a layer that has a UTM
projection into a Lat/Long projection, click and drag it from the MAP View with a UTM projection and drop it into
the MAP View with a Lat/Long projection. MAPublisher will automatically transform and scale artwork to match the
destination MAP View. The Missing Coordinate System dialog box appears when neither the origin nor destination
MAP View contains a defined coordinate system. Two options are available in this dialog box:

1. Specify coordinate system: specify projection using the Source Coordinate System function.
2. Sameas: specify coordinate system based on an existing MAP View in the document.
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Note: Many coordinate system transformations will inherently cause the loss of precision by the very nature of
complex mathematical calculations that must be performed. As a result, please be aware that some precision
may be lost if layers are dragged repeatedly from one coordinate system to another. When determining a
coordinate system to use via the drag method, we strongly recommend Edit > Undo to revert back until the
appropriate system is found.

Assign Georeferencing Information to Adobe lllustrator Layers

Existing Adobe lllustrator layers that do not contain georeferencing or attribute information also appear in this
panel under the default MAP View entitled [Non-MAP layers]. Such layers can be moved into a specified MAP View with
a matching geospatial configuration (coordinate system, scale, position on the page, etc.).

Note: Moving a non-MAP layer to a MAP View does not imply any transformation (the artwork is not redrawn).
Ensure that the art on the non-MAP layer is positioned and scaled properly on the page with regard to the
MAP View definition.

Moving a non-MAP layer into a specified MAP View prompts the Define Layer dialog box. Use it to specify the feature
type of the moved layer. Multiple layers may be selected and moved together to a specified MAP View. Use the Apply
toall option to assign the same feature type to all layers being moved. The Base attribute schema on option copies the
attribute schema from an existing MAP Layer (see chapter 5 for details).

Specify Anchors

The Specify Anchors function should only be accessed when referencing a new MAP View (for example in the
process of georeferencing an Adobe lllustrator file, see appendix A1) or to correct an inaccurate referencing.

When the Use Current MAP View's coordinate system option is chosen, Map Anchor coordinate values are entered in the
map units of the coordinate system of the MAP View. Map Anchor coordinates must be known from information
written on the map (e.g. graticule crossings) or from external sources (metadata, survey points or other). MAP World
Locations can be used as Map Anchors.

When the Use: [coordinate system] option is chosen, the current coordinate system link is enabled. Click it to open

the Select Coordinate System dialog box. The coordinates values entered will be in the unit (Point Style) of the chosen
coordinate system. When the selected or default coordinate system is projected, X and Y coordinates are entered in
the unit (Point Style) of the coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate
system is Geodetic, Lat and Long coordinates are entered in degrees.

Note: When the current MAP View coordinate system is a projected system, the default system specified in
Use: [coordinate system] is set to the geodetic system base for the projection. For example, if the MAP View
system is US State Plane NAD83 / Colorado North (ftUS), the default alternative system is set to NAD83 (to
enter the latitude/longitude coordinates in degrees).

The Page Anchor is entered in the current unit of the document. This unit can be changed through the Adobe
lllustrator menu File > Document Setup. Positions of points on the document in page coordinates are determined
using the Adobe lllustrator Info panel (menu Window > Info). MAP Page Locations can be used as page anchors.
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Layer Name Search & Replace

To quickly change the names of multiple Adobe Illustrator layers, use the Layer Name Search & Replace function
located in the MAP Views panel options menu. For example, MicroStation Design or CAD imports can contain

a large number of similarly named layers and doing a name search and replace is more efficient than manually
changing each of them.

Zoom to MAP Layer or to MAP View

To zoom to a MAP Layer, select one and click the Layers Operations button at the bottom of the MAP Views panel. Click
the Zoom to "[Layer]" in the context menu. When a MAP View is selected, this option becomes Zoom to all layers in "[MAP
View]". This is particularly useful for documents containing a large number of layers.

Layers Operations

The Layer Operations button will perform a variety of layer operations. If a MAP Layer is selected, use the context
menu to Lock, Unlock, Hide or Show "[Layer]" or to Lock, Unlock, Hide or Show all layers except "[Layer]". If a MAP View is selected,
the same options become for all layers in "[MAP View]" or all layers except layers in "[MAP View]".

MAP Layer Note

MAP Layer Notes contain general information about the layer, such as how it was created or on its source data. MAP
Layers with no layer notes are marked with an Add Note icon.

Layer notes can be automatically added when the layers are created through MAPublisher functions (e.g. MAP Data
Import, Plot Centroids, Web Feature/Map Service, etc.). To do so, enable the MAPublisher General Preferences option
Add notes for layers created by MAPublisher operations — see chapter 1 for details. The automatic notes show the function
and parameters used to create it. For example a note of a layer created by import indicates information such as the
path of the source data, format and date.

To add or edit a layer note, choose the MAP Views panel options menu Edit Layer Note. In the Add/Edit Layer Note
dialog box, type new text or edit the existing information. Click the Clear button to clear all information.

Edit Layer Note

Created by: Import oK
Format: Esri Shapefile
Dataset: C:\Jsersiikel \Desktop\Training Exercise Data\Exercise 2 - Chicagoland\ector Data\CityBoundary. shp Cancel

Encoding: System
Coordinate system: NADS3 / Tlinois East {ftUs) Clear

Feature count:
Created on: 4/7/2014 3:49:57PM

Last updated on: 4/7/2014 3:49:57 PM
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Export MAP Views and MAP Layers

The MAP Views panel offers the option to export a single MAP View or a single MAP Layer to a multitude of GIS
formats. This function is explained later in this chapter.

New MAP View For Photoshop Paths

The New MAP View For Photoshop Paths function creates a new MAP View using a reference file and associated
Adobe lllustrator file exported from Geographic Imager for Adobe Photoshop.

Adobe Photoshop offers a function to create vector paths and export them to Adobe Illustrator. Adobe Photoshop
uses Geographic Imager to maintain the spatial reference and outputs it as an rsf reference file. To import the paths
into Adobe Illustrator using MAPublisher, use the New MAP View For Photoshop Paths from the MAP View panel options
menu to create a new MAP View based on the rsf file. After doing this, the Adobe Illustrator layers can simply be
dragged from [Non MAP Layers] to the newly created MAP View to finalize the georeferencing. The vector data can
now be used in a current MAPublisher project, edited, transformed or exported to any external GIS format.

MNew MAP View For Photoshop Paths

Reference file: Browse. .. oK

ove non: ayers in iew as: ne v ancel
] M -MAP Layers into MAP Vi [ L Cancel
Destination artboard: Artboard 1

Tip: use the artboard tool to display artboard numbers

New MAP View For Photoshop Paths allows the creation of a MAP View using a reference file and assodated
Tlustrator file created in Photoshop and Geographic Imager.

*In Photoshop, create a vector path.

* Export this with referencing from Photoshop as an Tlustrator file. With the Geographic Imager plug-in
you can also export the associated refreference file.

*When the newly created Ilustrator file is opened with MAPublisher the reference file can be used to create
@ MAP View using this tool.

Remove MAPublisher Information

At the end of a project cycle, it may be useful to permanently remove all georeferencing and attribute information
in the current document. This can be accomplished by switching all MAP Layers to the [Non-MAP layers] category in
the MAP Views panel via drag and drop or clicking the Switch Map View button and the Remove MAP data option.

Note: This function should only be used as required and as a final step. Be sure to save a copy of the document
before performing this operation as this will erase all attribute data.
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Preview Pane - Displays the data ——

extents of the MAP View:

White rectangle - Artboard extents ——

Colour rectangle - Data extents of the

current MAP View ——

Crosshair - Location of the current ——

Map and Page Anchors

Configure margins - Adjust the ——

artboard margins

MAP View Editor

MAP Views panel > Edit MAP View / New MAP View,
Multiple Data Import > Create New > Editor

Edit "USA Map™

L3

Show/hide preview details - Display or
hide the Map and Page Anchors
and artboard margins

Name - Name of the MAP View —

Scale - Edit the MAP View scal
relative to the page. Auto-scals
automatically fits the data extent:
to the artboard or the margin:

Angle - Rotation angle of the MA
View. Click Reset Angle |@ | to rese
to zero; click Orient North [y t
orient the MAP View north u

Perform Coordinate System Transformatiol
Enable this option to transform th
data from one coordinate system to
another. Click the coordinate system
link to open the Specify Destination
Coordinate System dialog box.

Same as - Check this option
to transform to a coordinate
system used by another
MAP View in the document

FUNCTIONALITY

Name: |USA Map
Scale: 1: |20500000.000000 |+

.
angle: [0.00 2] degrees (@] [l

Source Coordinate System:

United States: L ambert Conformal Conic, meter

Destination: [No Coordinate System Spedified]
Sameas: (@ Alaska Map

Datum shift:

Auto-scale [+

—e[_| Perform Coordinate System Transformation:

—— Zoom buttons - Zoom in/out

Zoom: 25.82%

Cancel

Center current MAP View extents on
screen - Fit preview to the extents

V.

'J Options... 777

Show all artboards - Display artboards.

—— Options - Maintain point size, stroke

width and font size when scaling

Previews: | Coloured boxes -

Fd

Positioning:

or rotating

L

Pan preview mode - Pan around the
preview pane

——— Move MAP View Mode - Move the

position of the current MAP View

Quick aligrment | Fine-tuning | MAP LoGaTions

ooaog

ooog
ooaog

Align the MAP View to a position on the
selected artboard indicated by the
aligrment grid.

CINEREE

Previews and Configure preview
Select and configure how the
previews are shown

“Source Coordinate System - Displays
the current coordinate system
assigned to the MAP View. Click

Datum shift - Displays
the datum shift for the
transformation

From File - Load a destination
coordinate system from an
external file

Positioning (also see tabs below)

« Quick alignment - Click the grid to control
the alignment of the data extent relative
to the artboard

« Fine-tuning - Adjust the lower left corner of
the map extents

Positioning:
Quick alignment Fine-tuning MAP Locations
Lowerdeft X: -0,000305 px =
Lowerdeft V: 528.577795 px :

+ MAP Locations - Use MAP World and MAP Page
locations to choose a position on the artboard

Positioning:
Quick alignment Fine-tuning MAP Locations

=) [ apy ]

World location: |  MAPLocation1 =

Page location: [ ? Location 1

the link to open the Specify Source
Coordinate System dialog box to
select a new source coordinate
system. To be used only if the
source coordinate system is
undefined or is not matching

the data.

To apply a new coordinate system to
a MAP View, use Perform Coordinate
System Transformation.

Info - View the parameters of a
selected coordinate system
Clear - Remove all references
to a coordinate system

From File - Load a source
coordinate system from an
external file

The MAP View Editor displays and controls the geospatial parameters of the MAP View (coordinate systems and
scale on the artboard), the position of the data extents on the page (alignment and rotation) and provides a way to
change the MAP View name. A preview pane shows and allows users to move the current MAP View relative to the
artboard and to the other MAP Views in the document.

The MAP View Editor is also where coordinate system transformations are performed. Transformations affect the
data geometry on the page as map art is redrawn to match the new coordinate system properties.
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USING THE MAP VIEW EDITOR

The MAP View Editor can be accessed as part of the Multiple Data Import dialog box or from the MAP Views panel:
«  Multiple Data Import: Click the Create new option in the Destination MAP View section, and then click the
Editor button to open the MAP View Editor.
«  MAP Views panel: Select a MAP View, and then select Edit under the Options arrow in the upper right corner
of the panel. Alternatively, double-click the MAP View name in the MAP Views panel.

Preview Pane and Configure Previews

By default, the Preview Pane displays the data extents with a green rectangle and the MAP View orientation with an
arrow pointing north. To move the data on the page, click inside the green rectangle and drag the data to a more
suitable position relative to the page. Use the Zoom In, Zoom Out and Center buttons to set the magnification of the
preview. To move the page within the Preview Pane, click outside the MAP View extent and drag to move the page.

The Previews drop-down list changes the preview to Coloured boxes (previews up to ten MAP views, each with
different colours as specified in the Configure Previews settings), Thumbnails (preview a reduced image of the
document contents, including all MAP views) and Thumbnails & Boxes (shows both thumbnails and coloured boxes
of up to 10 MAP views in the document).

Note: Due to Adobe lllustrator rasterization limitations, thumbnails cannot be created for very large MAP Views.

To configure the previews, click the Configure preview button. To adjust the colour of the current MAP View preview,
click the colour chip and choose a colour in the colour picker dialog box. Layer visibility can be individually toggled
under the Visible column. Use the Show All or Hide All buttons to toggle the visibility of the entire list. To toggle
only the layers of a particular MAP View, right-click the MAP View to access a context menu that has the options to
Show All or Hide All. Adjust thumbnail quality using the drop-down list at the bottom of the dialog box. Quality
settings include: Low, Medium, High, and Very High.

Configure Preview

Current MAP View preview colour

Current MAP View preview colour: D Clickto Change the colour
Name Visible Cancel
MAP View a @ O Alaska Map

alaska_area
4 @ W usamap
uscities_point
MAP Layers Chicagy.Labe\
Mere Cities
usroads._line
usa_area
EH Map Divisions
4 @ W Hawaii Map
hawaii_area
4 [A] Non-MAP Layers
[A Layer1

Show Al

Toggle Visibility (MAP View's coloured box)
Hide All

Toggle Visibility (layer's thumbnails)

0 OROROO0O0RE

Thumbnail quality —* Thumbnail quality: |Low hd

Note: Auto-Scale will only apply to the extent of the visible layers.
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MAP View Name

The current name of the MAP View is listed in the Name box, which can be edited. MAP Views are ordered
alphabetically in the MAP Views panel, so changing a MAP View name may change its position in the panel.

Scale

The scale of the current MAP View is shown in the Scale box. For MAP Views in a projected coordinate system, the
scale value is a real world scale (exact ratio linear distance on the page over distance on the ground). For MAP Views
in a geodetic coordinate system (i.e. Lat/Long format in angular unit), the scale value is approximated using the
common formula 1°= 111.353m (metres per degree at the equator). This is not an accurate number because the
formula is only valid at the equator, but it is more intuitive for cartographic considerations.

The scale can be edited by typing in a precise value or by using the Up and Down arrows to increase or decrease the
scale by 10% of the starting value. The Auto-scale button applies the scale to fit the visible data in the preview to the
artboard or margins and centers the map on the page (see Preview Pane). Click the Auto-scale drop-down arrow to
use either the artboard or margins as the scale extent.

Rotation

A rotation figure can be applied or edited by specifying an angle in the entry field, or by using the arrow buttons.

Notice that changes to rotation will be automatically previewed in the Preview Pane with the green rectangle and
arrow depicting the new orientation of the data. Click the Reset Angle button to reset the angle to 0. Click Orient

North button to orient the MAP View True North up (True North is calculated at the center of the data extents).

Positioning

During the import process, MAPublisher sets the page and map anchors so that the lower-left corner of the
artboard coincides with the lower-left corner of the map extents. The page origin (0,0) is located in the upper-
left corner. Three positioning settings are available to precisely move MAP Views around the artboard. The Quick
alignment tab provides an alignment control grid with nine preset map extent positions relative to the artboard.
Click one of the positions (center-middle, lower-left, upper-right, etc.) to align the MAP View to the artboard. The
Fine-tuning tab shows the lower-left X and lower-left Y value boxes which change the position of the lower-left
corner of the data extents (in document units). The MAP Locations tab provides the ability to position MAP View
extents by matching MAP Page locations and MAP World locations accordingly.

Notes: Editing the lower-left corner position does not affect data integrity. It simply means that the data is shifted
on the page but the corresponding real world coordinates remain unchanged.

The Page Anchor does not always coincide with the lower-left corner of the map extent. When manually
registering an Adobe document, users can also enter a specific position using the MAP Views panel options
menu Specify Anchors (see first section of this chapter).
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Set Source Coordinate System

In most cases, the MAP View source coordinate system is initially assigned during the import process if the imported
data file contains such information (see chapter 3). To view the properties of the source coordinate system, click the
info button.

If no coordinate system is assigned during import, the MAP View source coordinate system displays [No Coordinate
System Specified]. In order to scale, rotate or transform the MAP View, a coordinate system must be specified. Click
the coordinate system link to open the Specify Source Coordinate System dialog box (explained below). Alternatively, use
From File to set the source coordinate system using an external file (e.g. WKT, MAP, PRJ or TAB).

Note: If you are referencing an ungeoreferenced Adobe lllustrator file, it is not enough to specify the source
coordinate system to reference your map, you'll also need to specify appropriate map and page anchors.
See Georeferencing an Adobe lllustrator file in appendix A1 General Tips.

In some rare cases, the source coordinate system may have been wrongly assigned during the import process
(due to a wrong manual selection or file issue). In this case, users may want to specify another coordinate system.
This should be done with caution as data integrity may be lost if the current coordinate system is mistakenly
overwritten. Changing the source coordinate system does not affect the data geometry on the page. To specify a
new coordinate system for a MAP View, use Perform Coordinate System Transformation.

Coordinate System Transformation

To transform a MAP View from one coordinate system to another coordinate system using the MAP View Editor,
click the Perform Coordinate System Transformation check box (the MAP View must contain data and a source coordinate
system for this option to be available) and use an option to choose the destination coordinate system:

- Specify a coordinate system from the MAPublisher database: click the coordinate system link in the Perform
Coordinate System Transformation frame to open the Specify Destination Coordinate System dialog box.

«  Specify a coordinate system used by another MAP View in the document: click the Same as check box
and select the appropriate MAP View in the drop-down list. This does not affect the page position.

«  Use a coordinate system from another file: click From File to set the destination coordinate system using
an external file (e.g. WKT, MAP, PRJ or TAB).

The Preview Pane displays the new data extents for the transformed MAP View, however the thumbnails view is not
available until the transformation is finalized by clicking the OK button in the MAP View Editor.

Some coordinate system transformations require a datum shift. When this is the case, MAPublisher selects the most
appropriate datum transformation. This can be edited by clicking the Specify button in the datum shifts frame and
selecting another datum transformation (see appendix A2 and Avenza Projections Guide.pdf for more information).

Note: Coordinate system transformations can also be performed in the MAP Views panel. Simply drag a MAP layer
from one MAP View to another MAP View of a different coordinate system.
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Specify Coordinate System

The Specify Source/Destination Coordinate System dialog boxes allow users to select, copy and edit coordinate systems and
associated parameters from the MAPublisher coordinate systems (Geodetic Data Source). The MAPublisher Geodetic
Datasource is explained in depth in Appendix A2.

Coordinate systems are divided in two categories: Geodetic and Projected. For convenience, they are sorted in
sub-folders by continent > country > sub-division (e.g. state or county). The *All* category lists all systems with no
sorting; the *Recent* category lists the last 10 systems recently selected; the *Search* category lists the result of a
coordinate system search. The MAPublisher coordinate systems may also contain custom systems.

New MAP Views

After clicking the New MAP View button, the MAP View Editor opens for users to set the name, coordinate system and
page scaling of the new MAP View. After a new MAP View is created, the Specify Anchors option from the MAP Views
panel must be used to define the tie-in point between Map Anchor and Page Anchor. Map Anchor coordinates can
be entered in any chosen coordinate system (for example, latitude and longitude in degree for projected map). This
functionality is explained in detail in Georeferencing an Adobe lllustrator file in appendix A1 General Tips.

Lat/Long Order (optional)

Enable the Show Latitude/Longitude ordering option in the MAPublisher Preferences for MAP Views > Editor (see chapter 1).
A Lat/Long order drop-down list will appear in the MAP View editor dialog box:

o
Mame: | ukpoly |
Scale: 1: | 5540124.915443 s Auto-scale |
Andle: 0.00 |5 degrees |@ Iy

Latflong order: |Longitude, latitude  +

When enabled, the latitude and longitude order—Longitude, latitude or Latitude, longitude—affects the following
tools or panels: MAP Info, MAP Point Plotter and Line Plotter.

Options

When the map scale changes, the point size, stroke and text font are maintained by default. To alter how scaling
affects these options, click the Options button in the MAP View Editor dialog box. In the Options dialog box, under
the Scaling section, adjust the options to your preference.

Options
=
Maintain paint size when scaling
Maintain stroke width when scaling
Maintain text font size when scaling

Cancel

Rotation:
[] Maintain peint rotation when rotating

[] Maintain point text rotation when rotating

Rotation options are also available. Maintain point and text rotation by enabling the options.
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Multiple Artboards

MAPublisher can manipulate multiple artboards in the MAP View Editor.

When a document contains multiple artboards, the MAP View Editor dialog box has an additional option to select
the Active arthoard. When choosing the active artboard, the preview pane displays the number of each artboard. The
current active artboard is shown in white, while the others are covered with a dotted pattern. The Quick alignment and
Scale calculations are based on the active artboard dimensions.

To move the data extent (green box in the preview pane) from one artboard to another, change the Active artboard
value to the artboard where the data is to be moved, then click the Auto-scale button or one of the Quick alignment

grid positions.

Artboards - Preview of all artboards —+—
present on the canvas

Active Arthoard - White background —

Other Arthoards - Greyed out —

Edit "USA Map"

Active Artboard- Select the number
of the artboard to be set as Active

Note: Adobe Illustrator allows users to move artboards. However, this action does not preserve georeferencing
(same effect as moving art on the active artboard). Instead of moving the artboard, use the recommended

workflow as follows:

| I1] Active arthoard:
P —

Zoom: 22.92%

L]
O

Previews: |Colowredboxes  +

1. Create a new artboard at the desired position on the canvas.

2. Open the MAP View Editor and move the MAP View from the initial artboard to the new one.

3. Delete the initial artboard.
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Export MAP Layers and MAP Views

MAP Views panel > Export and buttons (MAP View) (MAP Layer)
Object > MAPublisher > Export MAP Layers or MAP Toolbar > Export

Export
Format - Select the export —» Format: Esri Shapefile [*.shp] = =
format for the selected  _y character encocing: |Defaul System Encocing - cancel
layer or MAP View J MAP View: @ San Francisco Downtonn =————— MAPView- Choose a MAP
Character encoding - Assign - View to display available
a codec if the attribute O A layers for export
R . ; Post_Offices_point
information held in the Public_Schosls point
selected layer or MAP Highways_line
View uses a double byte nterstates_line Layers to export - All available
character set Ramp line i
Strects line MAP layers to gxport in Fhe
[] E background chosen MAP View. Certain
Land_area formats may not be able to
[ [E Porks_ares hd export some layers.

Check Al Uncheck All

Folder - Displays the
directory path for the ————
export of the currently
selected layer or MAP View

Folder: | C:Wsers\Public\Documents\Avenza MAPubiisher 3. 4{Tutorial Guide &Data

Browse. ..

« Folder is valid.

Attributes: |Export all attributes -

Settings - Extra parameters ——
for export. Each format has
its own settings

(see more below)

Properties: |Export only visible #Property attributes ~

[] Keep format extension on layer names

FUNCTIONALITY

MAPublisher supports the export of MAP Layers and MAP Views to various GIS and table formats that maintain
georeferencing and attribute information. The following export formats are supported:

AutoCAD Drawing/Exchange (dwg, dxf) Google Earth (kml, kmz)
Delimited XY Text Data (csv) Maplinfo Interchange Format (mif)
Esri Arcinfo Generate (gen) Maplnfo Table (tab)

Esri Interchange File (€00)
Esri Shapefile (shp)
Geography Markup Language (gml, xml)

MicroStation Design (dgn)
Microsoft Excel (xls)

Notes: Exporting a MAP View to AutoCAD, Geographic Markup Language, Google Earth or MicroStation format will
assemble all layers into a single file.

Exporting a MAP View to a web map or geospatial PDF is explained in chapter 15 and 16, respectively.

Only MAP Point layers can be exported to Excel and delimited text data formats.

PREREQUISITES

While imported and user created MAP Views that contain MAP Layers are suitable for export to GIS formats, not all
formats support certain MAP layers. Unsupported MAP layers are disabled in the layers list.
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USING MAP EXPORT

Export a MAP View (including all MAP Layers)

To export all MAP layers of a single MAP View, select the MAP View to be exported in the MAP Views panel, then
click the Export MAP View button. Alternatively, choose Export "[MAP View name]" in the panel options menu. In the Export
dialog box, all the MAP Layers will be selected for export. To customize which layers are exported, check or uncheck
the check box beside a layer to include or exclude it from being exported. Choose the required file Format and save
location, then click OK.

Export a MAP Layer

To export a single layer, select the MAP Layer to be exported in the MAP Views panel, then click Export MAP Layer
button. Alternatively, click Export "[MAP View name]" in the panel options menu or click Export > Export MAP Layers from
the MAPublisher Toolbar. In the Export dialog box, the selected MAP Layer will be selected for export. To customize
which layers are exported, check or uncheck the check box beside a layer to include or exclude it from being
exported. Choose the required file Format and save location, then click OK.

Choose a Destination Folder or Specify a Filename

Most export formats require the selection of a destination folder only. All exported MAP layers are saved in the
destination folder.

When exporting to certain formats (e.g. AutoCAD), it is required to specify a file name. In cases where a format can
have multiple format extensions (e.g. kml and kmz), it can be manually entered or chosen by clicking the Browse
button and choosing an extension from the Save as type drop-down list.

GENERAL EXPORT SETTINGS

Most formats have the following general settings.

Keep Format Extension On Layer Names

The name of the MAP Layer or MAP View selected for export is used as the default name of the exported

file. However, the feature type (i.e. _area, _line, _point, or _text) text appended to Adobe lllustrator layers by
MAPublisher in the Import process are removed during the export process. To keep the feature type appended to
exported files, ensure that the Keep format extension on layer names option is checked.

Attributes
Choose to export all attributes or to export only visible attributes.

Properties
Choose to not export #property attributes, to export only visible #property attributes, or to export all #property
attributes. See MAPublisher #Property Attributes section in chapter 5.
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FORMAT SPECIFIC SETTINGS

Depending on the selected export format, additional specific settings may be available.

Note: Google Earth format only supports WGS84 geodetic coordinate system. Export to it will automatically transform
the vector data from the MAP View's coordinate system to this system as part of the export process.

DWG/DXF Settings CSV/XLS Settings

Release: R2007 - Attributes: |Export only visible attributes - Indude header on first line
D Keep format extension on layer names Properties: | Export all #Property attributes + | [] Export coordinate system as  WKT
|:| Export coordinate system to .PRJ

Release - Set the AutoCAD version number to export Include header - Add the column headers at Export coordinate system as - Optionally
Export coordinate system to .PRJ - Include a PRJ file with the first line of the exported text file include a WKT or PRI file with the export
coordinate system information with the DWG/DXF

€00 Settings

Compression - Set the compression of the

Attributes: | Export only visible attributes ~ | Compression: |Mone exported €00 file (default is None)

Properties: |Export all #Property attributes -

["] Keep format extension on layer names

KML/KMZ Settings KML Format Property Assignment
Attributes: |Export all attributes = | [[] Assign headings to placemark icons Lavers [isdock ol e
. . ) . Format Property ~ Source Cancel
: -
Properties: | Do not export properties [¥] Create placemark icons from symbols R B scrooL e v
[] Keep format extension on layer names Write default symbol names as placemark names #id #1d v
[] Use attributes’ Display Mame instead of Name <address> [ PRIMARY AD v
<phonelumber> | KmiPhone V| Ay
GML/XML Setti e e
e Ings <styleUrl> KmiStyleUr! v Ay
¥ Coordinate ordering: | Only reverse ¥+ for geodetic coordinates [Default] ~ =t Kmilcontiref v A
- - <heading> KmilconHeading v| Ay
Feature collection: Use simple features profile -
<scale> Kmilconscale v| Ay
Attributes: Export all attributes -

KML Format Property Assignment - Click the KML
Format Property Assignment hyperlink to assign
[] Keep format extension on layer names attributes to KML/KMZ specific metadata. Warning
indicates no attribute with the specified name
exists and will not be assigned on export.

Properties: Do not export #Property attributes -

X-Y Coordinate ordering - Set the X-Y coordinate ordering Feature collection - Select
for GML files. This may help in third-party software. output GML schema
. Seed File - If required, select a seed file to
DGN Settlngs be applied to the exported DGN file . Click
§ Clear to remove the seed file selection
Coordinate Units: Master - Seed File:
Coordinate Units - Specifies how feature
[[] Keep format extension on layer names coordinates will be interpreted and
Allow area fils Browse... Clear converted (Master, Sub or Units of

Resolution)

Allow area fills - Controls whether or not fill
linkages will be written out for ellipses,
shapes, and solids
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MIF/TAB Settings

Delimiter: | Comma (default) + | [] Suppress Pen and Brush lines
. MIF/TAB Format Property Assignment
Attributes: | Export only visible attributes + | [] suppress Point symbols Click the MIF/TAB Format
Properties: |Export all #Property attributes - Property Assignment hyperlink
to assign attributes to MIF/TAB
[[] keep format extension on layer names specific metadata
Delimiter - Set the field delimiters to either comma, 5
semicolon or tab MIF Format Property Assignment
Suppress Pen and Brush lines - Check this option to =
remove all pen and brush styles in the output Layer: Interstates_line v
Maplnfo MID/MIF files
Format Property Source Cancel
Suppress Point symbols - Check this option to remove
point symbols in the output Mapinfo MID/MIF files Pen pattern MapInfoPenPattern v
Brush pattern

ADDITIONAL NOTES

Valid Area Direction (Area Layer Exports)

When exporting area layers to GIS formats, polygon outlines must have a positive Area value, whereas holes
contained inside compound paths (or complex shapes) must have a negative Area value. If some polygons in the
#Area property column of the MAP Attribute table contradict these guidelines, use the following tools to convert
the MAPublisher area calculation from a negative to a positive value or vice versa:

«  Fip Lines tool (chapter 8) to convert multiple areas.

«  Create a MAP Selection (chapter 11) to select all elements that have an #Area of less than zero (to select
negative values) or greater than zero (to select positive values). Then use the Flip Lines tool.

«  Edit the #AreaDirection property value (chapter 5) to convert areas one by one: select the area to edit
and then choose the alternate value for #AreaDirection in the MAP Attributes panel.

Text Exports
Itis not possible to export values in the #Text property column. An alternative is to create a new string attribute
column and assign it an expression of #Text. See Edit Schema in chapter 5 on MAP Attributes.

Texts on a path are exported as point text with an angle (main direction of the original path).

Opening Microsoft Excel Files Exported from MAPublisher in Microsoft Office

In Microsoft Office 2003 and 2007, a warning may occur when opening a Microsoft Excel (xIs) file exported from
MAPublisher. The file will open in Protected View stating that a problem was detected with the file. To edit the
contents of the file, click the Enable Editing button. The file is safe to use.

Similary, in Microsoft Office 2010 and newer, an unreadable content warning may appear. Click Yes to recover the
contents of the workbook. The file will open in Protected View stating that a problem was detected with the file. To
edit the contents of the file, go to File > Info and click the Edit Anyway button. The file is safe to use.

A workaround is to export to Delimited XY Data (csv) for use in Microsoft Office.
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MAP Info Panel

Window > MAPublisher > MAP Info or MAP Toolbar > MAP Info

Displays the parameters of the currently selected layer.

¢ MAP Info =
P“s'b“" M o Geodetic base - Longitude/Latitude - The longitude
Position - Easting/Northing - The Easting ..":“r:."_l“‘—‘;;f:z::iz';s L":_’“‘”jiizi‘f +————and latitude based on the geodetic datum of
and Northing coordinates of the cursor LA RrE=F the coordinate system
in current map units @usamap
Scale: 1: 20,500,000.000 Rotation:0.00° Units:Meter | Scale- Map scale of the current layer
‘Coordinate System:United States: Lambert Conformal Coni... Rotation - Angle of rotation

Units - Units of the coordinate system (if specified)

Coordinate System - Coordinate system of
i the current layer (if specified)

FUNCTIONALITY

The MAPublisher MAP Info panel displays the coordinates of the mouse cursor on the selected map layer, in current
Map Units and in Degrees. Geodetic latitude and longitude values are in reference to the geodetic datum set in the
coordinate system definition. The WGS84 latitude and longitude values are in reference to the World Geodetic
System. Ungeoreferenced layers display its coordinates in Page Units. The panel also displays Scale, Rotation and the
Coordinate System and Units of the active MAP Layer.

USING THE MAP INFO PANEL

Click the MAP Info button on the MAPublisher toolbar or from the menu Window > MAPublisher > MAP Info. The map
coordinates update in the panel with every change of the location of the mouse cursor.

The map units correspond to the units of the active layer. If it is a MAP Layer, the units are taken from the MAP
View's source coordinate system. If it is a Non-MAP Layer, the units of the Adobe lllustrator documents are used (see
File > Document Setup).

To show Geodetic, WGS84 or MGRS (Military

. . Show Geodetic Base
Grlq Reference System) values, click the~ panel | . . GRS hour et
options menu and choose the appropriate Longitude:-55.560565 Grid: 50X MQ 46566 61655

£ MAP Info

i v Show MGRS
display. The panel will update to display the Latitude:22.293466
h dinat | Cemzt Preferences...
chosen coordinate values. Scale:1: 45,578,651.941 Rotation:0.00° Units:Degres
Coordinate System:NAD27

Notes: The map coordinates update even when other tools are selected.

When the cursor is placed outside of the MAP View extent of the selected layer, positions' values are
indicated as Unavailable.
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Copy MAP Objects From

MAP Views panel > Copy MAP Objects From or MAP Toolbar

Copy MAP Objects From
Check the MAP Objects to copy: o 3
Document - Available open Object Source =
map document 4 Exercise2-12_flash_ready.ai
4 @ MAP Views
MAP Views - List of available @ Chicagoland
MAP Views to import 4 5 MAP Themes

Source Toggle - Click
check box to select
MAP Objects in source
document for copy to
the active document

Census Median Age

@ Male vs Female

MAP Themes - List of available Metra System Stylesheet
MAP Themes to import Pink - Census Median Age

Population Density

H Population Distribution

4 [ MAP Selections

Manual School Selection

MAP Selections - List of available @ Select Schools in West Town
MAP Selections to import fin Select West Town Community

fin Total Population not null

OO&OFNDOOO0OR E & & =

Copy MAP layers belonging to copied MAP Views

FUNCTIONALITY

Copy MAP Objects From is used to copy MAP Views (all of its layers are included), MAP Themes, MAP Locations and
MAP Selections from a working document to another open document. This can be a useful tool when merging parts
of several documents into a single document. For example, use it to copy a commonly used inset map.

PREREQUISITES

At least two Adobe lllustrator documents must be open to use Copy MAP Objects From. The active document does
not need to contain any MAP View, but the second document must contain at least one MAP View.

Note: Copy MAP Objects From imports all the layers contained in the selected MAP View. To choose specific MAP
layers to import, in the source document, make a duplicate of the MAP View and copy or move only selected
layers to it. Then proceed to import the duplicate MAP View.

USING COPY MAP OBJECTS FROM

Click the Copy MAP Objects From button on the MAPublisher Toolbar or click Copy MAP Objects From in the MAP Views panel
options menu.

The Copy MAP Objects From dialog box shows all other documents currently open, along with all the MAP Views,
MAP Themes and MAP Selections they contain. Click the toggles to select at least one MAP object to be copied from

the source document and click OK to copy it to the active document.

Note: Copy MAP Objects From can also be accessed in the MAP Themes and MAP Selections panel options menus.
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MAP
Attributes

MAPublisher can import GIS files into Adobe lllustrator while
maintaining both geographic referencing and attribute
information. This makes it very easy to produce high quality
maps.

Attribute information can be used in many powerful
MAPublisher functions such as MAPublisher labeling engines,
MAP Themes, MAP Selections and MAP Web Author.

This section explains the principles of attribute information
and how they are manipulated within MAPublisher.

Topics covered in this section are:
Attributes Foreword

MAP Attributes Panel

Edit Schema

Expression Builder

Find & Replace Attributes
Apply Expression

Join Table

Export Attributes
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Attributes Foreword

ATTRIBUTE INFORMATION

The attribute table that forms part of a GIS map file is one of the most important parts of the data set. It is in the
attribute table that we find important information such as street names for lines, zoning or zip code numbers for
areas and elevations for points to go along with our line, area or point vector data. Along with line, area and point
vector data imported as explained in the previous sections, MAPublisher also imports the attribute data table
associated with any vector map file that it supports.

MAP LAYERS

All MAP Layers contain attribute information (except Legend MAP Layers). Each MAP Layer is symbolized in
MAPublisher panels and dialog boxes with an icon depicting its feature type:

Area layer
Line layer

(e.g. county boundaries, urban areas, country outlines etc.)

(e.g. rivers, roads, railways etc.)

Point layer  (e.g. town and city symbols, railway stations etc.)
Textlayer  (e.g. text, labels, annotation, etc.)
@ Image layer (for referenced and unreferenced images)

MAPUBLISHER #PROPERTY ATTRIBUTES

In addition to the attribute values that were imported into a work session, Area, Line, Point, Text and Image MAP
Layers are also assigned a number of additional MAPublisher attribute columns. These property columns (prefixed
with a #) are designed to indicate the physical properties of map art on the Adobe lllustrator canvas. Art can be
modified directly from the attribute table by making edits to values in these columns. The following property
columns are attached to valid map layers in this version of MAPublisher:

Area layers

#lLayerName The name of the containing layer. This property cannot be set.

#ID The internal unique ID to refer to Adobe lllustrator artwork within the document. Read-only.
#Name The name of the polygon. Editing this property will change the name in the Layers panel.
#AreaDirection The direction as clockwise or counter-clockwise. Editing it will reverse the direction.
#VertexCount The number of points in the art. This property cannot be set.

#Style The Graphic Style in use. Editing this property will apply the selected style to the art.
#StrokeWeight The stroke weight of the path. Editing this property will alter the stroke weight of the art.
#Perimeter The perimeter of the area in world units. This property cannot be set.

#PathClosed Describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
#ArtScale The scaling of the line stroke. Editing this value will scale the stroke weight.

#Area The area of the path in world units. This property cannot be set.

#Opacity The opatcity level of the polygon. Editing this property will change the opacity of the art.
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Line layers

#LayerName
#ID

#Name
#VertexCount
#Style
#StrokeWeight
#PathClosed
#lLength
#ArtScale
#Opacity

Point layers
#LayerName
#PageX
#PageY
#ID
#Name
#HorizontalScale
#VerticalScale
#Rotation
#Style
#MapX
#MapY
#Opacity

Text layers

#LayerName
#PageX

#PageY

#ID

#FontSize
#FontFamily
#Name

#Text
#TextLength
#Rotation
#Style

#MapX
#MapY
#HorizontalScale
#VerticalScale
#Opacity

The name of the containing layer. This property cannot be set.

The internal unique ID to refer to Adobe lllustrator artwork within the document. Read-only.

The name of the polygon. Editing this property will change the name in the Layers panel.

The number of points in the art. This property cannot be set.

The Graphic Style in use. Editing this property will apply the selected style to the art.

The stroke weight of the path. Editing this property will alter the stroke weight of the art.
Describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
The length of the path in world units. This property cannot be set.

The scaling of the line stroke. Editing this value will scale the stroke weight.

The opacity level of the polygon. Editing this property will change the opacity of the art.

The name of the containing layer. This property cannot be set.

The x-coordinate in the document units of the current point.

The y-coordinate in the document units of the current point.

The internal unique ID to refer to Adobe lllustrator artwork within the document. Read-only.
The name of the point. Editing this property will change the name in the Layers panel.

The horizontal scaling of a point object. Editing this value will scale the symbol in the X axis.
The vertical scaling of a point object. Editing this value will scale the symbol in the Y axis.
The rotation in degrees of the art around its anchor point. Editing this value will rotate art.
The Symbol in use. Editing this property will apply the selected symbol to the art.

The x-coordinate in the world units of the current point.

The y-coordinate in the world units of the current point.

The opacity level of the polygon. Editing this property will change the opacity of the art.

The name of the containing layer. This property cannot be set.

The x-coordinate in the document units of the current point text. For text-on-a-path or text-in-a-
path, this will be the x-coordinate of the first vertex on the associated path.

The y-coordinate in the document units of the current point. For text-on-a-path or text-in-a-path, this
will be the y-coordinate of the first vertex on the associated path.

The internal unique ID to refer to Adobe lllustrator artwork within the document. Read-only.

The font size used by the text.

The font family used by the text.

The name of the text field. Editing this property will change the name in the Layers panel.

The contents of the text. Editing this will affect text on the page. Multiline text is allowed.

The number of characters in the contents of the text art. This property cannot be set.

The rotation in degrees of the art around its anchor point. Editing this value will rotate art.

The Character Style in use. Editing this property will apply the selected style to the art.

The x-coordinate in the world units of the current point.

The y-coordinate in the world units of the current point.

The horizontal scaling of a point object. Editing this value will scale the text in the X axis.

The vertical scaling of a point object. Editing this value will scale the text in the Y axis.

The opacity level of the polygon. Editing this property will change the opacity of the art.
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@ Image layers

#LayerName The name of the containing layer. This property cannot be set.

#ID The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name The name of the text field. Editing this property will change the name in the Layers panel.
#PixelWidth The number of pixels across the width of the image.

#PixelHeight The number of pixels across the height of the image.

#Opacity The opatcity level of the image. Editing this property will change the opacity of the image.
#LowerLeftX The lower left X coordinate of the image. Read-only.

#LowerlLeftY The lower left Y coordinate of the image. Read-only.

#UpperLeftX The upper left X coordinate of the image. Read-only.

#UpperLeftY The upper left Y coordinate of the image. Read-only.

#UpperRightX The upper right X coordinate of the image. Read-only.
#UpperRightY The upper right Y coordinate of the image. Read-only.
#LowerRightX The lower right X coordinate of the image. Read-only.
#LowerRightY The lower right Y coordinate of the image. Read-only.

Warning: The #ID property is not persistent. This means that if a document is saved and re-opened, the #ID value
might change. The value will usually not change over the life of a document session, but there are Adobe
lllustrator operations that can cause the value to change.

IMPORTANT ADOBE ILLUSTRATOR COMPATIBILITY NOTES

Several Adobe lllustrator functions may cause the link between artwork objects and their attributes to be broken,
resulting in possible data loss. These functions are:

«  Compound path (Make) «  Blob brush

. Pathfinder «  Shape-builder tool
. Live Paint . Eraser Tool

«  Gradient mesh . Knife Tool

By default, releasing a compound path also breaks the link between released paths and the attributes. To avoid

this behaviour, users may enable the option Replicate attribute data to compound path sub-components in the MAPublisher
Preferences for MAP Attributes. This option must be enabled before the attribute schema is created or updated for
the attribute data to be copied to the compound path components. To enable this option, follow the steps below:

1. Enable Replicate attribute data to compound path sub-components.
2. Change the visibility status of one attribute column to force the attribute schema to update itself.
3. Release the compound path.

Note: This option has an impact on performance, so it should only be enabled if necessary.

If required, users should first duplicate their working layer in the Adobe Illustrator Layers panel before using these
functions. The original layer can be kept for labeling (see chapter 10 and 18) or for information purposes.
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MAP Attributes Panel

Window > MAPublisher > MAP Attributes and MAP Toolbar

Click header to sort column
values alpha/numerically

Pin - Attributes remain viewable
even after features are deselected
MAP Data Snapshot - Open current
attribute view in a new panel. Click

MAP Attributes
" to update new panel. (CS6/CC only)
laye'r Selection - If data is selected on —feLayer: | Bl usa_area (51 aress selected) | I~] o EF Edit Schema - Edit the properties of
multlpleilaye'rs, select the MAP layer #1d [El#PathClosed  |[E #Area [GISTATE NAME _ [[FSUB_REGION | ElFiag | all columns of the current attribute
to view its respective attributes 1 504084430 ] 20,750323 deq? | Washington Pacific =] washington table: column names, visibility,
: . . :
2 504085248 ™ 45.134160 deg? | Montana Min = montana type and width, assign expressions
& 504077952 [ 9.570598 deg? | Maine NEng = maine to col
4 504078720 ™ 21.874768 deg? | North Dakota Vi N Cen 5 north-dako © columns
. . . 504079488 22.597730 deg? |South Dakota WiNC — Fi _Cli
Attributes and Properties Attribute and Z il Sl S = IEl south-dak Find & Replace - Click to find and
& 504050258 & R SB[ Min [ wyoming replace attributes in the current
property values on the selected 7 504083328 O] 16.477393 deg? | Wisconsin ENCen (A Mo image... atgibute table
layer are displayed here 3 504138240 4 24,391725 deg? |Idaho Min Mo image...
B 504137472 ] 2.794048 deg? | Vermont NEng A —— Apply Expression - To assign attribute
% 504139008 ™ 25,577963 deg? | Minnesota Vi N Cen A b imagqe— values or graphical properties to
selected art via the input of an
3 ar
Ee & 3£ X
51 arafas selected e Ee B, fin 3;5 . expression
| L JoinTable - Click to join an external data
Selected objects - Number Show/Hide Columns - Enable or ~ Zoom to Feature - Click the table to the current attribute table
of objects selected on the disable column names to show or  Feature number or right
current layer hide columns. Or choose to show  click the attribute and
all columns, or hide all columns.  select Zoom to Feature
Context menus
Right-click (Windows) or Ctrl-click (Mac) to display the menus: Panel options menu:
Edit Column - Edit the properties
In column header: In arow: New Column prop
Edit "STATE NAME" .. of the selected column
4=+ Resize All To Fit Content. % Zoom To Feature g
Delete "STATE_NAME" R
e Resize 'AREA' To Fit Content S e - Delete Column - Delete the
| e AREN Aute-Zoom currently selected column
Hide 'AREA §  New Column... Lock Zoom Level Auto-Zoom - When enabled, the
Hew Column.. 4 | BR T map document will zoom to the
#  Edit 'AREA Delete 'AREA' Edit Schema... N -
I how All I selected attribute automatically
Delete "AREA Show/Hide Columns » o
25 Show/Hide Columns s Show All Except Properties Apply Expression... Lock Zoom Level - When enabled,
[E  Create MAP Art Selection From Selected Row Hide Al T T locks the zoom level
Resize [column] to fit content .
Reessizee[(::ly tLt: sél(:ctt: d‘ (e e D #0pacity Export Attributes... Export Attributes - Export all
columns Hide Column - To hide the #ComponentCount Preferences. selectec} a'ttnbute information
currently selected column [ #layerName to a delimited text file
Resize all to fit content #d
- . - Preferences - Opens the MAP
Resize the width of HewColumn - Ads Cbute L) it Attributes azel references
all columns to fit the column to the attribute table #AreaDirection panelp
~ (see chapter 1)
Iongest value VertexCount

FUNCTIONALITY

The MAP Attributes panel displays the map attribute and property attribute records for selected features on MAP
layers and makes them available for editing. This panel is also the hub from which you can edit column schemas,
toggle visibility, add or delete columns, join tables, find and replace attributes, and apply expressions to selected
art. Only the visible attributes of selected map features will be displayed in the panel.

USING THE MAP ATTRIBUTES PANEL

Viewing Attributes

Selected features are sorted by layer. The Layer drop-down list shows all the layers that currently have features
selected, as well as the number of selected map objects for each layer (also reported at the base of the panel). The
attribute values displayed in columns in the MAP Attributes panel can be sorted in ascending or descending order
by clicking the column header. The widths of the columns may be changed by clicking the column separator and
manually dragging it to resize as desired. Use the recordset navigation controls to scroll through table entries.
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The type of attribute is indicated by an icon preceding the column name:
[E] Boolean column contains True or False values
i Integer column contains only whole numbers (limited to 10 digits)
Double column contains numbers carrying decimal values (formerly Real)
i3] String column can contain attributes that are both alpha and numeric
@ Image  column can contain images (PNG or JPG)

Edit Attributes

The MAP Attributes panel is a table that displays all the attributes of selected art. All attribute values may be

edited except for certain MAPublisher Property attributes (see earlier in this chapter). To change the value of a cell,
double-click it and enter the new value. Keep in mind that entered values must correspond with the column type
(i.e. only enter numbers into a column of type Double or Integer). The edits will be immediately reflected in the map
documents database records. Existing attribute records may also be edited or modified by performing a find and
replace operation on them.

Image Attributes

The image attribute type is used to store an image for each record in the MAP Attribute table. To assign an image
to a record, click the No image hyperlink or click the name of an existing image hyperlink to open the Edit Image
Attribute dialog box.

Edit "Flag Image”

Select/Replace image - Select or replace ————5, [ |3 = 4| (2 Zoom: 100% e——s—————— Navigation controls - Zoom to fit, Zoom
animage T to actual size, zoom in and zoom out

Cancel
Export image attribute - Export th
image attribute and save it to disk

Clearimage - Remove the current
image from the preview

WISCONSIN

Preview - Preview the image
before adding it to the
MAP Attributes panel

Name - The filename can be ——eName:  wisconsin.png
edited, which is reflected in
the attribute table

Image size: 150 x 100 pixels Disk size: 58,53 KB

Click the Select/Replace image button to browse for an image file (only PNG or JPG). The preview area shows the
selected image. Use the navigation controls to adjust the zoom of the preview area. Click Export image attribute to
save the image to a location on your system. Click Clearimage to remove the image from the preview. To adjust the
filename, edit the contents of the Name box. This will be the name used in the attribute table.

When creating an image attribute type column in Edit Schema (see next section), a default image can be chosen
that will apply to all records.
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Property Attributes

The attribute table can also be configured to display property attributes for datasets. These attributes describe the
current assignment of graphical properties such as the stroke weight, style, rotation and scale. Some of these fields
can be edited and provide the ability to modify a map object's graphical properties directly within the context of
the MAP Attributes panel.

Column Visibility

Click the Show/Hide Columns button (or right-click [Windows] or Ctrl+click [Mac] on a column in the dialog box) to edit
the column visibility, either toggling visibility for individual columns or for all columns. It is also possible to edit the
visibility of attribute columns with the Edit Schema tool.

This function will also Show All, Show All Except Properties (show only attributes that are non-property attributes,
consequently hiding any visible property attributes) or Hide All.

Zoom to Feature and Auto-Zoom

To zoom into a specific feature in the attribute table, select a single attribute and click the Zoom to Feature button. This
will automatically fit this feature to the screen and highlight it—useful for closer examination or to simply locate it
on the map. To highlight a specific feature on the page maintaining the current zoom level, click another attribute
of that feature.

To automatically zoom to a selected feature, enable Auto-Zoom in the panel options menu. As long as it is enabled,
the zoom will change every time a different feature is selected. Use Lock Zoom Level to maintain the same zoom level
for all features selected afterwards.

Pin Attributes and MAP Data Snapshot Panel

Click the Pin button to keep selected attributes active even after the artwork is deselected. This may be helpful
during attribute editing when accidentally deselecting artwork may occur. When attributes are pinned, attribute
values can be manually edited but the functions at the bottom of the panel are disabled except for Zoom to Feature.

Click the MAP Data Snapshot panel button to open another panel to view selected attributes (CS6 and higher). The
panel is useful for comparing attributes against other attributes in the same document or another document. The
MAP Data Snapshot panel remains active even after features are deselected. To update the panel with the latest
adjustments in the MAP Attributes table, click the MAP Data Snapshot panel button again.
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Edit Schema

MAP Attributes panel > Edit Schema / Edit Column / New Column

Edit Schema " Name - Edit the name of the

- selected column
. | [[E #Opacity A | Name: STATE_NAME
Up/Down - Click to move the ——- | | @ #CompenenCount e ‘
selected column up or down [ #LayerName TR STATE_NAME Cancel Display Name - Edit the column
the column list. Affects order #ld Type: [#3] string - display name
in the attribute table. 5 #Name
#AreaDirection Size: 13 5 Type - Choose column type:
Column list - Attribute and FertexCount Integer, Double, String or
(#) property columns on the B #style Defaut value: Boolean
property " #StrokeWeight
current layer are listed here. #Perimeter visible . . .
Select a column here to edit & #PathClosed [ Read-only Slze/I?EIImﬂS - Adjust the length
its properties on the right. #ArtScale o S . of String type or number
#hrea B of decimals of Double type
PERIMETER, Expression: & @
AREA Default Value - Assign the
same value to all items in the
[ STATE_FIPS lected col if ired
[ SUB_REGION v selected column, if require:
Add - Click to add a NeW —+——=|  Add Remove Visible - Choose to show or hide
column to the column list the selected column
Remove - Click to delete . .
the selected column Derive value from expression - Check this option to assign ————— Read-only - Check this option
an expression to the selected column. Either enter to ensure that values in this
the expression directly into the entry field, or click the column can not be edited

Browse button to access the Expression Builder dialog box.

In MAPublisher, the term schema is used to define the structure of the MAP Attributes table.

FUNCTIONALITY

The Edit Schema function provides settings to edit and manage the attribute structure of datasets, create, edit and
delete columns, set visibility preferences and assign expressions. Any changes made to the schema will instantly be
reflected in the MAP Attributes panel.

USING EDIT SCHEMA

Select map artwork containing attributes to populate the MAP Attributes panel. Click the Edit Schema button or
menu item in the MAP Attributes panel options menu to open the Edit Schema dialog box.

Note: Edit Schema can also be accessed via the Edit Column context menu. Within the MAP Attributes panel, select
the column to be edited, right-click the column heading or cell and click Edit [column name]. Edit Schema opens
with the same column immediately selected in the column list.

Edit Schema lists all of the columns which currently exist in the MAP Layer attribute structure, including MAPublisher
Property attributes (see previous section). By default, imported or created attributes will be visible, whereas property
columns will not be shown by default. Please note some #Property column structures cannot be edited (read-only).

Edit Column Format

Each column has a name and display name. The name is used in the expression builder and for export. The display
name is used when exporting to geospatial PDF (see chapter 16) and is shown by default in the column name in the
MAP Attributes panel (see MAPublisher Preferences in chapter 1).

Punctuation characters are not supported in column names in order to avoid potential conflicts when exporting to
external formats. The following illegal characters are replaced with an underscore '_" upon data import or join table:

space’ ~1@# S % A&*()-+={}[1];:""\,<.>/7?
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To rename a column enter new text directly into the Name field. All expressions referring to this attribute name are
updated instantaneously.

Note: Some external file formats have limits on the number of characters allowed for field names. Therefore, during
the export from MAPublisher, some field names may get truncated to comply to the chosen external file
format. For example, Esri shapefiles are limited to 10 characters (confirmed up to ArcGlIS 9.3), Esri Interchange
File (e00) to 16 characters, and Maplnfo to 30 characters.

Once the name is set, specify a data type by making the appropriate selection in the Type list.

To modify the amount of characters or decimals, enter a value into the Size/Decimal text box (the maximum string
size is 28000). A Default Value can be assigned for all new objects placed on the selected layer by entering text
accordingly. Check or uncheck the Visible option to edit a column’s visibility. Check or uncheck the Read-only option
to edit a column’s read/write status.

Check the Derive value from expression option to assign an expression to the selected column. Enter a valid expression
in the Expression field or click the Browse button to enter and edit expressions via the Expression Builder dialog box.
The Expression Validity icon will report if the expression entered is valid. Otherwise it will report and include additional
warning notes. This function is useful, for example, to populate the column values based on the contents of other
columns and/or mathematical formulas.

Note: Values derived from expressions are dynamically linked to the attributes used in the expression. Therefore,
they are read-only. Use the Apply Expression function to generate values that can be modified.

The following are some examples of basic expressions that can be assigned to columns in Edit Schema:

Basic expression Result

“Ontario” (applied to column = NAME) Allitems are assigned the value “Ontario” in the NAME column.

All area items are assigned the value “MAP Area 01” in the #Style column and

13 ” I -
MAP Area 017 (applied to column = #5tyle) are assigned the Graphic Style “MAP Area 01" on the page.

All point items are assigned the value 45 in the #Rotation column and are

45 (applied to column = #Rotation) rotated to 45° on the page

Note: String values are case-sensitive and must be entered between quotation marks (“.”).

Add, Delete and Re-Order Columns

Columns display in the MAP Attributes panel according to the display order established in Edit Schema. The display
order of attribute columns in the MAP Attributes panel can be set by reordering the existing column list. Any
column may be moved up or down the list by selecting it and clicking the Up or Down buttons.

To create a new column, click the Add button and input the desired column properties. To delete an existing column,
choose it from the column list and click the Delete button. Click OK to confirm the edits to the schema. These edits
will be immediately visible in the MAP Attributes panel.
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Expression Builder

Available in Edit Schema, Apply Expression, New/Edit MAP Selection,
Edit Chart Theme, Edit Stylesheet Theme, Rule Generator

Expression Builder

Expression Builder

Operator buttons - Click to insert an—e| ( | ) AND | OR = h=l<] > -1 1= &
operator into the expression at the - —
current cursor position (POP 1959/ AREA) =100 Cancel Library - Access all expressions for the
Expression Entry - Area to compose document including recently used,
. [i] Library... e=— attribute filters, named expressions
expressions
Expression Validity - Indicates if the — e The expression s valid. Position: 19 Save... | &= Save - Save the current expression to a
Lo . R ‘@ named expression.
_expr_esswn !s.valld-J o_r invalid @. Objects Description ” p -
Ifinvalid, additional info is reported. || = —— Cursor Position - Position of the current
4 Functione AREA text entry point
Objects - List of attribute and property |——e » MathFunctions Type: Real Description - Displays information about
columns, constants and functions for > String Functions Size: 2

use in the expression. Double-click
items to insert into expression.

Layer attributes - List of the attribute and
property columns

Functions - List of functions for use in the

» Miscellaneous Functions
4 Constants

expression if required

Default Value: 0.006000000

Refresh unique values

66.000000000

1044.000000000
2054.000000000
45976.000000000
6381.000000000
7507.000000000

the selected item in the Objects panel,
i.e. a description and example of the
function or constant, or information
regarding the format of the MAP layer
along with its attribute values.

When selecting an attribute, click the
link Display unique values* to display

the attribute values of the selected

Constants - List of constants for use in the—,
expression if required

attribute column.

*Display unique values only lists up

to a maximum set in the MAPublisher
Preferences for the Expression builder (see
chapter 1 for more information)

Save Expression
Save Expression dialog box appears when Save button in Expression Builder is clicked

Save Named Expression

A Save

Cancel

MName: | Population Density

FUNCTIONALITY

The MAPublisher Edit Expression tool is used for the entry and editing of expressions. It is used in a number of
locations such as creating new attribute values and properties, making selections or apply styles. Expressions are
built using a combination of names, operators and functions.

Edit Expression is available for a number of tools throughout MAPublisher:

Edit Schema: To create or edit an expression for the generation of values in an attribute or column.
(MAP Attributes panel > Edit Schema > Derive value from expression)

Apply Expression: To apply an expression to an attribute or property column for selected art only.
(MAP Attributes panel > Apply Expression)

New/Edit MAP Selection (chapter 11): To create or edit expression criteria for use in selecting map data.
(MAP Selections panel > New/Edit MAP Selection)

Edit Stylesheet Theme (chapter 9): To create or edit an expression for use in styling map data.

(MAP Themes panel > Edit [Stylesheet Theme name] > Advanced Expression mode
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ENTER EXPRESSIONS

Expressions can be built by typing or by clicking the operator buttons and items in the Objects list (attribute name
and values, constants and functions). These items are colour coded for easy identification: attribute names in

purple, string values in orange, operators and numerical values in grey, constants in green and functions in black.

Click any of the operator buttons or double-click an item from the Objects list to insert it into the expression.

It is recommended to use the interface rather than the keyboard to build expressions, to guarantee functions are
formatted correctly (e.g. with brackets and appropriate case) and for attribute values of type strings, quotations
marks are added automatically. Note that expressions are case-sensitive. For string comparison, all strings values
can be converted to a same case using the appropriate function (LOWER(“string”) or UPPER(“string”)).

Validity

The validity of the expression will be displayed below the Expression Entry text area and will be updated as the
expression is built. The Expression Validity icon will report if the expression entered is valid (green check mark).
Otherwise it will report invalid (red exclamation) and include additional warning notes.

Operator Buttons
Click to insert an operator at the current cursor position. Available operators are as follows:

( Open clause operator < Logical less than comparator

) Close clause operator >  Logical greater than comparator

AND Logical AND operator +  Mathematical addition operator

OR  Logical OR operator - Mathematical subtraction operator

= Logical equal to comparator | Mathematical division operator

I= Logical not equal to comparator *  Mathematical multiplication operator
&  Text concatenate operator
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Expression Components

Items in the Objects list are divided
into three function categories:
math, string and miscellaneous.
Information on a selected item is
displayed in the Description panel.
Double-click to insert an object at
the current cursor position.

<MAP Layer>*
List of attribute columns’

List of #property columns

Constants

[E] #false Boolean false value

& #true Boolean true value

#pi 7 numerical value (3.141592)

* Layer may vary depending on tool.
For Edit Schema, Apply Expression
and New/Edit MAP Selections, the
current layer is displayed. In Edit
Stylesheet Theme, all layers hosted by
the stylesheet are displayed.

1 Unique values contained in each
attribute column can be viewed in the
Description panel.

Notes: String values are case-sensitive
and must be entered in double

quotes (“.").

For functions using indexes for
text position (MID, SEARCH and
SPLIT), the first index number
is 0.
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ABS

ACOS

ASIN

ATAN
CONTAINS
Ccos
DEGREES
ENDSWITH
FIXED
FROM_HEX
IF

IF_CASE
LEFT
LENGTH

LIKE

LOG

LN

MAX
MAX_COLNAME
MIN
MIN_COLNAME
LOWER

MID

MOD
NUMBER
POW
PROPER
RADIANS
RAND
REGEX
RIGHT
ROUND
ROUNDDOWN
ROUNDUP
SEARCH

SIN

SPLIT

SQRT
STARTSWITH
SUBSTITUTE
SUBSTITUTE_RX
TAN

TO_HEX
TRIM

UPPER

Description
Absolute value of a number

Inverse of the cosine of an angle

Arcsine of an angle

Arctangent of an angle

True if source string contains search string

Cosine of an angle

Converts values from radians to degrees

Returns true the source string ends with the suffix string
Numbers as string values

Returns the decimal value of the hexadecimal string
Conditional statement

Conditional statement based on multiple cases

Extracts the first N characters of a string

Returns the number of characters in a string

Searches the source string using wild cards

Gets the logarithm of the value (base 10 log)

Gets the natural logarithm (base e log, e = 2.718281828)
Returns biggest attribute value

Returns name of attribute which has biggest value
Returns smallest attribute value

Returns name of attribute which has smallest value
Converts string to lower case

Extracts N characters of a string from a specified location
Gets the remainder of numerator divided by divisor
String values as numbers

Base to the power of an exponent

Strings converted to capital case

Converts values from degrees to radians

Generates a random value between zero (min) and value (max)
Searches the source string using a regular expression
Extracts the last N characters of a string

Rounds to specified decimals of precision

Rounds down to specified decimals of precision

Rounds up to specified decimals of precision

Returns the position of a character in a string

The sine of an angle

Splits a string and extracts the indexed part of it

Square root of a value

Returns true if the source string starts with the prefix string
Replaces a set of characters by another in a string
Replaces a regular expression by characters in a string
Tangent of an angle

Returns hex string version of value

Removes all spaces in a text (except single ones between words)
Converts string to upper case



Examples of Basic Expressions

APPLY EXPRESSION

Expression

Result

“Ontario” (applied to column = NAME)

All items are assigned the value “Ontario” in the NAME column.

“MAP Area 01” (applied to column = #Style)

All area items are assigned the value “MAP Area 01” in the #Style column
and are assigned the Graphic Style “MAP Area 01" on the page.

45 (applied to column = #Rotation)

All point items are assigned the value 45 in the #Rotation column and are
rotated to 45° on the page.

MAP SELECTIONS

Expression

Result

NAME = “Ontario”

All items with the value “Ontario” in the NAME column are selected.

POPULATION < 1000000

All items with values less than one million in the POPULATION column are
selected.

NAME = “Ontario” OR NAME = “Alberta”

All items with the value “Ontario” OR “Alberta” in the NAME column are
selected.

NAME = “Ontario” AND POPULATION < 1000000

Only the items containing the value “Ontario” in the NAME column AND
values less than one million in the POPULATION column are selected.

MAP THEME STYLESHEET

Expression

Result

NAME = “Ontario”

All items with the value “Ontario” in the NAME column are assigned the
selected style.

POPULATION < 1000000

All items with values less than one million in the POPULATION column are
assigned the selected style.

NAME = “Ontario” OR NAME = “Alberta”

All items with the value “Ontario” OR “Alberta” in the NAME column are
assigned the selected style.

NAME = “Ontario” AND POPULATION < 1000000

Only items containing the value “Ontario” in the NAME column AND
values less than one million in the POPULATION column are assigned the
selected style.
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EDIT SCHEMA

Expression

Result

LOWER(NAME) (applied to column = name)

All items in column name are assigned the value of the column NAME in
lower case (e.g. “ontario” for “Ontario”)

PROPER(name) (applied to column = Proper_name)

All items in Proper_name are assigned the value of the column name in
proper case (or capital case) (e.g. “Ontario” for “ontario”)

TRIM(JOINING_COLUMN)

All items are trimmed with all spaces except single ones between words
(e.g." Route 66 "becomes "Route 66"). This is particularly useful prior
to using the Join Table function because extra spaces at the beginning,
end or in between words will cause the join to fail.

Examples of Complex Expressions
MAP SELECTIONS or MAP THEME STYLESHEET

Expression

Result

LIKE (NAME, “*New*”)

All items with the string of letters "New" in the NAME column are selected
(e.g. “New Brunswick” and “Province of Newfoundland”)

STARTSWITH (NAME, “0”)

All items that starts with the letter “0” (“Ontario”) are selected.

EDIT SCHEMA

Expression

Result

ROUND((POPULATION/ AREA ),3)
(applied to column=density)

All items are calculated as “population divided by area’; rounded to three
decimals.

IF_CASE("null", VALUE>0,"positive" ,VALUE<0,
"negative')

A default status of "null" is assigned unless the value is strictly greater than
or less than zero.

SUBSTITUTE_RX(ROAD_NAME,"\D","")

All non digit characters (\D is the regular expression for non-digit char-
acter) are replaced by nothing (two double-quotes indicate that the new
string is blank), therefore only numerical values are kept. For example, if
the ROAD_NAME equals "Route 66", the result is "66" This can be useful to
prepare an attribute table prior to labeling roads with road number rather
than road names.

SPLIT(GEOLOGIC_UNIT,"(",0)

All items containing one or more open parenthesis are split in several text
blocks (as many as there are open parenthesis, plus one), and returns

the first block found (index 0). For example, if GEOLOGIC_UNIT equals
"Qmw(Qc)’, the result is "Qmw".

SUBSTITUTE(SPLIT(GEOLOGIC_
UNIT’" (",1),")"," ")

Removes all closing parenthesis (i.e substitute all closing parenthesis
with nothing) in the result of the same SPLIT as above, that returns the
second text block found (index 1). For example, if GEOLOGIC_UNIT equals
"Qmw(Qc)’, the result is "Qc™: first the SPLIT function returns "QC)" and
then ")"is removed with a SUBSTITUTE.

More examples of each individual function can be found in the Expression Builder dialog box. Expand the Expression
Components, choose a function or constant on the Objects list and the Description tab is updated with explanations

and examples.
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EXPRESSION LIBRARY

Expressions already entered in the MAP Attributes panel, MAP Themes stylesheets (see chapter 9) or MAP Selections
panel (see chapter 11) can be reused by selecting them from the Expression Library.

Expressions are sorted in three categories: Recent, Named Expressions or Attribute Filter. One or more entries can be
selected per category. Click the Insert button to add the selection to the Expression Builder—multiple selections are
concatenated with the AND statement.

Note: It is not possible to insert multiple expressions from different categories at once.

Recent Expressions

Expressions in the Recent tab of the Expression Library are expressions saved in memory for the time of the Adobe
lllustrator session (they are reset if the document is closed). They correspond to expressions recently typed

in the Expression Builder from the MAP Attributes panel or MAP Themes stylesheets but were not saved as a
Named Expression.

To delete a recent expression, select it in the Expression Library dialog box and click the Delete button.

Expression Library
Select one or more expressions: Insert - Adds the selection
Recent Expressions (&) Recent Named Expressions | /1% Atiribute Filter to the expression builder.
List of expressions recently Cose by Multiple selections are
used in MAP Attributes or (POP1999/AREA)100 ] concatenated with the AND
MAP Theme Stylesheets during statement.
the current session.
Select one or more entries in Close - Closes the dialog box
the list. without adding expressions
Delete - Delete the selected pekete

expression (enabled
for Recent and Named
Expressions only)

Note: In the MAP Attributes panel, expressions are saved in the recent list only when the Edit Schema dialog
box is closed.
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Named Expressions

Expressions entered in the Expression Builder can be saved as a Named Expression by clicking the Save button. Unlike
the Recent expressions, named expressions are saved within the Adobe lllustrator document. They are listed in

the Named Expressions tab of the Expression Library. To delete a named expression, select it in the Expression Library
dialog box and click the Delete button.

Expression Library

Select one or more expressions: o
) (&) Recent Named Expressions | /i Attribute Filter
Named Expressions - Lists Close
all the expressions saved Name Expression
through the Save Named
Expressions dialog box.
Select one or more
entries in the list.

Delete

Attribute Filter Expressions

The Attribute Filter tab of the library lists the expressions in use in the MAP Selections of type Attribute Filter. See details
on the MAP Selections panel in chapter 11. Attribute Filter expressions cannot be deleted from the Expression
Library (only the MAP Selections panel).

Expression Library
Select one or more expressions: o
I.mrlbute Flltey ExpressAlons @ Recent Named Expressions | /% Attribute Filter
Lists the Attribute Filter Close
expression saved in the Name Expression

—

MAP Selections Panel

(see chapter 11).
Select one or more Total Populatic.. TOTAL_POPULATION!=0

Select West To...  COMMUNITY="WEST TOWN"

entries in the list.

Delete
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Find & Replace Attributes

MAP Attributes panel > Find & Replace

Find and Replace
Find/ Replace - Choose to Find variables, or to Find
and Replace variables simultaneously ¢ | Find | Replace
Find what - Enter a variable on which to perform a ———e Find what: Florida v Find Next e———— Find Next - Move to the next value matching the
search in the current attribute table. Note this list ) Find what variable
will also contain previous criteria. || Replace with: | AL hd Replace o7
Replace In =T Replace - Replace the selected value with the
Replace with - Enter a variable on which to replace ) Al attributes oo A Replace with variable
found items. Note this list will also contain IR .
. - Replace All - Replace all occurrences matching the
previous criteria (® Just ¢ ¥
Find what variable
Find / Replace All Attributes / Just in Column - Perform [[] case sensitive Case sensitive - If checked, only values matching the
the Find or Fin? & Replacelr on all attr?:utes iln the [ Match whole word only Close case of the Find what variable will be found
current layer or only in a specified column Match whole word only - If checked, only words

matching the Find what variable will be found
(words containing the variable will be ignored)

FUNCTIONALITY

The Find & Replace tool provides settings to search and/or replace attribute values and properties contained in the
MAP Attributes panel. Note that only values in visible columns can be found and/or replaced.

USING FIND & REPLACE

Click the Find & Replace button at the bottom of the MAP Attributes panel or choose it from the panel options menu.

Find Only

Click the Find tab and enter the search criteria directly into the Find what entry field (previous criteria can be selected
from the list). A search may be performed on all attributes by default, or only on specific columns contained within
the MAP Attributes panel by enabling the Just option and choosing a column from the list. Criteria may be further
refined by enabling the Case sensitive and Match whole word only options.

Click the Find Next button to perform the search. Search results can be seen in the MAP Attributes panel; the column
header and row number containing the first matching record will be displayed in bold text. At this point, a search
for individual records can be done again by clicking the Find Next button.

Find & Replace

To replace records selected through the Find operation click the Replace tab. Find & Replace criteria can be typed
directly into the Find what and Replace with entry fields (previous criteria can be selected from the lists). A find and
replace may be performed on all attributes by default, or only on specific columns contained within the MAP
Attributes panel by enabling the Just option and choosing a column from the list. Criteria may be further refined by
enabling the Case sensitive and Match whole word only options.

There are two methods to replace values. The first method requires approving each replacement manually by
clicking the Replace button so that each instance of the attribute located via the search parameters is successively
replaced in the map attribute table. The second method allows for the replacement of all found records
simultaneously, accomplished by clicking the Replace All button.
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Apply Expression

MAP Attributes panel > Apply Expression fix)

Apply to - Select the attribute . " .
column on which to appl Apply Expression Exp! Builder - Opens the Expression
PPy Builder dialog b
the expression. Attribute and uilder dialog box
MAPublisher Property columns can e Apply to: PERIMETER - Expression Library - Opens the Expression
be assigned expressions. —* Expression: [popLLATION/ AREA | [F] & E— J7 Library dialog box
. E_xPreSSion -Enter the «" The expression is valid.
expression into th_e text _box or t Expression Validity - Indicates if the
click the Expression Builder or 1

expression is valid ¥ or invalid ©.

Expression Library button If invalid, additional info is reported.

FUNCTIONALITY

Use the Apply Expression function to assign new values or edit attribute properties. For example, it can be used
to compute attribute values based on the values in other columns, to assign a style by editing the #Style property
attribute, or to rotate symbols by assigning a fixed value to the #Rotation property attribute. Read-only attributes
cannot be edited with Apply Expression.

Note that property attributes are dynamic. Changes made to them in the map attribute table are reflected
immediately in the graphical properties and on-screen display of the data to which they are linked. Expressions can
be generated and applied to data based on the values found in an existing attribute column, providing a one-step
process to transform a vast number of different objects in a single operation.

Note: Unlike the Derive Value From Expression option in Edit Schema, values computed through Apply Expression are not
tied to the original attributes constructing the expression and can be edited later on. Only currently selected
artwork is affected by the changes.

APPLY EXPRESSIONS

Ensure the data required for the application of the expression is selected and appears in the MAP Attributes panel.
Click the Apply Expression button or choose it from the panel options menu.

First specify a column from the Apply to list to specify which attribute column the expression will be applied to. The
columns listed here are representative of the attribute structure unique to the data layer currently displayed in the
attribute table as well as the standard MAPublisher property attributes.

To assign an expression to a column, enter a valid expression in the Expression text box. Alternatively, click the
Expression Builder button to open the Expression Builder dialog box. To access other expressions saved in the map
document, click the Expression Library button to open the Expression Library dialog box.

The Expression Validity icon will report if the expression entered is valid (green check mark). Otherwise it will report
invalid (red exclamation) and include additional warning notes.
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Join Table

MAP Attributes panel > Join Table B-E

Format - Choose from one of the listed
formats to load the data —

Filename - Click the Browse button to —
select the data table to be joined

Specify Schema - Adjust the schema type
for each column —

Source Matching Column - Select a column

from the source table to match to a —* Matching column:

column in the destination layer

Target Layer - Select the layer containing
the MAP Attribute table about to be
joined with the source table;

Destination Matching Column - Select a
column from the destination layer to
match to a column in the Source Table

Cancel

Worksheet - Specify the worksheet to use

e———————— when a Microsoft Excel file is selected

Use first line as a header - When available,

Join Table
Source:
—e Format: |Microsoft Excel [*.xls] -
e Filename: inal Data‘\Population_census_stats.xls Browse...
Worksheet: |Population_census_stats - Copy -
Use first line as a header (detected)
—e Specify Schema
o Data loaded successfully. Q
[[3 TRACT -
Destination:
Target layer: Census_tract_area
H,
Matching column: | [f3] TRACT -

Options:
[] Case sensitive when matching

check this box to derive column names
from the first row

Encoding - When available, choose a
different character encoding if the
attribute data uses a different
character set

Case sensitive when matching - Values from
the two matching columns will be
matched based on case sensitivity

Add matching column from source - Add

the matching source column into the
destination attribute table

[ Add matching column from source

[7] Update existing columns instead of adding columns when possible

FUNCTIONALITY

Update existing columns instead of adding
columns when possible - Update existing
column values instead of adding more

Join Table provides the ability to merge external data tables directly into an existing MAP Layer attribute schema in
order to create a single extended attribute table. The following formats are supported:

dBase file IV (dbf)
Microsoft Excel (xIs)

Delimited XY Text (csv, tsv, txt)
Spatial Data Transfer Standard (catd.ddf)
Esri Geodatabase (ArcSDE, File, Personal)

When exporting tables from spreadsheet applications for use with MAPublisher, the preferred format to use is
Delimited Text as they have the widest range of compatibility.

Note: dBase tables created or edited in Microsoft Excel must have a proper data type assigned to each column
through cell formatting before being saved as DBF. For example, numerical values specified in a cell set with

a format "General" will import as an Integer type by default, therefore loosing all decimal values.

Windows users with licensed Esri software can join tables with feature classes and non-spatial tables of
geodatabases (ArcSDE, File and Personal). However, Basic File and Basic Personal geodatabases are not
supported. For information on Esri software requirements for this option, please refer to chapter 3.

PREREQUISITES

In order to join a table into an existing attribute schema, both MAP Layer and data table must share at least one
common attribute column with matching values. The column must be of a matching type (i.e. String, Real, Integer,
Boolean) in both the Source and the Destination table. If not, the join may not be successful.
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USING JOIN TABLE

Click the Join Table button or choose Join Table in the MAP Attributes panel options menu.

Source Data (Files)

Click the Browse button to select the data table for import. If a Microsoft Excel file is selected, use the Worksheet
drop-down list to specify the sheet to be used for joining. Select a column in the Matching Column drop-down list. This
is the source attribute column to join on.

In MAPublisher, double-byte characters are supported in attributes on import, allowing such attributes to be used
for labeling and export. To assign a codec suitable for a selected dataset, choose an appropriate entry from the
Encoding drop-down list.

If the table contains column names as headers, check the Use first line as header option. If it does not contain headers,
do not check this option and each column will be assigned a default heading name: Column1, Column2, etc.

Source Data (Esri Geodatabases)

Windows users with licensed Esri software can join tables with feature classes and non-spatial tables of
geodatabases (ArcSDE, File and Personal geodatabases are supported but the Basic File and Basic Personal
geodatabases are not).

If the Format drop-down list is set to Esri ArcSDE Geodatabase, click the Browse button to select the ArcSDE server
connection and then select the appropriate feature class or non-spatial table. If the Format drop-down list is set to
Esri File Geodatabase or Esri Personal Geodatabase, click the Browse button to select a feature class or non-spatial
table. Please refer to chapter 3 for information on ArcSDE server connection and feature class selection.

The attribute selection is the same as for Files source data.

Destination

The Target Layer is specified under the Destination section. Choose an attribute from the Matching Column drop-
down list. This column must match the format and values as the column chosen as the Source Matching Column to
achieve a proper join.

Additional Option

When the Case sensitive when matching option is checked, the column entries from the two matching columns will only
be matched by case. When the Add matching column from source option is checked, the source column is also imported
and the column name is appended with the number 1. The Update existing columns instead of adding columns when possible
option attempts to update attributes instead of appending more columns to the table.

Note: Attribute names can not contain all numbers. If a source column name contains all numbers the column is
joined but the attribute column name is changed to Attribute1, Attribute2, etc.
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Export Attributes

MAP Attributes panel options > Export Attributes

Export Attributes
File name - Click the Browse button to select I eFilename: a/Tutorial Data world_data. txt oK
the directory and type the file name where T T pp— —
to save the exported attributes. oiss e withe exportsein =Ll
Scope - Choose to export all the attributes—l— Options:
or only the visible attributes. L escope: () Export al atiributes

Include column names on first line
Click this option to export the
column names on the first line of
[ Include column names on first line the exported text file.

. . . (@) Export visible attributes only
Delimiter - Specify the field delimiter. Select —\_

Comma, Semi-Colon, Space or Tab from the
drop-down list.

—eDelimiter; | Comma  ~

FUNCTIONALITY

The Export Attributes function exports all selected attribute information from the current MAP Layer to a delimited
text file—comma, semi-colon, space or tab separated.

PREREQUISITES

Attributes will be exported as they are in the MAP Attributes panel. For example, users can change the number

of decimals for attributes of Double type prior to exporting (see Edit Schema in this chapter), to limit the size of the
exported file—or to turn on/off the visibility of some attributes, with Edit Schema or the MAP Attributes panel Show/Hide
function.

USING EXPORT ATTRIBUTES

Export attributes is accessed from the MAP Attributes panel options menu.

In the Export Attributes dialog box, click the Browse button to navigate to the directory where the exported file will
be saved and type a file name. By default, the exported file will be appended with a .txt extension—to export in
another delimited text format, type another file extension (CSV or TSV) in the file name (e.g. world.csv).

Users have the following options to set:
«  Export all attributes or visible attributes only.
. Set field delimiter in the exported text file to Comma, Semi-Colon, Space or Tab.
«  Export or not the column names on the first line.

The result is a delimited text file. Text attributes (type String) are exported in double quotes ("..") and are separated
by commas in example below. Image attributes are exported as string values based on the file name.

E export.txt - Notepad = =
File Edit Format View Help

"ELLEN AvV",2 2
"ELIZABETH ST™,2
"EDWARD 5T",2
“EDEN PL™,2
"DUNDONALD 5T",2
"DUNDAS 5T W",2
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MAP Locations
and Data Creation

The ability to accurately place locations on a map is basic
to cartography. This can be achieved with MAP Locations
to place page locations as well as world locations. MAP
Locations are used for reference and can be used in other
MAPublisher tools such Georeferencer, Area Plotter, Line
Plotter, Point Plotter, and Vector Crop.

Create data points to represent features such as cities, retail
shop, and airports, using precise location placement of MAP
Point Plotter. Also use it to plot centroids and create point
symbols at MAP Locations.

Create data areas with Area Plotter with known coordinates.
It is a great tool to make land parcels and shapes that have
been measured on the ground or with a GPS.

Create data lines with Line Plotter using known coordinates.
Plot multiple locations to draw lines point to point. For more
control, include distance and direction for navigation style
line plotting.

Topics covered in this section:

MAP Locations and MAP Locations Tool
Georeferencer

Find Places

MAP Point Plotter

Line Plotter

Area Plotter

Add Calculated Data
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MAP Locations and MAP Locations Tool

Object > MAPublisher > MAP Locations or MAPublisher Toolbar and Tools > MAP Location Tool

MAP Locations

Draw based on - Draw MAP World # Draw based on: | @ city Urban | = |
Locations based on the coordinate
g— " "
system of the chosen MAP View Name Xl Y] Latitude Coordinate System
W Page Location 1 38194 in -3.8750in [Page]
MAP Locations - Displays the Name, X s | Page Location 2 15,8472 in -25.81%4in [Pagel Remove MAP Location
and Y coordinates, and coordinate ) Click to remove a selected
system of each plotted MAP Page or @ World Location 1 563,925.342375 m | 4,813,980.562960 m | NAD83 / UTM zone 17N MAP Location from the list
World Location ® World Lecation 2 559,704.418762 m | 4,827,267.805285 m NADS3 / UTM zone 17N Edit MAP Location
i} — Edit the highlighted
#MAP Locations B ® R @ J i I,MAP Location in the list
T hd hd hd hd hd
: L Use Online Map Service
Cony MAP Locati di 2 MAP Locati Add MAP World Location  Add MAP Page Locati Create new MAP World Locations
‘ opy | ocation to |pb(favd 'oom to A f)(atlon ) dd orld Location d}i age Location using an online map service
Copy single or multiple MAP Location Zoom to the highlighted  Click to add a new MAP  Click to add a new MAP
coordinates to the clipboard MAP Location World Location to the list Page Location to the list

FUNCTIONALITY
MAP Locations are used as annotations to identify map world or page locations. These can be used when specifying

map or page locations in other MAPublisher tools such as Georeferencer, Specify Anchors, MAP View editor, Area
Plotter, Line Plotter, Point Plotter and Vector Crop.

USING MAP LOCATIONS
MAP World Location Tool

MAP World Locations define a real world coordinate Add MAP'Waridl Location

on the document. MAP World Locations can be plotted T — o
on any layer in a MAP View. Click the MAP World Location Coordinate SYStEM: (g) \s 54 Pseudo-Mercatar —
Tool in the Tools toolbar to enable it (the cursor changes O Geodeticbase: WGS 54 CoryTo Gippomrd -
to a crosshair). Click the artboard at an appropriate Inputformat: - projected units

location to open the Add MAP World Location dialog o 1 [10915712.030614 m

box. Indicated are the coordinate system (of the MAP o ¥ |a7s2160.933674 m

View) and coordinates of the clicked location. MAP World
Locations by default are blue, but a custom color can be chosen using the pin colour drop-down. Optionally, click
Copy to Clipboard to copy the coordinates to the clipboard. Click the Copy to Clipboard drop-down to copy with or

without locale.
--IE‘E3 )
Add MAP Page Location

MAP Page Location Tool
. . ame: 'age Location =
MAP Page Locations define a page coordinate on the document. MAP NomeunpPagelocain . [WI[| [ o€ |
Page Locations can be plotted on any Non-MAP layer (not contained o X |2.307354 [ Cancel
in @ MAP View). Click the MAP Page Location Tool in the Tools toolbar to o Y. |-5.763085 in | Copy To Clipboard |~

enable it (the cursor changes to a crosshair). Click the artboard at
an appropriate location to open the Add MAP Page Location dialog
box. Indicated are the page location X and Y value of the clicked
location. MAP Page Locations by default are green, but a custom color can be chosen using the pin colour
drop-down. Optionally, click Copy to Clipboard to copy the page coordinates to the clipboard. Click the Copy to
Clipboard drop-down to copy with or without locale.
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MAP Locations Panel

Click the MAP Locations panel button on the MAPublisher Toolbar to open the MAP Locations panel. The

MAP Locations panel is used to manage both MAP World and MAP Page Locations. It shows the name, X and Y
coordinates and coordinate system of plotted locations. When the MAP Location Tool is not enabled, selecting MAP
Locations in the panel will highlight the location and display its name on the artboard.

L Lo iocrion
MAP Locations
Name | X|longitude | ¥]latitude [Coordinate System
W Location 1 381.0000 px 643.0000 px [Page]
MAIII.urAli:mZ
W Location2 2443333 px 609,667 px [Page]
® MAP Location 430,804.352676 m | 5459,642.32134... | NADS3 / UTM z0...
===
® MAP Location 1 490,566.415456 m |5,459,909.04332... NAD83 / UTM zo.
| [ Locovons| | ® MAP Location 2 490,154.901555 m | 5459,154.60116... | NAD83 / UTM z0...
11MAP Locations BRiteam @ o6

To see how the MAP Locations are displayed using different coordinate systems of available MAP Views in your
document, select a MAP View in the Draw based on drop-down.

To add a MAP World Location using the panel, click the Add World Location button. In the Add MAP World Location
dialog box, enter a name and the X and Y coordinates (or longitude and latitude if geodetic). The available
coordinate system of the world location is based on what is selected in the Draw based on MAP View drop-down.
To add a page location, click the Add Page Location button and enter the X and Y pixel values. To add a MAP World
location from the web, click the Add MAP Location from Web button. Enter a location or click the map to add a world
location. Note that world locations are not visible until a MAP View is created in the document.

By default, with the MAP World Location tool or Page Location tool selected all MAP locations are shown. Use the
MAP Locations panel to view MAP Locations when any other tool is selected. MAP Locations selected in the panel
are shown on the map. To display them all the time no matter what tool is enabled, click the MAP Locations panel
options menu > Show MAP Locations > All. When set to None, the MAP Locations are only visible when the MAP
World Location or MAP Page Location Tool is enabled. To only show MAP Locations when the panel is visible, set the
panel option to Only show when panel is visible. To move a MAP Location manually, enable the MAP Location Tool
and hold Shift to move MAP Locations. Adjust MAP Location label visibility in MAPublisher Preferences.

To copy MAP Location coordinates to the clipboard, select a single or multiple MAP Locations, then click the
Copy MAP Location to clipboard button. Paste the values where required.

MAP Locations Used In MAPublisher Tools

MAP Locations can be used in several MAPublisher tools for georeferencing, as reference for corners, locations to
draw lines and locations to plot points. They can also be used in Specify Anchors to identify map and page anchors.
MAP Locations are available for use in Georeferencer, Specify Anchors, MAP View editor, Area Plotter, Line Plotter,
Point Plotter, and Vector Crop.
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Georeferencer

Object > MAPublisher > Georeferencer or MAPublisher Toolbar

Add world locations from:

Add world locations from an online map World Location
source (i.e. MapQuest) or from another Indicates which source the  X|Longitude, Y|Latitude world locations Georeference & Save
open document world location is from  World locations added from sources Aply the
| PpPly
eoreferencer geon_eferencmg
solution and create a
Reference Locations ‘dd world locations from: MapQuest | | ® Gpen documents... @] |ceoreference & save e=—— MAP View
The reference location lsValid Use insolution  Page Lacation World Location XlLongitude  ¥|Latitude  Coordinate System Save o Save
table shows connections v W Princeton/Marion (@ 71036677 deg 42377244 deg WGS 84 Cancel Save the reference
between MAP Page locations, but does
i v W Highland/Suffolk (@ 71031021 deg  42.386839 deg WGS 84 !
Locations and world ——s not georeference
locations. Three sources of v W Berkshire/York (@ 71091398 deg  42.369405 deg  WGS 84
worldtlocatl(l)lns: manual [V W Gorham/Cypress (@ 71124775 deg 42332779 deg  WGS 84 Coordi System
entry, online map, or E Th ~
. e coordinate
v W Swallow St & -78.028862 deg 42333647 deg WGS 84
another open document. system used for each
v [} W Patterson/SthE. @ Patterson/SthE. 1 -71.050752deg 42331858 deg WGS 84 reference location

Add/Remove Reference Location —— |5 &
Click Add to insert a new
reference location. Click
Remove to delete a selected
reference location.

[] Specify coordinate system: [lone]

|
Specify coordinate system
Specify a known coordinate system
for more accurate results

FUNCTIONALITY

Use the Georeferencer tool to give spatial properties to a non-referenced map by establishing a relationship
between page locations in the document (using MAP Page Locations) and world locations. There are three sources
for world locations: 1. an online map service; 2. entering location coordinates manually; and 3. MAP World Locations
from an open document. After connecting page and world locations, the tool calculates combined error using
different projected coordinate systems. Choose a projected coordinate system based on best fit and create a new
MAP View to contain the spatial information.

PREREQUISITES

«  Must start with an ungeoreferenced layer (Non-MAP Layer) with defined MAP Page Locations.

«  Asource of world locations. Sources are: an online map service, world location coordinates that are
manually entered, and MAP World Locations from an open document.

« A minimum of four page/world locations should be used. However, it is recommended to use more
locations for better accuracy.

- Data being georeferenced cannot have a perspective or skew. Incorrect results may occur if they do.

. Using an online map service requires active Internet connection.
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USING GEOREFERENCER

In all situations, it is required to define MAP Page Locations on an ungeoreferenced layer before choosing real world
locations to connect them to. Use the MAP Locations tool to plot MAP Page Locations in known locations so that

it is possible to connect them easily to world locations. There are three sources for adding world locations which
connect to MAP Page Locations: 1. an online map service; 2. entering location coordinates manually; and 3. MAP
World Locations from an open document.

Click the Georeferencer button on the MAPublisher Toolbar or go to Object > MAPublisher > Georeferencer.

Use online maps to add world locations

Add world locations from online map services such as MapQuest. In the Georeferencer dialog box, click the online
map service button to choose world locations for matching MAP Page Locations (if multiple map services are
available, click the drop-down arrow to choose). In the Add World Locations dialog box, choosing a MAP Page
Location from the drop-down list automatically pans and centers it on the artboard. Use the Zoom in and Zoom out
buttons to enlarge or decrease the artboard zoom level. To navigate the online map, pan and zoom with the mouse
(and mouse wheel) or use the navigation control slider. Optionally, enter street or city names into the Place search
bar to find places quickly.

‘Add World Locations 17— Zoom artboard
Zoom in and Zoom out of

Matching MAP Page Location 8 Matching MAP Page Location: | B Berkshire York | zoom artboard: @] (@) h board

Choose a MAP Page Location Click and drag pin to change its location. Right-click pin to delete it Cancel the artboard.
and click the corresponding
ition in th li Search
position in the online map. Scarchis ony performed vihin the dispiayed map axients. I X
Click the Zoom In and Zoom Nominatim search courtesy of MapQuest Location search
Out buttons to adjust the 4 G - Search for streets and cities
zoom level of the artboard. (Q o to help you narrow down
\E ik, specific locations
S : A
I =
World Location pl [ > i
Click the map to pick a world | 4 =
location. This placemark J Yo,
~

represents the world location &

that connects to the MAP Vo

Page Location. = 7 St
 Eora—|
mapquest [ — §

To plot a world location position on the online map, navigate to a location that matches the chosen MAP Page
Location and click it. A placemark designates that a world location has been set. To adjust the world location
position, click and drag the placemark to a new location and release the mouse button. Unassigned MAP Page
Locations are denoted by (UNASSIGNED) in the drop-down list.

The reference locations list gets populated with the matching MAP Page Locations and world locations. The World
Location column shows that MAP Page Locations are matched with an online map world location.

IsValid Useinsolution MAP Page Location World Location X Y Coordinate System

v W Princeton/Marion (@ -TLO3667733 deg 4237724449 deg WGS 84

v W Patterson/SthE. (@ 7105075222 deg 4233185778 deg WGS 84

Is Valid b4 M Highland/Suffolk (@ 7103102122 deg 4238683923 deg  WGS84

MAP Page Locations are v W Gorham/Cypress (@ TLA2477515 deg 4233277881 deg  WGS 84
connected to online map v W Berkshire/York (@ TLOO130775 deg 4236040456 deg  WGS B4

world locations
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Use a georeferenced document to add MAP World Locations

The source for world locations is an open Adobe lllustrator document with MAP World Locations already plotted
in it. It is essentially retrieving MAP World Locations from another georeferenced artboard and using them in the
current ungeoreferenced artboard. In the Georeference dialog box, click the Open documents button. When a
document is chosen in the drop-down list, the list populates with found MAP World Locations. Click the list to

choose MAP World Locations.

Choose MAP World Locations
Document ——e pocument: Boston_Other.ai -
Choose an open document
from the drop-down list. Map World Locations: | ® Clarendon/Montgomery 1 Cancel
The open document should : ;‘grl':_":;’c“t:m
MAP World Locations that ® Elm/Hancock 1
populates the list below it. "% Patterson/SthE, |
MAP World Locations @ Gorham/Cypress 1
Choose the appropriate @ Swallowst 1
MAP World Locations to add
to the reference list. Ctrl +
click to pick multiple items.

The reference locations list gets populated with MAP World Locations. Importing MAP World Locations with the
same name as a MAP Page Location will automatically match them and add to the solution. Choose the matching

MAP Page Locations for each row. The World

Location column shows that it is matched using an open document.

Is Valid Is Valid Usein solution MAP Page Location Warld Location X ¥ Coordinate System
Choose appropriate MAP v i W Br/Hancock  ® Eim/Hancock1 JLIITISION deg 4238980092 deg WS 84
Page Locations to match —-e
the MAP World Locations | ¥ ] W Princeton/Ma.. @ Princeton/Marion 1 7103667733 deg 4237724449 deg WG5S 84
added from the open v B W Highland/Suff.. @ Highland/Suffolk 1 7103102122 deg 4238683073 deg | WGS 24
georeferenced document. -
1] B @ Clarendon/Montgomeryl 7107200806 deg 4234412145 deg WG5S 34

Manually add X and Y world locations

In the Georeference dialog box, click the Add button to add new reference locations to the list. The MAP Page
Location column automatically populates with available locations. To add X and Y (or Longitude and Latitude) world
location coordinates, double-click the X and Y column entries.

Coordinate System
Choose an appropriate——e
coordinate system to
georeference in

X/Y or Long/Lat Coordinates
Enter world location——+e
coordinates that connect to
MAP Page Locations

Edit MAP World Location

Name:|Location 1 oK | O |

Cancel

Coordinate System: (g) g 84 / Pseudo Mercator
() Geodetic base: WGS 84 Copy To Clpboard |+

Input format: Projected units

o X |-13784012,150606

+ Y | 10068860.886348

The World Location column shows that MAP Page Locations are matched by manually entered world locations.

Is Valid <

When X and Y world —
locations are entered, it
connects to the chosen

14
£

MAP Page Location
(1]

IsValid Use in solution

MAP Page Location  World Location X ¥ Coordinate System
W Clarendon/Montgomery &~ -TLOT00806 deg 4234412145 deg  WGS 84
B Swallow St & 7102886204 deg 4233364727 deg  WGS 84
W Highland/Suffolk & 7103102122 deg 4238683023 deg WS84
B & 000000000 deg 000000000 deg WS 84
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Georeference and Save

When at least four reference locations are valid, it is ready for georeferencing. The check box in the Use in solution
indicates whether or not the reference location should be included in the georeference calculation. A minimum of

four reference locations are required for georeferencing.

Click Georeference & Save to begin the georeference process. MAPublisher calculates the georeferencing and produces

a list of coordinate systems that best fit the data.

Rank

This value represents the rank
of best fit. A value of 1.00 is a
better fit than a greater value.

Combined Error

The total error calculated (between
page and world locations) of X and
Y reference locations. Click Details
to see values of each location used.

Select Coordinate pystem

Name Rank  CombinedError  Rotation " ok
Coordinate System Name WGS 72BE / UTM zone 19N 1.00 0.00009005 deg 1,696 deg Cancel
Choose an
X WGS 72/ UTM zone 19N 0.00009005 deg 1.696 deg
appropriate

Rotation
The amount of

coordinate system. — LT e TEEEA ) 0.00009005 deg 1,696 deg

These are based

on the calculation WGSE UTM, Zone 19 North, US Survey Foot 0.00009005 deg 1.696 deg rotation required
of the reference NADS3 / UTM zone 19N 1.00 000009005 deg 1.696 deg to georeference
location points. the data.
NAD27 / UTM zone 19N 113 0.00008953 deg 1,697 deg

Error Details...  |Coordinate System Details...

The listed coordinate systems each have a Rank, Combined Error, and Rotation Value. The Rank value represents a
number that indicates the most appropriate coordinate system for the data. A value of 1.00 means the coordinate
system is the best fit based on error values, coordinate system envelope fit, rotation, and other calculated factors.
Rank values should be low but an appropriate match could be greater than 1.00. The Combined Error is the total
error calculated (between MAP Page Locations and world locations) of X and Y reference locations. Click the Details
button to see individual Error X, Error Y, and Combined Error for each reference location used in the calculation. The
Rotation value indicates the amount of rotation required to georeference the data and will vary depending on the
coordinate system. The resulting MAP View will be assigned this rotation.

After a coordinate system is chosen for the georeference, the final step in the process is to create a new MAP View
that will contain the referencing information. Optionally, select layers to move to the new MAP View. These layers
can also be moved to the new MAP View after.

Create MAP View

Name of MAP View:
Name of MAP View —L_o|Um zone 191 (72 to 66 )
Enter a name for the Layers to move to new MAP View:

new MAP View O @ Layer2
1A Layert

Cancel

Layers to move to new MAP View
Select layers to move to the
new MAP View. These layers
can also be moved after the

georeference.

Select All Clear All

Chapter 6: MAP Locations and Data Creation | 135

Georeferencer



GEOREFERENCE WORKFLOW (BRIEF)

1.

Place at least four MAP Page Locations on an unreferenced document in locations that will be matched to
known world locations (or MAP World Locations for an open document source).

Decide which georeferencing source to use to connect MAP Page and world locations (online map, open
document, or manual entry). Choose world locations based on the position of MAP Page Locations. Specify
the georeference coordinate system if it is known.

Ensure a minimum of four reference locations are used in the solution and click Georeference & Save.

In the list of results, view coordinate system details, fitness, combined error, and rotation value. Choose the
most appropriate coordinate system for the map and assign it to a new MAP View.

IMPORTANT GEOREFERENCING NOTES

136

Georeferencing cannot be performed on an unprojected map (i.e. a map in a geodetic coordinate system).
It is recommended to use as many points as possible to achieve the best geocoding results.
Reference points should spaced out as best as possible (e.g. one in each corner of artboard).

Zoom in to the maximum zoom level to get the most accurate location. This is true when plotting both
MAP Page Location and matching world location using an online map service.

See MAPublisher Preferences (chapter 1) to specify an alternate online map service.

It is recommended to provide meaningful names to MAP Locations for easier identification.
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Find Places

Object > MAPublisher > Find Places or MAPublisher Toolbar

Find Places

MAP View - Choose a MAP View to ——e e view: | @ chcagoana ~
change the online map extents ) Cancel .
school Search | 50 results i Search - Enter a search term into
Nominati search courtesy of apuest the Search box. The status shows
Srisravie oo how many places were found and
@ Protpec)Heights P are currently on the map.
ELres R To clear the search, simply enter

Navigation - Use the navigation —
controls to pan and change map
scale. Alternatively, pan and zoom
with the mouse.

a different search term into the
Search box. Only one search term
is allowed per search.

Click Add Places to add search
! results to the MAP View.

4 PI; ks - Hover over placemarks
Chieren to view its title. Click a placemark

f\’ ot Ci % to view more information about it.

' | ai = =

o e o =
e e ——

oo 023 ot sl obors, OOk

mapaquest (10

FUNCTIONALITY

Use the Find Places tool to search for points of interest based on the extents of a specified MAP View. Searches are
based on one search term (as to not confuse searching for two unrelated search terms). Found places are added to
MAPublisher as a MAP Point layer.

PREREQUISITES

An Internet connection is required to view the online map, search and collect places.

USING FIND PLACES

Click the Find Places button on the MAPublisher Toolbar. In the Find Places dialog box, enter a search term into the
Search box and press Enter or click the Search button. Search results appear on the online map as placemarks. A
limit of 50 placemarks can appear at a time per search term. To start a new search, enter a new search term into the
Search box and press Enter or click the Search button. It will clear the previous results and display new results.

Click the Add Places button to import places to the document. Places are saved to a MAP Point layer based on the
search term in the chosen MAP View. Depending on scale and location adjustments made to the online map, some
added search results may appear outside of the artboard, but within the MAP View extents.

Points may include attribute information. Open the MAP Attributes panel to view any attributes that may have been
included by the search provider.
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MAP Point Plotter

Window > MAPublisher > MAP Point Plotter and MAPublisher Toolbar

MAP Point Plotter Plot Centroids...

Current Layer: Plot MAP Locations...
7| Hotels_paint

le
NADB3 / UTM zone 10N

Current Layer - Displays the selected layer e
name and coordinate system i Symbol - Choose a symbol to represent plotted points. Click

the symbol link to open a list of symbols to choose from

Display: :
. : Scale - Change the size of the chosen symbol if required.
. . Symbol: MAPublisher Default Symb H .
Input Coordinate System - Specify the g o = : The arrow keys will increase or decrease the scale value by
reference coordinate system in which Scales izl‘ 100% : 10% increments.

the point coordinates are entered.

Use the current layer's coordinate Coordinates - -MI—

system, or specify a different one

(by default WGS84, lat/long format). Input Coordinate System: Address:
Click th'e Select butto‘n to open the ) Use: WGS 84 | 1155 Burnaby St, Vancouver o—’—— Address - Type an address
Select Coordinate System dialog box and T . - into the box to plot it. Be
choose any coordinate system. (&) Use Current Layer's coardinat system Geocoding courtesy of MapQuest, as specific as possible.
Format - Select the input format Format: | |» |
for values in degrees (when input
coordinate system is geodetic) ' ¥i|489,807.405282 m
Coordinates - Enter point coordinates in ?
map units or choose artboard location ¥ [5,459,004.26693 m *, Attributes may be added to this layer.

or MAP Location

Plot- Click to plot the symbol after
coordinates have been entered

PREREQUISITES

Points can only be plotted on MAP Point layers. The coordinate system of a MAP View can be used to calculate
where points and addresses are plotted. The plot button is disabled when another MAP layer type is active.

USING POINT PLOTTER

Click the MAP Point Plotter button on the MAPublisher toolbar or from the menu Object > Window >MAPublisher > MAP
Point Plotter.

Symbol Selection Setup

The symbols used by MAP Point Plotter are a direct reproduction of those that exist in the Adobe Illustrator Symbols
panel. To open the Adobe lllustrator Symbols panel, click the menu Window > Symbols. To add symbols to the
Symbols panel, create symbols as closed Adobe Illustrator objects and drag them into the panel. Alternatively,

open the Symbols panel, click the panel options menu > Open Symbols Library > MAP Symbols > MAP - Symbols. The
MAP - Symbols.ai file from the Helpful Styles & Symbols folder is installed with MAPublisher (see Appendix 4).

Choose a Symbol and Scale

Select an appropriate point symbol by clicking the symbol name link. The symbols displayed are the symbols that
currently exist in the Adobe lllustrator Symbols panel. To scale the symbol used, edit the percentage value in the
Scale box. Clicking the Up and Down arrows will increase or decrease the value by 10%.
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Select a symbol:

3 Point of Interest 29 A oK
# Cross3
© Cross4 Cancel

& Highway Sign 1
7 Point of Interest 34
) Highway Sign 2
&3 Point of Interest 13
H Point of Interest 15
ﬁ Point of Interest 33
][ Bridge 1

[ 4 Watves |

Note: When a MAP Themes stylesheet is assigned to a Point layer, it will override the map symbol chosen in the
MAP Point Plotter panel.

Enter Coordinates

In the Coordinates tab, when the Use Current Layer's coordinate system option is chosen, coordinate values can be
entered in map units of the current MAP View coordinate system. When the Use: WGS 84 option is chosen, the
coordinate system link enabled. Click the coordinate system link to open the Select Coordinate System dialog box to
choose an appropriate coordinate system.

When the selected or default coordinate system is projected, enter X and Y coordinates as map units of the
coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate system is geodetic, enter Lat
and Long coordinates as degrees in the following formats:

«  Decimal degrees (D+[.d*])

«  Delimited Degrees Minutes Seconds (D+ MM SS[.s*])

+  Degrees.Minutes (D+.MM)

«  Degrees.MinutesSeconds (D+.MMSS[s*])

«  Packed DMS with decimal point((D)DDMMSSI[.s*])

+  Packed DMS ((D)DDMMSS[s*])

Notes: Items in [] are optional, * means zero or more digits, + means one or more digits.

Lines of latitude run East-West (the Equator is an example), whereas lines of longitude run North-South (the
Greenwich Meridian is an example). Positive degree values represent north latitudes and east longitudes.
Negative degree values represent south latitudes and west longitudes. Directions can be entered either
with positive/negative values or using the N, S, E or W letters preceding or following the numerical values,
separated or not with a space.

Valid delimiters for Delimited Degrees Minutes Seconds format are:
- space, hyphen (-), colons () or underscore (_), e.g. 43 41 48.98N, 43-41-48.98N, 43:41:48.98N or
43_41_48.98N
- d(degree), single quote (minute), double quote (second), e.g. 43d41'48.98"N

Packed formats require the use of two digits for degrees of latitude (e.g. 1°N must be written 01) and 3 digits
for degrees of longitude (e.g. 1°E must be written 001).

Chapter 6: MAP Locations and Data Creation | 139
MAP Point Plotter



Examples of Latitude/Longitude values

Formats Decimals Delimited Degrees.Minutes | Degrees. Packed DMS with | Packed DMS
Degrees Degrees Minutes MinutesSeconds | decimal point
Seconds
Avenza Office: Lat | 43.6969N 43d41'48.98'N 43.418163N 43.414898N 434148.98N 43414898N
43°41'48.98"N Long | 79.3922w 79d23'32.38"W 79.235396W 79.233238W 0792332.38W 079233238W
79°23'32.38"W
(a1 863N 7923 5306w | LAt | 43.6969 43414898 N43.418163 N 43.414898 434148.98 N 43414898
(=48.6969°N | 79.3922°W) Long | -79.3922 W 07923 32.38 W79.235396 W 79.233238 079233238 W 079233238
lat | N43.6969 N 43-41-48.98 43418163 43.414898 N 434148.98 43414898N
Long | -079.3922 W 79:23:32.38 -079.235396 -079.233238 W 079233238 079233238

Note: Double-quotes (") are supported in MAP Point Plotter, but not in the import of Delimited Text.

Enter Address (available in CS6 and CC only)

Use this feature to plot points using a physical address (geocoding courtesy of MapQuest). In the Address tab, enter
a valid address into the Address box. The address should follow a specific-to-general granularity format (e.g. 1155
Burnaby St, Vancouver, British Columbia, Canada). Attribute data accompanying the address point may be added
to the current point layer.

Notes: Some international addresses may have to be modified to follow the specific-to-general granularity format.

Data returned by these services are subject to user verification for accuracy and correctness.

Plot Points and Addresses

Click Plot to plot the coordinate or address point in the designated MAP layer. To plot subsequent points, edit the
coordinates or address, and if required, choose different symbols and click Plot again.

Plot Centroids
MAP View - Select the MAP View — MAP View: @ Chicagoland -
containing the layers of interest N,
(Source Layer and Destination Layer) Source layer: Census_tract_area h Cancel
Source Layer - Select the Area or Line [ Plot centroids for selected art only

MAP Layer containing the paths on

which the centroids will be calculated Destination:

'_: ) Existing layer: metrastation_point

o,
(®) New layer: centroid Options:
This layes will inherit the source layer's attribute schema.
— Style - Select the symbol to use.
Destination Layer - Select either an Options: Available Adobe Illustrator Symbols
existing Point MAP Layer or create a are listed.
new one where centroid symbols will Style: @ [MAPubiisher Default Symbol] h
be added Seale: 100 % < Scale - Select the symbol
High accuracy (slower, forces centroid within area boundaries) *——————— Use high accuracy - if the selected source

layer is an Area MAP Layer, check this
option for a high placement accuracy.
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Plot Centroids adds point symbols at the center of polygons or lines, while copying the attributes from the source
MAP layer when the New Layer option is selected. This function is useful for cartographic generalization purposes
(e.g. replacing small island area by a symbol) or to simply add a meaningful symbol at the center of areas. For single
lines, the centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of
the largest polygon or longest line is used.

Note: The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the anchor
points are used to calculate the centroid's position. If necessary, use the Adobe Illustrator Add Anchor Points
function (Object > Path > Add Anchor Points) before running Plot Centroids on Bezier polygons.

The document must contain a georeferenced MAP View that includes a MAP layer of type Area or Line that contains
art. An existing Point layer may be used as destination layer (Existing Layer option). Desired symbols must be loaded
in the Adobe lllustrator Symbols panel to use them.

Using Plot Centroids

Plot Centroids is located in the MAP Point Plotter panel options menu.
«  Choose the MAP View that contains the layers whose centroids are to be plotted
«  Choose the Source Layer containing the polygons or lines for which the centroids will be based upon
«  Choose the Destination Layer, an existing Point layer or create a new one, to store the centroids
«  Choose the symbol Style and Scale to apply.

The High accuracy placement option makes more advanced calculations for the centroid positions to force them to
fall within the area boundaries (useful for areas with strange shapes, for example some S shape islands).

Note: When the New Layer option is enabled, the attributes from the source MAP layer are copied to the new
Point layer. However, when using an existing point layer, attributes do not get transferred unless the Point
layer was created with its attribute schema based on the same source MAP Layer (see chapter 4 for more
information on the Base attribute schema on option when creating new MAP layers).

Results

Symbols are added to the specified Point MAP Layer. Depending on the type of polygon or line (single or
compound path), symbols are located on the center of the polygons/lines or at the center of the biggest
polygon/longest line of a group.
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PLOT MAP LOCATIONS

Plot MAP Locations
Select MAP Locations to plot: o |
Select MAP Locations to plot W Location 1 A
i P W Location 2 Cancel
Select a single or multiple "
R W Location 3
MAP Locations to plot. W Locationd ]
W Location 5
® MAP Location
® MAP Location 1
® MAP | aration 2 &
Destination MAP View Selectal | |Clear Selection
Choose which MAP View the
MAP Locations are plotted to T Destination Map View: | @ Vancouver <
New layer name ———e New layer name: New
. v e Symbol - Choose a symbol to represent
Enter a Point layer name for .
the plotted MAP Locations Symbal: @ [MAPublisher Default Symbai] v e— the plotted MAP Locations
Scale: 100% =) e——————————Scale - Use the slider or enter a symbol
Include WGS84 latitude and longitud [] Include WGSB4 latitude and longitude as attrbutes scale for MAP Locations
as attributes - Enable to include

coordinates in the attribute table

Plot MAP Locations adds point symbols at positions of MAP Locations. This is useful for reference purposes or to simply
add a symbol at MAP Locations.

The document must contain a georeferenced MAP View that includes a MAP layer of type Area or Line that contains
art. An existing Point layer may be used as destination layer (Existing Layer option). Desired symbols must be loaded
in the Adobe lllustrator Symbols panel to use them.

Using Plot MAP Locations

Click the MAP Point Plotter panel options menu and choose Plot MAP Locations.
«  Select the MAP Locations to plot in the list
«  Choose a Destination MAP View to store the Point layer
«  Specify a new Point layer name for which the MAP Locations will be plotted
«  Select the Symbol and Scale to apply.

Results

Points are plotted where MAP Locations are positioned. The MAP Locations are maintained.

L Jive ocions

mmm MAmemnz

(AP Location &

L e oceion
{ Jive ocsion

L Jive iocons
[ Jooeiccuons

L Jive ocions
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Target layer - Indicates the
currently selected layer (can
be area or line layer) and its
coordinate system

Line Plotter

Object > MAPublisher > Line Plotter* or MAP Toolbar-

Line Plotter (Point By Point)

L

Line Plotter

——

- Target layer: Roads _line
Coordinate system: Iliinois Eastern Zone
Input Coordinate System:

(@) Use target layer's coordinate system

Input C System

Specify the coordinate
system in which the starting
point coordinate is entered.
Use the current layer's
coordinate system, or specify
a different one

(by default, the geodetic
system base of the projection,
in latitude-longitude format).

Format - Select the input
format for values in degrees
(when input coordinate
system is geodetic)

Starting Point - Enter the
coordinates of the first point
of the line or click the MAP
Locations button to choose a
location for the Starting Point.
Valid coordinates are marked
with a green check mark,
invalid ones with a red x.

Additional Line Points - Choose
Course & Distance to enter

a series of heading and
distance values

(O Use: WGs34

Format: | Projected units

Starting Point:
+ Xi |335,418.146905
=1
« Y 582,822.08071% m
Options:
[[] Close path (requires at least three points)

+|  Additional Line Points: |Point By Point l -

-

L d

)i

X Y Cancel
1 342,047.118672  563,146:985009
2 367824650538 576,930.075265

Additional Line Points - Choose
Point By Point to enter the
consecutive vertices of the line
by their coordinates

Line vertices - Enter here the

3 360,038.783338 391,081.413141

3 additional point(s)

Close path - Check this option to
automatically close the path
(recommended when using the
Line Plotter on Area layers)

from a list of MAP Locations.

Line Plotter (Course & Distance)

— Add and Add Point from MAP Locations - Click [3] to
add a new row. Click % to add a new point

point coordinates of each
line vertex

Remove - Select a row and click (@] to remove it.

Method - The distance method:

« Cartesian: distance in the
map projection

« Geodesic: shortest distance
along the Earth's curvature

« Rhumb Line: distance along
the Earth curvature at

Line Plotter
Target layer: Roads_line - Additional Line Points: Course &Distance  ~
Coordinate system: Hinois Eastern Zone Method: Cartesian - Cancel
Input Coordinate System: North type: | Grid north b
(®) Use target layer's coordinate system (o e -
O Use: Wwess4
Direction: | 4 Clockwise -
Format: | Projected units -
- Heading Distance
Starting Point:
- |1 35.0000° 625.0000 m
« X: |336,418.146905 m ?
« V: |582,822.080719 m A 2 128.0000 417.0000 m
Options: 3 8.0000° 178.0000 m
[] Close path (requires at least three points)
D & [=] 3 additional paint(s)
?
i
Import list of headings and di: Heading/Distance - Enter here a

Click to choose a text file (.txt)
that contains headings and
distances to import

series of heading and distance
to define the consecutive
vertices of the line

Chapter 6: MAP Locations and Data Creation

constant heading

North type - In the Cartesian
method, choose one of the
north options which headings
are measured from:

« Grid North: north along the
map projection (straight up
on the map)

« True North: actual north
direction (as given by a
north arrow)

Units - Select the linear unit for
distances

Direction - Choose Clockwise
or Counter-clockwise for the
direction of the heading value

143

Line Plotter



FUNCTIONALITY

The MAPublisher Line Plotter creates a new path to a Line or Area layer. Enter line vertices using two options:

«  Point by Point: enter a starting point and consecutive point coordinates.

«  Course &Distance: enter a starting point and a series of headings (angles) and real-world distances. Each
consecutive vertex is defined at an angle and distance from the previous point. Additional options are
available for angle and distance definitions (see hereafter).

The created path is made of straight segments connecting the points.

PREREQUISITES

Create a new MAP Layer of type Line or Area, or use an existing MAP layer of the appropriate type.

USING LINE PLOTTER

Select a Line or Area layer in the MAP Views panel or Adobe Illustrator Layers panel. Click Plot > Line Plotter button on
the MAPublisher toolbar or from the menu Object > MAPublisher > Line Plotter.

The name of the selected layer and its source coordinate system are displayed under Current Layer.

Input Coordinate System
The Input Coordinate System sets the system in which the starting point coordinates are entered. It also applies to
the coordinates of each vertex when the Point by Point option is selected.

When the Use Current Layer's coordinate system option is selected, coordinate values can be entered in the current
coordinate system of the MAP View containing the selected layer.

When the Use: [coordinate system] option is selected, the coordinate system link becomes enabled. Click the link to
open the Select Coordinate System dialog box and choose a coordinate system as required.
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When the selected or default coordinate system is projected, X and Y coordinates are entered as the unit of the
coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate system is Geodetic,
Lat/Long coordinates are entered as degrees. The degree format is selected from the Format drop-down list—see
chapter 6 for details on the supported formats.

Note: The Input Coordinate System is not applied to the distance settings when plotting a line by Course & Distance.
In that case, the layer's coordinate system applies.

Starting Point

Enter the coordinates of the first point of the line in the X, Y or Long, Lat fields. Click the MAP Locations button to
choose a MAP Location (if available).

Options

The Close Path option controls if the path will be closed automatically or not. When using Line Plotter on a Line
layer, this option is disabled by default. On an Area layer, the Close Path option is enabled by default—it is not
recommended to create open paths on an area layer.

A minimum of three vertices are required to create a closed path. If less points are entered, the path is left opened
by the Line Plotter.

Plot Line Point by Point

The Point by Point option in the Additional Line Points drop-down list provides a method to add consecutive line
vertices (or nodes) by typing in the coordinates of each point. This option is typically used to create a line from a list
of known locations. (Alternatively, Join Points could be used to connect points already plotted on the map.)

To add a new point, click the Add button or click the Add MAP Locations (if available). Then enter the new point
coordinates based on the selected Input Coordinate System and Format (if the coordinate system is geodesic). To
remove a point, select a row and click the Remove button.

Plot Line by Course and Distance

The Course & Distance option of the Additional Line Points drop-down list allows to define each consecutive line vertex
by its heading (azimuth or angle relative to the north direction) and real-world distance from the previous point.

The Method drop-down list offers three options to define the real-world distances:

«  (artesian: Distances in the map projection. They represent the distances as measured on the map and
multiplied by the scale. This option is only available if the layer's coordinate system is projected.

«  Geodesic: Shortest distances along the Earth's curvature. Geodesic distances are also known as
Great-Circle distances and are typically used for navigational purpose maps. They represent the actual
covered distance while walking or in a moving vehicle.

«  Rhumb Line: Distance along the Earth curvature at constant heading. They are typically used for
navigational purpose maps to represent routes of constant direction.

Note: Once the next vertex position is calculated on the map, the path segment is the straight connection between
the points. The paths are not drawn curved to follow geodesic or rhumb lines
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The North type drop-down list contains two options to define the north direction when the method is set to Cartesian:
«  Grid North: Refers to the northward direction of the map projection grid lines—Grid North is constant
throughout the map.
«  TrueNorth: Refers to the actual direction to the geographic North Pole. The True North direction can vary
depending on a point position on a map. Similarly, graticule longitude lines are pointing to True North
as well as MAP North Arrows (see chapter 14).

Note: The Geodesic and Rhumb Line methods are by definition using the True North as northward direction. The
North Type drop-down list is therefore disabled in these cases.

The Units drop-down list allows to select a linear unit for the distance. By default, the Units list is set to the Point Units
of the current layer's coordinate system, if it is projected. If the current layer's coordinate system is geodesic, the
Units list is set to Meters.

The Direction drop-down list indicates the direction of the heading angles. Typically, navigational headings (or
azimuths) are given in Clockwise direction. However, the natural angle direction in Adobe lllustrator is Counter-clockwise,
which may be preferred for simple drawing purpose.

Once all options are set, click the Add button to create a new entry of heading and distance. To remove an entry,
select a row and click the Remove button.

Click the Import list of headings and distances button to browse for a text file (.txt) containing headings and
distances. No column headers are required. Values listed should follow the format of heading then distance.
For example, a text file that contains four headings and distances will look like:

266.883,400773.2079
13.548, 365969.5053
270.353,322701.9679
331.837,99368.0284
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Target - Indicate the MAP Area ——
layer to plot the area on

Input - Specify which input ——
coordinate system to use

for plotting the Corner and
Opposite Corner coordinates

Options - Specify shape as
Rectangle or Ellipse. This —
dialog box shows location
type as Bounding box. To the
far right shows options for
Position location type.

Corner - Specify X and Y ——
coordinates to use as a corner
of the area

Opposite Corner - Specify X and ——
Y coordinates to use as the
opposite corner of the area

Area Plotter

Object > MAPublisher > Area Plotter or MAP Toolbar

Location type: Bounding box

Area Plotter

—e Target: | [E Community_area

Input:
() Page coordinates (Global Rulers)
Lo

(®) World coordinates: | @ Chicagoland

Coordinate system: Ilinois Eastern Zone
[ use:
Input format:

WGS 84
Projected units
— Options:
Shape: Rectangle -
Location type: |Bounding box -
Corner:
o X
e

336,418.146905

i

582,822.080719

Opposite Corner:
& X
Y

367,824.650538
Lo

576,930.075265

|

Cancel

Point - Specify —
anchor point
and Xand Y
coordinate of it

Dimensions —
Specify units,
width and height
of the area

FUNCTIONALITY

MAP Locations - Choose
predefined MAP Locations or
Artboard locations (corners)

Location type: Position

Options:
Shape: Rectangle

Location type:  Position

le Point: | [¥] Center -
o X

7

342,047.118672
563,146.985099
te Dimensions:

Units: | Meter

Width: | 500.000000000000000 m

Height: | 800.000000000000000 m

[] Constrain dimensions

The MAPublisher Area Plotter creates new rectangle or ellipse polygons on MAP Area layers by using page or world
coordinates, and by location type (using either a bounding box or by a single coordinate position). Use it to
create precise area shapes based on coordinate locations.

PREREQUISITES

Area Plotter only works

with Area layers.

USING AREA PLOTTER

On the MAPublisher Toolbar, click Plot > Area Plotter button or from the menu Object > MAPublisher > Area Plotter.
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Input Coordinates

The Input sets the coordinate system in which the starting point coordinates are entered. Input coordinates can
either be Page Coordinates or World Coordinates.

When the Page coordinates (Global Rulers) option is chosen, page coordinate values (in pixels) can be entered for the
Corner and Opposite Corner coordinates.

When the World coordinates option is chosen, the MAP View drop-down list becomes enabled. Choose the appropriate
MAP View to use. Its coordinate system is displayed directly below the MAP View drop-down list. The options in the
dialog box will change to reflect a geodetic or projected coordinate system and corner values can be entered either
as (a variation of) decimal degrees or in projected units. To use an alternative coordinate system, click the Use check
box, and click the coordinate system link. Choose an appropriate coordinate system in the Select Coordinate System
dialog box.

Shape and Location Type Options

There are two shape options to choose from when plotting areas: rectangle and ellipse. More importantly, two
location types determine how the shapes are plotted: Bounding box and Position.

When Bounding box is chosen, enter (map page or map world) coordinates into the Corner and Opposite Corner
coordinates to define the area. A preview of the area can be seen on the artboard (you may have to move the Area
Plotter dialog box to see it). Note: Any corner and its opposing corner can be used for the bounding box.

Corner Corner

Opposite Corner Opposite Corner

Rectangle, Bounding Box Ellipse, Bounding Box

Note: The bounding box for an ellipse is the same as the rectangle.
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When Position is chosen, choose a coordinate point position relative to the shape. These point position options
include Center, Upper left, Upper right, Lower left, and Lower right. In the Dimensions section, enter a width and

height and the appropriate units to plot. A preview of the area can be seen on the artboard (you may have to move
the Area Plotter dialog box to see it).

Point position Point position
® Ll

Rectangle, Position (Center) Ellipse, Position (Center)

Use of MAP Locations as Coordinates

Area Plotter To use MAP Locations as coordinates, click the MAP Locations button
N R = and choose an appropriate one from the context menu. Alternatively,
Inputs p— choose MAP Page Locations or Artboard Locations from the same
) Page coordinates (Global Rulers) context menu.
(®) World coordinates: | (@ Chicagoland -

e fims e Click the More MAP Locations in the context menu to open the Select
Input format: | progected units MAP Location dialog box. The X and Y coordinates and coordinate
options: system are displayed in a list. The Artboard Locations tab shows the
Shape: Rectangle -

page coordinates for the Upper left, Upper right, Lower left, and Lower
right corners.

Location type: Boundingbox

Corner:

« X: |336,418.146905 m ?
o Y: |582,822.080719 m| b
Opposite Corner:

« X: | 360,038,785339 m

« Y |591,081.413141 m

Location 1
Location 2

Location 3

- -0 -0 o | —80

Location 4

Artboard 1 >

MAP Locations...
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MAP Area Plotter Tool

Tools > MAP Area Plotter Rectangle Tool / MAP Area Plotter Ellipse Tool
FUNCTIONALITY

Use the MAP Area Plotter Tool to quickly draw georeferenced rectangles and ellipses to MAP Area Layers.

USING THE MAP AREATOOLS

The MAP Area Plotter Tool consists of two tools: Rectangle and Ellipse. There are two ways to use these tools: click and
drag to draw the shape; or single-click to open the Area Plotter dialog box and specify plot options.

Draw using Click and Drag

To draw a shape of unspecified size, click and drag in the artboard until the desired area is achieved. Use keyboard
modifiers to help draw shapes more efficiently: hold the Alt key (Windows) or the Option key (Mac) to draw from

the center; hold the Shift key to constrain the proportions; or hold the space bar to move the area. Enable Adobe
lllustrator Smart Guides to snap to features for better control when drawing. Release the left mouse button to finish
drawing the area.

Enter Specific Dimensions

To draw a shape of specified size, single-click at a point in the MAP document at the desired location to plot the
shape using options in the MAP Area Plotter dialog box (see previous section). By default, the area is centered over the
click point and its coordinates populate the X and Y boxes. Enter width and height values to specify a dimension. A
preview of the area can be seen on the artboard (you may have to move the Area Plotter dialog box to see it).
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FUNCTIONALITY

The Add Calculated Data tool has several calculation actions that can be performed on art geometry. The calculated

Add Calculated Data

Object > MAPublisher > Add Calculated Data or MAP Toolbar

data populates existing or new MAP Attribute columns. The calculation options are:
Centroid position for lines and areas
Elevation, Position, and North Angle for points
Colours for labels, lines and areas

Statistics
Auto-number
Art bounds

Calculated values are not updated automatically when the source column changes. Add Calculated Data must be
run again to apply newly calculations. Calculated data can be added or updated to all art on a layer or only to the
selected art, however statistical calculations are based on the entire dataset.

PRERE

QUISITES

Add Calculated Data can populate new or existing attribute columns. Only attributes of type Double can be
updated.

For statistic calculations, the source column must be numerical (Integer or Double). Users may need to use the Join
Table function to import appropriate numerical data beforehand (e.g. election results per county). See Edit Schema
in MAP Attributes - chapter 5.

USING ADD CALCULATED DATA

If necessary, select features before using the Add Calculated Data tool. Click the Add Calculated Data button on the MAP

Toolbar. Enable the Apply to selected features only option if required.

Calculate Centroid or Position

Certain calculations are layer dependent.

MAP View and Layer - Choose the
appropriate MAP View and layer to
apply the calculation to

Calculation - Set calculation type.

ColumnXand ColumnY - Select or add
the attribute column to receive the

x and y position values. The () —»

icon indicates that a new column
will be added to the attribute
table. The %% icon indicates that an
existing column will be updated.
An attribute type icon indicates
what kind of attribute type will be
used for the column.

AP View:

= Layer

~e Calcuiation:
Type:
Format:
Units:
Column X;
Column ¥:

Decimals:

Add Calculated Data

@ vancouver_Downtown

Land_area
] Apply to selected features only
Centraid

Native geodetic coordinates
Decmal degrees (D +[.d*])

Degree

new_positon x

new_position_y

8

v @@
v| @ add @

Type - The type of coordinates:

« Page coordinates: position in
Adobe document page units

« Projected coordinates: available if
the coordinate system of the MAP
View is projected

« Native geodetic coordinates:
Longitude/Latitude position

« WGS84 coordinates: Longitude/
Latitude position

« MGRS coordinates: Military grid
reference system position

Format and Units - When applicable,
choose the appropriate format and
units for calculation

—— Decimals - Specify the number of
decimal places to use
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Choose Centroid from the Calculation drop-down list to calculate the x and y position of line or area centroids. If the
selected data is on a Point MAP layer, choose Position from the Calculation drop-down list to calculate the x and y
position of points in a specific coordinate format.

Note: Centroid positions are calculated using the low accuracy method (see Plot Centroids for details).

In the Column X and ColumnY drop-down lists, users have the option to keep the default new column names
(new_position_x and new_position_y), type names of their choice, or select an existing column. Only existing
columns of data type Double are listed.

The positions coordinate format is set in the Type drop-down list. The options are:

- Page coordinates: x and y positions relative to the Adobe Illustrator page reference, in page units (as
specified in the Adobe Illustrator document setup).

«  Projected coordinates: x and y positions in the source coordinate system of the MAP View containing the
selected layer (if this system is projected).

«  Native geodetic coordinates: longitude and latitude positions — calculated from x and y positions of the
selected MAP View's native geodetic coordinate system.

«  WGS84 coordinates: longitude and latitude positions — calculated from x and y positions if the source
coordinate systems of the MAP View containing the selected layer is projected.

«  MGRS coordinates: military grid reference system positions — calculated from x and y positions if the
source coordinate systems of the MAP View containing the selected layer is projected.

The Unit drop-down list shows a selection of linear or angular units if the coordinate type is set to projected or
geodetic respectively.

Calculate Statistics

To calculate statistics based on a source attribute column, choose Statistics from the Calculation drop-down list.

Add Calculated Data

MAP View: | @ Vancouver_Downtown -
Target - Choose or add e k= || canee
the attribute column to e s
receive statistic values Caleuiations [statstes O Operation - Specify
“eTarget: | new_stat_col v @ Add

Source - Select the
attribute column to be 1
used as source for the

Operaton:

g Source:

Sum

#hrea

the operation to be

o~ performed: Deviation

Distribution, Mean,
Standard Deviation, Sum.

calculations

The following statistical operations are available:

. Deviation: for each row, difference between the current value and the mean.

«  Distribution: for each row, current value divided by the sum.

. Mean: sum of all the row values divided by the number of rows in the source column (same for all rows).

«  Standard Deviation: measure of the variability or dispersion of the row values in the source column.
A low standard deviation indicates that row values are very close to the mean, whereas high standard
deviation indicates that row values are spread out. Calculated as the square root of the sum of all
deviations squared, divided by the number of rows in the source column (same for all rows).

. Sum: addition of all the row values in the source column (same for all rows).

In the Target drop-down list, users have the options to keep the default new column name (new_stat_col), type a
name of their choice, or select an existing column. Only existing columns of data type Double are listed.
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Then, select the required function in the Operation drop-down list. Deviation and Distribution calculate a value
specific to each row; Mean, Standard Deviation and Sum create a single value for all rows.

In the Source drop-down list, select the source column from within all numerical attributes of the current layer.
Users have the option to add calculated data to all art on a layer or only to the selected art, however statistical
calculations are based on the entire dataset of the source column

Note: To obtain a distribution in percents, first use Add Calculated Data with the Distribution operation, then use the
Apply Expression function to multiply the column values by 100 (e.g. COLUMN = COLUMN * 100).

The standard deviation value MAPublisher uses is n. Microsoft Excel uses n-1.

Calculate North Angle

To calculate north angles of points on a Point MAP layer, , choose North Angle from the Calculation drop-down list.

Add Calculated Data

MAP view: | @ Vancouver_Downtown -
Layer PointsOfinterest_point | cancel

0 lected fe: 0
Target - Choose or add e

the attribute column to Calculation: |North Angle 5
receive north angle values Target: | new_north_sngle v © add

Calculate Colours

To calculate colours of layers or objects, choose Colours from the Calculation drop-down list.

Add Calculated Data
MAP View: | @ Vancouver_Downtonn -
Colour source - Choose il s - cance
the colour source as [ Apply to selected features only
the fill or the stroke of Calcuiation: |Colours =
the layer or objects — e colour source: stroke B
Colour model - Choose ——F Colour mocet: |cmvk <
the colour model: iCyan cyan v| © add
CMYK or RGB %Magemal magenta v| © ad
Colour attribute labels ——#relow: velow v| © ad
Specify attribute labels ;B\a:k: black v| © add Indeterminate Colours
to the associated CMYK  Range: 0.0-10 S Colours that cannot
or RGB COI_OU"S' Labels Indeterminate Colours: be determined (such
\thsetsbcea : r;)l(eq :‘Jri nl:azrﬁz o Reset attrbute to defauit nhen colour source is memjmce ) ___ asgradients) are reset
t 1 0 1 00 0 () Indicate indeterminate colour using: 1. 0 = to default ora SpeCiﬁC
.0 or 100. .
o100 value can be specified

Not available for point layers

In the Colour source drop-down list, choose from either Fill or Stroke of the current layer or objects. This will be the
source of which MAPublisher retrieves the colour values from.

In the Colour model drop-down list, choose from either CMYK or RGB. This will change the available colour attribute
label boxes below it and set the colour attribute values. When CMYK is chosen, colour values in the attribute table
are populated with Real numbers. For example, a cyan value of 0.2562 is equivalent to 25.62 in the Adobe lllustrator
Color panel. When RGB is chosen, colour values in the attribute table are populated with Integer numbers.
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By default, the colour attribute label boxes are populated with the name of the colour. These are the attribute
column heading names and can be edited, however, they must remain unique. An indicator to the right of the box
displays either "Add" or "Update". When calculating new colour attribute values and a new label is entered, the
indicator will display "Add". It is possible to update the values in the attribute table when the colour of the layer or
objects are changed. When using the same attribute labels, the indicator will display "Update". This overwrites the
existing colour values in the attribute table.

Adjust the CMYK colour Range value by representing them as numbers from 0.0 to 1.0 or 0.0 to 100.0.

Indeterminate colours are colours that MAPublisher cannot determine for a layer or object. The colour value will not
be calculated if:

«  objects do not have fill or stroke

- objects have gradient colour

- objects have patterns or hatches

«  objects have colors not in CMYK or RGB (e.g. Pantone)

«  colours are applied to the layer group (not object level)

In the Indeterminate Colours section, two options are available to deal with these situations. Reset attribute to
default when colour source is indeterminate sets the attribute values to 0 (zero). The Indicate indeterminate colours
using option allows you to specify a specific value. The default is -1.0000.

Calculate Auto-Numbers

To calculate auto-numbers for records in the attribute table, choose Auto-number from the Calculation drop-down list.

Add Calculated Data

MAP View: | (@ canada -
ia_area

Layer: = Cancel

Sortby - Choose an
existing attribute

column to order the
Target- Choose or add —reTaget:  Hid v| B Update auto-number ID by

the attribute column to Jr—osﬁrﬁng o: [0

Calculation: | Auto-number -

receive ID numbers Sortby: | [ NAME — Sort Order - determine
Sortorder: | Ascending ———=_ ascendingor

[] Use Natural Comparison descending order. Also
option to not sort.

Starting ID - the number
value at which to start

Choose or add the attribute column in the Target box. In the Starting ID box, specify a numeric value to begin
numbering from. In the Sortby drop-down list, choose which attribute the ID values should be sorted by. In the Sort
order drop-down list, choose ascending or descending order. Also, an option to not sort is available to preserve

the current object order. Enable the Use Natural Comparison check box to use an alphanumerical sort on the specified
attribute.
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Calculate Elevation

To calculate elevation for points, choose Elevation from the Calculation drop-down list.

Elevation - Choose or add —fegevaton

receive elevation values

Add Calculated Data

MAP View: | @ United States

Layer: usdities_paint.
(] Apply to selected features only

Calculation: | Elevation

elevation

‘your account page, click the ink to enable free web services.

the attribute column to J,_.Unit Meer

Unit - The unit of
measurement required
for elevation values

hitp: ffwnw geonemes.ora/login

A GeoNames account is required to calalate elevation values. Go to the link below to register for
an account. After activating your account, log in, and diick your username at the top-right. On

v @ Add
Go to www.geonames.org/login
and register for an account.
Specify your username in

Userame: | username

o thetext box to gain access

to the service.

Choose or add the attribute column in the Elevation box. In the Unit drop-down list, choose a unit of measurement.

To obtain point elevation values, a GeoNames account is required. GeoNames is an open source geographical
database that covers all countries and contains over eight million placenames that are available for download
free of charge. Go to www.geonames.org/login to register for an account. Once an account has been registered, go to

www.geonames.org/manageaccount and enable the account to use free web services. Enter the registered username into
the Add Calculated Data dialog box.

Notes: Although a GeoNames account is required, you do not have to be logged into geonames.org to calculate

elevation values. The important part is to enable your account to use free web services.

Elevation data values of -32,768 are considered as "no data" values.

Calculate Art Bounds

To calculate art bounds for features, choose Art bounds from the Calculation drop-down list.

Minimum and maximum bounds —
Choose or add the minimum
and maximum bounds for each
art object. Rename attribute
headings if necessary.

Add Calculated Data

MAP View: | & United States
Layer westusa_area

[ Apply to selected features only
Calaulation: | Art Bounds
Type: Page coordinates (Global ruler)
Format: Decimal degrees (D+[.4*1)
Units: Inches

Pin X: min_x

)

Min Y: min_y
Max Xz max_x
Max ¥: max_y

Decimals: |4

Type - The type of coordinates:
« Page coordinates: position in

hd Adobe document page units
T cancel « Projected coordinates: available if

the coordinate system of the MAP

= View is projected

« Native geodetic coordinates:
Longitude/Latitude position

~e—

—— « WGS84 coordinates: Longitude/
Latitude position
b (+) 2 « MGRS coordinates: Military grid
| © pad reference system position
o| © A
7 © — Format and Units - When applicable,

= choose the appropriate format and
- units for calculation
— Decimals - Specify the number of

decimal places to use
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Choose or add the attribute column in the MinX, MinY, Max X, and MaxY boxes. In the Type drop-down list, choose a
coordinate type: Page, Geodetic, WGS84 or MGRS. In the Unit drop-down list, choose a unit of measurement. The
unit of measurement depends on the coordinate type.

MaxY

R
MinX \\{ Layer: [ B canada_srea (1area selected) [~] =
| [E [Emin_x [Emin_y [Emex [Emex_y \
\ 1|Ontario | 165.851074 538.769531 | 626143438 73.227539
\
RN fﬁm\fg I‘l
B e Je— MaxX Larea selected ERETN = fx B E
"Q@%\? /a’/ Art bound values in page coordinates
I
[
&
MinY

ADDITIONAL ADD CALCULATED DATA NOTES

For single polygons, the centroid can be assimilated to the center of mass of the surface. For single lines, the

centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of the
largest polygon or line is used.

Note: The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the anchor
points are used to calculate the centroid's position. If necessary, use the Adobe lllustrator Add Anchor Points
function (Object > Path > Add Anchor Points) before running Add Calculated Data.
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Cartographic
Tools

MAPublisher has several special cartographic tools to handle
artwork on MAP layers without distorting georeferencing or
negatively affecting MAP attributes.

Create Halo creates halo around text and features. The

MAP Vector Crop Rectangle Tool trims all the vector data

(on all active layers) falling outside of a crop area. The MAP
Measurement Tools allows users to measure distances in
page or world units and to save the measuring path as an art.

Topics covered in this section:
Create Halo

Scale & Rotate By Attribute
Dash Offset

MAP Measurement Tool

MAP Themes are covered in Chapter 9.
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Create Halo

Object > MAPublisher > Create Halo or MAPublisher Toolbar @

Create Halo
Halo type - Choose Regular —— Halo Regular Preview:
Rl Ag I = —— Preview - Choose Area,
or Simple Feature type: Text - . .
Appearance: Cancel Line, Point or Text type
Appearance - Choose halo—pe o0 Mz Yo 100 Ke0 <[ Backoround colour: || /] More] - A to change the preview
colour, size, opacity and display below. Adjust
feather settings s S00m = the background colour if
Opacity: 100% 5 necessary.
[l use feather:  5.00px = - Preview display - Shows a
Output - Apply halo to a — L, PutPut: P re\"ew preview of.the. settings
specific MAP layer (to Targetlayer: LP_Community_text - made in this dialog box.
layer group, to all art on ) Apply to layer group
layer, or to selectled art @ Ppply toall arton layer
on layer). () Apply to selected art on layer Preview appearance options
Create style (not available with ——=* [ ] create style:  Graphice style Appearance: [l Arial Black, 40.00 ot ChaPnge§ dependjrng '
Simple halo type) - Create a & Gap on‘ review type. Text:
graphic style with the e adjust text colour and
saved settings size. Point: adjust point
symbol and scale (%).

The Create Halo tool creates halo graphic styles and applies halos to MAP layers.

PREREQUISITES

Halos are immediately applied to a MAP layer. A Non-MAP layer cannot have halos directly created for them,
however, graphic styles can be created and applied to Non-MAP layers manually.

Swatches and colours should be created before creating halos.

USING CREATE HALO
Click the Create Halo button on the MAPublisher Toolbar or from the menu Object > MAPublisher > Create Halo.

Halo type

There are two halo types: Regular and Simple. Simple does not have the Apply to a layer group option and the
Create style option available. This means that halos can be applied to a MAP layer without creating a graphic style.

Appearance

Set halo appearance settings based on Colour, Size, Opacity and Feather. All appearance settings can be seen in the
preview display.

The Colour drop-down box is populated with swatches from the Adobe Illustrator Swatches panel. The Size setting
affects the halo size. By default, the Size units are in pixels. Right-click the Size box to choose different units. Use the
Opacity slider or spin box to adjust the transparency of the halo (0% for no halo, 100% for opaque). The Use feather
option creates a soft gradient around the halo (default of 5.0 pixels). Increase feathering for a softer appearance,
decrease feathering for a sharper appearance.
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Output

Halos can be applied to one MAP layer at a time. Choose a Target layer from the drop-down list. Next, choose how
the halo is applied. Three options are available: the Apply to layer group option (for Regular type halo only), Apply to
all art on layer, or to Apply to selected art on layer.

For Regular type halos, a graphic style can be created. Graphic styles are saved to the Adobe lllustrator Graphic Style
panel and can be used at a later time. To create one, click the Create style check box and enter a unique name. This is
not available for Simple type halos.

Preview

The preview provides an idea of what the halo may look like on the artwork of you MAP layer. There are four
preview types: Area, Line, Point and Text. The Area and Line preview provides a link to change the fill, color and
stroke of the preview feature. The Point preview provides options to choose a symbol from the Symbol drop-down
list. The Text preview provides a link to change text options such as colour and size. For all types, the background
colour can be adjusted (by default, no colour is set). These Preview options do not affect the halo and only provide
you with an idea of what the halo may look like in a combination of settings.

RESULTS

Halos applied to a MAP layer are immediately visible (text example below). The Adobe lllustrator Appearance panel
shows that there is a Fill (halo) positioned at the bottom for this Type object. The halo can be adjusted in the panel.
This may be useful in cases where a few outliers need some fine tuning to make them more visually appealing.

APPEARANCE

Layer

1 |b Stroke: .

Contents

GRAPHIC STYLES

_ I N ENEERCE
Bayshore The Westing Hotel |

Orange Halo i

=, <% Bl 7
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Scale & Rotate By Attribute

Object > MAPublisher > Scale & Rotate By Attribute or MAPublisher Toolbar |t

Scale & Rotate By Attribute

Target Layer - Choose the
target layer whose artwork—— Target Layer: | [-| Points of Interest -
should be scaled or rotated

[] selected art only Cancel
Rotate - Specify angle or choose ——-[+] Rotate:
attribute value from target layer @® Spedified angle: | 15.00 degrees :
. () Fromattribute: @ @ #Rotstion Attri pression Mode Toggle
Rotate objects/patterns - Rotate Rotate abiects Choose between Attribute
patterns only applicable to——p—e "/ Rotat= o0 Mode or Expression Mode
Area and Line MAP Layers Rotate patterns (ability to build expressions).

Scale - Choose to scale ——[¥] scale: Unifarm -
uniformly or non-uniformly
(see below). Specify scale
value or choose attribute O From attribute: @ #Opadity
value from target layer.

(@) Specified value: |ES‘DD% S |

Scale objects

Scale objec /strokes and effects
Scale patterns and strokes and Scale patterns
effects only applicable to Area and Scale strokes and effects

Line MAP Layers

Scale Non-uniform

Scale: Mon-uniform
Scale Horizontal - Specify ———e Horizontak
horizontal scale value (®) Specified percentage: | 85.00% <
or choose attribute

value from target layer (O From atiribute: ® HEETEL

Scale Vertical - Specify ———e verticalk:

vertical scale value or (®) Specified percentage: |85.00% z
choose attribute value B
from target layer () From attribute: (-] #Opacdity

Scale objects
Scale patterns

Scale strokes and effects

FUNCTIONALITY

The Scale & Rotate By Attribute tool provides options to scale and rotate art objects using specified values or the target
MAP layer's attributes.

PREREQUISITES

MAP Attributes used for scale and rotate must be of type Integer or Double (see Chapter 5).

To only scale or rotate specific art objects, they must be selected first.
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USING SCALE & ROTATE BY ATTRIBUTE

Click the Scale & Rotate By Attribute button on the MAPublisher Toolbar or click Object > MAPublisher > Scale & Rotate By
Attribute.

Choose a Target MAP layer from the drop-down list. All art (including text) on the target layer is scaled or rotated
unless the Selected art only option is enabled.

Rotate

Click the Rotate check box to enable the rotate settings. To rotate by a value, in the Specified angle spin box, enter
a value from -360 to 360 degrees. To rotate by a MAP Attribute, click the From attribute drop-down list and choose
one. Alternatively, click the Attribute/Expression Mode toggle button to change the input settings. Build an
expression (see Chapter 5) to determine rotate value.

By default, the Rotate objects option is checked. The Rotate patterns option is enabled only when the target is a
MAP Area or Line layer. When the Rotate patterns option is enabled and checked, the Rotate objects option can be
unchecked (which will mean that only patterns are rotated).

Scale

Click the Scale check box to enable the rotate settings. There are two scale options: uniform and non-uniform.

The Uniform scale option means that all art is proportionally scaled. In the Specified value spin box, enter a value
from 0 to 1000 percent. To scale by a MAP Attribute, click the From attribute drop-down list and choose one.
Alternatively, click the Attribute/Expression Mode toggle button to change the input settings. Build an expression
to determine scale value.

The Non-uniform scale option provides independent horizontal and vertical scale settings. For each Horizontal and
Vertical scale settings, in the Specified percentage spin boxes, enter a value from 0 to 1000 percent, or choose a MAP
Attribute from the drop-down list, or build an expression to determine scale value.

By default, the Scale objects option is checked. The Scale patterns and Scale strokes and effects options are enabled
only when the target is a MAP Area or Line layer. When either of these two options are enabled and checked, the
Scale objects option can be unchecked.

Note: Scaling or rotating non-point objects may cause the georeferencing for affected features to become
inaccurate. To maintain accurate georeferencing, scale and rotate using the MAP View Editor.

Chapter 7: Cartographic Tools | 161
Scale & Rotate By Attribute



Dash Offset

r
Tools > Dash Offset
Dash Offset
Apply to all strokes - Use setting to adjust —— () Apply to all strokes:  0.00 pt s
dash offset for the selected path ®) Specify individually: Cancel
Stroke Dash Offset Preview

Specify individually - Specify individual —- I 2.000pt| 000t

dash offset values for each stroke of I 5.000 pt | 0.00pt
the selected path

a4l

Maote: Applying dash offset changes will remove any
variable stroke settings on the selected path.

FUNCTIONALITY

The Dash Offset tool can be used on paths and compound paths to shift or offset dashes by a specific point value.

PREREQUISITES

A path or compound path with a dash must first be selected before that Dash Offset tool can be used. A path must
have multiple strokes before they can be individually adjusted. Dash Offset only works on one path at a time.

USING DASH OFFSET

Click the Dash Offset button in the Adobe Illustrator Tools panel.

There are two options to apply dash offset: apply to all strokes (of selected art) and specify individually. Choose
Apply to all strokes and increase or decrease the offset (range of -100.00 to 100.00). Check the Preview check box to
view how the dash offset settings look on the artboard.

When a selected path has multiple strokes applied to it, the Specify individually option is enabled and lists the stroke
colors and stroke weight. In the Dash Offset column, the dash offset can be individually adjusted for each stroke.

Note: Variable stroke settings (such as corner alignment, arrowheads, and arrowhead scale) on the selected path
are removed when applying a dash offset.
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MAP Measurement Tool

Tools > MAP Measurement Tool
FUNCTIONALITY

The MAP Measurement Tool measures distances (between two points), path distances (multiple points), azimuths,
and the perimeter and area of closed paths in page or map units. Furthermore, the measuring path can be
converted to a line or area in the currently selected layer.

PREREQUISITES

To measure ground distances (great circle distance in map units), the Adobe lllustrator file must contain at least one
MAP View with an assigned coordinate system.

The map units used by the MAP Measurement Tool are set in MAPublisher Preferences. Use the current layer's map
units or select alternative units. The layer's map units are defined in the coordinate system definition of the selected
MAP View and can be viewed in the MAP View Editor by clicking the information button of the Source Coordinate
System (called Point Style in the Definition tab)—see chapter 4 and Appendix A2 for details.

The Adobe lllustrator page units can be accessed and changed in the Document Setup dialog box (Adobe Illustrator
menu File > Document Setup > Units drop-down list).

To use vector snapping while measuring, enable the Adobe Illustrator Smart Guides (Adobe Illustrator menu View >
Smart Guides). The snapping tolerance is set in the Adobe lllustrator Preferences for Smart Guides (Adobe lllustrator
menu Edit > Preferences > Smart Guides).

USING THE MAP MEASUREMENT TOOL
Click the MAP Measurement Tool button on the Adobe Illustrator Tools panel. The cursor becomes a crosshair —}- .

MAP Layers are measured in map units (great circle or real world distances). Select a MAP Layer and then click to
measure. The units of the layer's parent MAP View will be used in the measurements.

Non-MAP Layers are measured in page units (distances on the page). Select a non-MAP Layer and then click to
measure. The units of the document will be used in the measurements.

Note: While the MAP Measurement Tool is enabled, users can change the selected layer in the Adobe Illustrator
Layers panel. If the new selected layer is contained in a different MAP View, the distance values are updated
accordingly on the screen automatically without having to start a new measurement — e.g. if the MAP View
scale is different, the measurement will significantly change.

When Adobe lllustrator Smart Guides are enabled, the MAP Measuring Tool can snap to existing anchor points.
When the mouse cursors is near enough a point, Adobe lllustrator highlights it as shown in the image below.

/
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Measure Distance

By default, the MAP Measurement Tool measures distance between two points.

Click a starting point to begin measuring. As the mouse moves on the artboard, a distance label indicates the
distance (and azimuths, if enabled in MAPublisher Preferences) from the starting point to the current mouse
position. A second click digitizes the end point. As soon as the second point is clicked, the measurement is ended

and the total distance is displayed.
E’\ %

Total distance: 1108.085350 usft ™

A

Measure Path Distance

Click a starting point to begin measuring. Before clicking a second time, hold down the Shift key. The cursor

changes from —|- to 3. A new point is added on the path, but the measurement does not end.

Keep holding the Shift key while adding more points along the path. As the mouse moves on the artboard, a total
distance label indicates the length of the path already digitized and the distance from the last added point to the
current mouse position.

While digitizing the measuring path, hold the Alt key (Windows) or Alt/Option key (Mac) to display the length of each
digitized path segment.

Before adding the last point, release the Shift key. As soon as the last point is clicked, the measurement is ended
and the total distance is displayed. Hold the Alt key (Windows) or Alt/Option key (Mac) while clicking the last point to
display all annotations (segment lengths and total distance).

)
~§ b
$L

Segment: 833,592 usft
Total distance: 2845.43154% usft

1147.345156 usft
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Measure Perimeter and Area

To measure the perimeter and area of a closed path, follow the same steps as measuring the distance of a path.
When digitizing the last point, release the Shift button and place the mouse cursor over the start point—a box is
drawn around the starting point—click to close the path and end the measurement.

Hold the Alt key (Windows) or Control key (Mac) while digitizing to display the length of each segment.

Perimeter: 2483.107054 m
Arsa: 28BB85.023306 m2

Note: Holding down the Shift key while clicking the start point again prevents the path from being closed and the
measurement can continue.

Convert Measurement Line to Art

When any of the above measurement methods are finished, two options are available:

1. Click anywhere on the artboard once to clear the measurement line and label
2. Hold the Shift key and click anywhere on the artboard once. This converts the measurement line to an
Adobe lllustrator art object, adds it to the current layer and applies the current stroke settings.

A new click on the page starts a new measurement. To exit the MAP Measurement Tool, select another tool in the
Adobe lllustrator Tools panel.

MAP Measurement Tool Preferences

Access the MAP Measurement Tool Preferences by double-clicking the MAP Measurement Tool button on the
Adobe lllustrator Tools panel or from the menu Edit > MAPublisher Preferences > MAP Measurement.

Set the number of decimals for the measurement values, enable display of azimuths, and change the digitized path
and new segment colours. See chapter 1 for more information on MAPublisher Preferences.
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The Adobe lllustrator environment offers lots of flexibility
when working with vector art. To enhance Adobe lllustrator
functionality, MAPublisher introduces many geometry
operations designed specifically for cartographic purposes.

Create a proximity around lines using the Buffer Art tool.
Change the direction of lines using the Flip Lines tool; useful
for road mapping applications. Easily join points, lines and
areas to create seamless datasets. In addition, simplify art to
reduce the amount of vertex points, while retaining spatial
referencing.
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Join Areas

Object > MAPublisher > Join Areas* or MAP Toolbar > Join >

Join Areas Aur{hutes - Dgtermlnes how
attributes will be handled
Target Layer - Layer on which ——eTarget Layer: | [H water_area + | Attributes: once features are joined
the join will be performed into a single object. For
) P Attribute Operation Options Cancel N 9 ’
Destination: string fields choose to
R Joined | oY ——— HYDROUID Set to default if different N/A either Clear the field, Clear
estination - Joined results ——- — i di
O Copy results to new layer:  few layer B NAME  Joinon N/A if different (two or more
are on the target layer or S B i :
t getlay unique values are found),
copied to a new layer sein Types [ TYPE Set to default if different N/A sort Least Alphabetical (Z-A)
RAMK  Setto default if different N/A or Most Alphabetical (A-Z).
Join Type - Defines art to be Join &ll selected areas on target layer :
or Integer or Real fields
joined. Choose aII‘art on ®) Join areas by attribute: | [F1] NAME +| |E PrRUD Set to default if different N/A options include Clear the
layer or choose to join all [ nly join selected areas field, Clear if different (two
or selected grt on similar - or more unique values are
attribute values. Join Method: (® Apply to every grouped companent found), return the Sum or
. () Group areas () Only apply attribute operations to grouped companents that satisify:
Join Method - Group areas —+- ~ " Average of the grouped
creates Adobe Illustrator (®) Create compound areas & @ values or enter the Largest
groups of joined art. Dissolve borders between adjacent sub-areas Empty expression. In postion: 0 Value or Smallest Value of
Create a compound path the grouped fields.

for each grouped art
with the option to outline
group or leave internal
group borders intact.

L Only apply to grouped components that satisfy:
Use an expression to define which
joined areas the above attribute field
options will apply to.

FUNCTIONALITY

Join Areas groups art objects based on a specified similar attribute value. An attribute field is defined and a new
object is created for each unique value within that field. Options can be set to create Adobe lllustrator groups or
compound paths, while either maintaining the outlines of the original features or dissolving sub-areas into the
larger area.

USING JOIN AREAS

To use Join Areas, click the Join > Join Areas button on the MAPublisher toolbar or from the menu Object > MAPublisher
> Join Areas. Choose the Target Layer on which Join Areas should be performed. Specify the Join Type to either Join

all selected areas on target layer or Join areas by attribute. Specify an attribute which the join will be based on. It is noted in
the Attributes section Operation column as Join on.

Select the Join Method type to either Adobe lllustrator Group areas or Create compound areas. For the latter option,
choose to Dissolve borders between adjacent sub-areas. Not checking this option will maintain the borders of individual
areas. For example, when grouping the countries of the world by its Continent field attributes, the Continent field
will result in five new objects, one for each continent. Dissolving borders between adjacent sub-areas will leave the
continent outlines. Choosing not to dissolve, the outline of each country will remain. In both cases, there will be one
object for each continent in the attribute table.

When areas are joined, many attributes that were valid to the original lines may no longer be valid. For example,
after joining the countries of the world on the Continent field, the field containing country capitals will no longer
be valid, as each continent does not have one capital. Thus, operations can be set to determine how each attribute
field is handled. By default all attribute operations are set Clear if different, meaning that the attribute is cleared if
there are more than two unique values present after the join. Depending on the attribute type (string, boolean,
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integer or real) other operations include Clear, Sum, Average, Smallest Value, Largest Value, Least alphabetical, Most alphabetical
and Concatenate. The last three operations can only be applied to string attribute types. Alphabetical sorting returns
either the first or last item from an alphabetized list of attributes. Concatenate joins string values together and
separates them with a separator.

There are two options to apply attribute operations to grouped components. Choose Apply to every grouped component
option to apply all. Alternatively, choose Only apply to grouped components that satisfy to enable the expression builder
to enter an expression that will only apply the attribute operations to values of the object where the expression
condition is met. All other values that aren't satisfied will be cleared. For example, the expression "Continent =
Africa" would only apply the operations to attributes of the object that has the attribute "Continent" and value of
"Africa". All attributes for this art object will maintain its attributes.

RESULTS

To tell if areas are joined after executing the Join Areas function, look for visual differences of the features on the
map or look in the Adobe lllustrator Layers panel. Depending on the join method, compound areas or grouped
areas, the Layers panel will display the results. In the example below, the original Lower 48 layer is shown and two
join method possibilities. The Group areas method shows states grouped by the attribute Sub Region (W S Cen,
Pacific, etc). The Create compound areas method shows states joined by compound path (and in this case, with the
option Dissolve borders between adjacent sub-areas enabled).

Original Join Method: Group Areas Join Method: Compound Areas

LAYERS LAYERS LAYERS
MRS s . ET - [ S [
®| @] <Compound Paths (o] ® | v [#]w s cen Q B [#] <campound path:» o
® <Path= ° ®| [ [E]wncen o B [{] <Compound paths 5]
& [#] «Compound path- o b ® b [F]sad o ® <Compound Paths 5]
® <Paths [o] LI I [F] Paciic [5] & [#] <compeund Path= 5]
®| ] <path> (o] ® | v [#]wEng Q B [#] <Cempound Path:» o
& <Path> Q ®| I [H] Men o ® [B] <Compound paths o)
& [@] <cempound Path: [+] ® [+ [ wid At ] & (@] <Path> 5]
Eln 1] <Peth= o ® | b [Flescen o N (W] <P=n= o

®| [¥] <path= (o] Fi?ﬁ”‘&" o B (] <Path= o M
& [E] <path- [s) [ 1] vt e - 0| Oever B .
& [dg] <path=- o 8 Layers ] 8 Layers T
B [1] <Path= o
ml Dath o 7

8 Layers T
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Join Points

Object > MAPublisher > Join Points or MAP Toolbar > Join >

Join Points Attributes - Determines how
Source Layer - Select the Point layer —eSource layer: | |1 Pltizd Map Locations gy Aubutes L= ?,:L:’?et::uﬂ abree ?;ir:iljd
containing the symbols to join. [ Only joi seiected point= Rltibuts Ceosin CE Cancel into a single object. For
Destination Layer - Enter the name ——e Destination: o Setto defoult i different| N/A string fields choose to
of the output layer. This new layer Layer New Layer [ PlaceName Set to default if different N/A either Clear the field, Clear
will contain the generated lines. [ Close paths [ web Set to default i different N/A if different (two or more
Enable Close paths to generate an Group By: 8 image Set to default § different| NUA unique values are found),
Area layer. If unchecked, a Line  —easrbute: 5 Address ~ . sort Least Alphabetical (Z-A)
layer will be generatedAJr soton 9 logo_image Set to default if different N/A or Most Alphabetical (A-2).
Avallable columns Sort arder [ Address | Joinon /A For Integer or Real fields
Group By - Specify the attribute #Ratation - [ [ Telephone  Set to default i different N/A options include Clear the
column c_ontaining simila;valyes ::z\:X T o v field, Clear if different (two
to determine each group of points #Map¥ b O ©nly apply attribute operations to grouped companents the or more unique values are
Sort By Available Columns - Select an ——e %l found), retum the Sum or
attribute column containing [ image v Empty expression. In position: 0 Average of the grouped
ascending values to sort by. Then - values or enter the Largest
click the Add button to add the Value or Smallest Value of
column to the Sort Order. the grouped fields.

Sort Order - Contains a hierarchical
list of the columns specified to sort
by. Move columns up and down
the Sort Order hierarchy using the
Up and Down buttons

FUNCTIONALITY

Join Points allows a group of point symbols to be joined to form a line, based upon attribute values used as sorting
criteria. For example, it is common to form a line based on points collected by a GPS device. When Join Points

is completed, a new map layer is created that contains the line art. The generated line layer contains the same
common attribute column that was used to group the points together.

PREREQUISITES

Join Points can only function on Poeint layers, and can be used on both currently selected point symbols or all the
point symbols on a specified layer. There must be at least two attribute columns on the specified point layer in order
to use Join Points. To open the dialog box, click the Join > Join Points button on the MAPublisher toolbar or from the
menu Object > MAPublisher > Join Points.

USING JOIN POINTS

From the Source Layer drop-down list, select the Point layer containing the points to be joined. A join can be based on
either all points on the source layer or Only join selected points.

Specify a name for the Destination Layer that this operation will generate. By default, the program will generate a
Line layer. To generate an Area layer (by linking the line end to the start) check the Close paths option.

In the Group By Column drop-down list, select the attribute column containing the common attributes used to join
the point together. For example, to join points based on a unique ID, select the column containing the common ID
names. This will result in point symbols containing the same name being joined together.
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A logical order by which the points are being joined must be specified because each point will be represented by
anode in a line string. To properly join points, a sort order must be chosen based on an attribute columns. These
should be attribute columns which contain rising alphabetical or numerical values. For example, GPS data may
contain an attribute that specifies the order in which the points were collected (first node, second node, etc).

In the Sort By Available Columns list, select the primary sorting column. This should be the attribute column that
contains the best fit for rising alphabetical or numerical values. For example if points have rising values from 1-10,
the point with a value equal to 1 will be at the start of the generated line, and the point with a value equal to 10 will
be at the end of the line. Select a column and then click the Add button to place the column into the Sort Order list. If
all the values contained in the first Sort By column are unique,it is not required to set a secondary column.

If the first Sort By column contained any similar values, a secondary column must be specified. Again, click a column
in the Sort By Available Columns list, and then click the Add button to place the column in the Sort Order list. Similarly
third, fourth and fifth Sort By columns can be specified in the same manner if previous columns contain similar
values. Note that the Sort By columns are a hierarchy with the topmost specified column being used for the primary
sort, then the second, then third, etc.

To move columns up or down the hierarchy after they have been specified, simply select the appropriate column in
the Sort Order list and click either the Up or Down button. To remove any Sort By columns from the hierarchy, select
the column in the Sort Order list and click the Remove button.

Attribute operations can be set to determine how each attribute column is handled. By default all attribute
operations are set Clear if different, meaning that the attribute is cleared if there are more than two unique values
present after the join. Depending on the attribute type (string, boolean, integer or real) other operations include
Clear, Sum, Average, Smallest Value, Largest Value, Least alphabetical, Most alphabetical and Concatenate. The latter three
operations can only be applied to string attribute types. Alphabetical sorting returns either the first or last item
from an alphabetized list. Concatenate joins string values together and separates them with a separator.

Note that a maximum of five columns can be used to sort points into a logical order. If the columns specified to sort
by do not distinguish an ordering between certain points, the order of these points in the attribute table will be
used to determine the order of the nodes in the generated line string.

RESULTS

When all the options have been set click OK to join the points on the specified layer. A MAP Area or Line layer will be
generated, depending on the specified output layer type, which will be placed in the same MAP View as the Input
Point layer which has been joined.
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Join Lines

Object > MAPublisher > Join Lines or MAP Toolbar > Join >

Join Lines

Attributes - Determines how

Target Layer - Layer on which——e Target Layer: | [ usroads line ~ ~  Attributes: attributes will be handled
the join will be performed once features are joined

[ only join selected lnes Attribute Operation Options Cancel into a single object. For
- " i / tring fields choose to
Destination - Defines line — o LENGTH Set to default i different N/A s
features to be oined. Join | PIETS either Clear the field, Clear
res ) J . (@) Join original lines on target layer [© TYPE Set to default if different N/A if different (two or more
originallines on target 9] 1 k unique values are found)
layer or copy results to a @) CrE = DEEIEE [Fi] ADMN_CLASS Join on N/A 4
4 i new layer. — - sort Least Alphabetical (Z-A)
’ = [G] TOLL_RD Set to default if different N/A or Most Alphabetical (A-Z).
Proximity - Assign a . For Integer or Real fields
proximity value to Join Options: [ RTE_NUM1 Set to default i different N/A options include Clear the
determine how close —e sy [1 oogoog : E RTENUMR Set o default f different N/A field, Clear if different (two
together (in map units) or more unique values are
the lines must be in order B he [ ROUTE Set to default if different N/A found), return the Sum or
to be joined. Optionally, e [] Close segment gaps Average of the grouped
choose appropriate units.J oty o s it shres v fom: [ MaplnfoPenPattern Set to default if different N/A values or enter the Largest

Value or Smallest Value of

Close segment gaps - If [ ADMN_CLASS - (®) Apply to every grouped compenent the grouped fields.
two line segments are (_) Only apply attribute operations to grouped components that satisify:
separated by a distance 7]
less than the Proximity :
value, checking this Empty expression. In position: 0
option will create a line
segment that connects |_
the two lines. Otherwise a Only join lines with shared values from: Apply to every grouped Only apply attribute operations to grouped
compound path is created. Check to join lines that have component - Choose to apply components that satisfy: - Use an expression
shared attribute values (choose Join Lines options to every to define which joined lines the above
attribute from drop-down list) grouped component attribute field options will apply to

FUNCTIONALITY

Join Lines allows a group of line features to be joined based on a common attribute. For example, it may be desirable
to join all segments of a particular street by the common attribute of street name in order to create a single line
element representing that street. When Join Lines is completed, a new map layer is created that contains the joined
lines. These lines contain an attribute column based on the column used to join them.

Join Lines can be very useful for reducing the size of a data file by joining related lines and thus reducing the
number of segments and associated data present in the file. It is also very useful to run Join Lines prior to labeling
with Label Features in order to reduce the occurrence of duplicate labels (see chapter 10 Labeling).

PREREQUISITES

Join Lines can only be used on MAP Line layers.

USING JOIN LINES

To use Join Lines, click the Join > Join Lines button on the MAPublisher toolbar or choose Object > MAPublisher >
Join Lines. In the Target Layer drop-down list, select the Line layer where the join will be performed. In the Destination
options, choose either to perform the join on the original target layer or specify a name for the new line layer that
MAPublisher will create to hold the joined lines.

Under Join Options, a Proximity value should be entered and proximity Units assigned. Units can be specified in map
units or page units. A proximity value of zero will only join line segments that are touching. If the distance between
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the end of a segment and the start of another is greater than the set proximity value, these lines will not be joined.
If two line segments in the selection are separated by a distance less than the set proximity value, check the Close
segment gaps option to create a line segment that connects the two lines. When not selected, a compound path will
be created. By default, the Only join lines with shared values from option is checked. Specify an attribute which the join
will be based on. It is noted in the Operation column as Join on. For example, when joining streets, join based on a
common identifier or street name. To further narrow down which lines should be joined, check the Only Join selected
lines option. These lines should be selected prior to opening the Join Lines dialog box.

When lines are joined, many attributes that were valid to the original lines may no longer be valid. For example,
after joining street line data, an attribute that contains address ranges will no longer be valid because values will
not be unique anymore. Thus, operations can be set to determine how each attribute field is handled. By default all
attribute operations are set Clear if different, meaning that the attribute is cleared if there are more than two unique
values present after the join. Depending on the attribute type (string, boolean, integer or real) other operations
include Clear, Sum, Average, Smallest Value, Largest Value, Least alphabetical, Most alphabetical and Concatenate. The last three
operations can only be applied to string attribute types. Alphabetical sorting returns either the first or last item from
an alphabetized list of attributes. Concatenate joins string values together and separates them with a separator.

The Concatenate operation has options to adjust the separator. When Concatenate is chosen in the Operation
column for an attribute, the text Using defaults; double-click to edit appears in the Options column. Double-click the
text to open the Concatenate Operation Options dialog box. Choose a separator from the Use drop-down list or
specify a custom one.

Concatenate Operation Options

s

(®) Use: Comma then space Ad
: Cancel
() Custom:

Set string attribute size: | 200 S

If the attribute size is already larger than
this, it will remain unchanged.

String attribute sizes may become lengthy due to a join. Adjust the set string attribute size setting to increase or
decrease the maximum number of characters of which the attribute field can store.

There are two options to apply attribute operations to grouped components. Choose Apply to every grouped component
option to apply all. Alternatively, choose Only apply attribute operation to grouped components that satisfy to enable the
expression builder to enter an expression that will only apply the attribute operations to values of the object where
the expression condition is met. All other values that aren't satisfied will be cleared. For example, the expression
"Street = Main St" would only apply the operations to attributes of the object that has the attribute "Street" and
value of "Main St". All attributes for this art object will maintain its attributes.
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Simplify Art

Object > MAPublisher > Simplify Art or MAP Toolbar

Simplify Art
Proximity - Set the simplification ———e proximity: |0.500000 2| | Meter - oK
tolerance (type or use arrows)
based on specified units Vertex Count: Cancel
Criginal: 123406 . 5
Vertex Count - Shows the original —=—= _ " . oo Units - Select page units or map
number of vertices of the QbR (17%) units (ar?gul.arorllnear unit I_|st
selected lines. Click the Preview * Uises Diouglas-Peucker line simplification depend_lng |ffche map coordm_ate
button to display the number of e system is projected or geodetic)
vertices after simplification. used for the proximity tolerance

FUNCTIONALITY

Simplify Art allows for the simplification or generalization of vector line and area data. It uses the popular
Douglas-Peucker algorithm for removing nodes and vertices during simplification. For more information about this
algorithm, see Appendix A1.

Simplify Art is used to reduce the number of points required to represent a vector-encoded line where lines are
approximated by a stream of X-Y coordinates. The operation can be used on Line or Area MAP layers and removes
nodes based upon a proximity value in either Page Units or Map Units. The list of map units depends on the MAP
View coordinate system—e.g. angular units (page units, degrees, etc) for geodetic coordinate systems; linear units
(such as metre, feet) for projected coordinate systems.

The Proximity value or simplification tolerance is based on the vertical difference between the begin/end line

and points off a line, not the distance between anchor points on the line. The Douglas-Peucker algorithm takes
the proximity value and iterates through the line vertices to determine the points that fall within the specified
proximity distance off the line and removes those vertices. Once all vertices are determined to be greater than the
proximity value, the line processing ends. A smaller proximity value will usually result in a fewer number of nodes
being removed.

USING SIMPLIFY ART

To use Simplify Art, select the lines on a Line layer or areas on an Area layer, then click the Simplify Art button on the
MAPublisher toolbar or from the menu Object > MAPublisher > Simplify Art. Enter a proximity value in Page Units or
Map Units by making a selection from the Units drop-down list. Page Units are the units of the current document.
Enter a proximity value in the unit specified by typing a value or by using the arrows.

Click the Preview button to see the simplification result before committing to it. The Vertex Count shows how many
vertices are in the simplified result (and calculates a percentage of overall simplification). Adjust the proximity as
necessary in order to achieve the desired results particular to the scale and coverage area. Click OK to complete the
simplify operation.
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RESULTS

All selected lines or areas are simplified according to the settings. Simplified lines or areas will not be simplified
again unless the tolerance value is increased. For example, if a line has been simplified with a proximity of 1.5 km,
then it will not be simplified again until the tolerance is set to a value larger than 1.5 km.

In practice, it means that simplified lines can be selected again with non-simplified lines to run the operation again,
when the Simplify Art operation is run only the new lines will be simplified (unless the proximity value is increased).

Itis a good idea to perform Simplify Art on artwork before exporting to a web map (see chapter 15). This will
reduce the file size and improve performance and loading times.

Simplify Art will simplify stretches of a path that are non-bezier even if bezier components exist on the path.
However, it will never remove bezier points.

Bezier curves cannot be simplified using Simplify Art. To smooth the appearance of paths containing bezier
curves (achieve a non-bezier approximation), use the Adobe lllustrator Simplify tool (menu Object > Path >
Simplify) and set the angle to 0 degrees and enable the Straight Lines option. If the result is not acceptable,
you may need to add anchor points to give it enough fidelity to make a non-bezier line without damaging
the path's detail. After that, you can run Simplify Lines and remove any unnecessary anchor points.
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Flip Lines

Object > MAPublisher > Flip Lines or MAP Toolbar
FUNCTIONALITY

MAPublisher Flip Lines reverses the endpoints of a line or an area (open or closed path).

Adobe lllustrator Brushes and Type on a Path tools are designed to position patterns and text depending on the
direction of the endpoints. Two consequences of this are:
«  Labels are placed upside down and backward when using the MAPublisher labeling tools (MAP Tagger
tool and Label Features, see chapter 10 - Labeling).
«  When applying graphic styles with a brush pattern to paths (manually or using MAPublisher MAP
Themes), patterns are not applied at the right side of the line or in the expected orientation.

In order for the labels or patterns to be consistent for a group of lines, flipping lines may be necessary.

PREREQUISITES

Lines can be flipped on Line and Area layers.

USING FLIP LINES

To flip lines, select lines on the artboard and click the Flip Lines button on the MAPublisher toolbar or from the menu
Object > MAPublisher > Flip Lines.

Notes: Flip Lines is a discrete operation. It may not be apparent that the lines are flipped.

When exporting Area layers to GIS formats, polygon outlines must have a positive #Area value in the MAP
Attributes panel. If some values in the #Area column are negative (and #AreaDirection is equal to Counter
Clockwise), Flip Lines can then be used to reverse the #AreaDirection and convert the #Area to a positive value.

For compound paths, the #AreaDirection property is always equal to Indeterminate, even though compound
paths can be flipped.

The MAPublisher MAP Tagger tool and Label Features have an option to enable Flip upside-down labels to create
text in a consistent orientation, without requiring the use of the Flip Lines operation (see chapter 10).
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Buffer Art

Object > MAPublisher > Buffer Art or MAP Toolbar

. Buffer Art
Source Layer - Specify the layer to
base the buffer art on. To buffer onIy—L Source:
selected art on the specified layer, L ayer: T =l :
. . Cancel
check the option below it. [ Orly bufer selected art
Static value - Enter a specific Buffer Width:
value and choose appropriate Units: Meter S Units - Select a unit to use for the
units to buffer the art by L+ ® static value: 150,000000 m : buffer values. The default is the
[[] Add buffer atintervals of:  0,000000 m . current map unit.
Attribute value - Buffer by values ——e () Attribute value: #Opadity
contained in an attribute table Jﬂ.D Merge buffered resuits by buffer width value
Merge buffered results by buffer width Destination:
value - Dissolves separate segments () Existing layer & Downtown Boundzry — Destination - Choose an existing
to create one buffer area © New ayer: Buffered art Area layer that will hold the
e = buffered art or create a new Area
Options: layer (specify a new name)
Apply Style - En.ablc_e to cho_ose ——[7] Apply style: stroke: | [7] None] ~|[A® 100% 2 = toopt =
stylization options
Al Wc=7sm=0v=10k=0 ~ [ ® s0% *

FUNCTIONALITY

MAPublisher Buffer Art creates area objects of specified distance around point, line, and area features. This may be
useful when attempting to calculate distances on each side of a road, creating proximity around fire hydrant points,
or buffering parcel lots.

USING BUFFER ART

If required, select the art to buffer and click the Buffer Art button on the MAPublisher toolbar or from the menu
Object > MAPublisher > Buffer Art. Buffers are added to all art on the specified layer, unless the option to Only buffer
select art is checked.

The buffer width can be entered as a fixed value or by selecting an attribute column that contains numeric values.
With the Staticvalue option checked, a buffer is created with the specified value. With the Attribute value option
checked, a buffer is calculated and created based on the value related to the selected object in the attribute table.
Set the buffer value units in the Units drop-down list. For example, a value of 5 map units will create a buffer of 5
map units around a feature.

Optionally, enable Add buffer intervals of and specify an interval distance to create equally spaced rings around
features. This is also known as creating concentric rings. Enable the Merge buffered results by buffer width value option to
remove any compound path segments and create one resulting buffer area. This is also known as dissolving buffers.

Choose an existing Area layer as the destination for the new buffer. Alternatively, specify a new layer name to create
a new layer where the buffer areas will be stored.

Buffer Options
Enable the Apply Style option and choose a preset Graphic Style or Custom stroke, fill and transparency.
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Vector Crop

Object > MAPublisher > Vector Crop or MAP Toolbar

Location type: Bounding box

MAP Vector Crop Target - Target to crop
everything, MAP Views,
Input: Target: layers and sublayers
X L () Page coordinates (Global Rulers) (®) All layers in document
Input - Specify which input ——— ~ - Cancel
coordinate system to use for ®) World coordinates: | @ Vancouver ~| O Allayersin: @ Hotels
plotting Corner and Opposite Coordinate system: NADS3 /UTM zone 10N () only: ] Feature Labels Advanced... & Advanced - Advanced cropping
Corner coordinates [Juse: weses options dialog box

Indude sublayers
Input format:  Projected units

Options - Specify shape as

Rectangle or Ellipse. This Options: . . ops
dialog box shows location Shape: s o Location type: Position
type as Bounding box. To the — 7 § . Options:
far right shows options for Location type:| | o ins Ao T Shape: Rectangle -
Position location type.
ol Corner: Location type: Position -
& X: | 490,154,901555 m
Comer - Specify Xand Y —e ? Point - Specify —eraint: | [l Center =
coordinates to use as a corner o ¥ |5,459,154.601168 m |2 anchor point ’
of the bounding box «F X: |373,710.347268 m
Opposite Corner: and Xand Y ?
o % |481,823.815044 m coordinate of it ' Y |597,651.003312 m | &
Opposite Corner - Specify X —— T Dimensions —e Dimensions:

and Y coordinates to use as « ¥: |5,458,529.709683 m [ %
the opposite corner of the
bounding box

Specify units, Units: | Meter h
width and height

of the crop area Width: | 800.000000000000000 m -

Height: |800.000000000000000 m S

[] Constrain dimensions

Vector Crop Advanced Options

Advanced
Point Text - Choose how ——r-« point Text: Points: [k ] . .
point text is handled ) Vectorize and op [] Vectorize and crop Points - Choose how points are
when intersected by a ® Crop text based an: Cancel handled when intersected by
crop boundary ST ’ Cropping Boundary: . a crop boundary
(®) Crigin of first character Accuracy for bezier cropping boundaries: ese
(0 Text bounds e | Cropping Boundary - Adjust
Path Text - Choose how ———- More accurate Less accurate accuracy for vectorizing a
: ! Path Text: N -
point text is handled bezier path when intersected

() Vectorize and crop

when intersected by a by a crop boundary

crop boundary rap path only

rop text based on:

Origin of first character
() Text bounds

[] crop path

Mote: Attributes and feature type support will be lost when vectorizing points or text.

FUNCTIONALITY

The MAPublisher Vector Crop trims vector data to a rectangular or ellipse area by using page or world coordinates,
and by location type (using either a bounding box or by a single coordinate position). Use it to create a precise crop
of a larger dataset based on coordinate locations (by bounding box or position). It is very useful for creating map
insets (smaller maps centered on specific areas).



PREREQUISITES

Before using Vector Crop, ensure that layers being cropped are visible and unlocked in the Adobe lllustrator Layers
panel. Invisible and locked layers are not cropped. The extent of the map that will remain after cropping must be
visible on the screen, so make sure to zoom out sufficiently prior to starting the vector crop tool.

Note: Text typed on a path may not return to their prior state after an undo.

USING VECTOR CROP

On the MAPublisher Toolbar, click the Crop > Vector Crop button or from the menu Object > MAPublisher > Vector Crop.

Input Coordinates

The Input sets the coordinate system in which the starting point coordinates are entered. Input coordinates can
either be Page Coordinates or World Coordinates.

When the Page coordinates (Global Rulers) option is chosen, page coordinate values (in pixels) can be entered for the
Corner and Opposite Corner coordinates.

When the World coordinates option is chosen, the MAP View drop-down list becomes enabled. Choose the appropriate
MAP View to use. Its coordinate system is displayed directly below the MAP View drop-down list. The options in the
dialog box will change to reflect a geodetic or projected coordinate system and corner values can be entered either
as (a variation of) decimal degrees or in projected units. To use an alternative coordinate system, click the Use check
box, and click the coordinate system link. Choose an appropriate coordinate system in the Select Coordinate System
dialog box.

Shape and Location Type Options

There are two shape options to choose from when plotting areas: rectangle and ellipse. More importantly, two
location types determine how the shapes are plotted: Bounding box and Position.

When Bounding box is chosen, enter (map page or map world) coordinates into the Corner and Opposite Corner
coordinates to define the area. A preview of the area can be seen on the artboard (you may have to move the Area
Plotter dialog box to see it). Note: Any corner and its opposing corner can be used for the bounding box.

Corner Corner

Opposite Corner Opposite Corner
Rectangle, Bounding Box Ellipse, Bounding Box
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When Position is chosen, choose a coordinate point position relative to the shape. These point position options
include Center, Upper left, Upper right, Lower left, and Lower right. In the Size section, enter a width and height and
the appropriate units to plot. A preview of the area can be seen on the artboard (you may have to move the Area
Plotter dialog box to see it).

Point position Point position
® Ll

Rectangle, Position (Center) Ellipse, Position (Center)

Advanced Options

For point text, Vectorize and crop will create

an outline of the text and then crop it.

This option does not preserve text editing .Renaissance Vancouver Hotel Harbourside
ability. It should be used in situations where

having text is still important and requiresa  p.qrell Suites Hotel
clean cut (e.g. inset or key map). * Fairmont Hotel

.The Barclay House Bed and Breakfast

To preserve text while cropping, use the
Crop text based on option. The Origin of first Original layout before crop
character sub-option determines whether

the first character of text is within the crop area or
not. If it isn't, the text is cropped. The Text bounds
sub-option determines whether the text bounding
box is within the crop area or not. If it isn't, the text The Barclay House Bed and Breakfast
is cropped.

Renaissance Vancouver Hotel Harbourside
.

.Fairmont Hotel
Crop based on origin of first character

Renaissance Vancouver Hotel Harbourside
L]

'Rer
.The Barclay House Bed ¢ .The Barclay House Bed and Breakfast
Suites Hotel Pendrell Suites Hote.l
: Fairn Fairmont Hotel
Vectorize and crop Crop based on text bounds
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For path text, the similar options will yield the same results as explained above. One difference is the Crop path only
option, which is used to crop the path text to the crop shape. To preserve text while cropping, use the Crop text
based on option. Similarly, enable the Crop path check box to ensure the path is cropped.

For points, Vectorize and crop will create an outline |
of the points and then crop it. This results in small

areas that are now partially cropped. . .

For paths, to crop to a shape of unspecified size,
click and drag in the artboard until the desired
crop area is achieved. Use keyboard modifiers to

help draw shapes more efficiently. Point symbol Vectorized and cropped point symbol

RESULTS

On all visible and unlocked layers:

«  Text objects that have their anchor outside of the cropping boundary are deleted. Text objects with its
anchor inside the cropping rectangle are retained completely.

- Points falling outside of the cropping boundary are deleted (the position of the center of the symbol is
relevant). Symbols that have their center inside the cropping rectangle are maintained as a whole.

- Lines are clipped at the boundary of the cropping rectangle.

«  Areas (polygons) that are completely out of the cropping boundary are deleted. Areas intersecting with
the cropping boundary are clipped and closed following the edge of the boundary.

The overall result is a map coverage reduced to the cropping boundary. See examples on the next page.

Notes: The purpose of Vector Crop is to cut vector data (points, lines and polygons). However, some Adobe
lllustrator specific objects may not be cropped properly using this tool:

- Blend and Live Paint objects

«  Any art using effects that have been rasterized

«  Custom art such as scale bars, grids/graticules, north arrows (expand custom art to crop)

«  Compound shapes

«  Legacy and overflowing text

«  Locked objects (command box: either treat locked layers as unlocked or skip locked layers)
«  Hidden layers (will be skipped)

. Images

"Skipping art because topology is invalid" messages display in the MAPublisher Log when a line intersects
itself along the border of your crop boundary. "Hidden layer" messages display in MAPublisher Log.

Due to an Adobe lllustrator limitation, text on a path may flip after a crop. This can be corrected by checking
the Flip option in the Type on the Path Options dialog box (choose Type > Type on a Path > Type on a Path Options).

When cropping on import, text will be cropped based on whether its bounding box touches the crop extents.
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Crop Examples

Oy Crop result: lines and areas are
"(? U strasbion iy cropped, text with first letter
o f within the cropping rectangle
o - i pping rectangle
\ 3 and symbol with center pointin
s ! & o rectangle are maintained. The
— ««/ ¢ Q—1 MAP Objects can be scaled for a
\ o Magete L e better fit in the document.

Original map

Create Inset

Create a map inset using Vector Crop:
«  Open any map, and make a copy of it (choose File > Save a Copy).
Leave the original map open, make the copy the active document.
«  Use MAP Vector Crop to crop the area of special interest.

«  Make the original map active. In the MAP Views panel, select the option menu Import MAP View from
document. Select the MAP View from the copy .

OLiIIa

TR graaiien
OBrest 4 \

; f
@N ites i
ﬁi&w

o

o 9

Orlglnal Copy and Crop

The map now contains two MAP Views (at least). Their relative position can be managed from the MAP View editor,
as well as the scale of the inset map.

@Lille

Strasbour
@ Brest.- w
4 N tes
: . . 1 onr
. R = Bordeaux f Paris
01 show Anchors Previens: [Thumbrals & 80ces [v] f
_/‘\ ar; |Ile
\ !”— 2
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MAP Vector Crop Tool

Tools > MAP Vector Rectangle Crop Tool and Tools > MAP Vector Ellipse Crop Tool

FUNCTIONALITY

Use the MAP Vector Crop Tool, to quickly crop MAP Layers using rectangles and ellipses. This tool can be used using two
methods: crop using click and drag or crop using specific dimensions.

PREREQUISITES

Before using the MAP Vector Crop Tool, ensure that layers being cropped are visible and unlocked in the Adobe
lllustrator Layers panel. Invisible and locked layers are not cropped. The extent of the map that will remain after
cropping must be visible on the screen, so make sure to zoom out sufficiently prior to starting the vector crop tool.

Open MAPublisher Preferences to adjust crop settings for MAP Crop Tool. These are the same Advanced settings for
Vector Crop and Crop to Shape.

USING THE MAP VECTOR CROP TOOL

The MAP Vector Crop Tool consists of two tools: Rectangle and Ellipse. There are two ways to use these tools: 1. click
and drag to draw the crop shape; 2. click anywhere on the artboard to open the MAP Vector Crop dialog box and
specify crop options.

Crop using Click and Drag

To crop to a shape of unspecified size, click and drag in the artboard until the desired crop area is achieved. Use
keyboard modifiers to help draw shapes more efficiently: hold the Alt key (Windows) or the Option key (Mac) to draw
from the center; hold the Shift key to constrain the proportions; or hold the space bar to move the area. Enable
Adobe lllustrator Smart Guides to snap to features for better control when drawing. Release the left mouse button
to finish cropping the area.

Crop using Specific Dimensions

To crop to a shape of specified size, single-click at a point in the MAP document at the desired location to specify a
starting crop location using options in the MAP Vector Crop dialog box (see previous section). By default, the crop area
is centered over the click point and its coordinates populate the X and Y boxes. Enter width and height values to
specify a crop size. A preview of the crop area can be seen on the artboard (you may have to move the Area Plotter
dialog box to see it).
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Crop To Shape

Object > MAPublisher > Crop to Shape or MAP Toolbar

Crop To Shape

Target - Specify which layers —— Target:
to crop: all unlocked layers in (®) Al layers in document
document, all unlocked layers
in a specific MAP View, or a
specific layer (and sublayers). O only: H Grid_legend Advanced...

i - Cancel
O Alllayersin: @ Chicacoland

Indude sublayers

Crop To Shape Advanced Options

Advanced
Point Text - Choose how ———e Point Text: Points: ’—|DK
point text is handled Vectorize and crop [] vectorize and crop Points - Choose how points are
when intersected by a P PEETCE . Cancel handled when intersected by
crop boundary T Cronging Boumdary: - a crop boundary
(®) Origin of first character  Accuracy for bezier cropping boundaries:
() Text bounds = Cropping Boundary - Adjust
More accurate Less accurate accuracy for vectorizing a
Path‘Text- Choose how _.l_?“' Text: bezier path when intersected
point text is handled () vectorize and crop by a crop boundary

when intersected by a

() Crop path only
crop boundary

®) Crop text based on:
(®) Origin of first character
() Text bounds

[ crop path

Note: Attributes and feature type support will be lost when vectorizing points or text.

FUNCTIONALITY

Use Crop To Shape to quickly crop MAP Layers using shapes other than rectangles and ellipses.

PREREQUISITES

Before using Crop To Shape, ensure that layers being cropped are visible and unlocked in the Adobe lIllustrator Layers
panel. Invisible and locked layers are not cropped. The extent of the map that will remain after cropping must be
visible on the screen, so make sure to zoom out sufficiently. Crop To Shape only works with closed paths (areas).

USING CROP TO SHAPE

To crop to a shape, select a closed path object and click the Crop > Crop To Shape button on the MAPublisher Toolbar,
or from the menu Object > MAPublisher > Crop To Shape.

In the Crop To Shape dialog box, choose the layers to target for crop: All unlocked layers, All unlocked layers in a
specific MAP View, or only a specific layer (and sublayers).
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The All unlocked layers option will crop everything from an unlocked layer.

For the All unlocked layers in [a specific MAP View] option, choose a MAP View from the drop-down list. Only
unlocked layers in the chosen MAP View will be cropped.

For the Only [layer] option, choose a specific layer from the drop-down list. Only objects on that layer will be
cropped. Optionally, click the Include sublayers check box to include sublayers belonging to the chosen layer.

Path Utilities can resolve invalid topology by using the find self intersection points action or remove duplicate points

action for the area you are cropping. See Path Utilities, in the next section.

Advanced Options

The Advanced options here function the same as explained in the Vector Crop section.

Vectorize and crop

T ——

Bayshore The Westing Hotel
.

Loast Plaza Hotel & Suites

louse Bed and Breakfast

Fairmont Hotel
.

Sunset Inn & iton Vancouver Wall Center

.Opus Hotel

Renaissance Vancouver Hotel Harbourside
.

.
Sandman Hotel Vancouver City Centre|

.The Barclay House Bed and Breakfast
.Pendrell Suites Hotel

Sheraton Vancouver Wall Center
B

Crop text based on origin
of first character

.The Barclay House Bed and Breakfast
.Pendrell Suites Hotel

Sunset Inn & Suites Sheraton Vancouver Wall Center
. B

Crop text based on
text bounds
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Path Utilities

Object > MAPublisher > Path Utilities or MAP Toolbar

Path Utilities
Target Layers: oK
MAP View - Choose the ———e mar view: | @ City Transit - —
1. H ancel
appropriate MAP View Lavers: (] [ InformalTrails_line ~ preview - Ch N it
Freview  e———— Preview - Choose how points

totarget [ & Railway_line

trects_CreateRoutes_line edited 2011
treets_CresteRoutes_line edited 2011 offset
treets_line

ransCanadaTrail_line

are handled when intersected
by a crop boundary

Layers - Click the check ———

boxes to enable which
layers are affected by the ] B CityBoundary_area

Path Utilities action O ConservationAreas_area

[] [E Greenways_area
[] B GuelphLakeUTM _area
[] [E Guelph_CanvecHydro_area
["1 [E NaturalAreas area

Chedk All Unchedk All

[] only apply to selectsd paths

Action - Choose an action ———e Action:  Add detail
to perform on the

selected layers or paths Maximum distance between vertices: | 0,0000000000 S| | Meter -

The distance between vertices is too small, it must be at least a pixel.
The current distance is 0 px.

FUNCTIONALITY

Use Path Utilities to perform actions on paths that are on Line or Area layers. Actions include: adding detail, copying
vertices to a point layer, finding self intersection points, removing duplicate points, and converting beziers to
polylines. Actions made to paths can be previewed.

PREREQUISITES

To apply actions to only selected paths, select paths before opening the Path Utilities dialog box. In the Path
Utilities dialog box, enable the Only apply to selected paths option. Path Utilities only works on Line and Area layers.
Some actions require that a path be selected before it can function.
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USING PATH UTILITIES

In the Target Layers section, choose the appropriate MAP View to list its MAP layers. Click the check boxes to enable
which layers are affected by the Path Utilities action. In the Action drop-down list, choose an appropriate path action:

Add detail

Copy vertices to point layer

Find self intersection points

Remove duplicate points

Convert beziers to polylines

Convert compounds to groups

Create elevation plot

Add vertices to paths to create more detail. Specify a maximum
distance value and measurement unit between added vertices.

Copy a path's vertices to an existing Point layer or a new one.

Find vertices along a path that intersect itself. The vertices can be
output to an existing Point layer or a new one.

Remove vertices that are considered duplicate.

Transform beziers to polylines. Some GIS applications may not
support beziers, but can properly read polylines.

Transform compound paths to groups. Attributes are retained
and copied to each path.

Create an elevation plot (graph) for a path. A path must be
selected before using this action. Elevation data is obtained for
each point in the selected path. To produce a more detailed plot,
use the Add detail utility to add points to the path. Elevation values
are courtesy of MapQuest and can be shown in metric or imperial
units.
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MAPublisher MAP Themes provide tools for a variety of
thematic mapping operations. Stylesheet themes are used
for quick, easy and accurate styling of points, lines, areas
and text. Chart themes produces feature specific bar and pie
charts while Dot Density themes aid in the generation of the
thematic dot density maps.

No map is complete without a legend. Easily create MAP
Theme legends with a wide array of options to adjust and
tweak its appearance.

The topics covered in this section are as follows:
MAP Themes

Stylesheet Themes

Dot Density Themes

Chart Themes

MAP Theme Legends
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MAP Themes

Window > MAPublisher > MAP Themes or MAP Toolbar
OVERVIEW

MAP Themes are a collection of thematic cartography tools designed to increase productivity by automating how
styles and symbols are applied, chart production and data plotting. The former MAP Stylesheets (in MAPublisher 8.3
and older) have been integrated into MAP Themes and is now called Stylesheet theme. Two new types are the Chart
theme and Dot Density theme.

The new Stylesheet theme offers enhancements over the previous version of MAP Stylesheets. Adobe Illustrator
graphic styles can be assigned to stylesheet rules and stroke fill and opacity can now be assigned on a per rule basis
within the Stylesheet dialog box. The Stylesheet dialog box now offers a Batch Generate Rules feature where attributes
can be automatically classified using a variety of common classification methods.

The Chart theme offers an interface for quickly generating individual bar and pie charts for a chosen attribute of
selected features. The Dot Density theme provides a thematic mapping tool that assigns a unit value to Illustrator
symbols and randomly distributes symbols throughout associated areas based on attribute values.

MAP Themes offer a lot of flexibility. They can be edited, applied, duplicated, exported and cleared without affecting
the spatial referencing of map features.

ﬁ New MAP Theme - Opens the
MAP Themes Mew MAP Theme...

New MAP Theme dialog box to specify
Country stylesheet Duplicate "Placemnark stylesheet” theme type and options
yP P
N i Edit "Placemark stylesheet”...
MAP Theme List - List of MAP ———4ills GDP per country chart o——— Duplicate Selection - Create a duplicate of the
Themes in the current document. 8| ;‘aﬁ‘"‘:'k ZMESC:“ e selected MAP Theme
Displayed in order of Stylesheets "'. opuiation censt Delete Pl  stylesheet”
; (5] Rosds stylesheet =i UL Edit Selection - Opens the MAP Theme Editor
first, organized and color P
sorted by A,ga Line and Point & MAP Themes R ] Clear Results of "Placemark stylesheet” dialog box to edit the selected MAP Theme
Stylesheets Ch;rt Themes and Create Legend...
Dyot Density Themes. View Log... i\pptll: Secliedion - Atpply selected MAP Theme
o the document
Export MAP Themes...
Create Legend - Create a legend ————— Copy MAP Objects From i
based on the selected theme T Delete Selection - Delete selected MAP Theme
Apply MAP Theme - Apply selected ——| Clear Results of Selection - Removes the
MAP Theme to the document application of the MAP theme from the
document, not the theme itself
New MAP Theme - Opens the —M8
New MAP Theme dialog box to Create Legend - Create a legend from the
specify theme type and options selected MAP Theme
Delete MAP Theme - Delete ——————— View Log - A log viewer that provides
selected MAP Theme information on processes performed on

individual MAP Themes

Export MAP Themes - Export MAP Themes to an
Adobe lllustrator document

Copy MAP Objects From - Copy MAP Themes
from another open document

Preferences - Opens MAPublisher Preferences
on the MAP Themes Panel property sheet
(see chapter 1)
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Load Symbols and Styles

The symbology used by MAP Themes are directly related to the symbols and styles which exist in several Adobe
lllustrator panels. In order to correctly function, MAP Themes require that symbology or styles are established in the
corresponding Adobe lllustrator panels:

For Stylesheet themes:

Area stylesheets:  Graphic Styles panel (Window > Graphic Styles)
Line stylesheets:  GraphicStyles panel (Window > Graphic Styles)

Point stylesheets:  Symbols panel (Window > Symbols)

@ w B [

Text stylesheets:  Character Styles panel (Window > Type > Character Styles)

Fill/Stroke: Swatches panel (Window > Swatches)

For Chart and Dot Density themes:

Appearance: Graphic Styles panel (Window > Graphic Styles)

Labeling: Character Styles panel (Window > Type > Character Styles)
Fill/Stroke: Swatches panel (Window > Swatches)

Symbols: Symbols panel (Window > Symbols)

Custom symbology can be added to the Adobe lllustrator Graphic Styles, Symbols and Swatches panels. Another
great source of styles comes from the custom graphic style, symbol and swatch libraries installed by MAPublisher.

To open MAPublisher supplied graphic style, symbol and swatch libraries, navigate to the following panels:

Graphic Styles panel options menu > Open Graphic Style Library > MAP Graphics
Swatches panel options menu > Open Swatch Library > MAP Swatches

Symbols panel options menu > Open Symbols Library > MAP Symbols

These styles and symbols are stored in Adobe Illustrator documents in the Helpful Styles & Symbols folder. To create
a style library, simply create your own Adobe lllustrator documents containing your symbols, graphic styles and
character styles and save them to the appropriate Helpful Styles & Symbols subfolder. See Appendix 4 for more
information.

Along with the ability to style map art using Adobe Illustrator Graphic Styles and Symbols, MAP Themes allow users
to manually specify stroke, fill and scale properties on a per rule basis.
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FUNCTIONALITY

Apply MAP Themes

There are several ways to apply a MAP Theme. Click the Apply button in any of the Edit Theme dialog boxes to
immediately apply theme options to the map document. Another way is to click the Apply MAP Theme button in
the MAP Themes panel. This method is useful for applying themes at a later time. Save the theme settings made in
any of the Edit Theme dialog boxes and in the MAP Themes panel, select a MAP Theme and click the Apply MAP Theme
button. Alternatively, choose Apply "[theme name]" in the MAP Theme panel options menu.

Clear MAP Themes

Click the Additional MAP Themes options button and in the context menu, click Clear [Theme]. This does not delete
the MAP Theme, it only removes the style from the data.

Duplicate Themes

A document can contain as many MAP Themes as desired. Choose Duplicate "[theme name]" to create a copy of an
existing MAP Theme. The rules and styles are preserved during a copy. This is useful when creating different styles
for a map; each theme can have the same rules, but different visual properties. To apply the different themes, clear a
previous theme and apply another one.

Export MAP Themes

To export MAP Themes, choose Export MAP Themes from the panel options menu. In the Export MAP Themes dialog
box, click a check box beside each theme to select it for export. Click OK and a Save dialog box will prompt for a file
name. MAP Themes are exported to an Adobe Illustrator document and are considered MAP Objects. They can be
imported using the Import MAP Objects function. See chapter 4 for more information about Import MAP Objects.

Export MAP Themes

Select MAP Themes to export:

Object

r Charts
illy Chart Themel
&P Chart Theme2
&) Chart Theme 2

MAP Theme Log

MAP Theme processes can be viewed in the log file associated with each type of theme. View the log through the
Additional MAP Theme Option context menu. Logged theme processes include the start and finish time of theme
processes along with the number of pieces of art found and the number of pieces stylized.

MAPublisher Log —— Add/Remove Item from Selection
MAP Theme Log Operations Add or remove warning or
Lists completed processes for ; d critical messages

the selected theme. Use the When Layer Message Clear

Show buttons below to filter > (1 minutes ago! Application of MAP Theme 'Cycling $011° Clear Selection - Clear selected

information, warning, and 19 hours ago @ Modify MAP View ‘City Transit Deselect Al feature on the map
critical messages. 19 hours ago % Loading decument
Export ¢ Export - Save log to a text file
Show- Show general | Zoom To - Zoom to the selected

feature on the map

information, warnings and
critical messages.
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Stylesheet Themes

OVERVIEW

Stylesheet themes are able to read and work with the data found in the MAP Attributes panel and used to quickly
style MAP Layers using Adobe lllustrator symbols, graphic styles and character styles.

Theme rules can be created in two ways: manually (one by one) or generated using a data classification method.
In addition, themes can be applied to data on a one-to-one basis, where specific attribute values are assigned with
a specific style or symbol (e.g. each country its own distinct colour) or with attribute value ranges (e.g. a country's
population growth that falls within a range of 2.9 to 4.6% and a colour used to represent it).

FUNCTIONALITY

Create New Stylesheet

To create a new stylesheet, click the Create New Map Theme button in the MAP Themes panel. Alternatively, choose
New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box, where the
theme name, theme type, and feature type for a new stylesheet is specified. With Stylesheet selected as the theme
type, the Feature Type drop-down list contains a list of available feature types: Area, Line, Point and Text.

New Stylesheet MAP Theme
New MAP Theme
Name - Specify a name for the T® Theme name: |Stylesheet Theme oK.
new Stylesheet — [ ]
Theme type: | £ Stylesheet I - Cancel
Theme Type - Select Stylesheet from
Theme Options: theme type drop-down list
Feature Type - Specify a feature —* Feature type: Area -
type for the stylesheet: Tipe Double-cic i the Thems pan io it he theme.
Area, Line, Point or Text

Stylesheet themes are displayed in the MAP Themes panel. To edit a Stylesheet theme, double-click a Stylesheet
name or select Edit "Theme Name" from the MAP Themes panel option menu. This opens the Edit Stylesheet Theme
dialog box

MAF Themes =

Area Stylesheet Theme
Line Stylesheet Theme
£ Point Stylesheet Theme
Text Stylesheet Theme

4MAP Themes = v o @

Note: It may be useful to enable the Base attribute schema on option and then choose an appropriate MAP layer in
the Undefined Layer dialog box (see Chapter 4) before attempting to apply Stylesheet MAP Themes to a new
layer. The new MAP layer will inherit the chosen attribute structure and applying Stylesheet MAP Themes will
be easier because creating or editing the attribute structure is not required.
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Stylesheet Theme Edit

or

The Edit Stylesheet Theme dialog box is where rule generation and styling takes place.

Visual properties - Click to edit
reset options (see below)
|

Theme Name - Edit name of

Stylesheet theme

Layers - Opens the Select
Layers dialog ng—l_—.mame name: |Census Median Age

Edit Stylesheet Theme

Visual properties: Never resef

In

Cancel

Apply

Batch G te Rules

Generate multiple rules
based on different
classification methods.

See Add Stylesheet Rules with
Batch Generate Rules.

Batch Edit Rules

Edit visual properties for
generated rules.

See Batch Edit Rules.

Rule Name - Edit rule name as
it will appear in Legend

tab

Do not apply this rule - Prevent
rule from being applied

Rule Expi

Apply to all artwork - Apply to all
artwork on the layer

Apply to artwork that satisfies this
expression - Only applies style
to artwork that satisfies the
specified expression

Auto-assign - Automatically e/ Layers: Census_tract_area (3] Batch Generate Rules.... | gl Batch Edit Rules...
assign |ayers to stylesheet——- Auto-assign: No imported layers wil be auto-assianed to this stylesheet,
Rule Operations e Rules: o[ @
Add arule P Nane: [Less then 18
Copy arul '~ e omne e Expression | Viual Propertes
een 30 an
Remove SeleCted rUIE +” Greater than 60 (3 Do not apply this rule
+ NoData ) Apply to all artwerk
Move Rules UP/DOW" - Edlt rUle @) Apply to artwork that satifies this expression:
hierarchy (seenin Legend) MEDIAN_AGE v | ~ || 0.000000000 v o
<= + || 18.000000000 v
Rule List - Selectable list of: Expression: MEDIAN_AGE > 0.000000000 AND MEDIAN_AGE <= 18.000000000
named rules. The green Stap applying rules if artwork satisfies this expression
check mark indicates a valid
Expression. A red X indicates Name: | Less than 15
an invalid Expression. Select Rule Expression | Visual Propertes
arule to see its expression i stie: I =
and visual properties in the
tabs to the right. M stroke: M C-0M-0Y-0k=50 -
[ stroke opacity 00% % |fe
Stroke weight: | 0.50 pt S
" . : il ify cok
Visual Properties tab - Style properties || ™ Mspecfy colow u
applied to the selected rule, || CIFtop=aty: LS )
See Apply Visual Properties. || ClFirstaton: 000 = s
s relative to MAP View
[ scale: 100%. B S
[ Opacity: 100% S

The Theme name is reflected in the MAP Themes panel and can be edited.

- Displays the range
or subset of data to style for
each generated rule.

See Assign Expression.

Stop applying rules if art qualifies
for this rule - Limit application
of subsequent rules to art
that meets rule criteria

At least one MAP Layer must be specified before generating rules. Click the Layers button to open the Select Layers
dialog box to choose applicable layers. Multiple layers can be chosen, however, rules can only be generated on a
per layer basis (meaning multiple rules can not be created across multiple layers simultaneously). Selected MAP
Layers are listed beside the Select Layers button.

The Auto-assign setting can be used to auto-assign any imported layers to the stylesheet that have the same
feature type or only auto-assign layers to the stylesheet if they match a pattern.

The Visual properties setting can be used to either reset visual properties before applying rules or reset visual
properties for art that does not qualify for any rule. The Clear instead of reset setting removes all styles from art
objects, sets fill and stroke to none and returns opacity to 100%.
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Add Stylesheet Rules Manually

To add a single rule, click the Add Rule button. Rules are shown in the rule list on the left hand-side of the Edit
Stylesheet Theme dialog box. When a rule is selected, the settings for it are active to the right where its Name,
Expression and Visual Properties can be assigned.

Note: Use caution when assigning a Stylesheet theme to grouped objects or compound paths, the graphic styles
may not apply universally.

Assign Expression

The Expression section provides options to define the criteria in which the data chosen will be styled. There are two
modes to define an expression: simple and advanced.

By default, the Simple Expression mode is displayed and is intended to facilitate quick expression generation.

Comparison - Operators used
to compare values

Values - List of values in the
Attribute Column - Attribute column @ Apply to artwork that satifieslfhis expression: selected attribute column

of the associated MAP Layer ———e | g wenan_ace v||> = | | 0.000000000 v/ |f e— Toggle Mode - Toggle between

Range operator - Click to activate — | 2= = [ 15.000000000 - Simple and Advanced mode
the_st_econd row to enablgthe Expression: MEDIAN_AGE » 0.000000000 AND MEDIAN_AGE <= 18.000000000¢——— Expression - The completed
composition of range expressions expression

First, choose an attribute column from the drop-down list or manually type in an attribute name. Secondly, choose
from a comparison operator from the drop-down list:

>  Greater than >= Greater than or equal to
< Lessthan <= Less than orequal to
= Equalto 1= Notequal to

Finally, type or choose value against which the comparison will be applied. To create an expression based on a
range, click the Range operator check box to enable an additional comparison and value input pair.

Property and read-only attributes cannot be selected in the Simple Expression mode. To use property and read-only
attribute values, click the Toggle Mode button to switch to the Advanced Expression mode.

Expression Builder - Create an
Expression: l expression in the Expression
Expression - Type o use the ——e Pop_Gri_Rt >= 2.8 AND Pop_Grw_Rt <= 4.9 & Builder. See Chapter 5.
Expression Builder to define N -
P ' The expression is valid. Expression Library - Choose an existing

an expression. expression. See Chapter 5.

In Advanced Expression mode, construct more complex expressions and to use read-only and property attributes.
The Expression Validity icon will report if the expression entered is valid. Otherwise it will report invalid and include
additional warning notes. Alternatively, use the Expression Builder to create and edit expressions. To use a saved or
recent expression, use the Expression Library. See chapter 5 for more information on both.
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Apply Visual Properties

The Apply Visual Properties section provides many options to style data including graphic style, stroke, stroke
weight, fill, scale and opacities. Depending on the type of stylesheet feature type, the style properties may differ:

For Area and Line feature types

Style - Select a predefined Neme: |Less then 16
graphic style for selected rule ———eRdeEeresion | VeualPropertes
Style: Age_t ~| =] «——— Toggle Mode - Toggle between
Simple and Advanced mode
Stroke/Opacity/Weight - Choose a ———e [ stroke: Il C-0M-0 V-0 K30 -m P
predefined swatch style. Adjust ] stroke opaciy: el
tlr!e transparency of the §troke. suteweit: [o30p8 : =
Adjust the stroke weight (in pts) O BT -
3 Fil pacty: v 2 [ Fill/Opacity/Rotation - Choose a

e—— predefined swatch style. Adjust
the transparency of the fill.
Adjust the rotation of the fill
(use with patterns).

Scale - Adjust the scale of style
and stroke properties
Opacity - Adjust the transparency

for all properties ——e
[ opadity: 0% 5 |fe

[JFilretaton: 0,00 = £

is relative to MAP Vien

[ scale: 100% B fio

Click the check box beside each option to enable it. The Style option contains a drop-down list of styles that exist in
the Adobe lllustrator Graphic Styles panel.

For Point feature type

graphic style to apply to the

Graphicstyle - Select a predefined —I_ Rule Expression | Visual Properties
selected symbol

e [] Graphic style: [ ] [Defauit] fse—— Toggle Mode - Toggle between

Symbol - Choose a predefined ——r [¥] symbol: @ [MAPublsher Default Symbal] <] [f Simple and Advanced mode

point symbol style.

—e [] Rotation: 0.00 2 fou
Rotation - Specify a custom 7

sym bol rotation | Angle is relative to MAP View

[ seale: 100% + fe

[] Opacity: 100% 3 |fe

The Symbol option contains a drop-down list of symbols that exist in the Adobe Illustrator Symbols panel.

For Text feature type
Graphicstyle - Choose a
predefined graphic style to —I_ Rule Expression | - Visual Properties
apply to the selected text e [ Graphicstyle: |, | [Defauit] f=e—— Toggle Mode - Toggle between
Style - Choose a predefined —— [ stre: [ Normal Character Style] oo Simple and Advanced mode
character style to apply e [¥] Font: Family: | w Caiibri - | [fo
Font - Choose font and stylej Style:  |Hokd hd
Font size - Choose font size ——e [¥] Font size: 12.00pt < fo
[ stroke: [ANene] A
[ stroke weight: 1,00 pt = fe
L] Fi: (/] MNene] A
Angle is relative to MAP View
[ opacity: 100% 3 |fe

The Style option contains a drop-down list of character styles that currently exist in the Adobe Illustrator Character
Styles panel. Note that enabling the Font and Font size options will override the Style option.

196 | Chapter 9: MAP Themes
Stylesheet Themes



Click the Toggle Mode button to toggle between Simple and Advanced mode for style properties. In the Advanced
mode, an expression can be entered manually, created with the Expression Builder or chosen from the Expression
Library. This essentially allows attribute information to be used as the basis for style properties.

Rule Expression | Visual Properties Expression Builder - Create an
l expression in the Expression

Graphicstyle: [ | Type= Mode™ @ Builder. See Chapter 5.
Symbol: @ [MAPublisher Default Symbol] = =

Toggle Mode - Currently in

[] Rotation: 0.00 : o Advanced mode

] Angle is relative to MAP Viey
[ scale: 00% % fea

[ Opacity: 100% : |faw

By default, the Scale is 100%. Editing the scale will alter the symbol size (points) or stroke weight (areas and lines).
The maximum scaling factor is 1000%.

The Opacity setting adjusts the transparency of all visual properties. For area and line feature types, there are
separate fill and stroke opacity settings. Combine with the Opacity setting to increase overall opacity.

Move Simple Expression to Advanced Expression

It is possible to move an expression from Simple Expression mode to the Advanced Expression mode. This may
help when tweaking rule expressions to achieve optimal thematic results. To move a simple expression, right-click
below the Simple Expression input settings (on the Expression line) and click Move to Advanced in the context menu.

Rule Expression | Visual Properties

o not apply this rule

) Apply to all artwork
@) Apply to artwork that satifies this expression:
Pop_Grw Rt v | [>= - ||228 v | |fa
< MIESH v
Expression: Pop_Grw_Rt >= 2.28 AND Pop_Grw Rt 62

Stop applying rules if artwork satisfies thi E;I | Copy to clipboard
=  Move to Advanced

The expression will appear in the Advanced Expression mode.

(@ Apply to artwork that satifies this expression:
Pop_Grw_Rt »= 2.28 AND Pop_Grw_Rt < 3.62 7 &

& The expression is valid.

Note: An advanced expression cannot be moved to a simple expression. Doing so will remove the expression from
the Simple Expression mode.
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Add Stylesheet Rules with Batch Generate Rules

To generate multiple rules based on a classification, click the Batch Generate Rules button in the Edit Stylesheet Theme
dialog box. This opens the Batch Generate Rules dialog box:

Layer - Select source layer

Attribute - Select attribute
to generate rules for —

Load - Load the selected —
attribute values

Source - Displays number of —

values and unique valueSJf

Data Classification Method
Equal Intervals, Quantiles,
Natural Breaks (Jenks-
Caspall) or Unique Values
Data Classes - Number of
classes to classify by

Inclusive Boundary - Choose
either start value or end
value to include as class

data boundary

Visual Property Assignment—
Set the style properties
for the data classifications
above. The styles are
global and affect all of
the rules.

Source:
T® Layer:

77 Attribute: | [B POP_DENS
b e load

Data Classification:

Batch Generate Rules

[E Census_tract_area v | [ Ionore:

- Empty expression. In position: 0

e Source: 882 value(s) (864 unique) from POP_DENS

7@ Method: | Equal Intervals

v | Datacasses: |5 [§

7]

Inclusive boundary:  Start value ~

Expression

1 0<=POP_DEN...
2 7,219.32101307.

3 14,438.6420261

0.000000000000...
7,219.32101307...

14,433.6420261...

Start End Fill
7.219.32101307...
14,438.6420261..

21,657.9630392..

Add

Overwrite

Cancel

o

-

Add - Add these rules to
— the Rule list

— Overwrite - Overwrite
and remove all existing
rules in the Rule list

4 21,657.9630392.. | 21,657.9630302.. 28,877.2840522..,

5 28,877.2840522.. | 28,877.2840522.. 36,006.6050653.. [

[] Add rule expressions to Recent Expressions in Expression Library Add rule for ignored expression

Visual Property Assignment:
[ setstyle: Fromlistof 0 style(s): | Select... [d]  Osetscale: B 3t 100 [JReverse [
[ Set stroke: EEE + Grays g sethi: ] MaP Theme -5 v | [ 8]

L o Reverse colour ramp Reverse colour ramp

Dsetstokeopacitys 0% 3 o 00% 3 [ Reverss @] [Setflopsdtys 0% 5 to 0% = [ Revess |d
[ setstroke weight: ~ 1.00pt 2 [ setfillrotation: 0.00 = to 360.00 + Reverse E‘
[ set opadity: 0% ¢ to 100% + []Reverse El

Data d; table
Table that shows the
expression, starting
and ending range
values and any of
the visual property
assignment settings.

The Batch Generate Rules dialog box is used to generate rules on a per layer, per attribute basis (however, if multiple
layers share a common attribute, it can be chosen). Once a MAP Layer and attribute are chosen, click the Load
button to populate the Data Classification table below it. The default classification method is Equal Intervals, but
can be changed to any of the data classification methods described below. The classification is dependent on how
many data classes are specified. In addition, set the start or end value as the inclusive boundary which determines
whether the data range starts or ends on a boundary value. Enable the Ignore option and enter an expression (or
use the Expression Builder or Library) to specify data values that will be ignored.

Stylesheet MAP Themes support four types of data classification methods:

Equal Intervals

This classification method sets the value ranges in each category equal in size. The

entire range of data values is divided equally into the number of categories chosen.

Quantiles

of units in each category.

Natural Breaks
(Jenks-Caspall)

This method classifies data into the number of categories chosen with an equal number

This classification method is based on the Jenks-Caspall algorithm. It uses an empirical
approach based on minimizing the sum of absolute deviations around class means.

Using arbitrary set of classes, it calculates a total error and attempts to reduce this error
by moving observations between adjacent classes.

Unique Values

This method creates a category for each unique value in the chosen data set. This

method is most appropriately used when there are few unique values within a data set.
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Use the Visual Property Assignment section to specify how the data classifications are styled. Each style property
(except for stroke weight) can be set in two ways: as a ramp or as a single application. By default, the Ramp mode
is enabled. This applies a style property to all data classes in a ramp manner (ascending to descending, or if the
reverse option is checked, descending to ascending). When a style property is in Single Value mode, the options
available change. This option applies the same style property to all data classes.

For Area and Line feature types

Visual Property Assignment: Ramp mode - Style is

. & 7o in ramp application
[ setstyle: From listof O style(s): = Select... [] set scale: 1% T to 100% ¥ Reverse
g L ol mode. The style
Single Value mode ——— [ ] setstroke: 111 +  Grays [ Set fil: ] MAP Theme - 5 ~ | | gl e—— ramp is applied to all
The style is in single B :
Y g Reverse colour ramp Reverse colour ramp data classifications

value application in ascending (or
mode. The same style [ setstroke opacity: 0% 3 o 100% |3 Reverse Ii‘ [ setfill opacity: 0% T to 100% ¥ Reverse El descending) manner
applies to all data

classifications. [ setstroke weight:  1.oopt = [ setfilrotation: 000 |3 to 360.00 3| [Reverse [

[] set opacity: 0% 3| o 100% |3 Reverse li‘

For Point feature types
Visual Property Assignment:
Set style: @ [MaPublisher Default Symbol] -~ |a Set scale: 1% 2] to [100% %] []Reverse E|
[ setrotation: 0.00 = to 360.00 % Reverse El [ setgraphicstyle: From list of 0 style(s):  Select... El
[] setopadty: 0% 3 to 100% |5 Reverse El

For Text feature types
Visual Property Assignment:
[ setstyle: From list of O style(s): | Select... [ Setstroke: C=25M=40 Y=65K=0 -0 -
[ setfi: EEEEE+ Grays [ Set stroke weight: | 0,50 ot z
Reverse colour ramp
Set font: W Calbori - [ set font size: 1200pt = to 32.00pt * Reverse El
Bold -
[ setgraphicstyle: From listof Ostyle(s): = Select... Ii‘ [ set opacity: 0% s to 100% % Reverse E‘

Any enabled style options are shown in the data classification table under its own column heading and each
classification its respective style setting. When additional classes are added to the table, visual styles that are in
Ramp mode will be adjusted proportionally. For example, a layer has an opacity ramp from 0% to 100% and each
of its three classes has an opacity value of 0%, 50% and 100%. When a fourth class is added, the opacity for each
class is proportionally changed to 0%, 33%, 66% and 100%. This works best for visual properties that may be
continuously adjustable such as scale or colour gradients. A warning icon appears when there is a greater number
of classes than colour swatches (groups) or styles. This will lead to colours or styles being repeated.

When the rules and style properties are set, click Add or Overwrite. Add adds more rules to the Rules list. Overwrite
clears all existing rules in the Rules list and replaces it with the current rules and styles.
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Batch Edit Rules

Instead of overwriting rules just to change styles, click the Batch Edit Rules button in the Edit Stylesheet Theme dialog
box to edit existing applied styles.

Batch Edit Rules
Affected rules: Changes: =
" Pop_Grw_Rt: -04 to 0.94) Name Stroke  Stroke Weight Fill Cancel
" Pop_Grw_Rt: 0.94 t0 2.28 ancel

Pop_Grw_Rt: -0.4 to .94 0.25pt =
+ Pop_Grw_Rt: 22810 3.62] | P - ° P
+ Pop Grw Rt: 3.62t0 496/ | pop Grw_ Rt: 0.4 to 2.28 0.25 pt =
« Pop_Grw_Rt: 49610 6.3
Pop_Grw_Rt: 228 to 3.62 0.25 pt =1
Pop_Grw_Rt: 3.62 to 4.98 0.25 pt H-=-0
< 5| [PopGrw Rt 4961063 025 pt | B |
Overwrite Visual Properties:
[ setstyle: From list of O style(s):  Select.. E| [] setscale: 1% ]t 100% & Reverse Ii‘
[#] Set stroke: C=0M=0Y=0K=30 - O = [+] set fil: W Nevw Gradient Swe ~ E}
[[] reverse colour ramp
Clsetstokeopadty: 0% 3 o 00% 3 [ IReverse | [setflopadtys 0% 5 o 100% 3 [ Reverse |ad]
New Property - Add new [¥] setstoke weight:  0.25pt |+ [ setfilrotaton: 000 5 to 35000 5 [ |Reverse Ii‘
style property to rules
Yie property [] set opacity: 0% + to | 100% |+ Reverse El

Changes - Original (left)
changed to adjusted
style property

(right). New property
changes shown in new
columns.

Property Change - Adjust
existing style property

Select (or deselect) existing rules from the Affected rules list and change style properties in the Overwrite Visual
Properties section. Changes made to rules with existing styles are reflected in the Changes table where a green
arrow indicates the new style changes. Similar to the Batch Generate Rules dialog box, any new style properties
added are reflected in the Changes table. All style changes to rules are updated in the Edit Stylesheet Theme dialog
box. There is no need to recreate existing visual properties in order to maintain them.

MAPublisher dialog boxes that have adjustable size, distance or length settings can have its units converted.
Right-click the spin box and choose a new unit of measure. The value in the box automatically converts to the

chosen units.

Size:
Appearance: Strol
Fill:
(@) Use symbol:
Symbol: @ Map
Scale: 100%
Opadity: ‘

2.00pt

Current ruler units (px)

Inches (in}
Centimeters (cm)
Points (pt)
Picas (p0)
Millimeters (mm)

Piels (px]

Use preference (px)

]
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Auto-Assign Layers

The Auto-Assign Layers setting can be used to automatically assign any imported layers to the stylesheet that have
the same feature type or only automatically assign layers to the stylesheet if they match a pattern. This may be
useful when importing layers that are similar to an existing stylesheet theme and will decrease the amount of setup
time for each one. Click the status link in the Edit Stylesheet Theme dialog box to access the auto-assign settings.

Auto-Assign Layers

) Do not auto-assign any layers to this stylesheet,

() Auto-assign any imported layers to this stylesheet that have the same feature type. —
ance
(®) Only auto-assign imported layers to this stylesheet if they match one of the following patterns:

Type Layer Name Match Case Sensitive
Starts with boundary O
Wildcard road O
Contains poly O

Ends with border O

Equals Transit_Centerline
=) Ignore automatic import suffix when comparing {_area)

The pattern type can consist of Equals, Starts with, Ends with, Contains, and Wildcard. Enter the imported layer name
into the Layer Name Match column. Enable the case sensitive for a matching pattern to match a layer's character
case exactly. By default, the Ignore automatic import suffix when comparing option is checked. This ignores the suffix
(e.g. _area, _line, _point) that is applied to a layer during import.
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Dot Density Themes

OVERVIEW

Dot density themes are sometimes called dot distribution maps because they show where particular data
characteristics occur. It uses dots or other symbols to represent the number of occurrences of a given data
characteristic in a particular location. Each dot or symbol used on the map may represent a single entity

(one dot = one person) or as a one-to-many entity (one dot = 1000 people). The data is read from each MAP Layer
and MAP Themes quickly styles the data using Adobe Illustrator symbols and graphic styles.

Since dot density maps are most useful for showing where particular data occur, they only work on area MAP
Layers. Most often, symbols are used to represent data occurring within a bounding polygon such as a census tract,
zip code or county. Use caution when analyzing dot density maps, it should be understood that the dots or symbols
do not always indicate the exact location of the data.

FUNCTIONALITY

Create New Dot Density Theme

To create a new Dot Density theme, click the Create New Map Theme button in the MAP Themes panel. Alternatively,
choose New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box,
where the theme name, theme type, and feature type for a new Dot Density theme are specified.

New Dot Density MAP Theme
New MAP Theme
Name - Specify a name for the =® Theme name: Dot Density Theme
new Dot Density theme -
Theme type: | 3 Dot Density I - Cancel

Theme Type - Select Dot Density from
theme type drop-down list.

Tip: Deuble-cick in the Thams pans! & adit the theme.

Dot Density themes are displayed in the MAP Themes panel. To edit a Dot Density theme, double-click it or select
Edit "Theme Name" from the MAP Themes panel option menu. This opens the Edit Dot Density Theme dialog box.

MAP Themes

Dot Density Theme —— 2% Dot Density Theme

1MAP Theme = v o &
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Dot Density Theme Editor

The Edit Dot Density Theme dialog box is where attribute, density and symbols are chosen.

Edit Dot Density Theme
Theme name - Change the ——— Theme name:  Population Distribution
default theme name
Layer - Select source layer —— Layer: Census_tract_area - Cancel
Attribute - Select attribute — - Attribute: TOTAL_POPULATION - Apply
to base density on
Data range - Displays the Datarange: Motloaded Load
minimum and maximum Dotvahie: 50.00 =
values of chosen attribute "
Dot value - The value Dot Options:
represented by each dot o
(@) Specify:
Dot style: Cirde -
Specify - Choose a simple —— L
dot style, size and Size: 0.75 pt T
appearance (stroke, . .
stroke width and fill) eI Stroke: | [7] INone] | = toopt 3
using Custom Mode. Fill: Black 1 -
Alternatively, click the . u .
toggle but_ton to switch ".-':;. Use symbol:
to Graphic Style mode
to choose a pre-defined Symbol: @ [MAPublisher Default Symbal]
graphic style.
Scale: 100% B
Use Symbol - Choose a —+-
custom symbol to use and Opadity: 100%%
set its scale and opacity 3
Advanced:
[] Always regenerate dot positions when applying

Dot density is created on a per layer, per attribute basis. When an attribute is chosen from the drop-down list, click
the Load button. The data range displays the minimum and maximum values for that attribute. These values should
be taken into account when determining a one-to-many dot density and dot value.

A dot value of 1.00 represents a single (one-to-one) entity. A dot value greater than 1.00 represents a group
(one-to-many) entity. See Considerations for Dot Density Maps.

Dot Options

Choosing dot size is a subjective decision based on visual perception limits and aesthetics (see Considerations for
Dot Density Maps). There are two main options to style dots: simple and symbol. Choose the Specify option to use
simple dot styles from the drop-down list. By default, the Appearance options are in Custom Mode. Click the toggle
button to switch to Graphic Style mode, where a graphic style can be chosen from the drop-down list. Alternatively,
choose the Use symbol option to use symbols sourced from the Adobe Illustrator Symbols panel. Adjust the scale and
opacity as necessary. Check the Always regenerate dot positions when applying to randomize the dot positions when the
Apply button or Apply MAP Theme button in the MAP Themes panel is clicked.

Note: Only basic appearances can be applied to dot density dots. Adobe Live Effects, graphic styles with opacity,
multiple strokes and other non-basic appearances or effects cannot be used.
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After a Dot Density MAP Theme is applied, the effect is listed in the Adobe lllustrator serearance |
Appearance panel. Select an area containing the dot density effect and click Dot Compound Path )
Density in the Appearance panel to open the Dot Density dialog box. This dialog S| =

box differs from the Edit Dot Density Theme dialog box. The Dot Density dialog box
can be used to fine tune the dot density appearance of individually selected areas
instead of making a global change.

ipt

Considerations for Dot Density Maps

When creating one-to-many dot density maps, several considerations should be noted: enumeration units, dot size,
dot value and dot placement. The scale, size, shape, and distribution of data across enumeration units (e.g. census
tracts or block groups) can cause variations in how a dot density map is patterned. On average, smaller sized and
more regularly shaped enumeration units result in a more realistic density map.

The dot value and dot size should be determined together to get an idea of how many dots will populate the map.
Take into consideration the minimum and maximum values of the selected attribute. A rounded dot value should
be chosen for easy approximation. There is a trial and error phase when choosing the most appropriate dot value
and size. Generally, a medium sized dot should be chosen. Small dots produce a widely dispersed dot pattern and
may convey disproportionate map accuracy. Large dots produce overly dense dot patterns and hide any noticeable
map patterns. As a general rule when an appropriate dot value and dot size are chosen, two to five dots should be
seen in enumeration units with the smallest values. MAPublisher allows for automated, random placement of dots.

Too sparse Too dense Optimal

When the value for a particular feature is lower than the "Dot value', a dot may not be assigned for that object. This
happens because MAPublisher only accepts values that are greater than fifty percent of the dot value to be given

a dot. For example, if an object has a value of 4,000 and the dot value is 5,000, it will be assigned a dot because it

is greater than fifty percent (or 2,500) of the dot value. Alternatively, an object that has a value of 2,000 will not be
assigned a dot because it is less than fifty percent (or 2,500) of the dot value.
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Chart Themes

OVERVIEW

Chart themes come in two types: bar chart and pie chart. A bar chart is represented by rectangular bars with
lengths proportional to the attribute values that they represent. A pie chart is comprised of a circle divided into
sectors, showing attribute value proportion. These charts are generally placed near the center of the aggregation
area (e.g. census tract or state).

Chart data is read from attributes from a MAP Layer and MAP Themes quickly styles the data using Adobe lllustrator
symbols and graphic styles. Charts can plot both discrete and continuous data. Some examples of discrete data
include voters or hair color. Some examples of continuous data would be temperature or height.

FUNCTIONALITY

Create New Chart Theme

To create a new Chart theme, click the Create New Map Theme button in the MAP Themes panel. Alternatively, choose
New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box, where the
theme name, theme type, and feature type for a new Dot Density theme are specified.

New Chart MAP Theme
New MAP Theme
Name - Specify a name for the T* Theme name: |Chart Theme [ ox
new Chart theme
Theme type: | illa Chart v Cancel
I Theme Type - Select Chart from theme

type drop-down list.

Tip: Doublelick in the Theme pane to edi the theme.

Chart themes are displayed in the MAP Themes panel. To edit a Chart theme, double-click it or select Edit "Theme
Name" from the MAP Themes panel option menu. This opens the Edit Chart Theme dialog box.

MAF THEMES

Eﬂ; Bar Chart Theme
'q@ Piz Chart Theme

2 MAP Themes oI T ¥
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Chart Theme Edi

tor

The Edit Chart Theme dialog box is where the chart type, style and its options are chosen:

Theme Name - Edit name
of Chart theme —I_

Output Layer - Choose —
which layer where
charts are saved

Layer - Choose a layer —
to load the Attribute

drop-down IistJ—
Move Up/Down - Adjust

placement of attribute

in the bar or pie chartJ

Chart Attributes
Add attribute
Remove attribute

Edit Chart Themi
7@ Theme name: |Bar Chart Theme Type: il Bar chart =
—e Outputlayer: | FH Legend - [ 1gnore: | cancal
SourceData | ChartOptions | General Options | Tite | Labels o
——elayer: Census_tract_area ~ Scaling...
W FEMALE Attribute: FEMALE - I
Sl Label: \FEMALE B
I TOTAL_POPULATION :
Appearance:
Stroke: | [l Black 1 - W ®|100%z] =[lope 2
N .
fi: | c=3smM=10v=35k=10 ~ [l ® |w00%[:
@@
Preview:
Preview quality:  Medium Show actual size

Type - Choose chart
type: Bar chart or
Pie chart

Tabs - Switch
between tabs for
more options

Scaling - Click to
open the chart
Scaling dialog box

Appearance - Adjust
the stroke, stroke
width, fill, and
opacity of each
attribute using
Custom Mode
(default) or Graphic
Style Mode

Chart Preview

A preview of the
chart with current
settings. Adjust
quality of preview
in the Quality drop-
down list

The Theme name is reflected in the MAP Themes panel and can be edited. Specify either Bar chart or Pie chart from
the Type drop-down list. Depending on the type of chart chosen, several appearance and option settings will differ.
Choose the appropriate Legend layer to store the charts from the Output layer drop-down list. Enable the Ignore

option and enter an expression (or use the Expression Builder or Library) to specify data values that will be ignored.

Add Source Data

In the Source Data tab, choose a MAP Layer to load its attributes from the Layer drop-down list (Text layers are not
supported). Only the attributes of a single layer may be chosen at a time (meaning mixing layers and attributes

is simultaneously is not possible). Click the Add attribute button to add an Unspecified attribute slot into the list.
Select an <Unspecified> item in the list and choose an attribute from the Attribute drop-down list. The attribute
name is automatically used in the Label box, however it can be edited. Any changes to label and appearance are
reflected in the attribute list as well as the chart preview. To change the sort order, select an attribute in the list and
click the Up or Down arrow.
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Adjust Bar Chart Appearance and Options

To change the appearance of an attribute, select one from the list

to enable its appearance properties. The

Appearance section, in Custom Mode (default), has adjustments for stroke, stroke opacity, stroke width, fill and
fill opacity. Alternatively, click the Toggle Mode button to switch to the Graphic Style Mode. In that mode, choose

a predefined graphic style from the drop-down list (sourced from

the Graphic Styles panel). Changes made are

reflected in the style indicator in the attribute list as well as the chart preview at the bottom of the dialog box.

SourceData | ChartOptions | Gemeral Options | Tifle | Labels

Census_tract area

Layer: -

I FEMALE Attribute: FEMALE -
. ||l mALE . Stroke
Style Indicator - Color ] TOTAL_POPULATION tobeis  [FEMALE [ J stroke Opacits
chip shows a preview Appearance: l roke Opadty
| stroke: | [MlBack 1 - W ®|wxz toopt |38 Stroke Width

of the bar chart style
Fil:

Wc=35M=100v=35k=10 ~ [l @ w0%3

L Filopadty
Fill

Toggle Mode

In the Chart Options tab, adjust basic bar chart settings—width, height, bar orientation and bar spacing. Other
options include setting the bars relative to maximum data value. In this case, all the bar values are divided by the

maximum value and then drawn as a relative proportion to it. For
position the chart.

Bar orientation - Choose vertica.I.E

up/down or horizontal right/left : Tl

SourceData =~ ChartOptions | General Options

Bar style - Choose Normal or : " orientaton: il Verticalup
Stacked chart style : Bar style: il Normal -
Bar thickness/Maximum bar length E_‘ZBar thickness:
Adjust the size of each bar : simumbar length: |00 [

Bar height relative to - the bars
are adjusted to a relative :
maximum attribute data value :

r height relative to: |Chartmax value v

v spacing: oopx 3
Bar spacing - space between :

each ba.ré

point layers, an alignment control is available to

Initial Alignment - For Point layers only.
Choose alignment position for the chart.
It will only be aligned the first time.

Labels

: Initial Alignment:
‘goo
‘ooo
i fuini :
i Charts will only be aligned the first time they are created; when
: updating a chart, its current position is preserved. :

!

In the General Options tab, enable the Apply style to chart option to choose a predefined style. The Sort Values
option sorts (from left to right) increasing and decreasing values (not shown in the chart preview). The Draw chart
border option is not enabled by default; click the check box to enable it and adjust its appearance options.

Apply style to chart - Choose a ==

graphic style to apply to th

Source Data Chart Options General Options

entire chart : [ Apply style to chart: | [Defauli]
Sort Values - Sort the bars ———e[ ] Sort values: | Descending
in either‘ increasing of [Braw chart border: Stroke: | [l Back 1
decreasing order (no .
shown in preview, Fil: | [ None]
Draw chart border - Enabl Margin: |5.00 px %

to draw a borde
’ Margin - Adjust the
space between the
chart and the border

Labels

- W ® 0% =|1oopt

~ 1@ wox%:

Border style - Adjust the stroke, stroke width, fill,
and opacity of each attribute using Custom
Mode (default) or Graphic Style Mode
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Adjust Pie Chart Appearance and Options

The Pie Chart Appearance options differ slightly from the Bar Chart options. Only the options applicable to pie
charts are shown here. The other Appearance options function identically as explained in the previous section.
The Explode option creates separation of a selected attribute (slice) from the rest of the pie chart. To adjust the
separation of all slices, use the Explode option in the Options section.

SourceData | ChartOptions | General Gptions | Title [ Labels |
Layer: | [B&] world_area +
E] Unempl_Rate Attribute: | [ Arable_Pct -
Indust_Grwth
neusior Label:  Arable_Pct
M Inflat_Rate
M Arable Pt Appearance:
stroke: (1@ [0 = [100p
Fill: M =50 M=30 Y=0 k=0 ~ |l ® 1w00%:
Bxplode:  3.00px |2 Explode - Adjust how

far the selected
attribute is separated
from the pie chart

In the Chart Options tab, adjust basic pie chart settings—pie radius, hole radius, explode and rotation. The Hole
Radius option creates a hole in the middle of the pie chart and results in chart that looks like a ring. The Explode
option here is different than the attribute Explode option in that this applies to all the slices and not just a single
slice. The Rotation (default at 0) starts at the top (12:00 o'clock position) of the pie chart and rotates clockwise
(negative rotation values cannot be used) up 359 degrees.

The General Options function identically as explained in the previous section.

Source Data | ChartOptions | General Options | Tide | Labels |

iPieradius:  50.00px |2

Pie Radius - Adjust the size of
the pie chart

i iust si ‘Hole radius: 0.00px |5
Hole Radius - Adjust size of —— "= P

the hole in the pie chart iExplode:  0.00px [2

Explode - Adjust the %R“'B““f" 0 =
separation of all slices :
Rotation - Adjust the rotation
of the pie chart from 0 to
359 degrees :

For any adjustable size, distance or length setting, right-click the spin box to change the units.

SourceData | ChartOptions | General Options | Tite | Labels |

Bar orientation: il Vertical up -
-

Bar thickness: 10.0px

Current ruler units (pt)

el [

Maximum bar length: 40,0 px

Bar height relative to: |Chart max va et

Centimeters (cm)
Points (pt)
Picas (p0)

Bar spacing: 00px 5

Millimeters (mm)

Preview:
Pixels (px)
¥ Use preference (px)
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Chart Labeling

There are multiple options to label both bar and pie charts. In the Edit Chart Theme dialog box, the Title and
Labels tabs contain labeling settings. By default, all labeling options are disabled. Click the check box beside Show
title, Show attribute value labels and Show attribute name labels to enable labeling options for each one. The Show
attribute name labels option only applies to bar charts. The labeling options are shown below with an example of

what some of the settings do.

Appearance - Adjust the font

Specify a title in the box or :
choose from an attribute

and font size of the title. | [“sourcepata | ChartOptions | _General Options | Tite | Labeks | Examples
Show title Show title
{ Appearance: Il 2vicl Black, 12.00 0t Age Groups

that contains text

Alignment - Align the title to ) Specify: Chart Title
the left, center or right
Show title line - Add a line :
below the title. Adjust

its style properties using
Custom or Graphics Mode.

Shrink title to fit chart - Adjusts

) From attribute:

7

* Alignment:

[Z] shrink title to fit chart

S| #Layerhame

: [[] show tite line: ||| stroke: | [l Specify colour

<

W @ [100%2

=|vo0pt

the title so that it is
proportional to the overall :

Show value labels

: 0,
size of the chart : 22% 16%
0,
Offset - Adjust how far the - bl ‘ 14%
label is from the chart | Source Data | Chart Options I General Options | Title ‘ Labels ‘
. . - 9,
Rotation - Align the title to Show attribute value labels [*] Show attribute name labels 19%
A )
the left, center or ”ght Appearance: . Arial Black, 12.00 pt Appearance: . Arial Black, 12.00 pt 29%
Dlsplaye(:j deflma:s -|Set how C offset: sopx |2 Offset: il
many decimal places are : Show name labels
i T ? Rotation: 0 = Rotation: 0
shown with each label H ; AGE_30_49
Align value labels - Align all : Displayed decmals: 0 ¢ AGES.17
chart values horizontally i [F] Align value Isbels Ace-
R : AGE_65_UP
Label with pie percentage - § [] Label with pie percentage
Only for pie charts. Place .

percentage beside slice. :

Show name labels - These
options only applies to bar
chart themes

Click the Appearance text link to edit labels in the Edit Text Rendition dialog box. Click the Rendition toggle to
choose a predefined character style in Character Style mode or set appearance options in Custom mode.

Edit Text Appearance
Font: | T Arial - | 4T [12.00pt =
Black -

stroke: | [#] MNone] | A= toopt 3

Fil: | [llslack1 ~-

[] underline

[] strikethrough
Advanced:
Graphic style: | [/ [None] -
Note: If a Graphic Style s selected, its stroke & fill are interleaved with the
specified font stroke & fil as follows:

1. Graphic Style stroke

2. Font stroke

3, Font il

4, Graphic Style fil

Cancel

Custom mode

Edit Text Appearance

]| Character style: | s Grid Character Style

Advanced:
Graphic style: | /] [None] -
Note: If a Graphic Style is selected, its stroke & fil are interleaved with the
spedified font stroke & fill as follows:

1. Graphic Style stroke
2. Font stroke

3. Font fill

4. Graphic Style fill

Character Style mode
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Chart Scaling

There are multiple options to adjust how charts are scaled. In the Edit Chart Theme dialog box, click the Scaling
button to access the Scaling dialog box. There are two options to scale charts: fixed size or use a value from an
attribute. The fixed size option scales all the charts equally by the set percentage. From the initial size, a scale above
100% increases chart size and a scale below 100% decreases chart size.

To scale from attribute, click the attribute drop-down list and choose the appropriate attribute. Click the Load
button to load the data range so that the Scaling dialog box knows which values to use. When the data range
values are clicked, they populate the boxes below (Normalize and Tie to value).

Use the perceptual scaling option to create a more visually accurate depiction of the scale. Perceptual scaling
modifies the scaling slightly in a way that tends to make users perceive the relationship between scaled symbols as
intended. When checked, the scaling will not be mathematically accurate but should be viewed as visually accurate.

N Scalin
Fixed size - Scale the chart at 2
asetpercentage —e) qeguze: 0%
From attribute - Scale the chart ®) From attribute: Scale_value - Cancel
based on an attribute value. Load
Datarange: Notloaded Load

the data range to obtain values.

) [] Use perceptual scaling
Use perceptual scaling

Adjusts the scaling so that it .
is more visually accurate (®) Attribute value is scale percentage

() Normalize: o T =100%
Attribute value is scale percentage

Use this option if the attribute is

contains percentage values

() Attribute value determines scale from range:

Minimum: 5% : Tie tovalue: <
® Discard when value is below minimum

Normalize - Enter a value to set it as 100%.

Other values scaled based on it. Bound values to minimum

Maximum: | 100% g Tie to value: 0 +
Attribute value determines scale from range
Use the data range to determine scale.
Option to tie values to the minimum Bound values to maximum
and maximum.

®) Discard when value is above maximum

Use the Attribute value is scale percentage option to scale the charts directly using the values for the selected
attribute. The maximum scale value allowed is 999 percent. Any values that do not conform will be marked by the
MAP Themes Log as an error and the scale for that chart will not be applied.

Use the Normalize option to set a value as 100 percent. All other values are converted to a percentage based on
the set value and used to scale the charts. For example, if an attribute has a value of 2000 to be normalized as 100
percent, that means a value of 1500 will be considered as 75 percent, effectively reducing the size of the chart.

The Attribute value determines scale from range option contains a number of setting to fine tune how the scale is set
based on a range of values. The settings of the Minimum (default 5%) and the Maximum (default 100%) are based
on the minimum and maximum of the data range. The Tie to value box specifically states which value in the range
that is set as the Minimum or Maximum. It has two options available where any values below (minimum) or above
(maximum) can be discarded or bound. This may be useful if there are extreme low or high values that could affect
the scaling.
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MAP Theme Legends

OVERVIEW

A legend can be created from any MAP Theme—Stylesheets, Dot Density and Charts. Each theme has its own
options and settings to create a legend. A legend is composed of boxes to represent area layers, lines to represent
line layers, point symbols to represent point layers and text for text layers.

FUNCTIONALITY

MAP Theme legends must be added to a Legend layer. One can be created first using the Add MAP Layer button in
the MAP Views panel and choosing a Legend feature type (see chapter 4). Alternatively, MAP Themes will create one
if no Legend layers are present.

To create a legend, select a MAP Theme and click the Create Legend button at the bottom of the panel. Alternatively,
choose Create Legend in the panel options menu.

MAP Themes =

Area Stylesheet Theme
ills Chart Theme

Line Stylesheet Theme
£ Point Stylesheet Theme
Text Stylesheet Theme

5 MAP Themes LR
C T

|
Create Legend

The Legend Editor dialog box will differ depending on the type of MAP theme chosen: Stylesheets open the
Stylesheet Legend Editor, Dot Density opens the Create Dot Density Legend, and Charts open the Create Chart Legend.

Similar to other MAPublisher functions, the legend editors are dependent on several Adobe lllustrator panels
including Swatches, Graphic Styles, and Character Styles to style legend symbol elements. Populate these panels
with swatches and styles before creating legends.

Legends are not dynamically linked to the MAP Themes. When MAP Theme styles change, a new legend must be
generated. Select a MAP Theme that already has an existing legend, click the Create Legend button and adjust
the settings to create a new legend. It is most useful when tweaking a legend to make it match or fit a layout
design. Furthermore, legend elements can edited freely using the Direct Selection tool, in isolation mode or if it is
ungrouped (menu Object > Ungroup).
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Stylesheet Legend Editor

The Stylesheet Legend Editor is used to create legends from point, line and area Stylesheet MAP Themes.

MEDIAN_AGE > 0.000000000 AND MEDIAN_AGE <= 18.000000|

Save

Cancel Display name - Rule
name displayed in
e————————1legend (if enabled)

Display

Expression
displayed in the
legend (if enabled)

Legend Preview - A
preview of how
the legend key
looks with current
settings. Choose

Create Stylesheet Legend
Output Layer - Select a ——-o Qutput Layer: | [ Legend ~
Legend layer as output
Legend Entries Legend Key Options Title Border
Less than 18 Display name:
Between 18 and 30 Less than 18
|| Between 30 2nd 60 . ;
Display expression:
Greater than 60
. Me Dat:
Legend Entries o
Add entry
Remove entry
Qe Reset
Preview:
’_ Less than 18
’_ Between 18 and 30
’_ Between 30 and 60
’_ Greater than 60
No Data
Preview quality:  Medium

from several
preview qualities
and actual size.

Show actual size

In the Legend Entries tab, the Legend Entries list determines how many items are listed in the legend. Use the Add
and Remove entry buttons to adjust how many entries are listed and use the Up and Down arrows to adjust the
hierarchy. Select a legend entry and adjust the Display name and Display expression. These labels are used in the
legend and are dependent on whether or not the Include name and Include expression options are enabled in the

Legend Key Options (below).

Indude name - Check

to include the legend Indude name:
entry names ——e [ Indude expression:
Include expression -
Check to include the :
legend rule expression

Indude icon:

Indude icon - Check to
include the legend
icon. Set the size, icon
style or use Advanced
to match legend :
entries to rules.

Alignment:

Columns:

Space between entries:

Legend Entries Legend Key Options

Title Barder

B 2l Black, 12,000t

. Arial Black, 12.00 pt

% 20.00px T
Icon style:

20.00 px

Alignment - Align the
i legend elements to
: the left, center, or right

Columns - Specify
: number of columns in

1 =

3.00px %

* the legend

Space between entries -

i The distance between
: each legend entry

In the Legend Key Options tab, the Include icon option is enabled by default. This is the legend icon to the left of
an entry display name. Edit the size of the graphic using the vertical and horizontal size adjustments. Click the
Advanced button to apply more than one rule style to a legend layer. This may be useful in cases where two styles
such as one for a highway and one to represent high traffic volume, can be both chosen for one legend entry to
represent a high trafficked highway. In addition, there are many shapes available in the Icon style drop-down list.
The Icon style list is different for Line and Area Stylesheet themes (unavailable for Point Stylesheet themes). Use
the Alignment option to align the legend entries left, center or right. Use the Columns option to adjust how many
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columns are in the legend. The minimum number of columns is one and the maximum number is dependent on
how many legend entries exist. The Space between entries option determines the distance between each entry.

| LegendEntries | Legend key Options | Tite | Border |

Draw title:

Label: Legend

Style: B 2zl Black, 12.00pt
Ju—
[ Draw title line:
| stroke: | Il Specify colour - .‘23 100% 5| = |1.00pt |5

Spacing: [3.00 px

In the Title tab, use the Draw title options to add a title to the legend. Specify a title in the Label box and use the
options to align and set a style. Enable the Draw title line to place a horizontal line in between the title and the
legend entries. The Element spacing option determines the distance between the title, title line and legend entries.

| tegend Entries | LegendKey Options | Tite | Border |

Draw barder:

Margin: 5.00px =

In the Border tab, use the Draw border options to add a border around the legend entries. Toggle between Custom
Mode and Graphic Style mode to choose border style settings.
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Create Dot Density Legend
The Create Dot Density Legend dialog box is used to create a legend from Dot Density MAP Themes.

Create Dot Density Legend

Dot icon size - The dot size—l- Output layer: | B Legend A

represented in the legend
. e Doticon size: 10,00 px % vl Use actual size
Dot spacing - The space between e Save

the dot and the legend label

— Dot spacing: | 5.00 px 3 Cancel

Legend label - Label is entered
by default. Edit to change it.

—*Legend label: |is equal to %evalues,
%ovalue®s will be replaced with the dot's walue from the theme.
T Appearance: . Arial Black, 12,00 pt

Appearance - Adjust the legend

label font and font size s stroke: | [l Bock 1 T W ® 0w [t E
Border - Check to place e
border around legend Fil: | [Z]None] + [ [1® w02

entries. Use options to
style border.

Margin: | 5.00 px -

Margin - Adjust the distance Preview:
between the border and
legend label
- is equal to 50,
Preview quality:  Medium Show actual size

By default, the Use actual size check box for the Dot icon size setting is enabled. Uncheck it to manually set a size (in
pixels). The preview shows how the legend will look depending on the settings. Adjust the Dot spacing option to
increase or decrease the distance between the dot and the legend label.

The Legend label box provides the legend with a title. It uses a %value% variable to determine the value from
the Dot Density theme. To adjust the value, close this dialog box and edit the Dot Density theme. Click the label
appearance link to change the label font, style and size.

By default, the Border option is enabled. Use the options in either Custom Mode or Graphic Style Mode to set the
style of the border. Increase or decrease the value Margin option to adjust the distance between the legend label
and the border.
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Create Chart Legend

The Create Chart Legend dialog box is used to create legends from Chart MAP Themes.

Label app - Adjust the

legend label font and font size

Style Options - Depending on
Standard or Chart style, these
options will differ. See below.

Create Chart Legend
Qutput layer: HH Grid_legend -
Label appearance: . Arial Black, 12.00 pt Save
Style | Title &Border Cancel
e Style: = Standard +
Style Options:
Icon size: 20.00 px = % |20.00 px *
Columns: 1 :
Element spacing: | 3,00 px S
Preview:
[l FemaLE Pc
[ maLe pc
Preview quality: Medium Show actual size

Click the Label appearance link to change the font, style and size of the legend entry labels.

In the Style tab, the Style drop-down list has two options: Standard and Chart. The Standard option gives the
legend an icon style (see above screenshot). The Chart option provides more options to create a legend that is
representative of the chart. When the legend is created for bar charts, these options are provided:

Bar chart style options

Style:

Style Options:
Chartsize:  100.00 px =
Label offset: 3,00 px -
Do not apply chart graphic style
Align labels

Label angle: 45 deg =

Bar sizes: Increasing =

X 100.00 px B

The chart size is the overall size of the chart, not the individual bars themselves. The Label offset is the distance

between the bars and its respective label. The Do not apply chart graphic style option removes any graphic styles
that were applied to the chart when it was created. The Label angle rotates the label to a specified degree. Bar sizes
can be set to Increasing, Decreasing or Equal. These are for visual purposes only and do not reflect the actual data.
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When the legend is created for bar charts, these options are provided:
Pie chart style options

Style Options:

Chartsize: 100,00 px S % 100,00 px =
Label offset: 3,00 px =

Do not apply chart graphic style

Ignore explodes

Rotation: 0 deg =

By default, the Ignore explodes option does not display an exploded pie chart in the legend when it is checked. Set
a Rotation to rotate the pie chart clockwise.

In the Title & Border tab, use the Draw title options to add a title to the legend. Specify a title in the title box and use
the options to align and set a style. Enable the Draw title line to place a horizontal line in between the title and the
legend entries. Use Custom Mode or Graphic Style Mode to set the line style.

Output layer: HH ChartLegend +

Label appearance: [l ArialBlack, 12.00pt

Title & Border

appearance: [Jl] Arial Black, 12.00 pt

Draw title - Edit title and
appearance options

[ Draw title line:

| stroke: | [l Black B ® 0% =|Loopt
braw bordr - AGstborier —— 4 o g e W wnfs = soom
appearance
7A@ [

Margin: - 5.00 px =

By default, the Draw border option is enabled. Use the options in either Custom Mode or Graphic Style Mode to
set the style of the border. Increase or decrease the value Margin option to adjust the distance between the legend
entries and the border.
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Text and
Labels

One of the most useful features of MAPublisher is the ability
to create labels for map objects using values from the MAP
Attributes panel. Manually entering and placing labels is not
necessary, provided that the labeling information is included
in the map attributes of the MAP Layer being labeled.

MAPublisher provides two methods of adding labels
to a map, both of which contain options to place labels
intelligently using defined label settings.

One way to create feature labels is to first select all the
features to be labeled and use Label Features to label all of
them by specified attribute values.

An alternate method involves using the MAP Tagger Tool to
apply labels individually, also by specified attribute values.

As a complement to the labeling functions, Create Knockouts
masks the part of line features covered by text labels for
improved text legibility.

Topics covered in this section:
Label Features

MAP Tagger Tool

Create Knockouts
Right-to-Left Text

Text Utilities

For more advanced labeling capabilities refer to chapter 17
about MAPublisher LabelPro (additional license required).
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Label Features

Object > MAPublisher > Label Features or MAP Toolbar @

Label Features

Cox ]
. - Atrbute Torget stye =
Layer - Lists the Point, Line and Area [ SCHOOL_NAME 1] LP_Commun iyt Use current settings S Style - Labels are styled based on
'layet“;r;attcan be 'aielfdsc:n(ljy 5 FULLNAME [ 19 Metilnes et Mk St the chosen Character style or
selected features can be labeled. 1 TRACT Census text Census Style current settings
Attribute - Select the attribute that Target - The target text layer is where
contains the values you wish to use all the labels will be stored

as labels for the selected features

3 Area Settings Line Settings Point Settings

$ acement acar ste)
Label Settings - Click the appropriate —— O tigh (domer, forces label witin area bounderies)
tab to assign label settings and © (] Labeks e with nes ofattuce
rules for each |ayer type (see below) ] Adjustlabel f larger than area:

Reduce font um of: |5 pt

Reduce horizontal scaling to a minimum of: | 10% 3

Wrap labels that are too long

FUNCTIONALITY

The Label Features tool creates labels based on attributes of selected features on Area, Line, or Point MAP layers.
Features selected on multiple MAP layers can be labeled simultaneously. Additional settings to fine tune labeling
are available, such as alignment to lines of latitude, minimum font size, horizontal scaling and label position in order
to place labels intelligently.

PREREQUISITES

Labels need to be added to a Text layer. Use Add MAP Layer in the MAP View panel to create one (see chapter 4)

LAYER LABELS

Layer and Attribute

The Layer column shows the Area, Point, or Text layers that currently have selected features to label.

For each layer, the Attribute drop-down list is populated with the attributes of that layer. Click to choose the
appropriate attribute to label with.

Target

In the Target column, choose a Text layer that the labels will output to. Labels can only be created on Text layers in
the same MAP View as the MAP layer.

Style

In the Style column, choose a pre-defined character style or use the current settings. For best results, set up
character styles for type font, size, justification, fill and stroke in the Character Style panel before labeling (Window >
Type > Character Style). Alternatively, set the appropriate settings (fill, stroke, font, etc.) and then use Label Features
tool. Label Features will generate labels based on current settings.
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LABEL SETTINGS

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude,
minimum font sizes and horizontal scaling to best place labels within polygons and paths. These label settings are

common to Label Features and the MAP Tagger Tool (including MAP Contour Tagger).

Area Labels

Labels curve with lines of latitude
For projected layers, choose this option to
generate curved text along latitude lines

Adjust label if larger than line - Specify rules
for the scaling of text if the text will not fit
inside the area object in its entirety.

Click the Up or Down buttons to adjust
the order in which the rules will be
implemented in the labeling process.

]

Areasettngs | [ Lne Settngs Point Settings

Placement accuracy: () Low (faster)

@ High (slower, forces label within area boundaries)
® [ Labels curve with lines of latitude
® (7] Adjust label i larger than area:

[T Reduce font size to a minimum of: |5 pt.
(7] Reduce horizontal scaling te a minimum of: | 10%

[ Wrap labels that are too long

Pl Accuracy - To quickly generate
labels, choose Low. To force labels within
the boundaries of area of complex shape,
choose High.

Set all labels to the same minimum size - When
at least one label has been reduced in font
size due to the implementation of rules,

then all text items will be reduced to that
font size (Label Features only)

[ Setalllabels to the same minimum font size

MAPublisher places Area labels depending on the shape and size of the area polygon. Click the Area Settings tab to
see all the area label settings.

The High Placement Accuracy option makes more advanced calculations for the label positions so as to force them to
fall within the area boundaries (useful for areas with strange shapes, for example some S shape islands). However, it
does slows down the labeling process so a Low accuracy can be preferable depending on the expected results.

When the Labels curve with lines of latitude option is selected, MAPublisher creates a path that conforms to local lines
of latitude and place the text along it. If this option is not selected, the labels are placed horizontally. This option is
enabled only for MAP Views set with a projected coordinate system.

Labels can be modified if they exceed the size of the area in the current default font size. Check the Adjust label if
larger than area option to activate the label reduction rules. These rules are executed in a hierarchical order and can
be reordered with the Up and Down buttons. The Reduce font size to a minimum of option allows for font reduction

to a specified minimum size in points. The Reduce horizontal scaling to a minimum of option allows text to be scaled
horizontally by the fraction specified. The Wrap labels that are too long option adds a carriage return at the nearest
space in the text.

Note: The Wrap Labels that are longer than area option is not available if the Labels curve with lines of latitude option
is checked.

Label Features also provides an additional option which is not available with the MAP Tagger tool. If any of the labels
have been adjusted in size due to the deployment of an area adjustment rule, all labels can be resized to the same
size by checking the Setall labels to the same minimum font size option.

When a specified rule cannot be implemented successfully, MAPublisher will default to placing the label centered
over the area. In situations with compound areas, MAPublisher labels the largest area in the compound.
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Line Labels

Distance from start - Controls how text is
placed relative to the line:

Auto - places text at midpoint for straight ——
lines and finds the smoothest portion
closest to the midpoint for curved lines.
Fixed - allows for precise placement of text
along aline.

Adjust label if larger than line - Specify rules ——
for the scaling of text if the text will not fit
onto the text path in its entirety.
Click the Up or Down buttons to adjust
the order in which the rules will be
implemented in the labeling process.

Area Settings Line Settings |

Paint Settngs |

Label type: [Follow line, reate texton apath <] Pathlength: [Short -]

o Distance from start: Auto > [o%

Reverse right-todeft paths (fiip upside-down text)

Label type - Select whether text should
follow lines or be placed at a point near
the selected line. Path length option
creates short or long text on path.

— Reverse right-to-left paths (flip upside-down text)

[7] Smooth lines with offset: | 4.00 px

Always enabled by default, it automatically

Label position:

g ® Baseline
_g

) Descender

feature will not flip the label.

o

‘o [7] Adjust label flarger than line:

) Center

Reduce font size to a minimum of: |5 pt

Reduce horizontal scaling to a minimum of: |10%

Set al labels to the same minimum font size

Lorients labels uniformly. Disabling this

Smooth lines with offset - Check to smooth
the generated text path. Then, specify an
offset distance for the text path from the
original.

Label Position - Choose how the text will be
placed on the generated text path

Set all labels to the same minimum font size

When at least one label has been reduced
in font size due to the implementation of
rules, then ALL text items will be reduced
to that font size (in Label Features only)

MAPublisher places Line labels depending on the curvature and length of the line string. Click the Line Settings tab to
see line label settings. Choose a Label type to either Follow line and create text on a path, Follow line and create point text or
Don't follow line and create point text. The first option creates text that follows a path where its position can be adjusted
along it. The second option creates text that follows the angle of the path, but uses a point of reference. The last
option places the text at the middle point of a line and uses a point of reference.

MAPublisher controls where text is placed along lines by using the Distance from start option. Choosing Auto will place
text at the midpoint for straight lines and, for curved lines, will find the smoothest portion of the curved line closest
to the midpoint. When Fixed is chosen, the distance from start is set as a percentage of the length of the line.

Reverse right-to-left paths (flip upside-down text) is enabled by default and will automatically orient labels uniformly if
some lines are flipped. Disabling this feature will not flip labels.

When the Smooth lines with offset option is enabled, MAPublisher creates a smoothed version of the selected path for
each text object in the layer and places the text along it at the specified offset value. The labels can be dragged and
positioned at any position along a line. When Line Smoothing is not enabled, the labels follow the original path.

Note: For lines with a high number of vertices (e.g. contour lines), using the Line Smoothing option significantly

speeds up the labeling process.

The Label position option allows for the selection of the vertical position of the labels relative to the line. Three
options are available:
«  Baseline: places labels above the generated text path.
«  Descender: places the portion of a letter in a Latin-derived alphabet that normally extends below the
baseline of a particular font above the generated text path.
«  (enter: places the label on the generated text path.
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Labels can be modified if they exceed the length of the line in the current default font size. Check the Adjust label if
larger than line option to activate the label reduction rules. These rules are executed in a hierarchical order and can
be reordered with the Up and Down buttons. The Reduce font size option reduces the size of the font to a specified
minimum size in points. The Reduce horizontal scaling option allows text to be scaled down horizontally by the
percentage specified.

Label Features also provides an additional option (not applicable for the MAP Tagger Tool). If any of the labels have
been adjusted in size due to the activation of a line adjustment rule, all labels can be resized to the same size by
checking the Setall labels to the same minimum font size option.

When a specified rule cannot be implemented successfully, MAPublisher will default to placing the label centered

over the line. Also note that text generated for Line labels will be automatically orientated above the lines,
irrespective of the direction of the line.

Point Labels

5 Areasettings | = Lnesettngs | [ Pointsettings ‘

Label Position - Choose the position of the ———.eLabe! position:
label relative to the point symbol. The
preview displays label position.

Label

Labels curve with lines of latitude ———e [ Labels curve with lines of lsttude:
For projected layers, choose this option to [T use sounding styte labels

generate curved text on latitude lines.

Use ding style labels - Specific options
to label symbols marking a water depth
position according to hydrographic
conventions. See details in this chapter.

Click the Point Labels button to assign MAPublisher Point Label Settings.

The Label Position offers nine position options for the text anchor. Choose one of the placements in the drop-down
list: Upper Left, Upper Middle, Upper Right, Left, Center, Right, Bottom Left, Bottom Middle, Bottom Right. A preview
shows the label placement.

When the Labels curve with lines of latitude option is selected, MAPublisher creates a path that conforms to local lines
of latitude and places the text along it. If this option is not selected, the labels are placed horizontally. This option is

enabled only for MAP Views set with a projected coordinate system.
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Special Point Labels: Sounding Style Labels

The Use sounding style labels option is specific for users wishing to label point symbols marking measured water
depth positions. These types of labels are officially known as Charted Soundings and its representation on official
navigational charts are ruled by international standards.

The aspect of the soundings is always according to the following rule: Numerals representing the decimeter part of
a sounding should be visibly smaller than those representing whole metres and positioned slightly lower than the latter
(subscript). Zero decimeter values must not be shown.

For example: 12 92

Note: Traditionally, slanted text (in italic) represents depth values in metre, straight text represents depths in feet.

On official nautical charts, the actual depth symbol is not plotted — the label itself indicates the depth position.
Two options are possible for the soundings' placement relative to the depth point:

«  Usestandard label style: soundings are placed in such a way that the centre of gravity (geometric centre) of
the set of numerals (integer and decimal parts) coincides with the position referred to. This option is the
most commonly used.

«  Center on whole number: soundings are placed in such a way that the center of gravity of the integer part of
the number coincides with the position referred to.

7,

Sfandard styl Centered on whole number

;i " Depth .[. position relative
: 43 to label (if it was drawn).

Note: More information on these standards can be found on the International Hydrographic Office Website,
www.iho.int, see publication S-4 (formerly M-4).

The relative size and position of the decimal (subscript) relative to the integer number (regular type) is controlled
by the Adobe lllustrator document setup. Choose the menu File > Document Setup to change the subscript size and
position under Type Options. These settings should be performed prior to running the labeling function because
they affect the labels placement relative to the source symbols.

LABEL FEATURES RESULTS

When all the Layer Label Options have been set and the Label Settings have been specified click OK to label the
selected features.

Labels applied using Label Features appear in the current default color, font and font size (as set by the selected
character style).

If the destination text layer and source layer have the same attribute schema, the attributes of the labeled features
are copied as attributes to text features (to apply MAP Themes for example).
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MAP Tagger and MAP Contour Tagger Tool
Tools > MAP Tagger Tool and MAP Contour Tagger Tool
FUNCTIONALITY
The MAP Tagger Tool and MAP Contour Tagger Tool are interactive labeling tools that use the attribute data of selected
features as a source for the labels. These tools function similarly to the Label Features function, however, labels are
created by clicking features on the artboard. It provides greater control over the initial placement of the label. For

the MAP Tagger Tool, labels are placed at the position of the mouse click and leader lines can easily be created in
dense areas. For the MAP Contour Tagger Tool, labels are placed for Line layers only and works best on contour lines.

PREREQUISITES
Labels are added to a Text layer created using the MAP Views panel.

For best results, set up a character style for type font, size, justification and color in the Adobe lllustrator Character
Style panel. Select the appropriate style while using MAP Tagger tools otherwise labels will appear using the default
color, font and font size.

Double-click MAP Tagger Tool to enter new label settings or to edit settings. Click and hold the button to switch to the
MAP Contour Tagger Tool.

MAP TAGGER TOOL SETTINGS

Source Layer and Column

First set the options in MAPublisher to determine the attribute values that will be converted to text labels. The Source
Layer list shows all Area, Point and/or Text layers in the current document.

For each layer, the Column drop-down list is populated with the attribute structure of that layer. Select the column
that holds the desired attributes to label the data with.

Target Text Layer

In the Text layer drop-down list, specify the Text layer that the labels will be output to. Note that labels can only be
created in text layers in the same MAP View as the Source Layer.

LABEL SETTINGS

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude,
minimum font sizes and horizontal scaling to best place labels within polygons and paths. These Label Settings are
common to Label Features, MAP Tagger Tool and MAP Contour Tagger Tool (Lines only).
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TAG MAP DATA

Ensure the label settings are completed. With the MAP Tagger Tool enabled, click a map object to add a label for it. It
may be convenient to lock the layers in the Adobe lllustrator Layers panel or disable undesired features by setting
the attribute column option to No attribute selected for those data layers that do not require labeling to avoid
undesired results.

The following list of keyboard modifiers can be used for additional labeling options with the MAP Tagger Tool:
= click map object with MAP Tagger Tool

Standard label Line labels are placed at click point and assigned angle of line at click point
Area labels are placed horizontally at click point
Point labels are placed horizontally at click point

Label horizontally Line labels are placed horizontally at click point

Y shift

Create leader line Line labels are placed horizontally. Leader line connects text to line feature.
['@]+ [ + drag Area labels are placed horizontally. Leader line connects text to area feature.
Point labels are placed horizontally. Leader line connects text to point feature.

Label and move Line labels are assigned angle of line at click point and can be moved immediately
+drag Area labels are placed horizontally and can be moved immediately
Point labels are placed horizontally and can be moved immediately

Note: To create custom leader lines use a graphic style. Create or load a graphic style and select it in the Graphic
Styles panel while using the MAP Tagger Tool function.

The labeling procedure for MAP Contour Tagger Tool differs slightly. Labels are placed by drawing a line and dragging it
across paths (instead of clicking features to label them). This is particularly useful for contour lines, routes or rivers
that are positioned near each other. The label follows the path. Then use Create Knockouts to mask the lines behind
the labels.
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Create Knockouts

Object > MAPublisher > Create Knockouts or MAP Toolbar

Create Knockouts

Feature Layer - Select the line layer that Clear - Click here to remove all

will be masked with knockouts o Layer(s): Ralway line ~r= l;z:tcukroeul_t: ;::m the selected
Text Layer - Select the layer containing——®Textlayer: | [T] Feature Labels - Cancel

the base text for the knOCkOUtSJ__‘MEsknpaclty‘ 100% %
Mask Opacity - Set the mask opacity [ [¥] Replace exstng knockouts

(100% creates transparent knockout) T[] Use dipping mask instead of opacity mask (only use when exporting to FOF or PostScript)

Replace existing knockouts - Clear the [ Round corners using radius: ~ 5.00px = Round corners using radius

existing knockouts in the Feature Creates mask corners that are
Layer before adding new ones. Do not _ rounded to a specified radius
choose this option to append new ® Knockout baxes:
knockouts to the existing ones. Leftbuffer: — [200px [
Right buffer: Knockout boxes - Set a buffer size

Use clipping mask instead of opacity mask

Choose only if exporting document around the text box

Topbuffer: 0,00 px

ComED

to PDF or PostScript. It uses a Bottom buffer: |0.00 px Limit to cap height - Check this
clipping mask instead of an opacity [] Limit to cap height option to limit the text box height
mask beneath the label. to the size of capital letters.
() Text shaped knockout:
Buffer size: L00px % Text shaped knockout - Set a buffer
e knockout based on the shape of
i the text
Mare detail Less detail

The Create Knockouts function masks parts of line features that are covered by text. The knockouts can be created
for any MAP Layer. All lines in the selected feature layer are affected by the function. A knockout is created for all
text in the selected Text layer.

Knockout - Knockout extents —— "

-KI n g St re et—— Line Feature - Line feature being masked

Text Feature - Text base for the knockout mask

The opacity of knockout masks can be set in the Create Knockouts dialog box and can be modified afterwards
through the Adobe lllustrator Transparency panel.

By default, the size of the knockouts correspond to the Adobe lllustrator text bounding box—that includes
ascenders and descenders (e.g. bottom of letter g). This size can be increased by adding a buffer in pixels (side, top
and bottom) or limited to the height of capital letters. Optionally, choose the knockout to correspond to the shape
of the text. This allow for finer control over the appearance of the knockouts.

Create Knockouts can either append new knockouts to the selected feature layer or replace the exiting ones. It is
also used to clear knockouts that were previously created with the function.

Note: Any text layer can be used to create knockouts, it does not have to be generated by MAPublisher Labeling
functions. The Feature and Text layers do not have to be in the same MAP View.

PREREQUISITES

Create Knockouts requires any type of MAP Layer and a Text layer to be unlocked and visible.

All features in the selected layers will be affected by the function. Text and features that are not supposed to be
masked must be moved to a different layer beforehand.
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USING CREATE KNOCKOUTS

To access the function, click the Create Knockouts button on the MAPublisher toolbar or from the menu Object >
MAPublisher > Create Knockouts.

Layers

In the Create Knockouts dialog box, click the Select Layers button to choose at least one Feature Layer (visible and
unlocked), and then choose a Text layer from the drop-down list. Use the Layer Type Filter to filter which layers are
shown. Text in the selected text layer should overlap with some of the features in the selected feature layer to get
reasonable knockout results.

Mask Opacity

The Mask Opacity option sets the opacity of the masks created behind the text: a 100% setting creates an opaque
mask (the feature will be invisible behind the text) and a 0% setting does not hide any features at all.

Replace Existing Knockouts

The Replace existing knockout option clears the existing knockouts on the selected Feature Layer before adding the
new knockouts. This is useful when running the Create Knockouts function again after adjusting the settings
slightly. To append the new knockouts to the existing one, make sure this option is not checked.

Knockout Boxes

Several parameters are available to set the size of the knockout. By default, the knockout corresponds to the Adobe
lllustrator text bounding box. That bounding box can be slightly taller than the characters in the selected text
because it takes into account the size of ascenders and descenders (e.g. | and g characters). To increase the size

of the knockout, four buffer options are available: Left Buffer, Right Buffer, Top Buffer and Bottom Buffer. Buffer sizes are
entered as pixel values. The Limit to cap height option reduces the knockout size to the height of the capital letters. For
example, this option is useful when labeling contour lines that are close to one another where the regular knockout
size could create masks that overlap from one contour to the next. The knockout boxes are represented below by
the dashed line (for visual reference only).

e T p— I A
—King Street-  -King Streetr  —KIng.Jreet-
o .

Default knockout size Buffer knockout size (2 px) Limit to cap height
knockout size

To achieve a knockout that does not conform to a box, choose the Text shaped knockout option and specify a buffer
size. This creates a knockout that is based on the shape of each text character. It allows for finer knockout control.
Optionally, use the Round corners using radius option to round knockout box corners.

—Kimg(St-ree/t—
awd

Text shaped knockout (1 px)
Note: Text shaped knockouts may increase document file size.
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KNOCKOUT RESULTS
All art in the MAP Layers are masked by the text objects in the selected Text layer, where appropriate.

To achieve the knockout effect, Create Knockouts applies an opacity mask at the layer level as can be seen in the
Adobe lllustrator Layers panel.

® [ [» ] contour Labeis o)
B[ ||v[]contours o’ Layer with Opacity Mask - In Adobe Illustrator,
=0 [] <path> [5] a dashed line under a layer name indicates
s | [] <parh> [s) that the layer has an opacity mask
& | [ ] <Path> 5]
=1 | : <Path> )
A | : <Path> o
A | [] <Path> [s)
2 Layers [® = [ [ &

This masking does not affect the MAP Layer attributes or properties.

Edit Knockout Masks Opacity
The opacity of all the knockouts within MAP Layers can be edited using the Adobe Illustrator Transparency panel:
1. Inthe Adobe Illustrator Layers panel, click the target button next to the master layer name O .

2. Choose Window > Transparency to open the Transparency panel.
3. IntheTransparency panel, click the right-side preview to start editing opacity mask.

+ TRANSPARENCY

Normal w Opacty:| 100+ |Yoe] Opacity - Percentage of opacity
(transparency)
- = [Ccip
. . — | [|nvert Mask
Exit Edit Opacity Mask Edit Opacity Mask - Click to
Click to stop editing edit opacity mask
opacity mask [|1sclate Blending  [H] Knockout Group
I:‘Opac'lty & Mask Define Knockout Shape

4.  Click the left-side preview in the Transparency panel to exit the opacity mask editing mode.
Note: If for some reason the knockouts are not selected when you exit the opacity mask editing mode, the next

time you return to this mode, they will not be selected by default—you'll have to select the knockouts again
from within the opacity mask editing mode (click the object or use the Layers panel target button).

CLEAR KNOCKOUT MASKS

Open the Create Knockouts dialog box, ensure that the MAP Layers that contain the knockouts are selected and
click the Clear button.
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Right-to-Left Text

Object> MAPublisher > Right-to-Left Text or MAP Toolbar

Right-To-Left Text

Target - Choose which text to

apply right-to-left correction to Target:
and whether to apply it to only (®) Texton layer: Feature Labels -
selected text or not Cancel

() All text in document
[] only apply to selected text
Settings:

Preset - Choose a preset or use L Preset: Left-to-right -

custom settings below

Composer engine: Standard v ——  Composer engine - Choose from

N
| | [ ] Paragraph direction: ~ Left to right Standard or Adobe World-Ready
(R

Paragraph direction - Choose a Left

to right or Right to left direction Composer to handle text

[] ustification method:  Defauit — Justification Method - Choose from

Digits - Choose which language . O oigis: e Arabic or Naskh justification

numeric digits are to be typed

Kashidas - Check to insert |, [ Kashidas

Kashidas in Arabic language

FUNCTIONALITY

Many right-to-left languages, such as Arabic and Hebrew, require additional language-specific processing to get
the correct glyph output given the incoming character stream. The Right-to-Left Text tool is used to apply proper
formatting to right-to-left languages.

USING RIGHT-TO-LEFT TEXT

On the MAPublisher toolbar, click the Right-to-Left Text button or the menu Object > MAPublisher > Right-to-Left Text.

In the Target section, choose the target text to be a MAP Text layer or target all text in a document. Optionally,
check Apply to selected text only to only apply formatting to text that was selected before opening the dialog box.
In the Settings section, the Preset contains options (Left-to-right, Arabic, Hebrew) that sets Paragraph direction,
Justification method, and Digits. Any other settings chosen are considered as Custom.

The Composer engine has two modes: Standard and Adobe World-Ready Composer. The Standard mode uses the default
Adobe lllustrator text engine. The Adobe World-Ready Composer enables support for complex script languages
(such as Arabic and Hebrew).

The Paragraph direction can be chosen as Left to right or Right to left (this is the result, not the current text).

The Justification method can be left as Default (the same as the language set in the Character panel) or set to Arabic or
Naskh. To convert text to right-to-left without changing the justification or location of text, uncheck all options and
set the composer to Adobe World-Ready Composer.

Choose the language in which numeric Digits are to be typed. The Default setting means that the numbers will be in
the same language as set in the Character panel, otherwise, choose between Arabic, Hindi, or Farsi digits.

Kashida is a type of justification that elongates characters at certain chosen points. Kashida justification can be
combined with white-space justification to various extents.
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Text Utilities

Object > MAPublisher > Text Utilities or MAP Toolbar

Target - Choose which layer to
apply text utilities to or choose to
apply it to all layers in a specific
MAP View or all text in the
document. Optionally, only apply
it to selected text.

L, Target:

(®) Text on layer: Labels

O Alllayersin (@ Toronto NAD 83 / UTM 17
) All textin document

(] Only apply to selected text

Actions - Choose an action to
perform it on the target text.
More actions below. Actions
explained on the next page.

=® Action: Convert text on a path to point text

Action: Separate multline text -

Break muliline text into single pieces of text,
Options:
[T Create groups

Action: Merge text -

Merge multiple lines of text into a single text object.

[] Merge on attribute: | [S] HAMN

Action: Extend overflowing text -

Find text with the red +and extend the path so that all text is visible.

Action: Fiip upside down text -

Modify upside down text to be shown at a more appropriate orientation.

Action: sharten text path -

Modify the text path so itis only as long as the actual text by removing extra line segments at start
and end.

Action: Set text alignment -

Change the insertion point of point text without moving the text.

Options:

Aligment | = Left =

Action: [Rectify point text to angle -

Rotates specified text to this angle if the current angle falls between the angle +/- the tolerance
angle.

Options:

Rotate to  0.00° = for text within a tolerance of  5.00° —

FUNCTIONALITY

Text Utilities

Takes the first and last point of text on path, and makes rotated point text.

Cancel
Preview
Action: Draw shape around text -

Draws a shape around text,
Options:
Outputlayer: © Selectlayer: | [T] Feature Labels copy
@ Create new layer

) Same as text

EED:

Left buffer: 0.00 px

Shape:
Rightbuffer:  0.00 px

Top buffer: 0.00 px

] [ [ EE

Bottom buffer: 000 px
[ Limit to cap height

[7] Create single box for multiine text

Action: [Draw anchor point for text =

Outputlayer:  Select layer:
@ Create new layer

() Same as text

Action:

iCurve text to latitude -!

Curves single lines of text to lines of latitude.

(®) Use centre of text

_) Use start of text

Action: Fix one point text -

Searches for text on a path with a sindle point, and replaces the text path with multiple points along the actual text.

The Text Utilities dialog box centralizes many text related actions that map makers require. Many of these text

actions have come about due to the complexities of working with text, geographic data and follow cartographic

conventions. Common text issues that Text Utilities can handle are correcting upside down text, separating
multiline text into single line and cropping text path to text length. These actions can be applied to either all text
layers or specific text on a layer. Optionally, actions can be applied to selected text only.
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USING TEXT UTILITIES

On the MAPublisher toolbar, click the Text Utilities button or the menu choose Object > MAPublisher > Text Utilities.

In the Target section, choose the target text to be a MAP Text layer or target all text in a document. Optionally, check
Apply to selected text only to only apply formatting to text that was selected before opening the dialog box.

In the Actions section, choose an action to be performed (actions explained on the next page). Only one text action
may be performed at a time. Click the Preview button to see how the text may be affected.

Actions Original Result
Convert text on a path to point text )4; 511
Converts text on a path to point “Lay,/ ‘44314(,@
text removes curvature and creates ‘WLQDCQ ce
"straight” text. N
Separate multiline text Blue Blue
Separates multiline text into X .
individual lines of text (the points Springs Springs
starting each line in the result). Park Park

Example result produces three separate lines of text.

Merge text Main Main
Merge multiple lines of text into Street Street
a single text object. Not available North North

when "All text in document" is

chosen as the Target. MAPublisher will estimate the best text alignment to set for a group. Some lines of text may

shift as a result of the alignment used for a group. Text objects must have the same rotation.

Extend overflowing text

N
Extends text elements that contain RATHS
overflow.
Flip upside down text
Flips upside down text (corrects
left-to-right direction)
Shorten text path
Remove extra line segments at the
start and end of a path . %&_Ckeﬂzlé_

Set text alignment
Change the insertion point of Blue Springs Park Blue Springs Park
point text without moving the
text. Alignment can be set to left,
center, or right.

Example result produces right justified text.
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Original Result

Rectify point text to angle

Rotates point text to any angle
for text within a specific tolerance
angle.

EdwardSt ~  Edward>st

Example result rotated 8 degrees for text within a 10 degree tolerance angle.

Draw shape around text

Draws text shapes or boxes around
text. Change the style using the
appearance options. Optionally,
limit box to cap height of text and
choose a specific layer for output.

OxfordSt | Oxford St

Example result has a box shape with side, top and bottom buffer of 4 px.

Note:  Some text may not appear centered if no descenders are present and the limit to
cap option is disabled.

Draw anchor point for text

For point text, it draws an anchor

point at lower left. For path text it
is relative to the left anchor point.

Lakewood  Lakewood
Burhgron Buriigron

Adds a "Text" attribute when the point is on a MAP layer.

Curve text to latitude
Curve single lines of text to lines of
latitude

South Dakota
Wyoming

| South Dakota)
lowa ebgkap i

Example result has lines of text curved to match latitude of coordinate system.

Nebraska

Fix one point text

Searches for text on a path with a
single point and replaces the text
path with multiple points along
the actual text.

DO / 82 DO /
. VaLlLey River p o . VaUL—ey River

Legacy text may import with single points along a path. This text utility removes the single
point along the path.
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MAP Selections
and Data
Organization

MAPublisher contains tools for selecting data graphically and
by attribute values.

The MAP Selections panel provides functionality to create,
edit and save multiple selection criteria: based on attribute
expressions, manual art selections or spatial filters. MAP
Selections are saved with the document.

The Split Layer function allows to split MAP Layers based on
attributes values to facilitate data management.

The topics covered in this section:
MAP Selections

Merge Layers

Split Layer
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Window > MAPublisher > MAP Selections or MAP Toolba

MAP Selections

MAP Selections Panel

MAF Selections

MAP Selections List - MAP Selections saved —*|
in the current document

Six

18
Ir—_

Three different types of MAP Selections:
- Attribute Filter Jfix

« Art Selection E
« Spatial Filter &

Invalid MAP Selections for the currently
selected layer are marked with an

Interstate

MAP Selection Name - Name given to the

(ADMM_CLASS = "Interstate”) (Layer=usroads_line)
Toll Road

(TOLL_RD="Y") (Layer=Using current layer)
Southwest States

Selected Art

Roads Intersect Southwest States

Based on MAP Selection Southwest States (Cutput layer =usroads_ling)

MAP Selection. It can be changed in the
Edit MAP Selection dialog box.

MAP Selection Parameters - Summary of
the selection parameters. They can
be changed in the Edit MAP Selection
dialog box.

additional ‘& sign. 4 MAP

Selections

Panel options:

New MAP Selection...
Duplicate "Interstate”
Edit "Interstate”...
Delete "Interstate"...
Apply as Mew Selection Selection
Add to Current Selection
Remove from Current Selection
Get Subset of Current Selection

Copy MAP Objects From...e—————

Preferences...

property

o Expression Builder
= FME Auto
Qo Find Places
b 2 General
[3] Import Map Data

o———— Duplicate MAP Selection - Copies the
selected MAP Selection

—I— Edit MAP Selection - Opens the Edit MAP

Import MAP Objects - Opens the Import
MAP Objects function (see chapter 4)

dialog box

Delete MAP Selection - Delete highlighted
MAP Selections

Create New MAP Selection- Opens the New
MAP Selection dialog box (below)

Get Subset of Current Selection - Makes a
selection within the current selection

Remove from Current Selection - Removes
the highlighted criteria from the current
selection

Add to Current Selection - Adds the

highlighted criteria to the current
selection

o————— Preferences - Opens the MAPublisher
Preferences on the MAP Selections

sheet

Apply as New Selection - Makes a new
selection using the highlighted criteria

MAP Selections Panel Preferences

B southwest States Selected Art

= Interstate (ADMN_CLASS= "Interstate”) {Layer =usroads_line)
= Toll Road {TOLL_RD= ") {Layer=Using current layer)

234

MAP Selections

T e At @ MAP Selection 1 Based on MAP Selection S0 MAP Sslections

(3 MAP Crop Tool

[ MAP Info Panel Six mﬂatﬁ =T ds.Ine)

@ MAP LabelPro Joliee= ! S S LEusae e
> [P MAP Locations fix TolRoad :

S MAP Measurement (TOLL_RD= "Y") {Layer =Using current layer)
4 & MAP Selections Southwest States

= Panel - Selected Art

6 MAP Tagger Tool MAP Selections > Panel 4MAP Selections. MAP Selection 1

T MAP Themes Based on MAP Selection Southwest States (Output layer=usroads_ling)
> @ MAP Views [T] show selections on two lines Show filters on two lines - cleared

(@ Online Maps

9 Raster Georeferencing

4MAP Selections =

Show filters on two lines - selected
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New/Edit MAP Selection
JSix Attribute Filter

Name - Assign or edit the name of ——
the MAP Selection

Layer(s) - Choose layers to base ——
the selection on. By default, the
selection will be done on the
currently selected layer.

Click to « make a different choice

New MAP Selection
T® Mame: |Interstates
Type: | /10 Attribute Filter Save & Select
Layer(s): burlroads_line - Select
Expression: |ROAD= “Interstate” | 2] T‘B Cancel

Type (new MAP Selection only) - Choose
the MAP Selection type:

« Attribute Filter /i

- Art Selection

« Spatial Filter @&

Expression - Enter or edit the expression
directly into the entry field, or access

" The expression is valid.

]

in the Select Layers dialog box

<~ Expression Builder - see chapter 5

Library - see chapter 5

Expression Validity - Indicates if

Select Layers the expression is + valid or
@ invalid. If invalid, additional

e st e Lo information is reported

Chicago Label ] conc

7] More Cities O

usroads_line [m]

hawaii_area [m]

ska_area o

usa area 0 v
Use current layer Select All Clear
Layer Type Filter:
]

Art Selection
Art must be selected first.
Type: Art Selection » | Save & Select
There must be selected art to create an Art Selection, Select
Cancel
Edit Art Selection
Show Selection - Highlights the Art
Selection on the artboard ———s |Show Selection Replace Add Save &5Select
Replace - Replaces the saved Art Selection Cance

with the current artboard selection

Spatial relationship - Choose the method
applied for the spatial filter:
« Intersect and contain: objects that =
intersect or are contained within the _
delimiting features will be selected
« Fully contained: only objects that are
fully contained within the delimiting
features will be selected

Filter text by - Choose the specific
behavior for selecting text:

« First letter of text: the position of
the first letter of a text is used to
make a selection

Name:

Type:

« Full size of text: the bounding box
of the text is used for the selection

L o

I

Do not select art on the same layer as the 'Filter ————

Using' art - Check this option so as not
to select art that is on the same layer
delimiting feature

@ Spatial Filter

Intersecting Roads
@ spatial Filter ~ | [save & select
Select
Filter Using: xisting MAP Selection -
Cancel

Existing MAP Selection: | /1= Interstates (ROAD= "Interstate”) {Layer ~

Options:

Select from Layer(s): <aAll layers> -
Spatial relationship: |Intersect and contain v
Filter text by: Full size of text -

Do not select art on the same |ayer as the 'Filter Using' art

Chapter 11: MAP Selections and Data Organization

Add - Adds the current artboard
selection to the saved Art Selection

Filter Using - Choose where the features
that delimit the spatial filter are taken
from:

« Existing MAP Selection: select a MAP
Selection name from the Existing MAP
Selection drop-down list

« ArtSelection: use the current art
selection (see options above for edit)

« Attribute Filter: enter new attribute
filter parameters (see Attribute Filter

dialog box above)

o Select From Layers - Choose layers to

select from. By default, the selection
will be done on all layers.

Clickto =« make a different choice in
the Select Layers dialog box (see above)
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FUNCTIONALITY

The MAP Selections panel provides options to build, edit, save and apply multiple selection criteria based on:
«  Attribute Filters: selections based on attributes and properties of MAP Layers
«  ArtSelections: saved selections (done with the MAP Selections filters or with the Adobe lllustrator
selection functions)
«  Spatial Selections: selections based on a feature's position relative to another (e.g. select points
contained in a given area).

MAP Selections are saved in the Adobe Illustrator document. The Copy MAP Objects From function (see chapter 4)
provides a method to exchange MAP Selections between documents opened in Adobe lIllustrator.

Expressions created for Attribute Filter type MAP Selections can be saved in the Expression Library so that it can be
used in MAP Attributes and MAP Themes stylesheets (see chapter 5 and chapter 9, respectively).

PREREQUISITES

To save or use a MAP Selection, at least one piece of art must be selected on the artboard before creating a new
selection. This selection does not have to be on a MAP layer, although it must be visible and unlocked.

CREATE A MAP SELECTION

To open the MAP Selections panel, click the MAP Selections button on the MAPublisher toolbar or from the menu
Window > MAPublisher > MAP Selections.

To create a new MAP Selection, click the Create New MAP Selection button or from the panel options menu to open the
New MAP Selection dialog box.

Enter a meaningful Name for the new MAP Selection to facilitate its use. For example, a MAP Selection could be
named Cities or Countries with 80% or higher literacy or US Highways.

Choose the desired MAP Selection Type: Attribute Filter, Art Selection or Spatial Filter.

Attribute Filter

Attribute Filters select objects on one or more MAP Layers based on the features' attributes values or properties.
The selection criteria is an expression created from attributes names, values and/or preset functions.

By default, the selection is done on the currently selected layer. Users may choose a different layer or more layers by
clicking the Layers button to open the Select Layers dialog box. Check any layers that may need to be included.

In the Expression field, enter a valid expression. Optionally, click the Expression Builder button to open the Expression
Builder dialog box or click the Expression Library button to choose a saved or recent expression from the Expression
Library. The Expression Validity icon will report if the expression entered is valid or invalid (and will include additional
warning notes).

Note: The expression validity depends on the layer selection since it is based on some attribute column names.
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The following are some examples of basic expressions which can be entered for use as selection filters.

Expression Result

NAME = “Ontario” All items with the value “Ontario” in the NAME column are selected.

Result: Items with the value “Ontario” OR “Alberta” in the NAME column

NAME = “Ontario” OR NAME = “Alberta”
are selected.

All items with values less than one million in the POPULATION column are

POPULATION < 1000000
selected.

Only items containing the value “Ontario” in the NAME column AND

— s <
NAME = “Ontario” AND POPULATION < 1000000 values less than one million in the POPULATION column are selected.

Note: MAP Selections created in MAPublisher 8.3 or earlier are converted to MAP Selection Attribute Filters, based
on the <current layer>.

Art Selection

To store a current selection—done through the MAP Selections panel or using the Adobe Illustrator selection
functions (e.g. Selection tool, menu Select or Layers panel)—select the MAP Selection type Art Selection.
No parameters are required for this type of MAP Selection.

The current selection must be performed before creating a new MAP selection.

Spatial Filter
A Spatial Filter MAP Selection selects sets of objects based on their position on the artboard.

A Spatial Filter is based on a selection of features, the boundaries of which are used as a limit for the final selection.
The Filter Using drop-down list sets the selection of these features. Three options are available:
«  Existing MAP Selection: the delimiting features are taken from a saved MAP Selection. The MAP Selection
name is chosen in the Existing MAP Selection drop-down list below.
«  ArtSelection: the current artboard selection is used (the selection must be performed before creating the
new Spatial Filter). The current selection is stored as part of the Spatial Filter for later use.
«  Attribute Filter: the delimiting features are selected based on new attribute filter parameters (see Attribute
Filter MAP Selection).

Once the delimiting features are specified, additional Options can be set.

By default, all objects contained within the delimiting features will be selected, regardless on which layer they
belong to. The Select From Layer(s) option can be applied to limit which layers will be included in the final selection. To
do so, click the Layers button to open the Select Layers dialog box. Note that MAP Layers and Non-MAP Layers are
available for selection.

The Spatial Relationship drop-down list offers two options for the selection method:
« Intersect and contain: objects that intersect or are contained within the delimiting features will be selected.
«  Fully contained: only objects that fully contained within the delimiting features will be selected.

The option Do not select art on the same layer as the 'Filter Using' art is meant to avoid art that is on the same layer as

a delimiting feature from being selected based on that feature. For example, if the Spatial Relationship is set to
Intersect and contain, all areas that share a boundary with an area that is a delimiting feature will be selected. With
this option, areas that are on the same layer as the delimiting feature will be excluded from the selection.
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EDIT A MAP SELECTION

To edit an existing MAP Selection, click the selection name in the MAP Selections panel and choose Edit MAP Selection
in the panel options menu. Alternatively, double-click the selection name.

The Edit MAP Selection dialog box allows to rename the MAP Selection and to edit the selection parameters. The dialog
box options depend on the MAP Selection type.

When editing an Attribute Filter, the selection layer and the expression may be edited as new.

When editing an Art Selection, three options are offered:
«  Show Selection: shows the stored Art Selection on the artboard.
«  Replace: if art is selected, replace the stored Art Selection with the current selection.
«  Add:ifartis selected, add the current selection to the stored Art Selection.

When editing a Spatial Filter, all the parameters may be changed. If the Filter Using option is set to an Art Selection,
the same edit options as above are available (Show Selection, Replace and Add).

DELETE A MAP SELECTION

Click one or more selection names in the MAP Selections panel, then click the Delete button or choose Delete MAP
Selection in the panel options menu.

Note: Use caution when deleting, some selections may be dependent on others.

MAKE SELECTIONS

Click the Apply button when creating a MAP Selection. Saved MAP Selections can be applied again at any time.

Note: MAP Selections based on Attribute Filters that are set to <use current layer> may become invalid when a
different layer is selected because its attribute schema may not match the expression.
There are four methods for applying a MAP Selection (available as buttons and menu items):

Apply as New Selection | Clears the current selection and selects any art on the current layer that meets
the criteria of chosen selection filters

Add to Current Selection | Adds any art on the current layer that satisfies chosen selection filters to the
current selection

Remove from Current Selection | Deselects any art on the current layer that is selected and satisfies chosen
selection filters

Get Subset of Current Selection | Deselects any art on the current layer that is selected and does not satisfy
chosen selection filters

Note: These selection combinations can themselves be saved as an Art Selection.
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Merge Layers

Object> MAPublisher > Merge Layers or MAP Toolbar

Merge Layers
Source - Choose the MAP View ——s goyree: Attributes: ’T‘
and Feature type to include )
. N MAP View: B eastusa h Source Destination
in the merge operation . N Cancel
Feature type: Area v eastusa_area
AREA AREA
eastusa_area (6] STATE NAME  [53] STATE_NAME
westusa_area [ STATE_FIPS [5 STATE_FIPS N i
[l SUB_REGION [fi SUB_REGION - Layer attributes
| . [ STATE_ABER [ STATE_ABBR are listed under Source and
Layerlist- Chogse Wh'Ch, MAP POPULATION POPULATION Destination columns.
Layers are included in the 4 [ westusa area
merge. Ther attributes show AREA AREA Click a Destination attribute
up in the list to the right. = S (5 STATE NAME  [5 STATE MAME to choose the appropriate
[ STATE FIPs 5 STATE FIPS one. This is where the Source
Destination - Enter a Nnew ———- pestination: [E5] SUB_REGION [ SUB_REGION b il ied
destination layer name or [ STATEABBR  [1 STATE_ABER attribute will be copied or
ver! ® New layer: POPULATION POPULATION moved to.
use an existing layer - .
() Use existing: eastusa_area
Method - Copy or move the ——- yethod:
art to the destln_atlon layer ® Copy art to destination layer
specified above
() Move art to destination layer

FUNCTIONALITY

Merge Layers combines at least two MAP Layers of the same feature type into a new MAP layer based on its
attribute values. The art from the source layers can either be copied or completely moved to the new layer
(including its attributes).

This tool is particularly useful to combine layers that contains multiple objects. In the example above, eastusa
(eastern United States) and westusa (western United States) are being combined to form one layer containing both.
Merge Layers can be used as a preliminary to exporting layers to other GIS formats.

USING MERGE LAYERS

On the MAPublisher Toolbar, click the Merge Layers button or from the menu Object > MAPublisher > Merge Layers.

Source

In the Source section, choose a MAP View from the drop-down list to load its MAP layers. Click the Feature type
drop-down list to filter the layer list to only show a specific feature type (only layers of the same feature type can be
merged together). In the Layers list, click the check box of at least two layers to include them in the merge. When
chosen, layer attributes are shown in Attributes box.

Destination
In the Destination section, enter a new name in the Layer box or choose an existing layer. The new layer will be of

the same feature type of the source layers.

Method
The Copy art to destination layer and Move art to destination layer options are available to copy or move the source
art to the new layer specified in the Destination section, respectively.
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Attributes

The Attributes section displays the MAP layers chosen for merge. Click the arrow the arrow beside each MAP layer
to display its attributes.

The attributes are split into two columns: Source and Destination. The Source column shows the attributes for

all MAP layers. The Destination column shows where the Source attributes will be moved or copied to in the
destination MAP layer. To change the destination attribute, click it to reveal a drop-down list (which contains every
attribute from all chosen layers) and choose a new attribute. Alternatively, choose Drop to exclude it from the
destination MAP layer.

RESULTS OF MERGE LAYERS

The result of a merge when using at least two MAP layers is a destination MAP layer containing all artwork and
designated attributes. When the source layers have the exact same attribute schema (provided no changes to
destination attributes are made) the result in the destination MAP layer will be the same attribute schema.

Attributes:
Source Destination
+ B st e
B AReA 0 AREA Layer: | [ New Layer (49 areas selected) -] = &
[f5] STATE_NAME [ STATE_NAME
[E STATE FIPS [& STATE FIPS [ AREA [E3/STATE_NAME  |[E5]STATE_FIPS (i3] SUB_REGION }@FFATE_AEER [EE]POPULATION
- - 1 | 121,757.342899... New Mexica 3 Min [ 1819,0%
5 5UB_REGION & 5UB_REGION 2| 264,435.873000... Texas £ W5 Cen [T 20,851,820
[ STATE_ABER [© STATE_ABBR |3 | 70,003.5243995 .. Okiahoma e WS Cen 3 3,450,654
[ POPULATION popuLaTIoN | P |a_| 113,712.67%000... | Arizona 04 Min Pz 5,130,632
4 [E westusa_area 5 | 82,196.9550000... Kansas 2 W N Cen K 2,688,418
B ARE:\ [ AREA 6 | 104,101.230999 | Colerada 08 M |co 4,301,261
|7 | 157,776.309999...| California (3 Paific I 33,871,648
5] STATE NAME 5] STATE_NAME 5 | 84,871.9089599 . Utah % Min uT 2,233,169
[ STATE _FIPS [ STATE_FIPS 2| 110,669.975000... | Nevada R Mm Ny 1,998,257
Bmgsen  Baesiol | e R0V
[E POPULATION POPULATION

When source layers have different attribute schemas, the designated attributes in the destination layer may be
empty for the opposing layer (unless the attribute was specifically set as a destination for the other layer).

Source Destination
4 [ canada area
H cone B cone Emme
@ NAME H NAME lﬂys:‘ New Layer (30 areas selected) |v| @
POP2001 POP2001 [ [micooe [Enarve [Hrorzoor  |@ror20n0 [Elsqei 2001 [BAren [FIsiEnave | FISTATE Fips  [ialsuB_ReGioN  |GISTATE_ABeR | ElPOPLLATION
POP2010 [ poP2010 5 0 0 0| 97,603, 19639%5... Viyoming 5 Min WY 433,782
samzer  H saaan : z z e =
4 westusa_area 6 0 0 0| 147,244652999... Montana £ Min T 902,185
17 0 0 0 67,290.0610000... Washington 53 Padific WA 5,894,121
 AREA B Arca > e e mE mo il
STATE_MAME STATE_NAME s [cans Prince i |, 5294 10,8 560 o
7 " A7 Nova Scot: 908,007 942,506 53,338 0. ﬂ”
[ STATE_FIPS [ STATE_FIPS Ebnd . —_— s >
1 | Y 1755 50 o
[Fil SUB_REGION [fil SUB_REGION 2 |can Quetec 277 207,375 155,128 v
E STATE ABER E STATE ABER 23|caos Ontario 11,410,046 13,210,667 967,741 0. 0
POPULATION  [E POPULATION SEEr SOV e

Note: After a merge of MAP layers containing sub-layers, the original sub-layer structure is maintained.
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Split Layer

Object> MAPublisher > Split Layer or MAP Toolbar

Split Layer
Source Layer - Indicates the currently selected layer —e Source Layer: worldeast_area -
Action: Cancel

. . . [« t to destination |
Action - Select the option to copy or move objects St L

from the source layer to the destination layer

) Move art to destination layer

Method: Split art that satisfies this expression - Choose this
method to create a new layer from objects
that satisfy the specified expression.

Split art to new layer(s) by unique attribute value —e (@) Splitart to new layer(s) by unique attribute value:

Choose this method to split the selected

- X N Attribute: | [ COUNTRY -
layer into multiple layers - one per unique i . dit th ion direct!
value of the selected attribute column in () Spiit art that satisfies this expression: e - E"t‘;’ Ior; edit the expression directly
] . i into the entry field, or access:
the Attribute drop-down list. Expression: & B S

i | Expression Builder - see chapter 5.
Empty expression. In position: 0

Destination - Enter the name of the new layer Expression Library - see chapter 5.
to be created (split art by expression) or —e Destination: H
enter a layer prefix (split by attribute value). et eetE Expression Validity - Indicates if the expression
Use Copy attribute schema option to copy the i is  valid or @ invalid. If invalid, additional

attribute schema to the new layer i information is reported.

Copy attribute schema

FUNCTIONALITY

Split Layer divides a MAP Layer into new MAP layers based on its objects' attribute values. The new layers can either
contain a copy of the original objects or objects can be moved from the source layer.

The split can be done:
«  Based on an expression: when an object's attribute values satisfy the specified expression it is added to
a new layer.
« By unique attribute value: objects that have a same attribute value are grouped into a new layer. Hence
multiple layers are created (one per unique value).

This function is particularly useful to split a layer that contains a lot of objects. For example, a road layer with classes
such as street, highway and toll road could be split in three distinct layers. Split Layer can be used as a preliminary
to running MAPublisher LabelPro (to allow labeling of multiple classes with different styles, see chapter 17), or to
exporting layers to external GIS formats.

USING SPLIT LAYER

The MAP Layer to be split must first be selected in the MAP Views panel or in the Adobe Illustrator Layers panel. On
the MAPublisher toolbar, click the Split Layer button or from the menu Object > MAPublisher > Split Layer.

In the Action options, specify if the split art should be either copied or move to the new layer.

Note: If the source layer is locked, the only option is to copy to the new layers.
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When the Split art to new layer(s) by unique attribute value method is chosen, choose an attribute name from the Attribute
drop-down list. Each new layer created will contain only art that share the same attribute value. By default, the
name of these layers correspond to each single attribute value.

When the Split art that satisfies this expression method is chosen, enter a valid expression in the Expression field, build an
expression using the Expression Builder, or select an expression from the Expression Library — see chapter 5 for more
details (the expression validity icon will report if the expression entered is valid. Otherwise it will report that it is
invalid and include additional warning notes).

In the Destination section, enter a prefix to be added every layer name. Otherwise, the layer name will use the value
in the attribute that the split is based on.

The Copy attribute schema option duplicates the attribute schema from the source layer to the destination layer.

RESULTS

When Split Layer is run, a message is displayed that indicates the number of layers that will be created. Click Cancel
to cancel the Split Layer command or click Create layers to continue.

MAPublisher
163 unique values found.

< Create 163 layers.
163 layers will be created to accomodate the unique values found on the source layer

Always show - Cancel

Depending on the method chosen, one or more new layers are created according to the splitting criteria. The new
layers are placed on the top of the layers hierarchy in the Adobe Illustrator Layers panel.

The new layers have the same feature type as the source MAP layer and are included in the same MAP View.

If the Copy attribute schema was enabled, the new layers contain the same attributes as the source layer.
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Working With
Images

MAPublisher contains tools for working with georeferenced
raster images such as aerial photography and satellite imagery.

The Register Image function accurately registers raster images
with georeferencing information to vector map data.

Export raster images to various georeferenced formats
through the MAP Views panel.

Georeferencing information for raster images are usually
stored in a separate text file where the image and its
associated reference file have the same file name but a
different file extension.

The reference file formats that can be read by Register Image
or written to by Export Image are:

World (tfw)

Image Report (irp)

Maplnfo Table (tab)

Blue Marble Reference (rsf)

ER Mapper (ers)

ListGeo (Igo)

GeoTIFF (tif, tiff) (contains both the image and reference data)

Topics covered in this section:
Register Image

Export Selected Image

Export Document To Image
Export Document To Web Tiles
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Register Image

Object > MAPublisher> Register Inage or MAP Toolbar

Register Image

Register Image - VancouverDowntown

XYt - Specify the coordinates

- o LSEb e (in map units) of the selected corner of
Tie Points' - Change the tie point —e} X: | 488415.857391813 m the raster image
of the image by clicking another | Cancel
¥ | ¥: | 5460814.46391143 m
corner of the graphic |
LoadFile... e~ Load File - Choose a file containing

pixel in the selected map unit selected raster image. The information

Pixel Size' - Specify the size of each—L the georeference information for the

(updates the Effective Map Size). Image Size: 1260 by 907 pixels from the file will be inserted into the
Register Image supports non —e1pixel = [ x: 37032022187 m appropriate fields.
square pixels.
¥ | 3.7032210654 m

Constrain Proportions - Check this
option to maintain X and Y pixel

Constrain proportions

proportions (in map units) Refi File Coordinate System - Indicates
) ) X e the coordinate system of the loaded file
Effective Map Size X/Y' - Specify the T [ x[ss6.03470303160 = (for GeoTIFF images). Set to Unknown
X and Y size of the image in map by defaul
Y: | 3353.82150628835 m y default.

units (updates the Pixel Size)
Units - Select a unit to use for the
specification of georeferencing
information. The default selection is the
current map unit.

e Rotation: 0.000

Rotation - Displays the amount of
rotation of an image

* Editing these options is I SIEET

not required when using MNADS3 / UTM zone 10N
the Load File function.

Undefined Layer
This dialog box appears when an image on a
Non-MAP Layer is moved to a MAP View

Undefined Layer - Layer 1

Feature type - Choose Image e Feature type: 3] Image -
feature type
Cancel
Advanced:
[] Base attribute schema on: Hotels_point Apply to all

Check this option to inherit the attribute structuse from the specfied layer,

FUNCTIONALITY

Register Image applies geospatial referencing to images imported to the artboard. Register Image uses a coordinate
system and coordinates—entered manually or loaded from a reference file—to properly georeference and scale
an image. If the coordinate system of an image matches one of existing vector data, the image can be scaled and
rotated to fit with the vector data. If no matching vector data is found in the document, a new MAP view can be
created to store the cartographic information of the image to allow for data digitization with accurate positioning.

Note: Register Image does not have the capability to transform images from one coordinate system to another. Use
a product like Avenza Geographic Imager to transform images.
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PREREQUISITES

To use Register Image, the geospatial properties of the raster image must be known. Some raster image formats
store the relationship between source image coordinates (pixel location) and real-world reference coordinates

in an associated reference file but do not save the coordinate system information (e.g. TFW world file). The
commonly used GeoTIFF format is embedded with geographic information such as position and coordinate system.
Depending on the image format, check the position and coordinate system of imagery with the data provider
before attempting to use this tool.

Register Image can be used on non-spatially referenced images that are already imported to the artboard using the
Adobe lllustrator Place command (File > Place) or through Import as an Image feature type.

Notes: When placing an image, do not use the Convert Layers to Objects option. It will treat images that may have
multiple layers as grouped objects and will prevent it from being registered properly.

Using an embedded, unflattened image with an existing transparency may result in incorrect registration.

USING REGISTER IMAGE

With an image selected, click the Register Image button on the MAPublisher toolbar or from the menu Object >
MAPublisher > Register Image.

If the image is placed on a MAP Layer, the Register Image automatically registers the image using the coordinate
system of the MAP View containing that MAP Layer.

If the raster image was not imported to a MAP Layer, the Undefined Layer dialog box will appear. Choose either to
create a new MAP View based on the image or choose to add the image to an existing MAP View. In either case, the
Image feature type is the only one available for rasters. It is recommended to use the Image feature type for image
registration and for better layer management and workflow.

When creating a new MAP View, the anchor point and scale are derived from the registration information
(placement and image size). In the case of GeoTIFF images, the MAP View coordinate system is automatically read
from the image header—for other image formats, the coordinate system has to be specified manually in the MAP
View Editor after the registration process (see chapter 4 for more information on Specify coordinate system).

Registration using Reference File

To register an image using a reference file, click the Load File button and navigate to the folder containing the file.
The reference file may have the same name as the image, but may have a different extension (IRP, TFW, TAB, RSF, ERS
or LGO). In the case of the GeoTIFF format, the image file itself contains both the image and reference data and the
needs to be chosen to retrieve the georeferencing information.

The values contained in this reference file are automatically entered into the image parameters. If the file is in
GeoTIFF format, the image coordinate system is read and displayed under Reference File Coordinate System—for other
file formats, the coordinate system is left as unknown.
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Manual Registration

To manually enter image parameters, one of the following combinations must be available in page units or map units:
- The XandY coordinates of one corner of the image and the X and Y Pixel Size.
«  The XandY coordinates of one corner of the image and the X and Y size of the image.

First choose the units to use for entering parameters by making a selection from the Units drop-down list. Then, click
the appropriate corner of the graphic to indicate the image placement point and enter the X and Y coordinates for
this location in the adjacent fields. Next set either the Pixel Size or Effective Map Size. The Pixel Size is the value of a single
pixel in the units set. The Effective Map Size is the X and Y size of the whole image in the units set. Setting either
option will update the other accordingly.

Note: MAPublisher Register Image supports the registration of images having non-square pixels.

RESULTS

When registering GeoTIFF images, a warning message will be displayed if the coordinate system of the image
does not match the selected MAP View's coordinate system. When registering images not in GeoTIFF format while
creating a new MAP View, the coordinate system of the MAP View has to be specified in the MAP View Editor to
finalize the georeferencing.

Provided that the coordinate system, placement and size of the raster image are correct, the image will be scaled
and registered. When matching vector data is available, the image will fit to the artwork. The MAP Location Tool can
be used to check the positions (see chapter 4).

Notes: Raster images cannot be transformed into another coordinate system. If the vector data is transformed
through the MAP View Editor Perform Coordinate System Transformation function after the image has been
register, the image will have to be transformed externally (with Avenza Geographic Imager for example) and
registered again in MAPublisher.

Registered images will be scaled and rotated together with the vector data, but not automatically. After

the vector data has been scaled or rotated using the MAP View Editor, Register Image must be used to apply the
image referencing information. In the case of a manual registration, it is recommended to use the Export
Image function before applying the changes to the vector data (see next paragraph). This way, registering the
image again is only a matter of loading a reference file.

SUPPORTED GEOREFERENCED IMAGE REFERENCE FORMATS

World File (tfw, tifw, wid, eww, jgw, jpw, pgw, sdw, eww, blw, dmw)

World files contain the affine relationship between source image coordinates (pixel locations) and real-world
reference coordinates (lat/long or other real-world coordinate units). World files simply contain a computed
relationship between source image coordinates and reference coordinates and not the complete reference point
information. World files do not support storing coordinate system information.

IRP Image Report File (irp)
IRP Image Report files are ASCII report files indicating the coordinates of the four corners of the raster file and the
pixel size in ground units to allow for georeferencing of the image in other image processing, CAD, or GIS programs.
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Maplinfo Table File (tab)

Maplinfo Table file formats save the complete reference point list information such that it can be loaded again in the
future. MaplInfo TAB files support storing coordinate system information.

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area Hotine Oblique Mercator Hotine Oblique Mercator 1pt
Azimuthal Equidistant Lambert Azimuthal Equal Area* Polyconic

Cylindrical Equal Area* Lambert Conic Conformal Robinson*

Eckert IV* Mercator* Sinusoidal*

Eckert VI* Miller Cylindrical* Swiss Oblique Mercator
Equidistant Conic* Mollweide* Stereographic Transverse Mercator
Gall Stereographic* New Zealand Map Grid

* Coordinate Systems using this projection will not be stored when saving the reference file.

Blue Marble Reference File (rsf)

The Blue Marble Reference Settings File saves the complete reference point list information such that it can be
loaded again in the future. Within a Blue Marble Reference File, the first line contains the version of the file format
(not to be confused with the version of the software) and the total number of points in the file. The remaining lines
contain, in each line, the point ID, the x (row) pixel, the y (column) pixel, the z (elevation) value which is usually 0.00,
followed by the ground coordinates expressed as Latitude or Northing (Y), Longitude or Easting (X) and Elevation
(Z). The last value indicates whether the point described on that line is included in the solution, 0 = not included
and 1 =included. Blue Marble Reference files support storing coordinate system information (all are supported).

ER Mapper File (ers)

The ER Mapper header file is an ASClI file describing the raster data in the data file. The entire header file holds
information about the data source and is contained in the DatasetHeader block. There are two compulsory
sub-blocks, the CoordinateSpace block (to define the coordinate space and location) and the Rasterinfo block (to
define the characteristics of the data in the accompanying data file). The Rasterinfo block my contain a number of
optional sub-blocks. To completely define coordinate information in an ER Mapper header file you need to include
the following data: datum, projection, coordinate type, units, X and Y dimensions for cell size, registration cell X and
Y values, registration cell coordinates, and possibly null cell value. Coordinate information is frequently, but not
always, given for the upper left corner of an image. This would be registration cell X and Y values of 0.0 and 0.0.

For most projections registration coordinates are entered as eastings and northings, the coordinate type will be
"EN', and units will be meters (or occasionally feet). If you are using latitude and longitude the projection is Geodetic,
coordinate type will be "LL", and the X and Y dimensions for the cell size will be in decimal degrees.

ER Mapper files support storing a limited number of pre-defined coordinate systems. Check the coordinate system
details to ensure the ER Mapper identifier exists as the issuer for the coordinate system to be saved. The file will still
be exported however the coordinate system will not be saved with the reference file.

Note: ER Mapper reference files do not support rotated images. When attempting to export a reference file with a
rotated image ER Mapper will not be listed.
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ListGeo file (Igo)

A ListGeo files are text files containing the GeoTIFF metadata information (or tags), which can then be read, and
may also be used as input to other programs.

GeoTIFF File (tif, tiff)

Tagged Image File Format (TIF or TIFF) is a common raster graphic file format and one of the most common
geospatial image formats you are likely to come across. Many raster geographic images from GIS systems are stored
in this format. A GeoTIFF is a TIFF file with embedded geographic information such as position and scale in world
coordinates, coordinate system or an explicit list of ground control points.

Note: The only way to differentiate a regular TIFF image from a referenced GeoTIFF image is to open it in a spatial
imaging software application (such as Avenza Geographic Imager).

Unlike the other geographically referenced image formats discussed in this section, GeoTIFFs do not require a
separate reference file. When registering a GeoTIFF image in MAPublisher, the same file name must be selected in the
Load File dialog box—the required georeference information is contained in the file header.

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area Lambert Azimuthal Equal Area Polar Stereographic
Cassini-Soldner - Cassini Lambert Conic Conformal (1SP) Polyconic
Cylindrical Equal Area Lambert Conic Conformal (2SP) Robinson
Equidistant Conic Lambert Cylindrical Equal Area Sinusoidal
Equidistant Cylindrical Mercator Stereographic
Equirectangular Miller Cylindrical Transverse Mercator
Gnomonic New Zealand Map Grid Transverse Mercator (South Oriented)
Hotine Oblique Mercator Oblique Mercator VanDerGrinten
Laborde Oblique Mercator Oblique Stereographic
Orthographic
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Export Selected Image

MAP Views panel options menu > Export Image
Object > MAPublisher > Export Selected Image or MAP Toolbar > Export Selected Image

FUNCTIONALITY

MAPublisher has the ability to export placed raster files as georeferenced images for use in other application

or for archival purposes. This can be useful in a number of ways. For example, when working with an image for
which there is no georeferencing file, use the MAPublisher Export Image function to create a georeferenced image
file based on the coordinate system of the MAP View. If the MAP View contains georeferencing information, Export
Selected Image can be used to save a raster layer to a georeferenced image format. MAPublisher can export
selected images as TIFF, PNG or JPEG with several reference file format types or as a GeoTIFF, depending on whether
the image is linked or embedded in the document.

USING EXPORT SELECTED IMAGE

An image must be selected first. From the MAPublisher Toolbar, click the Export button and click Export Selected Image.
In the Export Selected Image dialog box, use the Export type drop-down list and choose to export both image and
georeferencing file or just georeferencing. The Reference format drop-down list has several available georeferencing
file formats: GeoTIFF, World (TFW), Blue Marble Reference (RSF), Mapinfo Table (TAB), and ER Mapper (ERS). For reference formats
that do no store coordinate system information, enable the Export coordinate system option to include a WKT or
PRJ reference file. When exporting a linked image, the original image format can be saved, but the colour mode
cannot be changed.

Export type - Export both image Export Selected Image
and georeferencing or just the

georeferencing information e Exporttype: | Image and georeferencing -
Image format - Choose the image — Image format: | PEG < Cancel
output format as original, TIFF, PNG, - e e
or JPEG. olour mode: =
Filename: ents\AvenzaMAPublisher 9. 4\Warld\Image.jpg Browse...

« Filename is valid.

Export coordinate system: | WKT definitions (*.wkt) +

Reference format - Choose the
georeferencing output format for
the selected image

—e Reference format: |World b

When exporting an embedded image, the colour mode can be changed to RGB, CMYK or grayscale (when
applicable). Depending on the Adobe Illustrator document colour mode, the allowed image format may change
when exporting embedded images:
Colour mode | Allowed Image Format
RGB | TIFF, PNG, JPEG
CMYK | TIFF, JPEG
Grayscale | TIFF, PNG, JPEG
Transparent RGB | TIFF, PNG, JPEG
Transparent CMYK | TIFF, JPEG
Transparent Grayscale | TIFF, PNG, JPEG
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When exporting to a GeoTIFF, only a single file is produced (TIFF) since both the image and the georeference
information are included in it. By default, the JPEG image quality setting is 75, the PNG compression level setting is
6, and the TIFF compression type is LZW.

Note: MAP Image layers are not included when an entire MAP View is exported to a spatial format (e.g. Shapefile).

Specify a name for the reference or image file and the folder location where it will be saved. A reference file will
have the same file name as the image and will be saved in the same folder location.

RESULTS

When the appropriate export options have been set, click the OK button. An exported image file can be
subsequently used in imagery applications, such as Avenza Geographic Imager for Adobe Photoshop, in other
Adobe lllustrator documents using MAPublisher, or in other geospatial applications.

Notes: Exporting a linked image in CMYK color mode or an embedded image with an existing transparency may
create incorrect color results. For the former situation, an image must either be set to a different color mode or
embedded. For the latter, the transparency must be removed from the source file.

When exporting linked images, alpha channels will be maintained. However, alpha channels are not
maintained with embedded images during export.

If a MAP View is rotated, the exported image will not store any rotation parameter (it will be automatically
rectified—oriented north up).
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Export Document To Image

Object > MAPublisher > Export Document To Image or MAP Toolbar > Export Document To Image

Export Document To Image
soure
(@) Only export art on this artboard: Artboard 1 -
Source - Exportarton a e 7 .- Cancel
specific artboard or export $ S i
all artin the document Destination:
Image format: TIFF -
Destination - Choose an image 1 co ; -
olour mode: -
format (TIFF, PNG, JPEG), a
colour mode (RGB, grayscale or [ indude transparency
CMYK), include transparency Filename: Publisher .5\mapocations-example-map.tif | Browse...
(with TIFF or PNG only), gnd  Fllename is vaid,
specify an output location
Options:
Resolution - Choose an export —e Resolution: % v ppi
resolution. Higher resolution value Image Size: 306 x 221 pixels
increases image size and file size.
e Anti-aliasing: Type Optimized {Hinted) -
Anti-aliasing - Optlrryzec;l anti-aliasing — (] Compress TIFF Include georeferencing - Include
modes for type or art georeferencing with the image.
Compress TIFF - Uses TIFF compression Indude georeferendng: — Specify the appropriate MAP View
(LZW compression type) MAP View: @ Hotels and choose a reference format.
Export coordinate system:  WKT definitions (*.wkt) Optionally export a coordinate
system file (WKT or PRJ) to be
Reference format: | GeoTIFF - . N .
included with the image.

MAPublisher has the ability to export the entire working artboard or document as an image that can include
georeferencing. This is particularly useful when working with spatial vector data and a suitable georeferenced
image of it is required. MAPublisher can export selected images as TIFF, PNG or JPEG with a choice of reference file
formats, including GeoTIFF.

USING EXPORT DOCUMENT TO IMAGE

In the Export Document To Image dialog box, choose a source to export as the image. The source can either be a
specific artboard or all art in the document.

In the Destination section, choose an image format, colour mode and filename. The Image format drop-down lists
several types: TIFF, PNG, and JPEG. By default, the JPEG image quality setting is 75, the PNG compression level setting
is 6, and TIFF uses LZW compression. The Colour mode drop-down list offers RGB, Grayscale and CMYK. The PNG format
does not allow for CMYK colour mode because it is primarily used for on-screen display purposes. TIFF and PNG
images allow for transparency.

In the Options section, choose an appropriate level of resolution and option to include georeferencing. The
Resolution setting includes 36, 72, 150, 300, 600 ppi, or a custom value. A high resolution of 300 ppi is more suitable for
print (larger file size), while a low resolution of 72 ppi is appropriate for on-screen display (smaller file size). Anti-
aliasing improves image quality; choose between Art Optimized and Type Optimized. Enable the Include georeferencing
option and choose a MAP View and reference format: World, Blue Marble Reference, MapInfo Table, ER Mapper ERS, or GeoTIFF.
For reference formats that do no store coordinate system information, enable the Export coordinate system option
to include a WKT or PRJ reference file. The GeoTIFF reference format is only available when the image format is set
to TIFF. Reference files are saved to the same location as the image file.

Note: Spot colour in the working document will not be maintained in the exported image.
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Export Document To Web Tiles

Object > MAPublisher > Export Document to Tiles or MAP Toolbar > Export Document To Web Tiles

— Advanced - Additional options: Export a

Export Document To Web Tiles 5
reference file that accompanies each

Frros ok ] tile and only export that's included in
?our(e -Exportartona O ErpErE i s artboard 1 - x the referencing MAP View
specific artboard or export - : Cancel
all art in the document. () Export all artin the document
Referencing is based onlthe Referencing: | @ World ~ Advanced... p1| | i Tl e
chosen MAP View. i i
Only Pseudo-Mercator-based MAP Views with zero Anti-aiasing: | Type Optimized (Hinted) -
rotation may be used for referendng.
o Image format: [PNG ~ | Compression: |6 =
Destination - Ch M Destination: Colour mode: [RGB ~
R —
gStlnatlon oosea .ap Map Provider: | [ Google Maps hd Include transparency
Provider (Google Maps, Bing Omacity o
N acity: o
Maps, OpenStreetMap, Tile e Werld Map "
Map Service, or MapBox) to - i . . AT
expgrt to. Choose ar?output Foider: cuments|Avenza\WMAPUblisher 8.6\Maps | | Browse... Options - Choose type or art optimized anti-aliasing.
. « Folder is valid. Choose an image format (PNG or JPEG), a colour

fold. d a fil .
olderandafile name mode (RGB or Grayscale). PNG can include

transparency. Adjust image opacity with the

Zoom Level Options Google Maps

Zoom Level - Choose a resolution — Opacity slider.
and number of zoom levels. Maximum zoom:  Level 16 - 2.4 meters/pixel -
Combination of the two Minimum zoom: Level 1 - 78272 meters/pixel — oo
i i oomLevel | Optons | Goodle Maps
settings determines total : S
9 b £ til Zoom levels: '—— Included Google Maps components:
number ot tiles. Total tiles: 251 Map type selector Qverview map

Scale bar Pan
Zoom Street View

Google Maps - Include Google Map components in the
HTML file. Uncheck to disable components. Tab only
available when Map Provider is set to Google Maps.

FUNCTIONALITY

MAPublisher has the ability to export the entire working artboard or document as tiled images based on several
map provider formats for use in web-based GIS.

PREREQUISITES

The MAP View must be non-rotated and have a WGS84/Pseudo-Mercator coordinate system before exporting to
web tiles. An Internet connection is required to use the online map providers after export.

Features must be within the acceptable export extents. The minimum/maximum latitude is -85/+85 degrees and
the minimum/maximum longitude is -180/+180 degrees.

USING EXPORT DOCUMENT TO WEB TILES

In the Export Document To Web Tiles dialog box, choose the source either as a specific artboard or all art in the
document. If multiple artboards are present, click the drop-down list and choose the appropriate artboard. In the
Destination section, choose a map provider, output folder and dataset name.

Several map providers are available in the drop-down list: Google Maps, Bing Maps, OpenStreetMap, Tile Map Service and
MapBox. Only the map providers Google Maps, Bing Maps and OpenStreetMap create a compatible HTML file that
combines the web tiles and uses their respective basemap style. The Tile Map Service creates an XML file and
associated web tiles. MapBox creates a file with an mbtiles extension compatible with the MapBox online system.
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Zoom Level tab

The Resolution drop-down list determines the web tile resolution and also the maximum number of zoom

levels that can be used. The resolution value ranges from 1 to 23 (depending on map provider), where a numeric
resolution value is shown for each in measurement units to pixel. Set the number of zoom levels up to a maximum
of the number chosen in the Resolution drop-down list. Higher resolution values will create more web tiles
(indicated by the Total Tiles value).

Options tab

Anti-aliasing improves image quality; choose between Art Optimized and Type Optimized. Web tiles can be created

in PNG or JPEG image format. Depending on the image format chosen, each format has several specific options
available. The Compression option is only available for the PNG format, with a compression range of 1 to 9 (1 being
lowest, and 9 being highest). The Quality option is only available for the JPEG format, with a quality range of 10

to 100 (10 being lowest and 100 being highest). The Include Transparency option is only applicable to the PNG
format. Depending on the compression or quality value, output web tile file sizes will vary. Use the Opacity slider to
set the transparency of web tiles: 0% is completely transparent and 100% is completely opaque. The Referencing
drop-down list specifies which MAP View will be used and must be WGS84/Pseudo-Mercator compatible.

Google Maps tab

These options only apply to Google Maps web tiles. The available Google Map controls are added to the HTML file
to aid in map navigation. Uncheck the options to disable them so that they are not included.

+ Map Type Selector: An option to choose standard Map view or a Satellite view

- Scale Bar: A scale bar at the lower-left of the map

« Zoom: A zoom slider widget to zoom in and out of the map

- Overview Map: An overview map available at the lower-right of the map(collapsed by default)
+ Pan: A pan widget to move the map

« StreetView: An option to include the Google Street View feature

Advanced

The Advanced dialog box has two options. Use the Export reference file option to output an associated georeference
file with each tile in World, Blue Marble Reference, or ERS format. This option is disabled by default and does not
output any reference files. Use the Export Coordinate System option to output coordinate system information in a
WKT or PRJ file. This option is disabled by default and does not output any coordinate system files.

Advanced

[] Exportreference file: World

[] Export Coordinate System: VKT definitions (*wki) Cancel

Note: World and ERS formats do no support coordinate systems. Choose Blue Marble Reference if there is a need to
include coordinate system information in a reference file or use the other option to include a WKT or PRJ file.
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Grids and
Indexes

Guti dlnd SR Pa MAPublisher contains tools to easily create map grids and
map indexes. Grids can be created for reference purposes,
or to follow designated lines such as latitude and longitude
(graticule), with optional labeling (cells or axis).

r £ A grid or a graticule can be used as a base to generate
6 o K index files. MAPublisher outputs a text file containing grid
Bl at indexes of text or map object locations that can contain map
; ’ : attribute information.
i _-F Topics covered in this section:
y Grid and Graticules
TR . Make Index
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Grids & Graticules

Object > MAPublisher > Grids & Graticules or MAP Toolbar
FUNCTIONALITY

The Grids & Graticules tool generates a grid or graticule based on a coordinate system (either of the current MAP View
or a chosen one). Each type of grid or graticule has numerous options for customizing grid lines, line labels, and cell
references. Three types of grids and graticules are available:

Index Grid | Divide the map into a grid of a specified number of rows and columns.

Graticules | Draw lines of latitude and longitude of a specified interval aligned over a
specified location.

Measured Grid | Lay out a series of grid squares of a specified linear unit size, aligned over a
specified location.

Once a grid or graticule is created, it can be resized dynamically using the corners of its bounding box anchors. To
edit it, select it and click the Grids and Graticules button on the MAPublisher Toolbar.

PREREQUISITES

Grids and graticules must be created on a MAP Legend layer. A new legend layer will be created automatically if one
is not present in the document. In the case that there are multiple legend layers in a MAP View (and neither are
selected), you will be prompted to choose one.

By default, Grids & Graticules uses Arial 12 pt black or the Normal Character Style as the style for line labels. Custom
character styles should be created (Window > Type > Character Styles) before using Grids & Graticules. Alternatively,
use the Custom mode to change text appearances directly in the dialog box.

By default, Grids & Graticules uses a default grid line style (black, 1 pt stroke width). Custom graphic styles should
be created before (Window > Graphic Styles) before using Grids & Graticules. Alternatively, use the Custom mode to
choose the style options directly in the dialog box.

The MAP View must have a coordinate system assigned in order to plot a grid. Graticules and Index Grids can be
generated for any coordinate system. Measured Grids cannot be generated for geodetic coordinate systems.
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USING GRIDS AND GRATICULES

Click the Grids & Graticules button on the MAPublisher Toolbar or from the main menu Object > MAPublisher >
Grids & Graticules.

In the Grids & Graticules dialog box, the left hand panel lists the grid collection (grids and graticules created for a
single object). Multiple grids can be created and edited in one collection. Three types of grids are available: an index
grid, a graticule, and a measured grid (if the coordinate system is not geodetic). An option to load grid settings from
an existing configuration file is available. When a grid or graticule is added or chosen, options will appear to the
right of the list. Grid line, line label, and cell reference options will differ depending on the grid or graticule chosen.

Grids & Graticules

Grid Collection: 9| [ [@)] Intervals:
NIPE-C] totiucer |4 s [ ot
Grid Lines Longitude: |4 deg
4 Grid Border Preview
Border Interval el
Line Labels Select a grid type to add T |save Settings.
Cell References 4
Grid Collection o [ Grticules Grid =]
N N Grid Lines Index Grid deg || id - Cli
Collection of grids and » Grid Border Divide the map into 3 grid o a specified number of rows and Create Grid - Click Add
graticules for one Grids & e columns - butt.on and choose
Graticules object. Use the Graticules agrid type to create.
top buttons to add, copy, Draw lines of atitude snd longjtude of 3 specified interval sligned When no grids have
° overa specified location: i
and remove grids. Use the been C{eated, th|§ is
up and down arrows to Measured Grid shodwn in the mlaln
i Lay out a series of grid squares of a specified linear unit siz Grids & Graticules
change the object draw i : dinlog b
order. Double-click grid oes 0737 n ialog box.
name to rename it. = Load From File wrism n
—!' Load grid settings from an existing config (".cfg) file
Load From File - Load a saved grid
== from a configuration file
L T =t deg
¢ Lat: | -50.000000000000 deg  lat:  -50.000000000000 deg

To save a grid (or a collection of grids) to configuration files, click the Save ~ tame  dsemsdiica  Type =
Settings button, then choose a folder to store the grids. % = % x

Two configuration files are created per grid: grid settings and label settings. . ——— B -
raticules Griducfg raticules ndex Grid.cfg Index

Grid settings configuration files store information for all related grid options e SALIE

(e.g. ticks, intervals, offsets, borders). Label settings configuration files store 3 by

information for all related label options (e.g. axis labels, fonts, styles), even

for multiple grids. Label settings are saved with a _labelData suffix. The ;

*_labelData.cfg file should not be renamed. MesrdGIAT i eibencia

When loading settings from a file, choosing the grid setting configuration file will automatically load the label
setting configuration file with the same name. If only the label setting configuration file is chosen, you will be
prompted to choose the accompanying grid.

Note: Graphic styles, character styles, fonts, and swatches that are used on one system may not be available on

another system. A warning message will appear in the event that any of these are missing.
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Index Grid

The Index Grid is a grid that is based on a specified number of columns/rows or cell size in page units. By default, the page
units are specified in MAPublisher Preferences (see chapter 1). The By cell size in page units option may result in
partial cells being created. When this option is chosen, the Partial cells get labeled option is enabled (in order to
include them in the indexing process) in Cell References. The Minimum size of cells setting is used to set the minimum
size of the partial cells to be labeled—cells that are smaller than this minimum will not get labeled and will not be

used for indexing.

By default, a grid is created for the entire extent of the MAP View. To limit the grid to only a certain extent, click the
Specify Grid Bounds option. Use artboard corners, coordinates, or MAP Locations to define grid boundaries.

See the following pages for detail on how to adjust and style grid lines, grid border, line labels and cell references.

Grid Collection:

Grids & Graticules

©| [ [©)] Srid Dimensions:

(® By number of

4 [ Index Grid

Grid Lines
4 Grid Border
Border Interval
Line Labels
Cell References

Columns: |10
Rows: |10

© By cellsize in page units
width: | 72.00pt

Height: | 72,00 pt

[] Spedify Grid Bounds:
Lower left: Upper right:
o X: | -2354989.892340765800 n o] O X: |225401.221806640737

v ¥: | 311794.894490559935 m V ¥: 3165529, 189817167842

Cancel

Preview

Save Settings.

By number of columns/rows

—— Select this option to create a
grid with the specified number
of rows and columns

o———— By cell size in page units

Select this option to specify
the cell size in page unit

(as specified in the Adobe
lllustrator Document Setup)

o————— Specify Grid Bounds - Specify

coordinates for the grid
bounds. Click the MAP
Locations button to use
defined page or world
positions or artboard corners.
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Grid Lines

Draw Grid Lines - Enabled by default. Draw
solid lines or intercepts (where grid lines
intersect). Click the style link (shows
stroke) to edit line appearance.

Grid Border

Draw Border - Enabled by default. Draws
a solid border. Optionally, choose to
increase offset from grid cells. Click the
style link to edit line appearance.

Draw Ticks Along Border - Draws tick marks
along the grid border. Choose to

increase offset from center of tick and set
orientation away from/toward map face.
Click the style link to edit line appearance.

Border Intervals

Draw Border Intervals - Draws border
intervals around the grid bounds. Use
the Minor and Major Intervals settings
to set a size (height). The Subdivide
Major Intervals option draws lines in the
subdivision intervals and can be set to
be drawn at even or odd intervals. Click
the style link to edit line appearance.

Line Labels

Coordinate Values Along Grid/Graticule Border
Click the Easting and Northing style link
to edit label appearance

Label Orientation - Settings that affect all,
east/west, north/south, or individual
labels. The West/East/North/South
settings are enabled based on
drop-down option. Click the style link to
edit its appearance.

Corner Labels - Click the style links to edit
the appearance, offset, rotation, and
format of corner labels

Remove overlapping labels

Remove overlapping labels from other
grids listed lower in the Grid Collection

Cell References

Place labels off cell by - Select a label offset
from the grid bounds

Border style- Affects border reference
labels. Click style link to edit appearance

Centerstyle - Affects center cell labels.
Click link to edit text appearance

Alpha/Numeric on left/right, top/bottom
Choose to swap the alpha and numeric
along the left/right and the top/bottom

Row/Column order - Chose descending or
ascending row/column label order
Advanced - Custom start alpha and

numeric characters, reference separator,
and reference label order

Grid Line Options:
Draw Grid Lines

®) Solid line

O Intercepts with size:

M iotBacki

Border Options:
Draw Border:
Offset from orid bounds: |0.00pt  [2] [ pt.
W iotBlack
Draw Ticks Along Border:
Ticklength: | 10.00 px
oOffiet:  [0.00px
Orientation: | Away from map face
Use grid style:
M iptelack1

Draw Border Intervals:
Style: [l LotBlack
Miter corners
Minor Intervals:
Division size: | 10.00 pt
Major Intervals:
Division size: | 10,00 pt
Subdivide Major Intervals:
Top: |Odd intervals -

Left: |Odd intervals -

Line Labeling:

Bottom: |Odd intervals

Right: |Odd intervals

Intercepts ——— + +

Ticks along border——e

Tick offset—l

Subdivide major
intervals (top)
(odd interval)

Border between Major
and minor interval border

ry

Miter corner

Border —¢

Subdivide major —4
Pt . intervals (left)
(odd interval)

pt .

Minor intervals

Coordinate Values Along Grid/Graticule Border:
Easting style: [l Arial Black, 12.00 pt

Northing style: [l Arial Black, 12.00 pt

Same orientation on al borders -
East:  Offset: 0 px, Rotation: 0

West: Offset: 0 0

Narth: Offse
South: Offse

px, Rotation: 0

Format: No formatting. no decimals

Ifline does not hit bounds, lsbel: Tore

‘Corner Labels:

Style: [ avial Black, 12.00 pt
X label orientation: Offset: 0 px, Rotation: 0
Y label orientation: Offset: 0 px, Rotation: 0
Format: o formatting, no decimals

[ Remove overlapping labels

Cell Reference Labeling:

Use easting style

t _  Comerlabel

o———————Y(Northing)

X(Easting)
i Label placement control - Click the labels to
i toggle between X, Y, Both, or Disabled

North label

34

£ e———90° rotation

Corner labels

o——Offset

37227266

West label  =>:0s57c0

Format
(decimal places)

Cell References:

Place labels off cell by: 0.00pt

Border style: W Avial Black, 12.00 pt
Center style: M ariai Black, 12.000t
Reference Order:

(@ Alpha on left/right, numeric top/bottom

() Numeric on leftjright, sipha on top/bottom

Row order: Descending
Column order: | Ascending
Advanced

Cell Ref Labels - Click the border and center
labels to toggle between enabled and disabled

Column ofder Border label
(descending)
= 10 % o— Offset
A A10 A9
Row order —
(ascending)
B B10 B9e— (Center label
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Graticules

The Graticules option places grid lines at specific intervals of latitude and longitude (in degrees). Specify the interval
for lines of latitude and longitude and, as required, a latitude and longitude value to pass through (in degrees). Use
the vertices slider to increase or decrease the number of vertices used in the graticules (use a higher number if the
graticules are highly curved due to the current projection). The Specify Grid Bounds option limits the extent of the
grid based on lower-left and upper-right values from artboard corners, coordinates, or MAP Locations. The Specify
Grid Constraints option limits the geographical extent of the grid based on lower-left and upper-right values from
artboard corners, coordinates, or MAP Locations (the minimum and maximum longitude and latitude).

See the following pages for detail on how to adjust and style grid lines, grid border, line labels and cell references.

Vertices - Use the slider
to increase or decrease
the number of nodes to
create the graticule line

Line Labels
Cell References

Cancel

Latitude interval - Specify the interval
for each line of latitude

TTT Grids & Graticules

LTTTT

117 Grid Collection: ©| [ [@] Intervals:

T Latiude: Degree
1l!.|i ..!l.- a [l Graticules Grid =i |
Grid Lines Longitude: |5 deg
4 Grid Border
Border Interval Eas= o

Input format: Decimal degrees (D+[.d*])
 Long: |0.000000

o Lat
Display Options:

0.000000

(use more for curved)

Vertices: Fewer

[] Specify Grid Bounds:
® Use current MAP View: NAD83/Canada Atias Lambert
Use: WGS 84

Format:  Projected units

Lower left: Upper right:
o X: |-1978787.153688022867 m o X: -1977424.755174499238
¢ Y: |475151.441528121350 m W Y: 477179.990865314496

[ Specify Grid Constraints:

Format:  Decimal degrees (D+(.d*T)

Preview

7| |save settings,

More

Longitude interval - Specify the
interval for each line of longitude

— Pass through longitude - The line of
longitude that must be included
(any meridian). Must be in decimal
degrees.

Pass through latitude - The line of
latitude that must be included (any
great circle). Must be in decimal
degrees.

— Speify Grid Bounds - Specify
coordinates for the grid bounds
using current MAP View or another
coordinate system

Specify Grid C - Specify
longitude and latitude coordinates
to constrain the grid

Grid Lines

Draw Grid Lines - Enabled by default. Draw
solid lines or intercepts (where grid lines
intersect). Click the style link (shows
stroke) to edit line appearance.

Show Ticks Along Grid Lines - Draw tick marks
along grid lines. Choose to place ticks at
specific intervals, specific pass through,
tick length, offset and orientation. Enable
Draw tick perpendicular to grid line to have
ticks placed at a 90-degree angle to a grid
line. Enable the Use grid style option and
click the style link to edit line appearance
(shows stroke).
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Grid Line Options:
Draw Grid Lines

@® Sold ne

© ntercepts wih size:

W LiotBck

Show Ticks Along Grid Lines:

Place tick every:
Pass through:
Tick length:
Offset:

Orientation:

Lower left: Upper right:
o Long: deg o Long:
S Lat: deg o Lat
w0.00pt
0.300000 2] [ Degee -
0.000 % deg
10.00pt 2] (ot
0.00 pt =] [t
Away from prime meridian and equator -

[] Draw tick perpendicuiar to grid line

Use grid style
W 1ptBiack
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Grid Border

Draw Border - Enabled by default. Draws
a solid border. Optionally, choose to
increase offset from grid cells. Click the
style link to edit line appearance.

Draw Ticks Along Border - Draws tick marks
along the grid border. Choose to

increase offset from center of tick and

set orientation away/toward map face or
central meridian/equator. Option for tick to
follow same direction as grid line. Click the
style link to edit line appearance.

Border Intervals

Draw Border Intervals - Draws border
intervals around the grid bounds. Use
the Minor and Major Intervals settings
to set a size (length), pass through, and
division size (height).

The Subdivide Major Intervals option
draws lines in the major intervals and
can be set to be drawn at even or odd
intervals. Click the style link to edit line
appearance.

Line Labels

Coordinate Values Along Grid/Graticule Border
Click the Longitude and Latitude style
links to edit label appearance

Label Orientation - Settings that affect all,
east/west, north/south, or individual
labels. The West/East/North/South
settings are enabled based on
drop-down option. Click the style link to
edit its appearance.

Corner Labels - Click the style links to edit
the appearance of corner labels

Line Tick Labels - These settings only
enabled when "Show Ticks Along Grid
Lines" is checked in Grid Line Options
section. Click the style links to edit the
appearance of line tick labels.

Remove overlapping labels
Remove any labels that overlap the
labels set here

Cell References

Place labels off cell by - Select a label offset
from the grid bounds

Border style- Affects border reference
labels. Click style link to edit appearance

Center style - Affects center cell labels.
Click link to edit text appearance

Alpha/Numeric on left/right, top/bottom
Choose to swap the alpha and numeric
axis labels along the left/right and the
top/bottom

Don'tlabel - Click check boxes to not label
first/last row or column

Advanced - Custom start alpha and

numeric characters, reference separator,
and reference label order

Border Options:
Draw Border:
Offset from grid bounds: [0.00pt (5] | pt.

W 1otBiack

Draw Graticule Outfine:
W iptBlack

Draw Ticks Along Border:
Ticklength: |10.00 pt

Offset: 0.00 pt.

Orientation: | Away from map face

raw tick in same direction as grid line

2 grid style:
W 1ptBlack

Draw Border Intervals:
style: [l LotBlack

Miter corners

Minor Intervals:

Interval size: |0, 160000

Pass through: |0.000

Division size: | 10,00 pt =

Major Intervals:
Interval size: |0.800000
Pass throuch: 0,000
Division size: | 10.00 pt :
Subdivide Major Intervals:
Top:  Oddintervals ~ | Bottom: | Odd intervals

Left: |Odd intervals ~ | Right: | 0dd intervals

Line Labeling:

Ticks along border —

Tick offset —

Subdivide major
intervals (top)

(odd interval) Border

RHHH

Miter corner—

HE

H
[ | T ] 1

Subdivide major —
intervals (left)
(odd interval)

Major interval size

Minor interval size—e

i
T—Minor interval division size
Major interval division size

ng o—

Coordinate Values Along Grid/Graticule Border:
Longitude style: [l Arial Black, 12.00 ot

Latitude style: [l Arial Black, 12.00 pt Use longitude style
Same orientation on all borders -

East: Offset: 0 px, Rotation: 0

West: Offse
North: Offse
South: Offset: 0 px, Rota

Format: Decmal degrees (D-+.d*T), no decmals
Ifline does not hit bounds, label: |None
Corner Labels :

Style: M izl Black, 12.00 ot
Latitude orientation:  Offset: 0 px, Retation: 0
Longitude orientation: Offset: 0 px, Retation: 0

Farmat: Decimal dearees (D+[.4*1), no decmals
Line Tick Labels:
Style: W Avial Black, 12.00 pt

Latitude orientation:  Alignment: Middle, Rotation: 0
Longitude orientation: Alignment: Center, Rotation: 0
Format:

Decimal degrees (D+[.d"]), no decimals

] Remove overlapping labels

Cell Reference Labeling:

Cell References:

Place labels off cell by: 0,00 pt

Border style: W Arizl Black, 12.00 pt
Center style: [ avial Black, 12.00 pt
Reference Order:

(@) Alpha on left/right, numeric top/bottom

() Numeric on leftjright, aipha on top/bottom
Roworder:  |Destending

Column order: | Ascending

Don'tlabel: [ ] Firstrow [ ] First column
[Jtestrow [ Lastcolumn

Advanced...

. :
Corner label |

Lat e———————latitude

Tick label

pt

Label placement control - Click the labels to
toggle between Lng, Lat, Both, or Disabled.

North label
Corner labels E E 5 e———90°rotation
73 . ie——Offset
West label 70
7 To—
Line tick label —
Can rotate to
follow line
65
5. 5
1
Coll d
OUMn OTCET g o der label
(ascendlnly)
1 2
A HH
Row order —

(ascending)
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Measured Grids

The Measured Grid option creates a grid based on a grid cell size specified in map units, when the current MAP View
is in a projected coordinate system. The cell size is specified in the Width and Height boxes (the map units can be
specified in the Units drop-down list). Measured grids may contain partial cells. The pass through can be specified
by entering an X, Y position (Grid passes through point) or choosing an alignment position relative to the page extent
(Preset origin). Grid bounds limit the extent of the grid. Use artboard corners, coordinates, or MAP Locations to define

grid boundaries.

See the following pages for detail on how to adjust and style grid lines, grid border, line labels and cell references.

Grid Collection:

4 [ Measured Grid

Grids & Graticules

Coordinate System:
(®) Use curment MAP View: - NADES [ Canada Atlas Lambert

o me

(O Specifys [Click to selected)

Grid Lines
@ Grid Border
. . Cell Siz
Grid passes through point Border Interval W‘;ﬁ"“ [om
. . Line Labels "
‘Choose t.hIS option to N feenees et —
specify coordinates for the o
XandY pass through R
(@) Grid passes through paint:
Preset origin - Choose a « : [0.000000
position for the X and  ¥: |0.000000
Y origin () Preset origins
ooo
Coordinate System 000
moo

The coordinate system of
the grid. Use the current
MAP View or an alternative
coordinate system. Chosen
coordinate system is
reflected in the grids list.

[] Specify Grid Bounds:
® Use current MAP View: NAD33 /Canada Atlas Lambert
Transform bounds from: WGS 84

Format:  Projected units

Cancel

Cell Size - Specify the width and
height of each cell in the grid. The

Mater

Preview

Save Settings,

Units drop-down provides many
units of measurements to use.

o——————— Specify Grid Bounds - Specify

coordinates for the grid
bounds based on the current
MAP View or transform
bounds from another
coordinate system. Click the
MAP Locations button to

use defined page or world
positions or artboard corners.

Draw Grid Lines - Enabled by default. Draw
solid lines or intercepts (where grid lines

Lower left: Upper right:
Grid Lines  sniuncopsons
[¥] Draw Grid Lines
(@ Solid line
() Intercepts with size: 10,00 pt &

intersect). Click the style link (shows
stroke) to edit line appearance.

Show Ticks Along Grid Lines - Draw tick marks
along grid lines. Choose to place ticks at
specific intervals, specify a pass through,
tick length, offset and orientation.
Enable Draw tick perpendicular to grid
line to have ticks placed at a 90-degree
angle to a grid line. Enable the Use grid
style option and click the style link to
edit line appearance (shows stroke).
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W 1otBlack

Show Ticks Along Grid Lines:
Place tick every: | 120000.000
Pass through: | 0.000

Tick length: 0.00pt

| Y

Offset: 0.00pt

Orientation: Away from prime meridian and equator
Draw tick perpendicuiar to grid ine
Use grid style

W 1ptBack
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Grid Border

Draw Border - Enabled by default. Draws
a solid border. Optionally, choose to
increase offset from grid cells. Click the
style link to edit line appearance.

Draw Ticks Along Border - Draws tick marks
along the grid border. Choose to
increase offset from center of tick and
set orientation away/toward map face
or central meridian/equator. Click the
style link to edit line appearance.

Border Interval

Draw Border Intervals - Draws border
intervals around the grid bounds. Use
the Minor and Major Intervals settings
to set a size (length), pass through, and
division size (height).

The Subdivide Major Intervals option
draws lines in the major intervals and
can be set to be drawn at even or odd
intervals. Click the style link to edit line
appearance.

Line Labels

Coordinate Values Along Grid/Graticule Border
Click the Easting and Northing style link
to edit label appearance

Label Orientation - Settings that affect all,
east/west, north/south, or individual
labels. The East/West/North/South
settings are enabled based on
drop-down option. Click the style links
to edit its appearance and formatting.

Corner Labels - Click the style links to edit
the appearance of corner labels

Line Tick Labels - These settings only
enabled when "Show Ticks Along Grid
Lines" is checked in Grid Line Options
section. Click the style links to edit the
appearance of line tick labels.

Remove overlapping labels
Remove any labels that overlap the
labels set here

Cell References

Place labels off cell by - Select a label offset
from the grid bounds

Center Style- Click the style link to edit the
text appearance

Axes Style - Click the style link to edit the
text appearance

Alpha/Numeric on left/right, top/bottom
Choose to swap the alpha and numeric
axis labels along the left/right and the
top/bottom

Label partial cells if cell size is larger than
the minimum size of partial cells before
being labeled

Border Options:
Draw Border:

Offset from grid bounds: |0.00pt '+ Pt
M LotBlack Ticks along border

Draw Ticks Along Border:
Tick length: | 10.00 pt = [ et
Offset: 0.00pt ] ety .
Orientation: |Away from map face ~ Tick offset _1
Draw tckin same directon 2 grid e -
Use grid style
W 2ptoeck Subdivide major
intervals (top)

Draw B:kr Intervals: (odd interval) Border
Style: 1ptBlack

Miter comers . r
Miter corner — |'L| H H _{ H H H

Minor Intervals: [TT T T TP Td

Interval size: | 24000.000 3| |Meser . . I

Pass through: 0,000 = Su_bdnvndema,or_I_

” oma =T intervals (left) 5

wvision size: o +] (ot .
(odd interval) —

=S Major interval size—é [ T ||

Interval size: | 120000.000 o] |Mer e

pass through: [0.000 I . T

o —— Minor interval size—e HH

ivision size: | 10,00 pt +| [ pt -

(] subdivide Major Intervals: . ]

Top: | Odd intervels ~ | Bottom: |Odd intervals - A Minor interval division si
inor interval division size

Left: [odd intervals ~ | might: |oddintervals - L L
Major interval division size

Line Labeling:

. X (Easting)

T—(ornerlahel Label placement control - Click the labels to

i toggle between X, Y, Both, or Disabled.

¥ e——— Y (Northing)

Yo—f———————Ticklabel

‘Coordinate Values Along Grid/Graticule Border: Nor(h Iabe|, format:
Easting style: Il Arial Black, 12.00pt N N
Northing style: [l Arl sl=ck, 12.00 pr Use easting style Full value with units

and Direction

Same orientation on all borders -

Corner labels

53689mA7

HHe———90° rotation
2741‘?15mN ._Offset

East: Offset: 0 ox, Rotation: 0
West: Offset: 0 px, Rotation: 0
North: Offset: 0 px, Rotatio
South: Offset: 0 px, Rotatio

Format: Ne formatting, no decimals
West label T

Ifline does not hit bounds, labelz |None < 2 I R T T B 11
24(9(9000mN]

‘Corner Labels : -

Style: M Ariai Black, 12.00 pt .

X label orientation: Offset: 0 px, Rotation: 0 Line tick label —————— 2100000

Y label orientation: Offset: 0 px, Rotation: 0

Format: No formatting, no decimals Can rotate to h
follow line

Line Tick Labels:

Style: M Avial Black, 12.00 pt

X label orientation: Alianment: Middle, Rotation:
¥ label orientation: Alignment: Center, Rotation: 0
Format: Mo formatting, no decimals

[] Remove averiapping labels

Cell Reference Labeling:

Column order Border label
(ascendinr)

1 2

i ——Offset

A1 A2

Cell References:

A
Row order —e
Place labels off cel by: 0.00pt 2| [ot.| (ascending)

Border style: M 2zl Black, 12,00 pt
Center style: [ izl Black, 12.00 ot
B B1 B2 «— (enter label

Reference Order:
Alpha on leftfright, numeric top/bottom

©) Numeric on leftfight, alpha on top/bottom

Row order: Descending -
Column order: | Ascending h
Advanced - Custom start alpha and
Label partial cells if cell size is larger than: | 10%|s numeric Charactel’s I'Efel'ence separator
Advanced... and reference label order
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Grid Line and Border Styles

Click the grid line and grid border style links to open the Edit Appearance dialog box. The are two modes to edit the
appearance of grid lines: Custom and Graphic Style.

Custom mode

Switch Mode - Click to switch to 2 BTl 17— Stroke Weight - Set the stroke width of

Graphic Style mode _ stroke: | [l Back - W ® e =0 & the grid/border line. 1.00 pt is default.

Stroke - Choose a colour from the | Stroke Opacity - Set the trgnsparency of
drop-down list. Alternatively, click the Cance the stroke or fill. 100% is opaque.
colour chip to pick a custom colour.
Graphic Style mode
Edit Appearance
Switch Mode - Click to switch to ——ei]| style: | []Road 14 style - Style - Choose a graphic style from the
Custom mode Graphic Style panel.
Cancel

Line Labeling

The Coordinate Values along Grid/Graticule Border options affect the coordinate labels of the grids and graticules (X,Y

for indexed and measured grids; Lat, Lng for graticules). In the label placement control, click a label indicator to
change its status: disabled, X, Y or X&Y for grids; disabled, Lat, Lng, Both for graticules. When the mouse hovers over label
indicators or label options, green highlight appears to indicate its relation.

Click the label style links to open the Edit Text Appearance dialog box. The are two modes to edit the appearance
of grid labels: Custom and Character Style. Character styles must be defined in the Adobe Illustrator Character Style
panel before use in this dialog box.

B S ESTCIE Font - Set the font family, font style, and

Toggle Mode - Click to switch to ——/| Font: | r arial « | T [12.00pt = — font size with these settings
Character Style mode Black ~ @ |wo% |3 g TextOpacity - Set the text opacity. 100%
: - = | 100 = is most opaque
Stroke/Fill- Choose a colour from the —— Stk | [ enc] =m0 =
drop-down lists. Alternatively, click the Fill: Il 5pecify colour A |
colour chip to pick a custom colour. [] Underiine
[[] strikethrough
Advanced:

Graphic Style - Choose a graphic style ——eGraphic style: | [] None] -

from the Graphic Style panel Note: Tf a Graphic Style is selected, its stroke & fl are interieaved with the

specified font stroke & fill as follows:

1. Graphic Style stroke
2. Font stroke

3. Font fill

4, Graphic Style fill

Click label orientation links to open the Label Orientation dialog box. Label offset and orientation can affect all
borders at the same time, left-right/bottom-top, or individually (west, east, north, south).

Label Orientation

Offset from border or line - Specify ———e offset: | 0.00 px 3
an offset to place labels further Cancel Rotation - Choose from
away from the border or line Rartation: Y oRg iy — T ——— Norotation, 90° counter-clockwise,

90° clockwise, and 180°
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For Line Tick Labels, click the Format links to open the Label Orientation dialog box (Graticules and Measured grids).

Label Orientation

Position: Middle -
Offset: 0.00 px B Cancel
. ) == Additional rotation - Choose from
Base rotation - Set tick ——ase rotation Bttt pacg e No rotation, 90° counter-clockwise,
label to be flush with Additional rotation: |No rotation v e—————— 90° clockwise, and 180°

page or follow grid line

Click the Format links to open the Label Format dialog box (applies to Index and Measured grids).

Label Format - Available UTM format styles or Label Format
choose No UTM Format:
—e Label format: No UTM Farmat M oK .
TEAIE .t e s e % I hoplytocateormatting
E1234000 Full value with Direction prefix Number of decmals: |0 |3 Cancel to numbers - Apply
EMM flvae i Label values: Coordinates b number formatting
34 Thousands with leading value i, according to the locale
34 Thousands value anly ] Append urits to lahel orain ‘
3 Ten Thousands value only FESL IR TR settings in MAPublisher
Label values (Index grids only)/ Append units to labels (] Aply locale formatting to numbers Preferences. Only for
Include unit to labels. Index grids.
For a graticule, only these label formats apply:
Label Format

Label Format - Choose a label

format style. The drop-down —e Label format: Decimal degrees (0+.d%]) -
list includes Degrees Minutes

Seconds format variations.

Number of decimals: |0 i

Cell Reference Labeling

The Cell References options affect the indexing labels of grids and graticules. In the label placement control, click a
label indicator to change its status: border labels (A, B or 1, 2) and center labels (A1, A2, B1, or B2). When the mouse
hovers over label indicators or label options, green highlight appears to indicate its relation. To swap the border
alpha and numeric border label positions, choose either Alpha on left/right, numeric on top/bottom or Numeric on left/right,
alpha on top/bottom. The Row order and Column order settings set the border labels in ascending or descending order. The
position is relative from the top-left corner of the grid. Specify the border label distance from the grid border using

the Place Labels off cell by setting—a negative value places labels inside the grid. Click the Center style and Border style
links to edit text appearance.

Advanced Cell Reference Labeling

Click the Advanced button to access additional grid extents and labeling options.

Advanced To edit the first alpha or numeric value used for cell labels, change the Start alpha
e — index at or Start numeric index at values. To omit certain alpha characters from cell
Start alphaindexat: |4 o references, enter them into the Do not use characters box. For example, it may be
ancel
Start rumeric index at |1 useful to omit the characters “”and “O” for indexing purposes (when entering

Do not use characters:

alpha characters to omit, separate characters with a comma). Enter a character
into the Reference separator box. For example, a ~ separator will yield a label like so:
A~1.The Reference label order can be set to either alpha-numeric (A1) or numeric-
alpha (1A).

Reference separator:

Reference label order: 14
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Generating and Editing the Grid

G e When all the options have been set, click the Preview button to display a preview of the result. The

— Grids and Graticules dialog box can be minimized in the preview mode by clicking Hide In Preview.

Cancel

Click OK to create the grid or click Restore to return to setting up the parameters. The grid is plotted
on the legend layer using the entered parameters.

Restore

When the grid is added to the artboard, use the bounding box of the generated grid (View > Show Bounding Box) to
resize it. Resizing grids horizontally or vertically will add, remove or resize (index grid) component cells in the grid.
All grids within a grid collection will be affected. Note that grids with specified bounds cannot be resized this way.

After transforming a MAP View containing a grid, the grid will be transformed and scaled within its current bounds
(the physical extents of the grid on the page is not edited). The grid may have to be resized manually.

To change any parameter without generating a new grid, simply select the grid and click the Grids & Graticules
button from the MAPublisher toolbar. This opens the Grids and Graticules dialog box populated with the current
parameters of the grid. All parameters can be edited, even the grid type selection.

IMPORTANT NOTES

Manually editing grid text positions, fonts, and colours is not possible in its default custom art state. To manually
edit a grid, it will need to be expanded (Object > Expand). However, this will prevent any opportunity to further edit
the grid using the Grids & Graticules dialog box. When expanded, grids cells are converted to both polygons (from
index) and lines.

Please see Appendix A3 for more information on working with grids and graticules in MAPublisher.
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Make Index

Object > MAPublisher > Make Index or MAP Toolbar

Make Index
Current Grid: - Select from available grids ———- Current Grid: Save As...
or MAP Area layers to make index from
GridName:  Index Grid Cancel
MAP View: @ Vancouver
Layer: B Legend Advanced... | e=— Advanced - Click this button to open
the Advanced Options dialog box
Specify Grid... (below) to specify additional options
for the index format
Make index based on label position - An index ) Make index based on label position
will be created by assigning one index TR Fram s =
location for each label found on the
selected label textlayer U, @) wae index based on label and matching feature positon
Make index based on label and matching Labellayer: Feature Labels i
feature position - MAPublisher will Feature layer: Hotels_paint -
determine what features to index by
matching label text on the indicated Label text matches attribute: | (6] HOTEL_NAVE e wly iter th
Label layer to the indicated attribute Spatially filter the sourceart
on the Feature layer. An index will be [0 Make index based on feature positon and atirbute value Check this checkbox to limit
created for every grid cell in which the Feature layer: | [2] Holels_point . Icr;wdoes);rtwoblgﬁigiﬁr a";‘)”n:eeftsrec“ng
labeled feature can be found. 99 Yy
Attribute: @® #Opacity -
Make index based on feature position and Byarton Iayer - 59|9CF alayer and
attribute value - An index location is [ spatial fiter the source art corresponding attributes to filter by
added for each feature found on the ) .
selected label Feature layer. The index ® By art onlayer: B Lond_area . = UMS,I:IE g:lpescetlieo(rt\“t,g ;‘lfteelre;t asaved
label will be the value of the selected ) Y
Attribute for each feature. e M
Specify Bounding Attributes Specify Bounding Attributes - Select
one or more attributes from the
bounding art to be included in

the index
.
Advanced Options
Advanced Options
Sortby - Choose to sort the Sart By: |[Feature label - Select Additional Attributes:
entries in the index file by [ indude ketter headers From: [H canada_area —
either Feature label or Grid [ £0pacity
cell address T ‘im’m Format: [ #ComponentCount
® single-ine condensed [l #LayerName
Output Format ") Single-ine expanded & #1d - )
Single-line condensed O Mitine [ #Name Select Additional Attributes
Creates one index entry B FAreaDirection Select one or more
for each unique label. The ~ —® [ Treat grouped textas a singe entry attributes to be added
index is compressed in the 3 to the index file. The
format: A1-3:82,4 Specify Index Separator: 2Perimeter selected attributes appear
: e Label [tab | Attribute [ | A [<> | 2 [-] 5[] 7 ;] 82 ::atI;C\Iosed in separated columns
2] rtScale P
Single-line expanded To<hnge h st v St o e i the WAP 2Area delimited by the chosen
Creates one index entry Attributes panel. 6 cope Index Separator.
i [E NAME

for gach unique label. The Sample Indexes: sopatt

index is in the format: Toronto Ontarie  AS-7;B3

A1,A2,A3,B2,B3 Edmonton A2E3 SQKM_2001
Vancouver AC2L2,
Multiline a2 Haspital;Zoo
Creates one index per [Enss [ Apply locale formatting to numbers (2.g. thousand Apply locale formatting
label recurrence to numbers - Choose to
. J . apply locale formatting
reat grouped text as single entry — . e.0. decimal separator
Select this option to create a Specify Index Separator— — Click a button to open the g. P
oF " " as dot or comma), see
single index for grouped text Select a delimiter to separate the Edit Separator dialog box. MAPublisher Preferences,
different elements of the index file: Choose between Tab, None .
label, attribute, grid column, grid or a Custom separator.

row, continuous spanning, discreet
spanning and next in the list. Choices
are reflected in Sample Indexes.
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FUNCTIONALITY

The Make Index feature can be used to generate a map index based on the position of text elements or map features
in a grid (index or measured), a graticule or a MAP Area Layer. Index files generated using this function are produced
as a simple text file and sorted alphabetically (by label or cell reference). A typical file would be formatted as follows:

Millwood Road B4
University Street A4
Broadway Ave BS5

For text elements, the position of the first letter of the text is indexed. For map features of type Line or Area, all cells
intersecting the feature are index. For map feature of type Point, the center of the symbol is indexed.

The index file contains a header indicating the name of each column (name, attribute name [if applicable], and grid
locations).

Note: Overflowing text that is not visible on the page can't be indexed.

PREREQUISITES

To create a map index, an Index grid, Measured grid, Graticule or MAP Area layer can be used. This grid must exist on
a Legend layer and not be expanded (by Adobe lllustrator). An index will be created even if grid labels are hidden.

The Text layer containing the labels to be indexed and/or the Feature layer must be located in the same MAP View as
the grid.

USING MAKE INDEX

Click the Make Index button on the MAPublisher Toolbar or from the main menu Object > MAPublisher > Make Index.

«  The selected grid will be used as the index reference.

« When no grid is selected, Make Index will detect a grid in the document. If more than one grid is
found, the Select Index Grid dialog box opens. Click the Previous Grid or Next Grid buttons to browse through
available grids in the document. The selected grid is highlighted on the artboard.

«  Alternatively, Use area layer as grid (choose appropriate area layer and grid label attribute). This layer can
be of irregular shape (non-rectangular).

Select Index Grid
(®) Use index grid
More than one grid was detected, please select the grid you Cancel
wish to use for this Index
Grid Name: Index Grid
MAP View: & Vancouver
Layer: B Legend
<< Previous Grid Next Grid >
() Use area layer as grid
Area layer: A Water_area
Grid label attribute: #Opacity
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Index Based on Label Position

Select the Make index based on label position button to generate an index using this method. Then choose one or

more layers containing the text to be indexed from the Label layer drop-down list. This method creates an index by
assigning one index location for each label found on the selected text layer. For example, if the label "High Street" is
only found in grid cell A4, the only entry for "High Street" in the index file would be as follows: High Street A4

Index Based on Label and Matching Feature Position

This method creates an index by matching label text on a selected Label Layer to the indicated attribute on the
Feature layer, creating an index entry for every grid cell in which the feature can be found. Note that only features
that have labels will be indexed. For example if "High Street" passes through grid cells A3, B3 and C4, each grid cell
will be in the index — on a single or multiline (see advanced options). For example as: High Street A3, B3, C4

Use this function as follows:
Select the Make index based on label and matching feature position option to generate an index using this method.
Choose the layer containing the text to be indexed from the Label layer drop-down list.
Choose the layer that was used to generate the labels from the Feature layer drop-down list.
In the Label text matches attribute list, select the attribute column in the selected Feature layer which matches
the labels to be indexed.

Index Based on Feature Position and Attribute Value

This method creates indexes for map features that have not been labeled.

The map features to be indexed are contained in the selected feature layer. Any MAP Layer of type Point, Line or Area
contained in the same MAP View as the grid can be selected.

The index position is based on each feature on the grid — for Area and Line layers all cells that intersect with the
feature are indexed; for Point layers the cells that contain the center of the feature symbol are indexed.

The actual index label listed in the output index file corresponds to the value of the selected Attribute.

Spatially Filter the Source Art

This option affects the range of feature labels, feature labels and art, or pieces of art selected to be indexed.

Choose the Byart on layer option to limit index creation to those entries that intersect the bounds of the art on the
specified layer.

Choose the Using MAP Selection option to limit index creation to those entries that intersect the bounds of the art
selection resulting from the application of the chosen pre-defined MAP Selection.

Click the Specify Bounding Attributes button to open the Specify Attributes dialog box. Use this dialog box to select
multiple attributes from the bounding art to be included in the index.
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Advanced Formatting Options

To set additional options to control the formatting of the index file, click the Advanced button.

The Sortindex by option controls the order of the index entries. The default setting is Feature label — entries are
ordered based on the label text (alphabetical). Alternatively, Grid cell can be selected to sort by the cell indexes.

The Specify Index Separator indicates which delimiter is used to separate the different columns in the index file (label,
additional attributes and indexes). To change a specific delimiter, click the separator button in between the two
desired elements. The separator options are Tab, None, or a Custom delimiter. When using a custom delimiter, type the
desired character(s) in the adjacent text field. The separator settings are reflected in the Sample Indexes section.

The Treat group text as single entry option is required to create a single index for grouped text. Enabling this option is
recommended to create index for labels created with MAPublisher Label Pro because the generated text is often
grouped (e.g. multiline labels or along a curve).

There are three output formats for indexes (examples are using the default separators):

Output format Description Example Notes

Single-line condensed | One index for Label A1-3; |+ Adash (-) indicates a range: A1-3 means the label
each unique B2,4; F-H9 is found in cells A1, A2 and A3; F-H9 means the
label is created, label is found in cells F9, G9 and H9. The ranges
condenses grid by number are grouped first and then the
locations ranges by letter.

« A comma (,) indicates a list: B2,4 means the label
is found in cells B2 and B4 but not B3.
+ A semicolon (;) separates each entry.

Single-line expanded | One index for Label A1, « A comma (,) separates each entry.
each unique A2,A3,B2,
label is created B4, F9, G9,
H9
Multiline One index Label Al » Each entry is on its own line
for each cell Label A2
reference is Label A3
created

Users can add more attributes to the index file by selecting one or more attributes from the Select addition attributes
drop-down list. Additional attributes are inserted in the file in columns between the label and the grid locations,
separated by the chosen Index Separators. For example:

Label Attributel Attribute 2 A1-3;B2,4;F-H9
Note: Duplicated labels that have different selected attribute values, will have a separate entry in the index file

(single-line options). Duplicated labels that share the same attribute values will have a single index entry but
each location will be reflected in the cell references.
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The Apply locale formatting to numbers option applies number formatting according to the locale settings in the
MAPublisher General Preferences (e.g. 10000 may be written 10,000 or 10.000 or 10 000).

Saving the Index File

When all indexed options have been set, click the Save As button. Then specify a name for the text file, and the
location where it will be saved. The index file can be opened in a text editor, or placed back into the document
using the Adobe lIllustrator Place function.
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Scale Bars and
North Arrows

MAPublisher contains tools for plotting accurate scale bars
and north arrows onto your map.

The Scale Bar tool offers a number of different designs that
you can choose from, including double-bar designs for the
placement of scale bars in multiple units.

North Arrows are created from selected artwork on the page
using the Create North Arrow tool and are immediately aligned
to true north.

Topics covered in this section:

Scale Bar
Create North Arrow
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Style - Choose a style to browse

Scale Bar

Object > MAPublisher > Scale Bar or MAP Toolbar @

Object > Edit Scale Bar

Scale Bar

the different scale bar styles

Style: |Simple -

Preview scale - Displays a preview
of the generated scale bar.
Adjust quality if required.

Units - Select the desired
map units to be used in the
selected scale bar

Interval - Specify the length of
each interval in the selected map
unit. Enable Maintain relative size
to convert interval values when
units are changed

Height - Specify scale bar height

Appearance - Edit scale bar appearance

Tick label appearance - Select the
Adobe lllustrator Character
Style to be applied to the text

Tick label spacing - Specify the
spacing between the scale bar
and scale bar label.

Display scale value - Check this
option to enable options to
position the scale value above
or below the bar and left,

0 600,000 1,200,000 1,800,000 2,400,000
Preview quality: Medium  ~ Show actual size
Intervals | Labels
Main Bar Unused
Units: Mater - -
Interval: 600000 ] 600000 }@

Number of labeled intervals:

Mumber of horizontal ines:
Mumber of intervals to sub

Number of sub-intervals:

Maintain relative size

V| Maintain relative size

4interval(s) 2] 4intervalls) z
0line(s) 2| olines) z
divide: |0 interval(s) 3 ointervalis) o
2subinterval(s) | 2 subinterval(s) +

Apply locale formatting to numbers (.. thousand separators) in interval labels

[ Add interval left of '0"

Cancel

Height: 20,00 px z
Appearance: [0 1ot Bladk / None]
Scale Bar
s [smie v

o

600,000 1,200,000

1,800,000 2,400,000

Preview quality:  Medium
Intervals | Labels

Tick label appearance:

Tick label spacing:

center or right aligned.

Display units to right of last interval label
Check this option to display the
interval unit at the end of the last
interval label.

Display page to map units ratio
Check this option enable
options to show the scale as
page unit to map unit ratio
(select from Inches, Centimeters
and Millimeters), the decimal

precision and placement.
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Scale Bar

[] Display scale value:

W Avisl Black, 12.00 pt

[T] Display units to right of last interval label

["] Display page to map units ratio:

Page units for captions:

Predision:

Flacement:

Show actual size

3,00 px B
i Show above ~ | | = Align center -
Inches =
2 decimal(s) :
i Show above ~ | = lign center -

Cancel

Number of labeled intervals - Enter
the number of interval which will
comprise each bar

Number of horizontal lines - Select
the desired number of horizontal
lines to be included in the scale
bar. Used with certain scale bar
styles only

Number of intervals to subdivide
Enter the number of scale bar
intervals to be subdivided

Number of sub-intervals - Select the
number of sub-intervals for each
subdivided scale bar interval

Apply locale formatting - Use the
locale format settings specified
in the General section of
MAPublisher Preferences

Add interval label left of '0' - Places
an interval label left of the zero

marker on the scale bar.

Customize Labels...
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[¢ ize Labels

Opens the Customize Labels
dialog box. Use it to change the
label of page and world units
and adjust the appearance and
variable of scale and ratio labels.
See next page.



Customize Labels

Page unit and World units - Check Unit Label Overrides
these options to be able to 8, ! Page unit Inch Cancel Apply locale formatting to numbers
specify custom labels. These World units (Main 8ar): | Mie Insert a comma (or another
override the unit labels specified Reset locale format) to the scale and
in the Scale Bar dialog box. Formatting: ratio numbers.
Apply locale formatting to numbers (e.g. thousand separators) in Scale and Ratio ®———————————7
Scale Appearance = Scale appearance: [l ArialBlack, 12.00 ot

Set the scale label style in the
Edit Text Rendition dialog box.

Scale Label and Ratio Label

Set the scale or ratio label. Use
the variables available below. A
preview of the scale or ratio is
shown below the text box.

Scale label: Scale 1:%scale%
Scale 1:21,602
= Ratio appearance: [l Arial Black, 12.00 ot
Ratio label: 1 %page_unit% = “worid_per_page% Y%world_units%
1Inch = 548.69 Mile

Variables:
iables - Use these Variable Name UseableIn  Description
variables in the Scale and Shscale% Scalelabel  Scale value
Ratio label text boxes Y%page_unit¥% Ratiolabel  Value entered in 'Page unit'
: Yoworld_units% Ratio label  Value entered in World units'

“norld_per_page%  Ratiolabel  World units per page unit

FUNCTIONALITY

MAPublisher contains ten different scale bar designs that may be incorporated into a map. After creation,
MAPublisher scale bars can be subsequently resized using the bounding box (for example to add or remove
component intervals). Scale bars can also be edited by selecting the Object > Edit Scale Bar menu item.

PREREQUISITES

To accurately create a scale bar, a MAP View must contain accurate georeferencing information and the coordinate
system must be projected. (i.e. not in degrees). Scale bars are added on Legend layers. If no legend layer is present

in the document, a new legend layer will be created automatically. To manually create a new Legend layer, use the
Add MAP Layer button on the MAP View panel and specify a feature type of Legend (see chapter 4 for more details).

If a custom character style is to be used for the labels of the Scale Bar, it is also advisable to establish this style
(Window > Type > Character Styles) before opening this dialog box. Alternatively, use the Edit Text Rendition dialog

box to specify the font, colour, size and style of text to use.

Note: A scale bar cannot be created on a MAP View that contains a coordinate system using custom (user defined)
point styles or units.

ADD A SCALE BAR

Click the Scale Bar button on the MAPublisher toolbar or choose Object > MAPublisher > Scale Bar.

General Options

Use the Style drop-down list to select a scale bar design. Note that some scale bar designs contain two bars and
when such a design is selected, the Second Bar column of options is enabled.
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Interval Tab Options

In the Units drop-down list, specify the units for the scale bar intervals to be based on. The default units are that of
the current MAP View.

In the Interval text box, specify a real-world distance that each interval of the scale bar will represent. This number
will be in the unit specified in the Units list.

Specify the number of cells in the scale bar by entering a number in the Number of labeled intervals scroll box.

Depending on the chosen style of scale bar, it may be required to specify the Number of horizontal lines that will
compose the scale bar.

To subdivide some of the intervals or cells in the scale bar, specify a number in the Number of intervals to subdivide scroll
box. The subdivided cells begin at the left side of the scale bar. The Number of sub-intervals that compose each of these
cells can be specified in the next scroll box. As required, choose to Add an interval left of '0'.

Labels Tab Options

Click the Tick label appearance to adjust the tick labels of a scale bar in the Edit Text Rendition dialog box. Choose a
predefined Character Style in the Graphic Style mode or set font, stroke and fill options in the Custom mode.

In Graphic Style mode, labels can be styled using predefined Adobe Illustrator Character Styles. Graphic Styles can
be applied to these labels by choosing one from the Graphic style drop-down list. In Custom mode, labels can be
styled using the font, font size, stroke, stroke width and fill options available.

Edit Text Appearance Edit Text Appearance
Font: | T Arial v T 1200pt [ ty]| Character style: | [ ] [Mormal Character Styl] A
Black e Cancel Cancel
Stroke: Z [None] - Z = L00pt E
Fil: | [llslack Al |
["] underline
[] strikethrough
Advanced: Advanced:
Graphic style: | [] [None] - Graphic style: | [/] [None] -
Note: If a Graphic Style is selected, its stroke & fill are interleaved with the Note: If a Graphic Style is selected, its stroke & fill are interleaved with the
spedified font stroke & fill as follows: specified font stroke & fill as follows:
1. Graphic Style stroke 1. Graphic Style stroke
2. Font stroke 2. Font stroke
3. Font fill 3. Font fill
4. Graphic Style fill 4. Graphic Style fill
Custom mode Character style mode

Adjust the Tick label spacing to increase or decrease spacing between the tick label and the scale bar.

The Display scale value option shows the scale value above and to the left of the scale bar (by default). The position
and alignment can be changed using the respective drop-down lists. The Display page to map units ratio option adds the
page unit to map unit ratio label (select from Inches, Centimeters and Millimeters). Use the decimal precision and
placement options to adjust the appearance as necessary.
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To further enhance the look of scale bar labels, click the Customize Labels button. Under the Label Unit Overrides
section, check the options to override the Page unit and World unit labels and type text into the text boxes. Under
the Formatting section, click the Scale and Ratio appearance links to open the Edit Text Rendition dialog box (same
as above) to adjust the font, color, size, stroke and fill of the scale and ratio labels. Type text into the Scale and Ratio
label text boxes to specify custom labels along with using the available variables (e.g. %page_unit%). The variables
represent stored values from the Scale Bar dialog box and the map document. A preview of the scale is shown
below each of the text boxes.

Click OK to place the selected scale bar on the legend layer at a default position (centered on the artboard).
The Adobe lllustrator editing tools may be used to move the scale bar to a desirable location.
EDIT SCALE BAR APPEARANCE

In the Scale Bar dialog box, click the Appearance link to change the scale bar appearance. The Scale Bar Appearance
dialog box consists of settings to change the Main colour and Alternate colour.

Main colour Alternate colour Stroke
= ! ! oK
N Cancel
o 600 1,200 1,800 2,400
Scale Bar Appearance
Main colour: | [l Black - W ® %] =t
Alternate colour: | [ c=s0M=0Y=100k=0  ~ |[] ¥ 100% % l Cancel
Main and alternate swatch colours Opacity Stroke

To adjust the height of the scale bar, edit the Height value. Changes are reflected in the preview.

After the scale bar has been created, use the bounding box of the generated scale bar (View > Show Bounding Box)
to resize. Resizing scale bars horizontally will automatically add or remove intervals from it. Resizing vertically will
adjust the width of the bars. Scale bars can also be resized using the Adobe Illustrator menu Object > Transform >
Transform Each, by changing the horizontal or vertical scales.

To change the style of the scale bar or to modify any parameter without generating a new one, select the scale bar
and click Scale Bar button on the MAP Toolbar. This will re-open the Scale Bar dialog box and the current parameters
of the bar are available for editing.

Note: Manually editing a scale bar is not possible in its default grouped state. However, manual editing is still
possible if the object is expanded first (Object > Expand). Note, that this will break the dynamic link between
MAPublisher and the scale bar and it cannot be edited using the Scale Bar dialog box. Please see Appendix
A3 for more information on working with scale bars in MAPublisher
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Create North Arrow

Object > MAPublisher > Create North Arrow or MAP Toolbar
FUNCTIONALITY

The Create North Arrow tool converts a selected symbol into a directional true north arrow.

In this process, the selected symbol is rotated toward true north at its location. This property is maintained through
subsequent moves of the map, projection or rotation.

The true north is the direction to the geographic North Pole — this direction may vary on a map depending on the
selected MAP View coordinate system. To visualize this, think of the lines of latitude in a graticule (see chapter 13) —
these lines can be straight or curved.

Note: True north usually differs from magnetic north (the direction of the magnetic north pole, which varies in time
and space) and grid north (the direction northwards along the measured grid of a projected map).

PREREQUISITES

Any Adobe lllustrator symbol may be used to create a north arrow. The only requirement is that the symbol is placed
on a Legend layer (within a MAP View) and must be selected.

Note: Sample north arrow symbol designs are included with MAPublisher. In the Symbols panel options menu,
choose Open Symbol Library > MAP Symbols > Other Symbols > North Arrows.

CREATING A NORTH ARROW

Select the symbol to be converted to a north arrow and click the North Arrow button on the MAPublisher toolbar.
Alternatively, from the main menu Object > MAPublisher > Create North Arrow.

Upon creation, the selected symbol is aligned to true north, based on the coordinate system of the MAP View and
its position on the map. If the north arrow symbol is repositioned on the map, it will be re-oriented to true north at
the new location.

Note: If the selected art is not already a symbol, it needs to be converted to an Adobe lllustrator symbol. Simply
add it to the Adobe Illustrator Symbols panel.
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MAP Web
Author

Users should have a basic understanding of HTML and
general web terminology to use this feature.

MAP Web Author creates interactive Flash and HTML5 web
maps. Flash maps are supported when the Adobe Flash
Player plug-in is installed. HTML5 is natively supported by
many of the leading web browsers.

Export Adobe Illustrator documents with GIS attribute data to
interactive web maps complete with callouts, rollovers, layer
control, search, pan and zoom controls. Additionally, web
map export offers controls for the layers visibility and map
features (points, lines, and areas).

Users with a good understanding of HTML, CSS (Cascading
Style Sheets) and JavaScript will be able to customize maps
to embed into any webpage using the MAP Web Author API
and CSS tools.

Topics covered in this section:
MAP Web Author Workflow
MAP Web Author Panel
Edit Web Tag

Export to Flash

Export to HTML5
Advanced Features
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MAP Web Author Overview

MAP Web Author creates interactive Flash or HTML5 maps for display in a web browser. Users can either create
new or work with existing documents to create web maps. Create web tags (callout bubbles) to display attribute
information about features. Although the web tag creation process may feel similar to both Flash and HTMLS5, each
web map type has it's own unique differences.

Creating a Flash map requires the Adobe Flash Player plug-in. Exported maps are based on Flash technology and
can only be viewed with web browsers that support the Adobe Flash Player. Mobile web browsers may not be able
Flash compatible. Creating graphs and expressions in web tags are only available in Flash.

Creating an HTML5 map does not require any extra plug-ins. Most modern web browsers are natively compatible
with HTMLS5, including mobile web browsers. A fundamental difference between HTML5 and Flash maps is the way
HTML5 handles the artwork. Vectors are rendered as vectors, including symbols and other line work. Map tiles are
created for the base layer.

MAP WEB AUTHOR WORKFLOW

The following workflow outlines the major steps to create a web map.

1) Design map with considerations for a web map
Create a map document for viewing on the web while taking into consideration purpose, document size, and how it
will be viewed (on desktop or mobile device). To create Flash maps, ensure the latest Flash Player version is installed.
2) Preparing for MAP Web Author

a) Create a working directory and source media folder

Create a folder to store all the components for the web map and the exported Flash or HTMLS5 files.

b) Prepare attribute table information

To use attribute information for web tags, it must be organized using the MAPublisher MAP Attributes panel.
This may require creating new attribute columns for elements such as website links or graphic file paths.

c) Prepare data
Optimize the map by removing unused art. Use the crop tool, generalize features, simplify lines, and remove
unneeded attributes.
3) Using MAP Web Author
a) Choose the source media folder
Choose an absolute or relative path to the Source Media Folder. It contains images used in web tags.
b) Create callout bubbles

Use the Edit Web Tag dialog box to insert content (such as a title, images and text) and use the Show Preview
option to see an example of how the callout bubble will look prior to the export process.
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4) Export to Flash or Export to HTML5

Export the map to either Flash or HTML5. Each has its own unique settings. It is recommended to try different
configurations to achieve optimal results as maps vary widely.

5) View exported maps with a web browser

Update to the latest version of Firefox, Internet Explorer, or Chrome web browser. HTML5 maps can be viewed in
any of these web browsers and mobile browsers such as Mobile Safari. To view Flash maps, ensure the latest Flash
Player version is installed. Flash maps may not be supported in mobile browsers.

WEB MAP EXAMPLES

Entertainment
Choose Venue

Services

[ehooseservesr  [¥

OVERVIEW MAP.

NISKAYUNA
2IP 12309

USING YOUR MAP,

PROPOSED
METRUS
DEVELOPMENT
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MAP Web Author Panel

Window > MAPublisher > MAP Web Author or MAP Toolbar

MAP Web Author Panel
MAP Web Author & - -
E‘ ! Specify Source Media Folder...
R EILIE - Specify Source Media Folder - The local
Edit - Open the Edit Web Tag dialog directory of media files
box. Create or modify web tags ———— Edit ‘ ‘ Remove ‘ ‘ Flash | ‘ HTMLS ‘ -~ Export to Flash or HTML5 - Open the
Remove - Delete web tags of any i Export to Flash or Export to HTML5
selected objects Selection: dialog box to choose export settings
AllWeb Art - Select all artwork that have — L | ]l Web Art| Web Art On Layer Web Art On Layer - Select all the artwork
a web tag in the document that have a tag in the currently
13 pieces of art selected selected layer
Specify Source Media Folder
Specify Source Media Folder —— Browse - Browse to the directory
Absolute Path - Choose this option to [ containing the media files (images and
set an absolute path (best used when Source media folder: Browse... Flash animations)
working on a single computer) () fbsolutepath @ Relative path Cancel
Relative Path - Choose this option to set reset *——— Reset- clear the current Source Media
a path relative to the current location An mpty relative path indicates the ssme fokder as the document. Folder settings
of the Adobe lllustrator document

(best used when files have to be
moved). Newly created documents must
be saved for this option to be enabled.

FUNCTIONALITY

MAP Web Author is used to export MAPublisher documents as interactive Flash or HTML5 maps for display in a web
browser. Together with the map artwork, web tags (also known as callout bubbles) are included in the export. Prior
to the export process, the MAP Web Author panel is used to create, edit or modify interactive objects.

Web tags can either be populated one object at a time or for a selection of objects. To create or edit multiple web
tags, select artwork and click the Edit button. Using this method, the same web tag format is applied to all selected
artwork. Information can be entered manually or extracted from MAP Attribute fields (when available for the object

layer). At any time, web tags can be edited or modified.

Text and image formatting is created using simple HTML (Hyper Text Markup Language). The results can be checked
in the Show Preview window available in the Edit Web Tag dialog box.

Additional settings such as customizing the navigation and callout bubbles are available during the export process.
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PREREQUISITES

The Adobe lllustrator artboard will determine the size of the web map. It is recommended to set an appropriate
document size before completing the map (using the Adobe lllustrator Artboard Tool). Using pixel units is the most
practical to determine web map sizes suitable for a web browser.

To populate web tags, MAP layers must have relevant attributes populated in their MAP Attributes tables. For example,
to insert links to graphics (images and Flash animations [Flash only]), the MAP layer can have a dedicated attribute
field containing a path (e.g. \images\picture1.jpg). The Source Media Folder containing the graphics must be organized
properly. The supported image formats are JPEG, PNG and GIF and supported Flash animation format is SWF.

Notes: Not just any map can be made into a web map. A print ready map does not necessarily mean that it is ready
to be a web map. Extra art and unused attributes should be removed and lines should be simplified or
generalized. Layers that do not require tagging will still be exported.

Only the active artboard will be exported as a web map.
The MAP Layer image attribute type is not supported when exporting a web map.

MAPublisher exported Flash web maps require Flash Player to be installed. A link to download Flash plug-in
appears if a browser does not have it. To ensure compatibility, download and install the latest Flash Player at
http://get.adobe.com/flashplayer. HTML5 web maps do not require any plug-ins to be viewed, only an up-to-date
web browser is required.

USING MAP WEB AUTHOR

Specify the Source Media Folder

The Source Media Folder is the directory containing graphics that might be displayed in the web tags (callout bubbles).
The path to this directory is chosen through Specify Source Media Folder in the MAP Web Author panel options menu.

Either an Absolute Path or a Relative Path may be entered. An absolute path refers to the full folder directory path
(e.g. C:\folder1\folder2...). A relative path refers to the folder path from the current location of the Adobe Illustrator
document. In the example below, the relative path starts from \MAPWebAuthor_Tutorial.

Absolute Path example < tewiviskicy Relative Path example 1 mapwebauthor Tutorial

| MAPWebAuthor_Tutarial | A Flash_Canada.ai
}2l| Flash_Canadaai | ImageFiles AB.png
BC.png
_] ImageFiles ABpng

Canada.png

8C.png
Canada.png
MB.png
NB.png
NFpng
NS.png
NV.png
NWT.png
ON.png
PELPNg
ac.png
sK.png
YK.png

MB.png
NB.png
NFpng
NS.png
NV.png
NWT.png
ON.png
PElLpng
QC.png
SK.png
YK.png

If the Adobe lllustrator file is to be exchanged between computers, it is good practice to use a Relative Path to avoid
having to reset the link to Source Media Folder when the files are moved.
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Add, Edit and Remove Web Tags

To add or edit a web tag, select a piece of artwork and click the Edit button in the MAP Web Author panel. In the
Edit Web Tag dialog box, use the options to define web tag settings (see next section). When multiple artwork is
selected, any settings made in the Edit Web Tag dialog box are applied for all of the selected artwork. They may be
individually modified by scrolling through the web tags or at a later time by selecting the artwork and clicking the
Edit button.

To remove web tags from selected artwork, click the Remove button in the MAP Web Author panel.

Notes: Document artwork (lines, areas, points) associated with callout bubbles are also called web art. Only web art
will be searchable in a web map. Text cannot be tagged as web art.

Grouped art will not display attributes.

Selection

Select artwork in the document and the MAP Web Author panel displays if it is web art. To only select all artwork
with web tags, click the AllWeb Art button. To select all artwork with web tags on a specific layer, select the layer in
the Adobe lllustrator Layers panel, and click the Web Art On Layer button.

Export

A map can be exported in two formats: Flash and HTMLS5. In the MAP Web Author panel Export section, click either
the Flash button or the HTML5 button to begin the export process (opens the Export to Flash and Export to HTML5
dialog box, respectively). See the Export to Flash and Export to HTMLS5 sections for detailed information.
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Callout options - Change available —

options based on callout type

Title - The title of the web tag
(callout bubble)

Content - Enter web tag content.
Supported HTML tags may be
used to format the text and
images in the content.

Use HTML Tags and Graphic Tools
to edit the text. From left to
right: Bold, Italic, Link, Line
Break, Unordered List, and
Image. For Flash only: Bar
Chart, Pie Chart, and In-line
Expression. The Insert Attribute
drop-down list contains
attributes stored in the layer.

Web Tag Size - Set the size (width
and height in pixels) of the
callout bubble. Use Auto Size
to automatically size the callout
bubble around its content.

Web Tag Example

Web tag title

Web tag image

FUNCTIONALITY

Edit Web Tag

Edit Web Tag
® Callout options (@) Flash () HTMLS B - B
Slout apnans (&) Fash L Province: British Columbia
Web Tag Text show Preview |4 | 11 [P _——
E = i —————— P e
i B @ | \cn| |:=| |E|| |dy||§B| fo|| | Insertatrbute S s Capital® Victoria
g £ ————
Titie: ra—

<b>Province: %NAMEY%</b>

e

Content: canital: SCapitalCity%

Enter HTML 1o be displayed in the callout fe and content areas,

Click bere 1 see which HTML tags are supported in Fiash,

Web Tag Size
Width: | 120 px
Height: 120 px
Auto size

External URL Triggers

Click URL:

Hover URL:

Use original size  Width: 50 pic

Web Tag Image

ImageFies/EC.png

The spaciied URL(E) will ba opaned when the user hovers over or cicks art. Usa the target 1o bad

the URL in a specic bum f

| frame or 2 new window,

+ Height: 48 px =

Browse For Image | |
Target: v
Target: v

Province
o] L™

\\ N - ! }Iqal ul
'\"ellnwl?nlfew .
el -

x

Capital: Toronto

L}

Wy

Show Preview - Open or close the
preview of the callout bubble.
Click Previous or Next arrow
buttons to switch from one web
tag to another (enabled when
multiple artwork is selected).

Web Tag Image - Browse for an
image or type an attribute name
that contains a path to the image.
Specify the image width and
height in pixel or use the loaded
default size.

External URL Triggers

Control how URLs are opened
when either clicking or hovering
over Web art. Framesets or target
must be created to direct the Web
page to a specific frame.

Web tag contents - It can contain
text, images, and graphics

Click the Edit button in the MAP Web Author panel to open the Edit Web Tag dialog box. This dialog box is used to
design the web tags (callout bubbles) using HTML. These callout bubbles appear when objects in the web map are
clicked or hovered over (however, not all objects in the map need to be associated with a callout). Use the Show
Preview option to see how the HTML affects the web tag.
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PREREQUISITE

In the Edit Web Tag dialog box, text and image parameters are formatted with HTML (Hyper Text Markup Language). A
markup language is a set of markup tags. These HTML tags are keywords (tag names) surrounded by angle brackets
like <htmlI> that indicate how the Web browser should display content. There are opening tags and closing tags
and usually come in pairs, like <a> and </a>, where the end tag contains a forward slash. To learn more about HTML
formatting, visit http://www.w3schools.com/html/default.asp.

Examples of text formatting
Opening Tag Closing Tag Result
<b>Maps of the world</b> ——» Maps of the World
<i>Maps of the world</i> ——» Maps of the World

Examples
Some HTML tags are used to insert links and images.
e <a href="http://www.avenza.com">Avenza Web Page</a>
— Creates a link to www.avenza.com accessed when clicking "Avenza Web Page" text.

e <img src="sourcemedia/picture.jpg" hspace="0" vspace="0" align="Tleft" >
—» Inserts an image (picture.jpg located in the Source Media Folder).

HTML ignores extra spaces and returns, therefore tags such as <br> (to create line breaks) and <p> (to start a new
paragraph) should be used. In addition to the HTML tags, MAPublisher uses special text to extract data from the
MAP Attributes table. These attribute field references are surrounded by percent signs, like %AttributeName¥%.

Examples of using attribute fields
o <b>%Street_Name%</b>
— Main Street

e <img src="sourcemedia/%imageX%" hspace="0" vspace="0" align="Tleft" >
—» Displays image indicated in the attribute called "image" (a string text). hspace and vspace sets the
horizontal and vertical space left blank around the image. The align setting sets the image alignment to the
left of the page.

e <a href="http://%website%">Avenza wWeb</a>
—» Avenza Web (opens the website value indicated in the website attribute).
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USING EDIT WEB TAG

Web Tag Preview and Size

The Show Preview option displays a preview of the web tag (callout). As the title, text and graphics are inserted, the
preview is updated accordingly. Set the width and height of the callout (in pixel units) in the Web Tag Size section.
Use the Auto Size option to automatically size the bubble to its contents.

Insert a Title

A title are typed in as text, but it can also be a MAP Attributes field, like %PARK_NAME%. Titles can be formatted
using HTML tags.

Add and Edit Contents

The Edit Web Tag dialog provides a set of HTML tag buttons to help format content (see table on next page). Several
options are only available depending on the Callout option chosen. Charts and In-line Expressions are only available
when creating Flash callouts.

To insert a tag into the Content box, click a tag button. Then type callout text in between the opening and closing
tags. Alternatively, highlight content text and click a tag button to wrap tags around it. Use the preview to see how
the text, links or charts are displayed.

Aside from HTML tags, pick MAP Attributes from the Insert Attribute drop-down list (visible attributes only) to add
them to the Content box.

Notes: MAP Attributes field names are case sensitive.

Flash options do not appear if the final web export is to HTML5 format. Expressions are not supported for
HTMLS5 and are not evaluated even if included in the Content box.

To improve searchability in the map viewer, remember that the searchable attribute must be in the web tag.
Otherwise, enable the Export all attributes with map features setting (this may increase exported file size).

Insert an Image or Flash Animation

Images and Flash animations (Flash only) can be inserted into web tags. To insert an image, click Browse For Image
and navigate to the image file. To use an attribute value containing the path to the graphic file, enter the attribute
field name into the Web Tag Image box, like %Image_File%.

By default, the original image size is used. To change the image size, adjust the width and height value in the web

Tag Image section (aspect ratio is maintained). The preview shows the size actual size of the image.

Notes: The maximum size for a callout is 800 pixels by 800 pixels. When this limit is reached, graphics are
automatically scaled to fit (aspect ratio is maintained).

Flash elements such as charts cannot be shown in the preview.
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Tag button Tag Function HTML tag example Result

@ Bold <b>Madrid, spain</b> Madrid, Spain
Italic <i>Land Parcels</i> Land Parcels
Link <a href="http://www.avenza.com”>Avenza website</a> Avenza website
m Line Break orlando,<br>Florida Orla,ndo’
Florida
<u1;_ Roads</1i + Roads
. <li>Roads</1i>

Unordered List <li>Avenues</1i> - Avenues

</ul>
Insert Image <img src="ImageFile/Canada.png”’> I * I

.,-_w <chart type="pie” showLegend="true” values="’keyl’,
4 Pie chart ‘%attribl%’ | ‘key2’, ‘%attrib2%’” colors="0xff0000,
(Flash only) 0x00ff00” width="180" height="180" > B et
key2
<chart type="horizontalbar" showLegend="true" kE"".
Horizontal bar chart showAxisvalues="true" values="'keyl', '%attribl%'
(Flash only) | 'key2', '%attrib2%'" colors="0xff0000, 0x00ff00" l"E"'l-
@ width="180" height="180" > B
0 20 60
Horizontal
Vertical )
<chart type="verticalbar" showLegend="true" =
(Flash only) Vertical bar chart  showAxisvalues="true" values="'keyl', '%attribl%' E .
(Flash only) | "key2', '%attrib2%'" colors="0xff0000, 0x00ff00" . [ |
width="180" height="180" >
[
. . %IF(LENGTH(attribute)>0, "Attribute: " & attribute & Attribute:
In-line Expression "br/s". Y%
, o <value>

(Flash only)

Additional information for pie and bar charts (Flash only):

«  keyl: Legend for the first value. Enter a text in between single quotes. For example: 'Table Title'

. %attrib1%: Attribute that contains the first numerical value for the graph, as found in the MAP Attributes
panel. For example, if the attribute is named MALE_POP enter '%MALE_POP%'

«  key2: Legend for the second value. You can enter a text of your choice in between ' sign. For example:
'Female Population'

«  %attrib2%: Attribute that contains the second numerical value for the graph, as found in the MAP
Attributes panel. For example, if the attribute is named FEMALE_POP enter '%FEMALE_POP%'

. colors: enter a list of colors for the chart (first color, second color etc...). The color values must be entered
in hexadecimal values. For example, use the Adobe Illustrator Color Picker and select color : the hex
value (below the B of RGB). However, lllustrator writes the color as #BC1E1E, but in MAP Web Author,
the # sign by Ox (zero-x) replaces the # — so 0xBC1E1E must be entered.

«  width and height: Size of the graph in pixels.
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Advanced HTML tag combinations can be used to create more effects. For more information and a complete list of
HTML tags supported by Adobe Flash, click the link on the Web Tag dialog box or go to http://livedocs.adobe.com/
flash/9.0/main/wwhelp/wwhimpl/common/html/wwhelp.htm?context=LiveDocs_Parts&file=00000922.htmi.

Note: Inserting attributes with HTML recognized characters such as "<" and ">" (e.g. <AttributeName>) may cause
MAP Web Author to interpret them as HTML tags instead. Avoid naming attributes in this style.

External URL Triggers

The External URL Triggers settings allow an advanced Web designer to load a specified HTML document (designated
by its URL address) into a targeted HTML frame. Attribute fields may be used (i.e. %ATTRIBUTE_NAME%). This option
occurs when web art is clicked or hovered over.

A web browser can be divided into multiple panes called HTML frames in order to present documents in multiple
views, which may be independent windows or sub-windows. For example, within the same window, one frame
might display a static banner, a second a navigation menu, and a third the main document that can be scrolled
through or replaced by navigating in the second frame. An example layout could be as follow:

r—-——=-=-= _| _______ A
| | |
Frame 1
| | |
e . |
Frame 3
| | |
| Frame 2 | |
I I I
L — — — — — I a

Names of frames created by Web designers must begin with an alphabetic character (a-z/A-Z). Some special
purpose HTML frames have reserved names with a leading underscore. The following reserved names are available
for selection from the Target drop-down list.

_blank  Loads a linked document into a new blank window (unnamed).

_parent Loads a linked document into the immediate parent of the document
the link is in (frame containing web map).

_self Loads a linked document into the same frame in which the link was
clicked (frame containing web map).

_top Loads a linked document into the entire window, clearing the frames.

To use the External URL Triggers, enter a URL of the HTML document to open in the Click URL or Hover URL boxes. The
URL can be any page available locally or any external webpage (for example http://www.avenza.com). In the Target
drop-down list, enter the name of the destination frame (type in the name given by Web designers or use one of
the four available reserved names).
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Export to

Flash

Export Settings

Export to Flash

Export location- The destination
folder of the exported

ExportSettings | Viewer Style | Viewer Settings

Flash documents

Layer Controls - Lists all the layers

in the active artboard. All layers
will be visible, but only checked
layers under User Toggle can be

port location: | C:\Users\Mkel \Documents\Canada_Wieb_Map\jndex.html
# Flename s vaiid.

shown/hidden by a user.
Options - Set layer export
options. Show a layer at certain
zoom levels, set initial layer
visibility and static content is
affected by pan and zoom.

Compress map data file map.xml
Compress the map data file,
map.xml to make it smaller

Use Preserve Appearance setting for
Flash export - When unchecked,
path simplifications are applied
by Adobe Illustrator.

Simplify outlines of tagged artwork :
Simplify outlines of tagged :
artwork in the Flash map

Format numbers using locale
Use numbers formatted to
your region

JPEG Image quality & resolution :

User Toggle Layer Name Options
Major city names
Major cities
Provinces
background
Map Settings
Width: | 500 px 3 PanX: Dpx 3 Inital zoom: 00% [
Height: | 500 px 2 PanY: Dpx Z Minimum zoom: | 100% |
Set To Arthoard Masdimum zoom: |500% |3

Compress map data file map.xml {recommendied)

["] Use Preserve Appearance setting for Flash export

Simplify outines of tagged artwork

PEG image quality & resolution:  Low

Flash Player seaurity sandbox: | Auto

———@ [_| Format numbers using locale (not compatible with attribute expressions or functions such as FIXED()

High

Export...

Close

-—

— Export - Export the document to
a Flash map

Map Settings

Width and Height - Size of the
_iFlash map in the browser.
Cannot be larger than the
Adobe lllustrator document.
Set To Artboard - Reset the width
and height to its original values
PanXand PanY - Initial pan shift
applied to the Flash map (from
top-left corner)

Initial zoom - Zoom level when
the Flash map is opened
Minimum zoom - The minimum
zoom level that the map can
be set to

Maximum zoom - The maximum
zoom level that the map can
be setto

Flash Player security sandbox
Provides a restricted area for
the map that prevents access
to private data. Depending
on location of final Flash map,
choose Local or Network. It is

Drag the slider to control

the amount of JPEG file
compression

set to Auto by default.

Viewer Settings
See next section for more details

Export to Flash

Viewer Style
See next section for more details
Export to Flash
Export Settings Viewer Style Viewer Settings Export.

4 Pan Up Button

Leit

4 Pan Down Button
Top
Leit

4 Pan Leit Button
Top
Leit

4 Pan Right Button
Top
Leit

4 Pan Home Button
Top
Left

4 Zoom In Button
Top
Left

4 Zoom Out Button
Top
Leit

4 Zoom Slider
Top
Leit

4 Click Callout Bubble
Cormer Radius
Drop Shadew

1

19

19

57
19

186
19

El
16

tue .

[g) Use external €55 fie

ResetTo Defaults

Browse...

Export Settings | ViewerStyle | Viewer Settings
Navigation
nable navigation

how Penning Vidget
Show Zooring Widget
Sho Search Box
[ Automatically zoom to search resuits
[ show ciick Callout for search resuts
Show Layer List.
Shon Overview Map

rag map with mose to pan

ouble-dick on map to zoom In

Zoom with mouse scroll wheel

Expressions
[ Alow expressions in Search Box

[C] Alow expressions in web Tags

Callout Bubbles
Show the Click Callout Bubble

[0 Use Lightbox style for Cick Callout
‘Show the Hover Callout Bubble:

] Show the Fixed Position Callout Buibble

Use centroid nstead of mouse for callout position

Animations
] Disable viewer navigation animations

[ se low stage quaity during animations

2] Use fllallout content for Hover Callout

Attributes

[ Export al atributes with map features

Export.

Cose

Use external CSS file - If an external CSS file

is specified, it will override any of the
settings specified above. When a CSS

specified, an Edit link is enabled. It opens
the file in the system's default text editor.
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Export to Flash

Viewer Style - Use these setting to
control the style and position of
navigation objects and map elements.
Any changes to the default settings
will output a new CSS file.

file is

Chapter 15: MAP Web Author

Viewer Settings - Customize the navigation
controls of the map. The default settings
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FUNCTIONALITY

Use Export to Flash to set the appearance of a Flash map. Style navigation objects and map elements such as buttons,
the search box, overview map, layer list, callout bubble, zoom slider, and highlight lines and colours.

: Search
« s
Navigation bu:tnns- Pan up, pan down, + w e—— Search hox - Type text into search box
pan left and_ pan right buttfons. + . :E' and it searches through the contents
Home button in the center o the "‘_ < Canada 1+l of all the exported callout bubbles.
pan buttons centers the_ ”."ap t(.) its ' 1’5 -t 1_,) Results are highlighted on the map.
original view. b N }', E » . Populstion 31,672,897 )
Zoom Slider - Move the slider arrow =-4r7‘~ - Arn BEAETD T
Whiteh <+ ‘-"‘t—”
up or down to zoom in or out, .-m “F ¥ ? i\ b » )
respectively. Use the Zoom In or el j“l Ll
Zoom Out buttons to zoom at 5 Callout Bubble - Web tag or pop-up
specific increments L Province: New Brunsvick displays content created in the Web
} . Population: 723900 Tag Dialog
= & Capital City: Fredericton
Edm
Go to the government website st ';")
W'W ..W Highlighted Lines - By default, objects
w f Chalotietonn clicked on are highlighted in blue,
Québec/ JM, . ';(hum objects hovered on are in green
Outges "™ and objects found by the search are
- N
sforonto in yellow

Overview Map - Displays the full

extent of the map at all times. When
zoomed into the main map it shows
V] Provinces : the zoom extent. The zoom extent is
interactive and can be used to pan
around the map.

| Major city names

|¥] Majer cities

Layer list - Check boxes toggle ———
layer visibility. Only layers
checked under User Toggle are
shown in the layers list.

PREREQUISITE

Web tags must be first created using the Edit Web Tag dialog box.

USING EXPORT TO FLASH

In the MAP Web Author panel, in the Export section, click the Flash button. The Export to Flash dialog box contains
three tabs: Export Settings controls the export location, layer controls (visibility, toggleable, etc.) and the Flash map
settings; Viewer Style controls the appearance of Flash widgets; and the Viewer Settings controls how Flash widgets
operate and function.

EXPORT TO FLASH - EXPORT SETTINGS

In the Export Location box, specify the directory that will store the HTML index file (by default index.html) and Flash
export files.

Layer Controls

To have a layer list in the Flash map, at least one layer check box in the User Toggle column must be checked (Export
Settings tab) and the Show Layer List option must be enabled (Viewer Settings tab). Layers that are checked are
included in the Flash map layer list and can be toggled on or off. The layers that are unchecked are exported, but
can not be toggled on or off.
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Layer Export Options

To customize the visibility and zoom of each layer, double-click [Double Click Here To Set Layer Options] to access the Layer
Export Options dialog box.

Layer Export Options

Layer Export Options

Initial Visibility - Show or hide —Fe Initial Visibility

the layer when the map is first
loaded in a Web browser.

Zoom Range Visibility - By default, —
the layer is always shown.

@) Show the layer when the map is nitially loaded

() Hide the layer when the map is initially loaded

e Zoom Range Visibility
(@) Always show the layer

() only show the layer at zoom levels:

Cancel

Choose a zoom level range for
the layer to be visible within.
When the layer is outside the

zoom range, it is hidden.

From:
To: =
Static Content Layer - By default, —7® Static Content Layer
the layer will be affected by pan ® Pan and zoom the layer in the viewer
and zoom. Choose the second
option so that a static layer is
not affected by pan and zoom.

(O The layer wil not be affected by panning and zooming

Map Settings

Use map settings to change how the Flash map is displayed in a web browser:
«  Adjust the width and height of the Flash map. It cannot be larger than the Adobe Illustrator document.
Click the Set To Artboard button to reset the width and height to the original artboard values.
«  Set the initial position of the Flash map upon load using Pan X and Pan Y (if zoomed-in).
«  Set the initial zoom upon load. Set the minimum and maximum zoom that the map is allowed to have.

Additional Settings

The Compress map data file (map.xml or map.xml.zip) is used by the Flash viewer to get information on the initial zoom
level, Web tag content, tagged object geographic coordinates. It is recommended to keep this option enabled to
use a compressed version of this file (map.xml.zip) to maintain a fast loading map. However, advanced users may
use the uncompressed version (map.xml). For example, an advanced user could create programs that automatically
update the Web Tag contents. Once compressed, this file cannot be uncompressed to map.xml. If this file is required,
the export must be run again with this option disabled.

The Use Preserve Appearance setting for Flash export option flattens the artwork to a single layer before exporting. It is
recommended to maintain the artwork quality. However, some known issues with Adobe Illustrator Flash export
cause some documents to fail to export with this option enabled.

Use the Format numbers using locale option to format numbers based on the locale setting in MAPublisher Preferences.
This option does not work with expressions.

Use the Simplify outlines of tagged artwork option to generalize tagged artwork to reduce overall file size.

Images in Adobe lllustrator are exported as JPEG. The JPEG Image quality & resolution slider sets the compression level of
exported images. This setting does not apply to images included in web tags.

See Flash Security and Permissions section to learn more about these settings.
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EXPORT TO FLASH - VIEWER STYLE

To set the style and position of Flash map viewer controls, edit the Viewer Style list or use CSS (Cascading Style
Sheet), a style sheet language that enables the separation of document content (HTML, JavaScript) from document
presentation—it is a simple mechanism for adding style (e.g. fonts, colors, spacing) to multiple webpages at once.

The Viewer Style list contains map viewer controls and properties in the Viewer Styles list are as follows—all positions
are relative to the top left corner of the Flash map:

«  PanUp Button (Top, Left) - Position of the pan up button.

«  PanDown Button (Top, Left) - Position of the pan down button.

«  PanLeft Button (Top, Left) - Position of the pan left button.

- PanRight Button (Top, Left) - Position of the pan right button.

« PanHome Button (Top, Left) - Position of the pan home button.

«  Zoom In Button (Top, Left) - Position of the zoom in button.

«  Zoom Out Button (Top, Left) - Position of the zoom out button.

«  Zoom Slider (Top, Left) - Position of the zoom slider widget.

«  (Click Callout Bubble (Corner Radius, Show Arrow, Drop Shadow, Fill Colors Start, Fill Colors End) - style of a
callout bubble when it is clicked.

«  Hover Callout Bubble (Corner Radius, Show Arrow, Drop Shadow, Fill Colors Start, Fill Colors End) - style of a
callout bubble when it is hovered over.

«  Fixed Position Callout Bubble (Top, Left, Width, Height, Corner Radius, Draw Bubble, Fill Colors Start, Fill Colors
End) - position and style of a static position callout bubble.

«  (Click Highlight Line - (Visible, Color, Transparency, Line Thickness).

«  Hover Highlight Line - (Visible, Color, Transparency, Line Thickness).

«  Search Highlight Line - (Visible, Color, Transparency, Line Thickness).

«  SearchBox (Top, Left) - Position of the search box.

- LlayerList (Top, Left, Width, Height) - Position and size of the map layer list.

- Overview Map (Top, Left, Proportion) - Position and proportion (relative to map size) of the overview map.

Each control can be styled and positioned by adjusting basic property values. Users can export with the default
values without further adjustment. If any control properties are changed from the default values, a custom CSS file
is exported to the export data folder. The controls in the Viewer Style list contain only basic properties, use CSS for
more advanced designs.

For advanced users, the appearance of Flash maps can be fully customized using CSS. Enable the Use external CSS file
option and browse to a CSS file. The file will overwrite any of the configurations made in the Viewers Style list. Using
an external CSS file for styling the viewer is advantageous because more visual aspects of the viewer can be set—
such as, callout bubble style, text font, images for buttons—and external CSS can be reused for multiple maps. If the
need arises, the external CSS file can be updated after the map has been exported.

The CSS implementation is based on the Adobe Flex 3 CSS system. Only class selectors are supported. Full
documentation is located at http://www.avenza.com/mapublisher/mapwebauthor/css. This site includes full maps,
CSS samples and examples of CSS code.
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EXPORT TO FLASH - VIEWER SETTINGS

The Viewer Settings tab contains settings that affect the operation or function of Flash widgets. Check or uncheck any
of the options to enable or disable them. Most of these options are enabled by default unless otherwise specified.
The visibility of these controls may also be set through an external CSS file (specified in the Viewer Style tab).

Navigation
- Enable Navigation - Displays all of the navigation buttons, search box, layers list and overview map.

«  Show Panning Widget - Show pan widget in map viewer.

«  Show Zooming Widget - Show zoom widget in map viewer.

«  Show Search Box - Show search box in the map viewer.
«  Automatically zoom to search results - Zoom the map viewer to search results. Disabled by default.
« Show Click Callout for search results - Show click callouts for search results. Disabled by default.

«  Show LayerList - Show the layer list in the map viewer.

«  Show Overview Map - Show the overview map in the map viewer.

«  Drag map with mouse to pan - Allows the user to pan the map using the mouse in the map viewer.

«  Double-click on map to zoom in - Allows the user to zoom in with the mouse on double-click.

«  Zoom with mouse scroll wheel - Allows the user to zoom in and out using the mouse.

Callout Bubbles
+ Show the Click Callout Bubble - Display a callout bubble when a feature with a Web tag is clicked.
«  Use Lightbox Style for Click Callout - Disabled by default.
« Show the Hover Callout Bubble - Displays a callout bubble when a feature with a Web tag is moused over.
«  Use full callout content for Hover Callout - Displays full callout bubble when option to show hover callout
bubble is enabled. Disabled by default.
« Show the Fixed Position Callout Bubble - Displays a fixed position callout bubble. Disabled by default.
« Use centroid instead of mouse for callout position - places the callout bubble position of a feature with a Web tag on
the centroid. Disable it so that the callout position occurs where the mouse position is.

Animations
« Disable viewer navigation animations - Enabling this option disables panning and zooming animations. Disabled by
default.
« Use low stage quality during animations - Lowers the quality of animations for improved performance. Disabled by
default.

Attributes
« Export all Attributes with map features - Forces all attributes to export, regardless of whether they are used in a Web
tag or not. Disabled by default.

Expressions
« Allow expressions in Search Box - Allow users to type expressions into the search box. Disabled by default.
« Allow expressions in Web Tags - Evaluate expressions in web tags at runtime. Disabled by default.
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WEB EXPORT LOG (FLASH)

In the Export to Flash dialog box, click the Export button to begin the export process. An export summary is
displayed in the Web Export Log.

An index.html file and index_data folder are created in the specified export directory (default names; a custom name
and location can be substituted in the Export Location box). Some of the important files are:

« map.xml.zip (or map.xml when the Compress Map Data File option is not checked).

«  MAPublisherViewer-local.swf and MAPublisherViewer.swf (map viewer implementation files).

«  map_L#swf (where # is the layer number; one file per layer when option to toggle is checked).

Note: View the README.txt file inside the export data folder for more information about each file.

The Web Export Log displays several export file size statistics: the total SWF file size and the metadata file size. These
file sizes are meant to warn the users when files get very large. Large files should be avoided as they may slow the
Flash map when opened on a website. Several recommendations to reduce exported file sizes are provided at the
bottom of the dialog box.

Web Export Log - Flash

Export folder - Link to the export —L Web Export Log
folder. Right-click to copy link ™ Export folder: C:Wsers\Mikel \Documents'Canada Web Map) e o Export Again - Return to the Web

location to clipboard. J——o Set folder permissions in the Flash Player Global Security Settings panel Export Dialog

Set folder permissions - Set folder Layer File # of Vertices Size
permissions. Read more Major city names. map_L1.suf 0 10KB
bout Flash Security and Major cities map_L2suf 0 1KB
about Flash security an: Provinces map_L3.swf 203 156KB
permissions section. background map_Ld.suf 0 6KB
Layer List - List of the exported
layers, including file name,
number of vertices and file size
Total SWF file size - Total file size ———e Total SiF fie size: 17346
Ofthe Cl’eated SWF ﬁles' This size shoukd be kess than €DOKE for best performance.

e Metadata (.xm) fle size: 15KB
T be bess than 50 400 for best performance.
To reduce exported fil sizes:

Less than 600 KB is ideal.

) . *Use the "Simplify Lines” tool to reduce the number of vertices in your data.
Metadata (.xml) file size - Size of *Export as few attributes as possible. Only attributes that appear in Web Tags are exported.
»Un-check the "Use Preserve Appearance Setting for Flash Export” setting.
the created metadata.xm file. *Use a lower “JPEG Image Quality & Resolution™ setting.
Less than 50 KB compressed *Reduce the number of raster images used in your map.

(xml.zip) is ideal.
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Flash Security and Permis

The Flash Player security sandbox (located in the Export to Flash dialog box) provides a secure area in which a Flash map

sions

will load. Three options are offered:
«  Auto: If the file is opened from a Web based URL, the sandbox is automatically switched to Network.
If the file is opened from a file folder, the sandbox switches to Local.

«  Network: Flash Player classifies assets (including SWF files) from the Internet in separate sandboxes
that correspond to their Website origin domains. By default, these files are authorized to access any
resources from their own server, but can not load any local files or resources unless these are enabled
through the Flash Security Settings (see later in this chapter).

«  Local: Flash Security Settings are not required, however only content from the local host computer can
be accessed by Flash Player (i.e. hyperlinks, APl will not function). This option is recommended when
distributing Flash maps on CD, for example.

When exporting a Flash map intended for Web distribution, choose the Network option in the Flash Player Security
Sandbox drop-down list. If a Flash map is intended for only local use, choose the Local option. By default, the Auto
option is chosen and automatically detects whether the Flash map is run on a network or locally. If the Network
option is selected, the Global Security Settings must be configured in the Adobe Flash Player Settings Manager
before an Internet browser can properly view the Flash map without posting it on a server. If the Local option is
chosen, it is not necessary to set folder permissions. However, files exported with this option will not work for a
Website and will have to be exported again with either the Network or Auto option.

Click the Set Permissions button in the Web Export Log dialog box to access the Adobe Flash Player Settings Manager
(http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html):

Adobe Flash Player™ Settings Manager
&Ee® & 8P
Global Security Settings
system of security. This is usually harmiess, butitis
‘website attempts to use the older system to access

@ Always ask 0@ Always alow

Some websites may access information from other sites using an older

possible that some

sftes could obtain unauthorized i formation using the older system. When a

information:

O Always deny

Always trust files in these locations:

Edit locations.

cations

@ 1. Click Edit Locations.

2. Click Add Location.

3. Click Browse For Folder or copy the full path as written in
the Web Export Log dialog box and click Confirm.

The folder is added to the list of trusted locations. Locations
can be modified or deleted at a later time.

Trust this location:

[DExport_Fiasn

[(Browseforfies__| [ Browse for foider__]

Confirm Cancel

Note: You must be connected to the Internet in order to set these permissions.

View Flash Map

To view the exported Flash map, browse to the Flash export folder (as specified in the Web Export Dialog) and open the

file index.html (or name specified in Export Location) in a Web browser. Check that the Web browser has the latest
version of Flash Player installed (http://www.adobe.com/products/flashplayer/). An outdated version may cause the

Flash map to display incorrectl

Note: Depending on the security settings of the Web browser used, some warnings may appear when opening files

y.

exported with Local option enabled. These can be ignored.
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Export to HTML5

Export Settings

Export location - The destination ———e exortlocation: |c:\isers Wikel Documents\Canada_wieb_Maplindex html

folder of the exported web files

Viewport - The web map ———— ys:

viewport size. Click the Set
Viewport To Preset Size button to
choose a predefined viewport
size depending on use. Enable
Set an initial viewport home
location to create a custom
view location when the web
map home button is clicked.

Navigation - Adjust web map ——

interactive settings and
navigation controls

FUNCTIONALITY

« Fiename is vaid.

Viewer | Hide/Show layers | Scale Dependentlayers | Theme
Viewport

Height:

soopx 3] [soopx [3

[ aintain aspectrati

Set Viewport To Preset Size

] setlocation and zoom scale for home button
Center X: Center ¥: Zoom:
Opx + Opx B 100% k2
Navigation
Allow panning with mouse and touch
Allow zooming with mouse and touch

o navigation controls

Positon: |Topleft  ~

Maximum zoom: |400% -

Export to HTMLS

Browse.

Export.

Close
Advanced

Controls
[ show Search Box

Position: |Top Right

Show Layer List

—— Export - Export the map to an
HTML5 web map

Controls - Hide/show and choose

Position: |Top Left -
Callouts
Show the Click Callout

[] use centroid instead of mouse position for Callout

position for the Search box and
Layer list

Callouts - Hide/show and adjust

Show the Hover Callout:
[ Use full allout content for Hover Callout
[ show the Fixed Callout
Top: Left
sopx |5 [sox B
Width: Height:
wopx |5 w0px |2

Feature Highlights

settings for callouts

how Clik Highliht
Show Hever Highlight
Show Search Highlight

Feature Highlights - Hide/show
web feature highlights

Export to HTMLS5 is used to export a MAPublisher map to a package of files that includes an HTML document that
will enable you to view it in a web browser. Use Export to HTML5 to set the appearance of an HTML5 web map. Style
navigation objects and map elements such as buttons, the search box, overview map, layer list, callout, zoom slider,
and highlight lines and colours.

PREREQUISITE

Web tags must be first created using the Edit Web Tag dialog box.

The largest challenge when creating an HTML5 web map is making it work efficiently across all desktop and mobile
browsers. Export to HTML5 has many similarities and differences to Export to Flash and it should be noted that a
map designed for Flash may not be directly exported as an HTML5 map.

USING EXPORT TO HTML5

In the MAP Web Author panel, in the Export section, click the HTML5 button. In the Export location box, specify the
directory that will store the HTML index file (by default index.html) and associated web export files.

The Export to HTML5 dialog box contains four tabs: Viewer has controls to set export location, viewport size,
navigation controls and callout settings; Hide/Show Layers has controls to show and hide specified layers; Scale
Dependent Layers has controls to adjust what is visible at set zoom scales; Theme has controls to adjust the appearance
of foreground, background, and highlight colours; and Advanced has controls to adjust additional settings.
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EXPORT TO HTMLS5 - VIEWER

The Viewer tab contains settings that affect the operation of elements in the web map. Check/uncheck any of the
options to enable or disable them. Most of these options are enabled by default unless otherwise specified.

Viewport
Use the viewport settings to change how the web map is displayed in a web browser:
«  Adjust the width and height of the web map. It cannot be larger than the Adobe Illustrator document.
Enable the Maintain aspect ratio option to adjust the viewport width and height values in the same ratio.
Click the Set Viewport to Preset Size button to set the width and height to the predefined widths including
800px (large, for websites and tablets), 640px (medium, for websites and tablets), 320px (small, for mobile
phones), or set to artboard size.
. Enable the Set location and zoom scale for home button option to choose a custom home position on the web
map (based on Center X and Center Y for position, and zoom scale)

Navigation
« Allow panning with mouse and touch - Allows the user to pan the map with mouse and by touch on mobile.
+ Allow zooming with mouse and touch - Allows the user to zoom the map with mouse and by touch on mobile.
«Show navigation controls - Show navigation controls in the web map. Choose position and maximum zoom.

Controls
« Show Search Box - Show search box in the map viewer. Choose position. Disabled by default.
« Show Layer List - Show the layer list in the map viewer. Choose position.

Callouts
« Show the Click Callout - Display a callout when a feature with a web tag is selected. The Callout will appear at the
current tap or click position.
«  Use centroid instead of mouse position for Callout - The callout will appear at the centroid of the feature rather
than at the mouse position.
+ Show the Hover Callout - Display a callout when the mouse pointers moves over a feature with a web tag. This is
not available on touch devices.
«  Use full callout content for Hover Callout - Displays full callout when option to show hover callout is enabled.
Disabled by default.
« Show the Fixed Callout - Display a callout at a fixed position when a feature with a web tag is selected. Disabled by
default.

Feature Highlights
« Show Click Highlight - Show a highlight over top of a feature when it is selected.
« Show Hover Highlight - Show a highlight over top of a feature when the mouse moves over it. This is not available
on touch devices.
« Show Search Highlight - Show a highlight over top of a feature when it matches a search.
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EXPORT TO HTMLS5 - HIDE/SHOW LAYERS

The Hide/Show Layers tab contains settings that allow layers to be toggled on and off in the viewport. Click the Allow
the user to hide and show layers in the layers list option to enable its controls. Layers can be added individually or be
grouped. Grouped layers all share the same options.

Viewer | Hde/Show Layers | Scale Dependentlayers | Theme | Advanced

Allow the user to hide and show layers in the layers list

) a| [¥]| Optons
 [Provinces Display Name: |Pr
layer Provinces b v o
4 New Layer Group Initally Visile e—————Options - Change the displa:
Layer group [T] Major city names [ Do Mot Show In Layer List 9 play

name, set initial visibility, hide
from layer list, and add a layer
list icon.

Major cities Layer List Icon {32x32 pixels or smaller)

Browse... | 3

In the Options frame for each respective layer or group, there are settings to change the display name (what is
shown in the layer list in the web viewer), a setting to change initial visibility, or to not show it in the layers list at all.
The layer list icon (must be 32x32 pixels or smaller) is optional. The Only show one layer group at a time option (bottom of
the dialog box) allows the visibility of one layer group at a time in the viewport.

EXPORT TO HTMLS5 - SCALE DEPENDENT LAYERS

The Scale Dependent Layers tab contains settings to adjust layer visibility at specific zoom scales. Click the Hide and

show layers only at specificzoom scales option to enable its controls. Layers can be added individually or be grouped.
Grouped layers all share the same options. It is important to note that layers cannot be added to both the
Hide/Show Layers tab (above) and Scale Dependent Layers tab (below). It is recommended to prioritize which layers
can have its visibility hidden/shown and needs to be shown at specific zoom scales to ensure the correct display in
the viewport.

Viewer | HidejShowlayers | Scale Dependentlayers | Theme | Advanced

Hide and show layers orly at specific z00m scales

) Options

show layers at zoom scales:

Layer group

4 Always visible
Provinces From 100% -

Options - Change the zoom scales
4 Visible above 50% zoom
Jual layer Major cities To 300%. - for layers and layer groups
4 |Visible above 100% zoom

Major city names

When a layer is added to a group it will be displayed at the top of the map layer hierarchy when exported.
This means that if a layer that was at the bottom of your map hierarchy and it is added to a Hide/Show Layer layer
group, it will automatically be moved to the top level or your layer hierarchy when exported.

A layer that is not added as a Hide/Show Layer is considered a base layer. A base layer is comprised of rasterized
images (tiles) for the required number of zoom scales. Layers do not have to be designated as a base layer as this is
the default location for all layers. A base layer appears underneath all other layers.
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Important Layer Notes

Due to hardware and software limitations with mobile devices and most desktop browsers it is best to limit the
number of toggleable layers to no more than three hide/show layers (however this limit is completely dependent

on the size of the map and the data that is used).

EXPORT TO HTMLS5 - THEME

The Theme tab contains settings to change the appearance of the web map viewer. Two default themes are available:
Light Theme and Dark Theme. The Custom Theme option has custom colour settings available. Themes do not affect the
style in your map document, it only affects the appearance of the map viewer foreground, background, border, and

highlight colours.
Viewer Hide /Show Layers Scale Dependent Layers Theme
() Use Light Theme - Black text and lines on a white background.
Theme types ———— ) uce DaricTheme - ihie text and ines an a back background.
(®) Use Custom Theme:
Control Foreground: | [l Specify colour
Control Background: Spedfy colour
Custom Theme settings Control Highlight: Spedfy colour
Control Border: Ml specify colour

Feature Highlight: [ specify colour

Advanced

EECOOME

[ Firetox ~— - [ =)
| € flercusers .. web_ Map/indechtmi | + |
|+ 08| & files///C:/Users/mlew/Decuments/Canada_Web_Mapfindexht (K PO~
Control foreg: d &N -—
. - 2
ontrol hi 139 o
Xiphwid Canada i+l
i
Control border o, TErIES Poputaton 31512507
~ i .
|y = Area 9564670 km’
C | back d Whitehorse - 4 4
ontrol backgroun: - S ckatchoman
M Population: 988928
3 Edmanion ’
¥ L P
Vietor negind 3
f Winnpeg fonetonn
Feature . ::!:;S . 4;2‘”“
S
e
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EXPORT TO HTML5 - ADVANCED
The Advanced tab contains extra settings to change functionality of the web map viewer.

Web Tags
+ Format numbers using locale - Use locale as source for number formats. Disabled by default.
- Simplify outlines of tagged artwork - Removes extraneous vertices from artwork.
« Export all attributes with map features - Map attributes are included in the exported web map. Disabled by default.

Tiled Layers
« Use JPEG for base layer tiles - Change format to JPEG for base layer tiles. Disabling this option will use PNG for base
layer tiles.
« Scale patterns in tiled layers - Patterns are scaled for better looking tiles.

Debugging
« Display frames per second in the viewer - Shows value in a corner of the viewer. Disabled by default.
+ Include the debug information widget in the viewer - Debug information Disabled by default.

WEB EXPORT LOG (HTML5)

In the Export to HTMLS5 dialog box, click the Export button to begin the export process. An export summary is
displayed in the Web Export Log dialog box.

An index.html file and index_data folder are created in the specified export directory (default names; a custom name
and location can be substituted in the Export Location box). Some of the important exported files are:

«  avenza.css and avenza-theme.css (CSS files that can used to customize style of the map viewer).

«  layer # folder (where # is the layer number; folder contains tiles).

. avenza-viewer.js (the Javascript file containing information to form the map viewer).

«  datajs (the Javascript file containing information to place data in the map viewer).

The Web Export Log displays several export file size statistics: the number of tiles created and total file size, and the
map data total file size. Large file sizes should be avoided as they may slow the web map when opened in browser.
Several recommendations to reduce exported file sizes are provided at the bottom of the dialog box.

‘Web Export Log

Export Folder: C:\Users\Mikel \Documents\Canada Web Map
322,90 KBs in 24 tiles

p—

To reduce exported file sizes and improve map viewer performance:

<< Export Again

*Export as few atiributes as possible. Cnly attributes that
appear in Web Tags are exported.

*Simplify all artwork for tagged features. Simpler features
require less space to spedfy outlines and highlights appear
faster in the viewer,

*Clip all artwork to the artboard.

*Resize the artboard to match the size of the viewport that
you intend to export to,

*Use a lower maximum zoom walue to limit the number of raster
map tiles created.

* Limit the number toggleable layers. A separate set of raster
tiles must be created for each layer that can be toggled.
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HTML5 WEB MAP DATA AND DESIGN CONSIDERATIONS

Artboard Size

The Export to HTML5 processing time is dependent on map size. A large artboard means there are more pixels to
export. It is recommended that web map dimensions are 800 x 600 pixels. Keep in mind what kind of devices your
web maps may be viewed on (smartphone, tablet, or desktop).

Viewport Size

The viewport is independent of the artboard size and will affect the runtime speed of the map. Generally, a smaller
viewport will produce a faster web map. Use the Set Viewport to Preset Size options to choose an appropriate size.

Zoom scales

Export to HTML5 creates tiles for your art based on the number of required zoom scales. So, the more your map can
zoom in and out the longer it will take to export and larger the exported files will be.

Data Generalization

For all exported data, the detail (e.g. artwork, number of objects) and amount of data on the artboard will affect
the processing speed of the export. Art that contains web tags could slow performance of the final map. Web art is
always exported with a vector layer to be able to show the highlighted feature.

iOS/Android/Mobile Limitations

Mobile devices using operating systems such as Apple iOS and Android have the ability to render HTML5, however
these devices have limited hardware and software which may cause HTML5 rendering issues. Using hide/show
layers on a mobile device may slow the device. Use a maximum of three hide/show layers. Web maps viewed on a
mobile device (with a touch screen) will have the following HTML5 viewer options disabled:

«  Show Hover Highlight

+  Show the Hover Callout

Attributes

A large number of attributes associated with web tags can cause performance issues in the exported web map.
Unused attributes are removed automatically from the tagged layers when exporting.

Browsers

All browsers (including mobile browsers) display HTMLS5 differently. Ensure that your exported HTML5 web map is
tested on popular browsers before it is deployed. Web safe fonts work better in certain browsers.

Navigation

Pan and zoom gestures when viewing websites on a mobile device are very similar to pan and zoom gestures when
viewing a web map. It is recommended that only one type of gesture is active (i.e. disable pan and zoom in the map
or disable pan and zoom on the web page). The included example index.html shows how to disable pan and zoom
on the web page.
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Advanced Features

Users with good knowledge of HTML and Javascript can benefit from some advanced MAPublisher features.
Additional information about these features is provided on the Avenza Systems Inc. website (www.avenza.com).
This information is available to all MAPublisher customers. MAP Web Author examples are also provided on the
MAPublisher DVD.

EXTERNAL CSS

As explained earlier in this chapter, the visual aspects of the widgets that appear in the MAPublisher Web Author
viewer can be configured using CSS (Cascading Style Sheets). The CSS implementation is based on the Adobe Flex 3
CSS system. Only class selectors are supported.

Refer to the webpage at http://www.avenza.com/mapublisher/mapwebauthor/css for information on how to edit the
CSS file and for a reference to the list of classes available for styling and their supported properties.

MAP WEB AUTHOR API REFERENCE

The MAP Web Author API Reference allows developers to embed and interact with maps produced by MAPublisher
in web pages. There are two API references: Flash and HTML5.

Some webpages have been developed on the Avenza Systems website to provide a guide to the APL. It includes
both Flash and HTML5 API References, FAQs and examples.

Refer to http://www.avenza.com/mapublisher/mapwebauthor/api for more information.
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-~ Document to
Geospatial PDF

e : Adobe lllustrator documents with GIS data can be exported
e D Gy AL i : to geospatial PDF using the MAPublisher Export Document to
gz 4 | | Geospatial PDF utility.
;f ¥ % A geospatial PDF is an Adobe Acrobat file that contains
£ p geospatial coordinates, the ability to store spatial data

e

8 st e i

B

and attributes in layers . With coordinates, users can view
and interact with the PDF to find and mark location data.
Attributes can be viewed and searched in Adobe Acrobat.

ey in Adobe Acrobat to:

jpessidre s S AN : «  Find and mark location coordinates

«  Measure distance, perimeter, and area

. View coordinates in measurement units in
various formats/units

- Copy location coordinates to clipboard

. | Geospatial PDF files exported with MAPublisher can be used

e S G «  View attributes of map objects
«  Reopen geospatial PDF in Adobe lllustrator with
o ot MAPublisher capabilities maintained.

- show and hide layers

Topics covered in this section:
: Export Document to Geospatial PDF
2 s View Geospatial PDF

CARONADO
NAT'{ FORES
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Export Document to Geospatial PDF

MAP Toolbar > Export > Export Document to Geospatial PDF
FUNCTIONALITY

The Export Document to Geospatial PDF utility exports a MAPublisher document to the Adobe Acrobat geospatial
PDF format. It has the ability to retain georeferencing and attribute information (however image attributes are not
supported). All layers can be exported to PDF, including non-MAP layers (regular Adobe Illustrator layers).

The geospatial PDF files exported from MAPublisher are compatible with Adobe Acrobat 9 and higher. The Adobe
Acrobat Analysis Tools allow viewing and marking coordinates, viewing attributes, measuring distances, perimeters
and areas.

With Acrobat Pro and Pro Extended (version 9), the measurement tool is always enabled. To enable this tool in
Acrobat Reader (standard), the file must first be opened in Acrobat Pro to enable annotations on the PDF (go to
Comments > Enable for commenting and analysis).

Note: Geospatial PDF files can also be opened in Adobe Acrobat 8, however no geospatial information will be
visible, only attributes.

PREREQUISITES

Export Document to Geospatial PDF can only be used with MAPublisher documents, meaning that it must
contain at least one MAP View with a specified coordinate system. All coordinate systems within MAPublisher
are supported, including user-defined systems*. Multiple MAP Views are supported with no limitation. Individual
document size must be smaller than 14,400 pixel by 14,400 pixel to maintain correct georeferencing.

* With some unusual coordinate systems, measurements in Adobe Acrobat may not give proper results. This is an Adobe
Acrobat limitation. Predefined coordinate systems with an EPSG code will provide accurate results.

Adobe lllustrator documents created using MAPublisher legacy versions (8.1 or earlier) as well as documents
created by third-party software (such as Cartographica) must be opened, saved and closed with at least
MAPublisher 8.3 prior to exporting to geospatial PDF. If these steps are not taken, a warning may be prompted on
export and the Adobe Acrobat data tools (see later in this chapter) will not function properly.

Note: Some Adobe lllustrator effects are not supported during export. The attributes will not be visible for objects
with the following effects:

«  All Adobe Photoshop effects

. Any effect that modifies the outline shape of the artwork will cause attributes to fail. (e.g. Warp effects,
Convert to Shape, 3D effects, Distort and Transform, and some of the Pathfinder effects).

. Any effect that rasterizes the art will cause attributes to fail (several SVG filters do this).

«  Gradient Fills are supported, although transparency gradients (going from opaque to transparent) and
Gradient Mesh are not supported.
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Geospatial Information Extents

A geospatial PDF only contains geographic information in the extent covered by a MAP View. In other words, Adobe
Acrobat Geospatial Location Tool and Measurement Tool will not work outside the spatial extents of a MAP View. To
increase the extents of the MAP View so that it covers a larger part of the document, create a polygon on a MAP
area layer.

Layers and MAP Views Structure

All layers in the Adobe Illustrator document are exported including locked and hidden layers. The visibility status
is maintained in the exported geospatial PDF, however not the locking status. Locking layers must be done within
Adobe Acrobat.

Layer name and order are maintained as they are in the Adobe lllustrator document (with the exception of nested
layers). Layers must have a unique name. If multiple layers have the same name, a warning message is prompted
upon export. Adobe Acrobat does not support nested layers and only the top most (parent) layers are shown in the
Layer List. Objects in nested layers are still exported but they are included in the parent layer. Use caution when
using nested MAP Layers and non-MAP layers together.

All MAP Views are exported in the order that they appear in the MAP Views panel (alphabetical): the top most

is exported first and lowest is exported last. If some MAP Views are overlapping, the positions shown in Adobe
Acrobat are calculated based on the coordinate system of the latest exported MAP View (the lowest one in the MAP
Views panel). When working with inset maps, the inset MAP View should be placed at the bottom of the tree in the
MAP Views panel (using an appropriate MAP View name since the order is alphabetical).

Notes: Due to Adobe Acrobat limitations, attributes of Text layers cannot be exported. In addition,
<compound path> objects that have an element outside the artboard are exported without attributes.

Attribute Names

Only visible attributes for map objects are exported to PDF. The attribute name displayed in the Adobe Acrobat Model
Tree Property list corresponds directly to the attribute Display Name specified in the MAP Attributes panel.

Prior to exporting, delete or hide/display relevant attributes in the MAP Attributes panel (through the Edit Schema
dialog box or using the Show/Hide button). The Edit Schema dialog box is also used to change the attribute display
name - see chapter 5 for details):

Edit Schema

| [E =0pacity Name: CITY_NAME

- i:;ZxNWE Display name: CITY_NavE ———————Display Name - Attribute name
#Pager Type: 1 string - displayed in the Object Data pane of
21d the Model Tree
@ #Name Size: 18 z
#HorizontalScale
#VerticalScale Default value:
#Rotation
[ #Style Visble Visible - Set the visibility status of the
#MapX [ Read-only selected attribute column
#Map¥ [ Derive value from expression:

Column - Select the column to edit ———<E CTVNAME |
[55 STATE_NAME Expression: < @
[ TYPE
[E CAPITAL
Add Remove
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USING EXPORT DOCUMENT TO GEOSPATIAL PDF
To export to geospatial PDF, click Export > Export Document to Geospatial PDF button on the MAPublisher Toolbar.

The Geospatial PDF Export Settings dialog box opens to offer the export options described hereafter. After settings are
made, click Export to choose an export directory and file name.

Layer List & Model Tree

The Layer List & Model Tree tab provides all the settings to customize what will be displayed in the Adobe Acrobat Layer
List and Model Tree. It is the default tab when the Geospatial PDF Export Settings dialog box opens.

Geospatial PDF Export Settings

Change layer order - This only Include in Layer List - Include
changes the order shown Content | LayerList &Model Tree | Options selected layer in the Layer
in the Layers List and Model Double-click a group or layer to edit its name. — List in Adobe Acrobat
Tree. It dqes not change the - Chicago Label ) | Include in Layer List @
layer display order on the ————s More Cities & 8| [ Indude in Model Tree Y
actual map. uscities_point > -8 Include in Model Tree - Include
- Include feature attributes .
usroads_line - g Save Settings... selected layer in the Model
.Layers and Layer Groups 4 @ Group e Use attribute for feature name: Tree in Adobe Acrobat
Ahvallatéle |aye"dslafe listed hawaii_area a8 atrbute: | [ STATE NAME v Profles T Indude feature attributes
ek'l’e' r?mt)ls Layel'SLél'te alaska_area « 8 sort ord rp— Include all the attributes of
0rt oraer: SCending -
S .own In the Layer List, usa_area - °f g the selected feature
but its MAP layers are not. i
EH Map Divisions - .
Grouped layers can be A Layer Use attribute for feature name
expanded in the Model Tree : Enable display of attribute
name rather than the

to view its MAP layers.
Group Sl Adobe lllustrator object

name in the Model Tree.

Currentlya Included in Ungroup all Then ch ib
sub-layer Model Tree ) | en choose an attribute
Group by MAP View Profiles - Choose between from the drop-down list
= < i Group or Sort- Quickly ——e  Group by feature type Standard, No Layers List, No and a sort order.
i group or sort based on the Model Tree, No Attributes,
) settings in this drop-down ST e or PDF Maps.
Included in Sort by feature type
Layer List

By default, all available MAP Layers that can be exported are listed. To prevent specific layers from being exported,
click the Content tab and uncheck the check box beside a layer. Layers not being exported are grayed out in the
Layer List & Model Tree tab.

Note: Disabling layers in the Content tab or loading a settings file that may have a different layer order will cause
the document to reflect the changes after export. After export, use Undo to restore it to its current state.

To group layers, select multiple layers and click the Group button. Grouped layers can be included in both Adobe
Acrobat Layer List and Model Tree, however, its sub-layer names are not shown in the Layer List (the features are
shown under the parent group name). Click the Group or Sort settings drop-down list to quickly group by MAP
View or by feature type; or sort by name or by feature type. Click Ungroup all to ungroup everything at once.

To include a MAP layer or group in the Adobe Acrobat Layer List, select a MAP layer or group in the list on the left
and check the Indude in Layer List option. An icon indicating that it will be included in the Layer List will be visible in
the list.
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The sub-layer icon appears when a MAP layer is currently a sub-layer (i.e. child of a parent layer). Sub-layers cannot
be included in the Adobe Acrobat Layer List, only its parent layer can be. However, a sub-layer can be included in the
Model Tree.

To include a MAP layer or group in the Adobe Acrobat Model Tree, select a MAP layer or group in the list on the left
and check the Include in Model Tree option. An icon indicating that it will be included in the Model Tree will be visible
in the list. This option enables additional Model Tree settings. Enable Include feature attributes to include all visible
attributes of the layer. Enable Use attribute for feature name to use an attribute value as the name for each feature. Use
the Attribute and Sort order drop-down lists to choose the appropriate settings.

It his highly recommended to enable these settings. By default, the name of the objects displayed in the Structure
Pane of the Model Tree are derived from the map object's name as shown in the Adobe Illustrator Layers Panel. The
default names given by Adobe lllustrator to objects are often meaningless an end user. For example, lines and areas
have a default name of <Path> or <Compound Path>, points have the name of the symbol or ordering number.

In Adobe Acrobat, the Model Tree displays a list of all the map objects in the document along with their attribute
information (if applicable), organized in a tree structure in MAP View/Layer Name/Object Name—see next section
on how to view a geospatial PDF.

MAP Views Panel Adobe lllustrator Layers Model Tree
[ e D [ E] AT m
-
@ world B . C
& [} dities_point I/_\P EP .
® D [+ rivers_ine [@  cities point - B ) cities_point a
® 0 [ countries_area 2 |[® rivers_iine 4 || BB rivers line [
- ZNunMAP Layers & ’; countries area & =T countries_area
® [ALayer 1 = P =) Afghanistan
@ N =5 Albania
) Algeria
= Andorra
&z ez = Angola
— = Anguilla
1MAP View A, of & e & E E [ Antarctica
= Antigua
B3 Argentina
B Acenonis S
4 I, ] »
—

In the Options tab, the Embed Al file within PDF option preserves Adobe lllustrator editing capabilities in the exported
geospatial PDF. This option is enabled by default. When the Adobe Illustrator editing capabilities are preserved,
users will be able to retrieve MAP Views, MAP Layers and MAP Attributes when opening the geospatial PDF in
Adobe lllustrator (see chapter 3 - Geospatial PDF Import). When this option is disabled, the geospatial PDF will open
in Adobe lllustrator with no georeferencing or attribute information and all layers will be merged into one—this
may be useful for secured documents.

Note: If a preserved geospatial PDF is opened in Adobe Illustrator and some changes are made, the file will have to
be exported again using the Export Document to Geospatial PDF function. Simply saving the document will
not maintain the geospatial capabilities of the PDF.

To save geospatial PDF export settings, click the Save Settings button, choose a location and specify a filename. Files
are saved as *.pes format. To load a geospatial PDF export settings file, click the Load Settings button and browse for a
*

.pes file.
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The Profiles drop-down list contains pre-configured optimization settings. Choose from Standard, No Layer List, No
Model Tree, No Attributes or PDF Maps (the Avenza mobile iOS and Android app). The No Layer List profile removes
Layer List settings so that layers do not appear in the Layers List in Adobe Acrobat. The No Model Tree profile
removes Model Tree settings. The No Attributes profile removes all attribute settings. The PDF Maps profile removes
Layer List and Model Tree settings and disables the Embed Al file within PDF option to minimize file size. Choose
Standard to enable all standard settings.

RESULTS

The exported geospatial PDF can be opened in Adobe Acrobat—the geographic reference and attribute
information are available for query (see next section).

The default PDF settings are applied, regardless of any specific preferences set elsewhere:
«  Compatibility: Acrobat 8, PDF 1.7.
«  General: Embed Page Thumbnails and Create Acrobat Layers from Top-Level Layers.
«  Compression: no image compression, Compress Text and Line Art is enabled.
. Security: no master or user password required.

Notes: After export, the document will be modified and an Undo will be needed to restore it to its current state.
Layers exported without attributes can be seen in the Adobe Acrobat Layers panel, but not in the Model Tree.

During export, a warning may appear: "Multiple Art Objects Matched - One or more map objects may be
missing attribute information". This simply states that the layers listed in the warning have objects that are
close enough in proximity to each other that they are indistinguishable. There is an option in the warning to
select these objects in the event that the user may want to work on them.

To change PDF file settings (compression, password access, etc.) open the exported geospatial PDF file in Adobe
Acrobat Pro or Pro Extended (version 9) and resave the document.
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View Geospatial PDF

Geospatial PDF files are compatible with the geospatial tools in Adobe Acrobat 9 and higher. The availability of
these tools depends on the Acrobat version: Reader, Standard, Pro, or Pro Extended (Adobe Acrobat 9 only), but no
additional Acrobat plug-in is necessary to view a geospatial PDF.

Note: Geospatial PDF files can also be read in Adobe Acrobat 8, however, only attribute information is accessible
(through the menu Tools > Object Data > Object Data Tool) and it does not have the geospatial tools that are
available in Adobe Acrobat 9 or higher.

All traditional Adobe Acrobat tools apply with the following being the most relevant:
- Search: select objects with matching name first, then objects that have a matching attribute value.
«  Acrobat Layers panel: displays all layers and controls the display and lock of the layers.
+  Object Data Tool: select map objects and display their attributes in the Adobe Acrobat Model Tree
(Structure Pane and Object Data Pane).

Adobe Acrobat has the following special tools to access geospatial information:
. Measuring Tool: measure distance, area and perimeter.
«  Geospatial Location Tool: display, mark and query geospatial locations.
«  Geospatial Registration Tool: spatially register a PDF document by digitizing control points (Adobe Acrobat
9 Pro Extended only).

These tools and the Object Data Tool are found on the Analysis Toolbar (menu View > Toolbars > Analyze).

¥ Analyze

e ObjectDataTool - Enable selection of MAP
objects and display name and information in
the Adobe Acrobat Model Tree (menu View >

— El.m Measuring Teool Navigation Panels > Model Tree).

@ Object Data Tool

Measuring Tool - Measure
distance, perimeter and area.

@ Geospatial Location Tool e—————— Geospatial Location Tool

Snap Types Measurement Types Display, mark and query geospatial locations.

NN X Y Y

Preferences for the Measurement and Geospatial tools are found in the menu Edit > Preferences, under the category
Measuring (Geo).

Preferences EX

Markup Settings

) Enable Measurement Markup

[¥]Use defaut distance un

Use defaultarea wit: Square Miles

“ parency lay and

oK Cancel
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These analysis tools are described in detail in the Adobe Acrobat documentation that can be found under the
Adobe Acrobat menu Help > Adobe Acrobat Help or on the Adobe Website www.adobe.com.

Not all tools are available for every Adobe Acrobat version, below is a matrix showing the features availability per
Adobe Acrobat version:

Acrobat version Reader 9 and higher Standard and Pro Pro Extended 9
9 and higher (Windows only)

Geospatial Measuring Tool

Measure distance/perimeter/area v v Ve

Store measurements as comments v v v

Export/import PDF comments v'* v v

Geospatial Location Tool

Show on-screen coordinates v v v
Search for/zoom to a location N4 v v
Mark location with right click X v v
Copy coordinates to clipboard X v v
Geospatial PDF Registration Tool

Create from GeoTIFF/JPG2000 X % v
Georegister a PDF map/image X X v
Add shapefile layers to a map X X v

*To enable the measurement tool in Acrobat Reader, the file must first be opened in Acrobat Standard, Pro or Pro
Extended to enable annotations in the PDF (menu Comments > Enable for commenting and analysis).

Notes: The extended tools of Adobe Acrobat Pro Extended are not necessary for MAPublisher users because these
functions can be performed by MAPublisher. Adobe Acrobat Pro Extended is currently not supported for Mac
operating systems.

By default, viewing coordinates with the Geospatial Location Tool will show latitude and longitude in WGS84
when the Always display latitude and longitude as WGS 1984 option is enabled in Adobe Acrobat preferences.

A map with a geodetic base other than WGS84 should have the Always display latitude and longitude as WGS

1984 option unchecked.
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MAPublisher
LabelPro™

MAPublisher LabelPro is a comprehensive collision-free
labeling solution integrated into MAPublisher. Using rules
and styles for text placement, it extracts label information
from map layer attributes and performs fast, intelligent,
cartographic text placement. Placement rules can be saved to
a file and imported into other labeling work sessions.

Topics covered in this section:
MAPublisher LabelPro
MAPublisher LabelPro Settings
MAPublisher LabelPro Styles
MAPublisher LabelPro Rules
Label Verification

MAPublisher LabelPro is available as an optional add-on to
MAPublisher. To purchase a MAPublisher LabelPro license,
please contact sales@avenza.com or visit www.avenza.com.

For information on how to activate a purchased or evaluation
license please refer to chapter 1.

Note: The evaluation version of MAPublisher LabelPro
scrambles the text of placed labels but preserves the
case, spacing and punctuation, so that the results give
a sense of how actual labels would be placed based on
the rule settings.
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MAPublisher LabelPro

Object > MAPublisher > MAP LabelPro or MAP Toolbar

Source - Displays MAP

Views and its associated
MAP Layers chosen for specify if a layer
labeling in Setup Layers  should be labeled

Label - Clickto  Obstacle - Click to
specify if a layer
should be an obstacle

Priority - Assign a label priority
level to each layer. Multiple layers
can have the same priority.

Setup Layers - Open the

Setup Layers dialog box to
choose which layers are

to be used for labeling
and/or obstacles

Label source - Choose the '
attribute containing the

data to be used as labels
for selected features

Output layer - Choose a
layer to save labels to. Use
an existing text layers or

generate one on the fly.

Style - Choose a default set
of label styles or create
custom styles that change
label appearance

Rules - Choose a default
set of label rules or create
custom rules that dictate

label placement

Suppression layer

Store labels in a layer that

could not be placed based

on the rules set

Context menus

MAP LabelPro
& Setup Layers| | [] Only label selécted prt Label =
4| Source T & | Mame: |Label filter #1 Save
w | 4 @ San Francisco Downtown rsaEeTs —
Post_Offices_point
El Public_Schools_paint D & , Is labeled
[T Labelfitter#1 55 & 1 [:1abel source: 53] SCHOOL_NAME - Advanced. ..
Streets line & 1
Land_area Output layer: SCHOOL labels -
Parks_area D& 1 [ipronty: 12 TieT i s -
Style: School_Label_Style - |47 Export Settings. ..
Rules: School_Label_Rule - |73
Suppression layer: | [Z] [Ignored] -
Label Filter:
O Apply o all
(®) Limit by expression:
PTNAME= "SF Unified Scheol District (sFUsD)” | & [
« The expression is valid,
[] Stopif art satisfies this expression
Label fiters: || [0 [@]  |@
Label filter controls Batch generate label filters - Generate multiple
Add, copy, remove label filters based on unique values of a
selected label filters specified attribute
Right-click (Windows) or Ctrl-click (Mac) to access the following context menus:
Source MAP View
Set destination layer - Set the same ——s  5et destination layer ¥
destination layer for all source | o Setsuppression layer
layers in the MAP View J_ PP ¥
Set suppression layer - Set the same & Setup layers... o—— Setup layers - Opens the

suppression layer for all source
layers in the MAP View

Edit style - Opens the —
Style dialog bOXJ-
Edit rules - Opens the
Rules dialog box

Batch generate label filters J_ <

Opens the Batch Label Filter
Generator dialog box
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Setup Layers dialog box

Source MAP Layer

o Edit style..
#§  Edit rules..

Hide this layer o— Hide this layer - Hide the layer
from being labeled

]

Batch generate label filters...

Setup layers...

Label - Label based on the
settings in the dialog box

Save - Save the current
settings in the LabelPro
configuration dialog
box without performing
labeling process

Advanced - Specify user
defined extents for
labeling operations

Import/Export Settings
Import or export a MAP
LabelPro Settings file (Ips),
a format that stores all
the settings in the current
dialog box

Labelfilter - Label or
obstacle unique values
for a specified attribute.
Create multiple label
filters to perform flexible
labeling options.



FUNCTIONALITY

The MAPublisher LabelPro labeling engine offers advanced labeling capabilities beyond those available in
MAPublisher Label Features. The MAPublisher LabelPro engine contains sophisticated algorithms that solve

many of the most common map labeling problems such as complex conflict resolution across multiple layers, the
ability to specify data as obstacles and the ability to create complex labeling conventions via user defined rules.
The MAPublisher LabelPro engine uses map data attributes for labeling and provides a much greater level of
sophistication and control that can be configured through an intuitive user interface. Data layers may be assigned
an order of prioritization for labeling sequences and existing text can be recognized as obstacles for multiple
labeling sessions if necessary. Placement rules and properties can be saved to a settings file and imported into
other documents.

Only Point, Line and Area layers can be labeled using MAPublisher LabelPro. Text layers may be used as obstacles.

PREREQUISITES

Before labeling with MAPublisher LabelPro, it is recommended to create destination MAP Text layers (where new
labels will be contained). Optionally, create text suppression layers for labels that can't be placed by MAPublisher
LabelPro. To create a new text layer, use Add MAP Layer in the MAP View panel (see chapter 4). Alternatively, create Text
layers on label generation.

For each source layer, MAPublisher LabelPro derives the labels from a selected attribute column. Use the

MAP Attributes panel to analyze and/or edit the information prior to labeling. For instance, to force some labels to be
stacked, users can insert the characters && in the MAP Attribute value to indicate a Carriage Return — this can be
done by combining two columns into a new one or using the Find and Replace function.

MAPublisher LabelPro generates static text, therefore, the map extent and scale should be established prior to
labeling. Once placed, labels do not maintain a link with the source data.

To label only selected art, make an art selection on the artboard, start MAPublisher LabelPro, and click the Apply
only to selected art option.

In MAPublisher Preferences, the base rule and style folder paths can be set for MAPublisher LabelPro. By default,
invisible objects are ignored by MAPublisher LabelPro (they will not be labeled or used as obstacle). To take them
into consideration, uncheck the Ignore invisible artwork option. Also, check the Merge multiline text option to create
single line text labels. For more information about MAPublisher Preferences, see chapter 1.

USING MAPUBLISHER LABELPRO

To start MAPublisher LabelPro click the MAP LabelPro button on the MAPublisher Toolbar or from the menu
Object > MAPublisher > MAP LabelPro.
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MAPublisher LabelPro Settings

SETUP LAYERS

Before labeling, click Setup Layers to configure which MAP Layers are used in the Source list in the MAP LabelPro
dialog box—these source layers can be set as obstacles, as labels, or both. Obstacles are map objects that are
included in the conflict resolution decision making process, and are considered objects that must be avoided
when trying to place a label. The Setup Layers dialog box displays all valid MAP Views and their MAP Layers in
the document. To show layers in the Source list, check the appropriate Show check box to the right of the layer
name. All layers are listed in the dialog box, but only layers that are checked will be included in the labeling
process or considered as obstacles. All label settings (including styles and rules) are remembered even if a layer is

subsequently not shown.

Setup Layers

Name - Displays all MAP Views
associated layers that can be
used as labels or obstacles

Mame

2 @ San Francisco Do
LAND_labels
MAP_TITLE
PARK labels

STREET_labels

Public_School

Note:

HIGHWAY_INTERSTATE_|abels

SCHOOL _labels

SUPPRESSED labels
Post_Offices_point

Highways_line

Ok

Show — Enable the check box for

wntown
Cancel

s_point

ORRO000000 §

each data layer to be shown in
the main MAP LabelPro dialog
box. This control enables or
disables which source layers
can be labeled or set as
obstacles. Enabling the option
beside the MAP View name
will enable the label option
for all the data layers that
belong to it.

Layers may be used as both a label and an obstacle concurrently. It is possible to perform labeling operations

for multiple MAP Views simultaneously, however, source data layers and output text layers must belong to

the same MAP View.

ADVANCED OPTIONS

In the Advanced options dialog box, set the Label Placement Area option to the extents based on the current
artboard or the extents of labeled source layers. To set Label Margins, enable the option and enter the extents of the
label container in increments of the current document units. Data that is outside of the label margins is disregarded
in the labeling process. Right-click Label Margin boxes to change measurement units.

Extents of the current artboard

(Default) Label all designated data
that falls within the extents of the
current artboard

Extents of labeled layers — Label data —,_
only to the extents of the selected
MAP Layers

Label Margins — Enable to add
margins to the selected extents

Obstacles — Enable to specify that
paths without stroke are not
considered obstacles.

Note:

Advanced

Label Placement Area:
— (®) Extents of the current artboard

—e () Extents of labeled layers

—e ] Label Margins:

Top:

Left: 0.50in

.

Right:  |0.00in

A ([4v] [

Bottom: |0.00in

Obstacles:
.
[] Paths without stroke are not considered obstacles

Cancel

These settings are applied in conjunction to the settings from the Source Art section in the main MAP LabelPro

configuration dialog box. Units for margins are determined by Document Setup in Adobe Illustrator.
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LABELS AND OBSTACLES

The Source column shows the MAP View, Area, Point, Line and Text layers that are enabled in Setup Layers. Select a
layer in the Source list and view its settings to the right of the Source list. Each layer can be set to either be labeled
or be an obstacle. Click in the Label column beside the layer to set it to be labeled or click in the Obstacle column to
set it to be an obstacle. Obstacles are used to prevent labels from being placed over or around specified features.

When a layer is set to be labeled, its label settings become enabled. Choose the appropriate attribute as the source
for labels in the Label source drop-down list (see how to style labels in the MAPublisher LabelPro Styles section).

Note: By default, label case matches the attribute table exactly. To modify a label's case, use the Label case setting
located in the Style dialog box.

OUTPUT AND SUPPRESSION TEXT LAYERS

Generated labels are placed on layers specified in the Output layer and Suppression layer drop-down lists. Choose
an output layer to contain only the labels that could be placed successfully on the map based on the defined rules.
Existing Text layers can be used as output layers or use the [Create on label generation] option to create a Text layer
automatically when labels are generated. These layers will be named [layer name] Labels.

Suppression layers are repositories for labels that could not be placed successfully according to the rules and
have not met all placement conditions. For best viewing results after labeling, hide the suppression text layers.
Alternately, set the suppression layer to [Ignored] and unsuccessfully placed labels will not output to any layer.

Note: Locked output or suppression layers are displayed in red in the Source list in the configuration dialog box.
It is normal for a certain percentage of labels to not succeed in being placed due to rule or data conflicts.
Information regarding the success rate of placement can be reviewed in the MAPublisher Log.

PRIORITY

The Priority setting allows for complex hierarchical labeling sequences. The priority is the order of preference

in which labels are placed. Set priority by selecting a number in the Priority setting for a respective layer. Layers
with a priority of 1 will be placed first (high priority). Layers with a priority of 12 will be placed last (low priority).
Consequently, layers with a low priority may have more labels sent to suppression layers (dependent on how styles
and rules are setup).

Note: A maximum of twelve priorities may be assigned at any given time, however the same priority number can
be assigned to multiple layers.
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LABEL FILTERS

Label filters are used to label unique values for a specified attribute. For example, a road layer contains multiple
codes to classify its type (local, highway, ramp, etc). The label filter can be based on the classification code where
rules and styles for each filter can be customized to label each road type differently.

To add a label filter to a selected source MAP layer, click the Add Label Filter button (below the Source list). In the Label
Filter section, the Limit by expression option provides settings to enter an expression (or use the Expression Builder

or Expression Library—see chapter 5). The labels limited by expression will follow the label settings specified

above the Label Filter section. A label filter can effectively be "disabled" by choosing Apply to all. This means that any
remaining labels in the source layer that are not filtered by an expression will follow the rules and styles set in the
label filter with the Apply to all option enabled.

Reorder label filters using the up and down arrows to the left of the Source list. The order is important if the Stop if
art satisfies this expression option is enabled. This option can prevent subsequent label filters from being executed.

Add multiple label filters to a MAP layer to create flexible labeling options. To create multiple label filters at once,
click the Batch generate label filters button. In the Batch Label Filter Generator dialog box, base the label filter on an
attribute in the Attribute drop-down list and click the Load button to view how many values the chosen attribute
has. Then choose a data classification method (Equal Intervals, Quantiles, Natural Breaks or Unique Values). The
number of data classes will determine the number of label filters generated. Optionally, in the Default Settings
section, choose whether the label filters should be an obstacle, a label, or both. All the settings in this section are
considered the default for all of the generated label filters.

Batch Label Filter Generator

Source: Streets_line O . =
A gnore: d 5
Attribute — Choose an attribute T attribute: | [ CLASSCODE - ) )
and click Load to display Empty expression. In position: 0 Cancel
the values into the Data Load
Classification section Data Classification:

Source: 2,937 value(s) (4 unigue) from CLASSCODE

Method: |Unique Values v | Datadasses: 4 |=  Indusive boundary: Start value

Expression

Data Classification — Choose
a classification method to
determine the expression

used for each label filter

Default Settings:
) [] 1s obstade Priority: 1 2.
Default Settings — Set default —e
settings for the label filters. Is labeled Style: Street_Label_Style i
Further customization for Label source: | [f3] CLASSCODE +| Rue: Street_Label_Rule -7
each label filter can be done
after adding them here. Output layer: STREET |abels ~ | Suppression layer: | [7] [lgnored] -

1 CLASSCODE = "0"

2 CLASSCODE = "3"

3 CLASSCODE = "4"

4 CLASSCODE = "3"

v

[] Add rule expressions to Recent Expressions in Expression Library

Add rule for ignored expression

After adding label filters, the settings for each label filter can be further customized. Select a label filter and its

settings appear to the right of

the Source list.

To copy a label filter, click the Copy Label Filter button. To delete a label filter, click the Remove button.
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MAPublisher LabelPro Styles

POINT AND AREA STYLES

The Style dialog box is used to set label style properties for each map layer. To access the dialog box, click the
Style edit button. Set the text properties for font family, style, size and colour. A sample preview of the stylized text

reflects the changes made.

Name - Name of the saved style.
[Custom] is shown when the style is
modified and unsaved

Font family/style - Specify the font and
font style for the labels

Size — Specify the font size

Color - Click the color chip to
open the Adobe lllustrator
Color Picker dialog box.

Choose by color model or pick
colors from available swatches.

opacity for the labels

—e [] Add halo to label
Opacity - Specify the level of

Add halo to label - Add a halo to
the labels. Click the color chip
to choose a different color.
Adjust the size of the halo in
the Size setting.

e Name: [Custom]

e Size:

e Colour:

—e Opacity:

Style

Font family: | T Arial -

e

Fontstyle: |Regular A

35.00 pt z

—— Save As — Save the current settings
into a style file

Label case: {Leave as

100% %

colour: ||

Size:  1.00pt s

Preview:

Sample text

Label case — Change the label case:

« Leave as is: default case of the
attribute value

« Convert to lower case: e.g. abcd

- Convert to upper case: e.g. ABCD

« Convert to proper case: e.g. Abcd

Show actual size

Preview — Text sample (result may not
be exact for some font families)

When a saved style is edited, the Name is changed to [Custom], indicating that style settings have changed and is
unsaved. Click the Save button [E to save the style as new or overwrite an existing one. Style files are saved to either
a point, line or area folder depending on the type of map layer it is associated with. By default, styles are saved in

the following location:

Windows 7/8: C:\ProgramData\Avenza\MAPublisher 9\LabelPro\Styles
Mac OS X: Applications/Avenza/MAPublisher 9.5/MAPublisher Plug-In/LabelPro/Styles

The default save path for the Styles can be modified in the MAP LabelPro section of MAPublisher Preferences.
Choose Edit > MAPublisher Preferences (Windows) or choose lllustrator > MAPublisher Preferences (Mac).

Notes: For Windows, labeling with PostScript Type 1 fonts that are not placed in the Windows system font folder will
produce a Failed to perform label placement: FontNotFound Exception error message. In these very rare cases,
the font files should be copied from the Adobe font folder (usually under C:\Program Files\Common Files\
Adobe\Fonts\Reqrt\Base) to the Windows font folder (found from Control Panel > Fonts). Notably, Myriad font
is such a PostScript Type 1 font that is not installed on the Windows font folder by default.

Notes:

Attributes consisting of Unicode characters must be labeled with a Unicode font that contains the

appropriate characters. For example, attempting to label Japanese characters with an Arial font will result in

an error or incorrect results.
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LABEL LINE DATA WITH SYMBOLS

MAPublisher LabelPro has the ability to place labels inside symbols. A typical application of this would be

numbered highway route shields. To label lines with symbols, check the Label with symbol check box to enable
the symbol options. Choose an appropriate symbol set from the Symbol File drop-down list and select a symbol
from the Symbol drop-down list. Use the Height option to change the size of the symbol in the Adobe Illustrator

document unit (e.g. inches or millimeters).

Name - This style is currently a ——
saved style. When [Custom] is
shown, that means the style has
been modified and is unsaved.

Label with symbol - Enable to ——
activate the symbol options

Symbol file - Choose a symbol J
file (Isf) that contains the
desired set of symbols

Symbol - Choose the symbol
from this drop-down list

Style

e Name: Highway Style
Font family: | 7 Verdana
Font style: | Bold
Size: .00 pt z
coour: [l
Label case: |Leave asis -
Opacity:

[ Add halo tolzbel

Colour: ||

Size:  1.00pt :

—*[] Label with symbol
e symbol fle: | generic_shields.sf -

Symbol:

Preview:

@ Blue Interstate Shie ~ | Height: | Auto '+

100% %

—t

No preview available

Symbols are stored in the location set in the MAPublisher Preferences (see chapter 1). The default locations are:

Show actual size

Windows 7/8: C:\ProgramData\Avenza\MAPublisher 9\LabelPro\Symbols
Mac OS X: Applications/Avenza/MAPublisher 9.5/MAPublisher Plug-In/LabelPro/Symbols

Notes: The label font size and a fixed symbol height (not Auto size) affect how a label is sized inside a symbol. For
example, if a fixed symbol height of 0.5 in is used, but the label font size of 5 pt, the symbol will be 0.5 in but
the label inside will be no greater than 5 pt. If the label font is set to 50 pt, but the fixed symbol size is 0.5 in,

Height- Specify a height
manually or allow the symbol
to be scaled automatically

to fit the label's text via the
Auto option.

the label will have a maximum size of whatever fits inside the symbol or the selected font size.

Symbol preview is not available in the Preview box.

Each symbol file has one version in RGB colour and one in CMYK.

Labeling with symbols is only available for Line layers. To label areas with symbols, use Plot Centroids in the

MAP Point Plotter (see chapter 6).

320 | Chapter 17: MAP LabelPro

MAPublisher LabelPro Styles



MAPublisher LabelPro Rules

MAPublisher LabelPro provides users with an intuitive, easy to understand graphical user interface for setting up
labeling rules. Each Point, Line and Area rule dialog box has numerous label placement options for a high level of
label detail and a variety of configurations.

To access label rules for each layer, make sure it is set to be labeled, then locate the Rules drop-down list. Click the
Rules edit button beside the list to open either the Area, Line or Point Rules dialog box.

Rules operate in a very similar approach to styles in that once added to the Rules list, they can be immediately
applied, reused later in the same file or in other documents provided they are being applied to the same type of
data. Rules are saved to the Area, Line or Point folder depending on the feature type of the MAP layer.

MAPublisher LabelPro offers a pre-configured [Default] rule for each data type. It is loaded by default and used until
new rules have been created or selected. The default rules are a good starting choice as it is configured to be useful
for the most common labeling situations, however, creating custom rules can be very useful when specific labeling
conventions are required. Default rules can be overwritten. Saved rules are added to the Rules drop-down list.

In an Area, Point or Line Rule dialog box, the rules are organized into tabs based on Placement, Grouping (Lines
only), Fitting, and Conflict Avoidance. The sequence in which the rule options appear and are checked have no

bearing on the order of label placement, only whether the option is enabled or not. Adjust the Priority value of
layers to adjust the sequence of label placement.

Existing rules may be deleted by selecting them from the Rules drop-down list and clicking the Delete button.

When a saved rule is modified, it turns into an unsaved rule indicated by the name [Custom]. Click the Save
button [El to save the rule as new or overwrite an existing one. Rule files are saved to either a point, line or area
folder depending on the type of map layer it is associated with. Rules are saved to the location set in MAPublisher
Preferences (see chapter 1). The default locations are:

Windows 7/8: C:\ProgramData\Avenza\MAPublisher 9\LabelPro\Rules
Mac OS X: Applications/Avenza/MAPublisher 9.5/MAPublisher Plug-In/LabelPro/Rules

Note: Labeling results will vary depending on which rules are enabled. If no rules are enabled, MAP LabelPro will
not perform any labeling.
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AREA RULES

The Area Rules dialog box contains the label configuration options for labeling Area layers. Rules can be set by
selecting an area feature type layer and clicking the Rules edit button in the Rules column. The placement settings in
the screenshot below represent the default configuration, however, these settings may be changed to match any
labeling requirements. Click the Save button to save the rules to file. Click OK to confirm the current settings.

Allow horizontal inside
Labels are allowed to
be placed horizontally —
inside the polygon

Allow dominant angle —
Labels are allowed to
be placed parallel to
the dominant angle of
the polygon

Allow extending beyond —
boundary - Labels are
allowed to exceed

Area Rules

Name: [Defaul]

Placement | Fittng | Conflict Avoidance

0T Allow horizontal inside

H, [] Allow dominant angle

—e [ Allow extending beyond boundary
[ Allow outside
[ Allow inside, along boundary

the boundaries of the
polygon being labeled

|

B[ o« |

Cancel

Allow outside — Labels are
allowed to be placed outside
the polygon being labeled

Allow inside, along boundary
Labels are allowed to be
placed inside the polygon,

following the polygon

boundary

About Allow overlapping labels

Allow use of leader lines —
Incorporate the use of leader lines.
Allowed line crosses permits the
number of lines the leader line will
be allowed to cross. Leader width and
Arrow style adjusts the thickness and
style of the leader line, respectively.

Flacement

Fitting

Large

City
City
City
City

Placement

Fitting

Conflict Avoidance

Allow stacking:

Lines: Up to 3lines

Alignment: | Feature

Allaw font reduction:
Steps: 4 (3

Allow stacking — Labels

are allowed to stack
e——————— up to a maximum

of two, three, or

four lines. Choose

Alignment option:

Feature, Left, Center

or Right.

Allow font reduction

Each step allows LabelPro 1o shrink the selected font by
0.5 o, # nacessary.

Conflict Avoidance

o———— Automatically
reduces the label size
incrementally, when
necessary. Each step
shrinks the selected
font by 0.5 pt.

Allow labels to cross obstacles

Allow labels to ross obstades e—————————— | abels are allowed to
cross line features and

Urban Area

.

S

[ Allow overiapping labels

area boundaries.

[ Allow use of leader lines:

Allowed line crosses:

Leader width:

3

1.00 pt

Allow labels
Area Labels are
allowed to overlap
other labels in the

B same labeling session

Style #1

When the Allow overlapping labels rule is enabled, labels are placed without applying other placement rules. In other
words, this discards other specified rules and labels are "forced" at its first position. Generally, it is recommended to
leave this rule off and use Allow font reduction, Allow stacking, and Allow use of leader lines to increase label placement.

Notes: For Area type data, labels are placed relative to an object's centroid.

For areas grouped in a compound path, the largest area of the compound will be labeled.
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LINE RULES

The Line Rules dialog box contains the label configuration options for labeling Line layers. Rules can be set by
selecting a line feature type layer and clicking the Line Rules edit button in the Rules column. The placement settings
in the graphic below represent the default configuration, however, these settings may be changed to match any
labeling requirements. Click the Save button to save the rules to file. Click OK to confirm the current settings.

Starting Point — Specify
where the start of the —
label is placed.

Centerline / Offset - Place
labels using an offset or
on a centerline. Offset

labels Above or Below a ——

line. Vertical split places
multiple word labels
above and below the
line and relative to

the center of the line.
If the generated label
only has one word, it
will be placed on the
suppression layer.

Specify label offset —-—-! .

Specify a specific

Line Rules

Mame: [Defaul]

Placement | Grouping | Fitting | Confict Avoidance

_. ) First character at start of ine
[ | ® centered

() Last character at end of line

() Centerline only
(® Any combination of the following offset positions:

Barton Roxd 1 (] pbove

[ Below

[ Vertical spiit

] Specify label offset:
Casay Strest
Units: | Inches

® Spedific |0.20in

Range: [0.20in o |0.20In B

distance or range

B[ o

Cancel

where labels are placed
from a line

Placement | Grouping | Fiting | Conflict Avoidance

m (®) Label compound features as one feature,
Label compound features as ——

one feature

Places one label on
aline that is joined
together. Label each
feature labels each and
every segment of a
joined line.

() Label each feature of a compound feature.

[] Divided highways

Divided highways — Label multiple road segments with
a common symbol such as a shield. Lines must be
within 0.25 inches and 75% of the lines must be
parallel to be considered a divided highway. The
divided highway symbol will be placed on the line
with the longest geometry.

Repeat labels every — Repeat labels
along a line at specified amounts

Spread words every — Multiple

Fitti
Placement | Grouping itting | Conflict Avoidance word labels placed a
[ IRepeatlsbelsevery 500 = Inches specified distance apart
|Oak St Oak St
| —

Allow overhang - Labels

_ [ spread words svery 100 3 Inches are allowed to overhang
the line up to a set

percentage. The
[] Mow overhang: 70,000 = *—————— percentage of overhang
MempilsEDs 1 is relative to the start of
the label and the end of

Alow stacking the line.
Street
Allow stacking — Labels

o

—
are allowed to stack to a
] Allow : X ]
City Allow font recucton maximum of two lines
City Steps: |4 =
City Exch step allows LabslPro %0 shrink the selected font by 0.5 t i
Gty | Frm shink the =& Allow font reduction

o————— Automatically reduces the
label size incrementally,
when necessary. Each step
shrinks the selected font
by 0.5 pt.

Placement | Grouping | Fitting

- Allow labels to cross obstaces e—————————————— Allow labels to cross obstacles
Market Strast
—

Labels are allowed to
cross line features and

[] Alow overlapping labels area boundaries
Markat Street
—

Allow overlapping labels

Confiict Avoidance

goundary | (] Allow use of leader lines:
/

~
\{

Allowed line crosses: |3

Leader width: 100pt

Arrow style: Style #1

Allow line labels to

— overlap with other labels

in the same labeling

s session

Allow use of leader lines — Incorporate the use of leader
lines. Allowed line crosses permits the number of
lines the leader line will be allowed to cross. Leader
width and Arrow style adjusts the thickness and style
of the leader line, respectively.

Notes: Text as obstacles will not work unless the Allow labels to cross lines option is disabled. This is because text

obstacles are treated as areas and not as text. Also, text will only be avoided being placed where it intersects
the outline of the shape and not within it.

Using the Placement option Vertical Split may require additional line smoothing (straightening or simplifying).

Offset distance is the distance between very outside extent of an object and the very outside extent of the
text bounding box. Offset range uses the position of the text anchor, not the bounding box, to calculate label
placement. When offset range is used, MAPublisher attempts to place labels close to the minimum range value.
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POINT RULES

The Point Rules dialog box contains the label configuration options for labeling Point layers and follows the same
conventions mentioned for the previous two data types.

Point Rules
Name: [Custom] B oK
Placement | Fitting | Confiict Avoidance Cancel
Placement - Click the
Placement | Fittng | Confiict Avaidance .
placement buttons in Clear Last Allow stacking - Labels
the desired order of North Allow stacking: e————are allowed to stack
priority. Use the Clear 1 ez Palm lnes:  |Uptodines v up to a maximum
: Beach
Last or Clear All options g ® Algnment: |Feature - of two, three, or
to remove selections. four lines. Set the
Unselected positions R alignment to the
will not be considered. City - - Fet;tur:, Left, Center,
; City ps: |4 |3 or Right.
Click the center ’ g
| b Select label placement in order of priarity; unselected @z Esch sizp slows Labelpr o shink the sieaad fons by
placement button to positions wil not be used. Label offset wil not be ty | osmdnessn o pllowfont reduction
set label on the center appled to the center placement position. Automatically
of the point S
71 Snedfy label offset: reduce the label size
i tally, wh
i _ Ol incrementally, when
wta == Units: | Inches
B oﬁsﬁet 0Tt necessary. anch step
Specify a specific - .
_p fy P ® specificc |0.20in : hrinks th I d
distance or range shrinks the selecte
Range: [0.20m |5 to 0.20m |2 font by 0.5 pt.
where labels are placed
from a line

Allow labels to cross obstacles Placement | Fitting | Confiict Avoidance

Labels are allowed to—s [ = allowlzbels to eross obstacles
cross line features, area ©
boundaries.

" + | ] Allow overlapping labels
. Prattyille
Allow overlapping label Allow use of leader lines

Allow point labels to Incorporate the use of

olvzrllap thrt]h other - [ Allow use of leader lines: leader lines. Allowed
abels in the same uilding N K
labeling session e/ Allowed line crosses: |3 B line crosses permits
¢ /\\ Leader widt Loont . =———the number of lines
: I the leader line will be

Arrow stle: Style #1 allowed to cross. Leader
width and Arrow style
adjusts the thickness
and style of the leader
line, respectively.

Notes: For each point label there is a fixed minimal zone of 0.3 inches, within which no other point feature can be
labelled. Consequently, when two point features are closer than 0.3 inches of each other, their labels are
automatically placed in the suppression layer (if selected).

Offset distance is the distance between very outside extent of an object and the very outside extent of the
text bounding box. Offset range uses the position of the text anchor, not the bounding box, to calculate label
placement. When offset range is used, MAPublisher attempts to place labels close to the minimum range value.

In a situation when both Specify label offset and Allow use of leader line rules are enabled, MAP LabelPro will
ignore the offset rule if a leader line needs to be used. (This applies to Point rules and Line Rules).

324 | Chapter 17: MAP LabelPro
MAPublisher LabelPro Rules



SAVE AND LABEL

Once the layers, main configuration, style and rule based options have been completed, proceed to label the map data
by clicking the Label button. Click the Label button to save the current settings, close the main MAP LabelPro dialog
box and begin the labeling process.

Progress

Labeling

I W wn @

Due to the complexity of the calculations involved in rule based text placement, a progress meter will be displayed
for most labeling processes except those that are sufficiently simple or small. Cancel the labeling process at any
time by clicking the Cancel button in the progress dialog box.

Alternatively, save the current settings without labeling by clicking the Save button. This will close the main MAP
LabelPro configuration dialog box and will not label any features. The dialog box can be reopened later to edit the
saved label settings or be used to label the map.

IMPORT AND EXPORT SETTINGS

MAPublisher LabelPro settings can be saved to a LabelPro Settings file (LPS). In the MAPublisher LabelPro dialog box,
click the Export Settings button.

Export Settings

Saved Styles & Rules: | Save contents -

The contents of [Custom] Styles & Rules are shways saved,
Cancel

[] include advanced settings

The Saved Styles & Rules drop-down list contains two save options: Save contents and Save reference only. Save
contents saves all layer and obstacle settings including styles and rules. Save reference only saves only the reference
to the Style and Rule (meaning the individual settings in Style and Rule could change, but the reference to it is kept
intact). Click the Include advanced settings option to also save settings from the Advanced dialog box.

To import a LabelPro Settings file, click the Import Settings button and navigate to the location of it.
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Label Verification

The graphic below shows results of a typical labeling result using options such as stack labels, repeat labels, allow
labels to cross lines, and many others.

AN

£

BROADNIEY l I._

Verify that labels were successfully placed in accordance to the rule base set out in the MAP LabelPro configuration.
Also verify that labels were placed on the appropriate Output layers. Text failing to meet the labeling criteria will

be placed in a Suppression layer (if one is available and has been set). If no Suppression layer is available, the label
is ignored and is not generated. Once placed, the labels are considered standard text and may be further modified
using Adobe lllustrator or MAPublisher operations.

Note: Undo and Redo operations are supported when labeling. LabelPro settings are retained after an Undo.

MAPublisher Log

Open the MAPublisher Log to view statistical information after the labeling process is completed. This information
is useful in determining how successful the labeling operation was based on the number of labels written to
Destination and Suppression layers. It may help indicate whether adjustments to the rule base are required to
achieve a higher rate of successful placement. The log can be exported as a text file for future reference.

MAPublisher Log

When Layer Message Clear
4 2 minutes ago Q; LabelPro labeling session
4 2 minutes ago ¢ Messages during label generation Deselect Al
» 2 minutes ago 7| metrastation_point messages
» 2 minutes ago Census_tract_area messages Export
» 2 minutes ago metralines_line_joined messages
6 TOTAL: 138 label(s) were placed
&9 TOTAL: 881 label(s) were discarded
18 minutes ago s Document Load

Show:
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Export to
PDF Maps App

PDF Maps is a mobile map application that enables you to
download maps for offline use on your Apple iOS or Android
smartphone or tablet. MAPublisher can create map packages
from your documents and be used in the PDF Maps app.

Map publishers registered on the PDF Maps Store (the in-app
map store) can upload maps directly to the vendor portal and
have them ready for submission and for sale quickly.

For information about the PDF Maps app and how to be a
map vendor, visit www.pdf-maps.com.

Topics covered in this section:
Export to PDF Maps Package
Upload to PDF Maps Store
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Export to PDF Maps Package

Object > MAPublisher > Export to PDF Maps Package or PDF Maps > Export to PDF Maps Package

Export to PDF Maps Package

Source - Export art on a Eris
specific artboard or export
all artin the document. )
Referencing is based on () Exportall artin the document
the chosen MAP View. Referencing: | & Vancouver Downtown -
Higher quality results in
more tiles generated.

Ok
(® Only export art on this arthoard: Artboard 1

Cancel

Quality: High (300 ppi) o
Tile count: 134 tiles

Destination:

Destination - Specify a destination e | Folder: jenzs|MARublsher 9.6\Maps

folder to save the map package to  Folder is valid.

Map Package Options:
Convert to indexed colour mode (recommended)
e

Map Package Options - It is recommended
to have map package tiles be Post Export Options - Launch the Upload
converted to indexed color mode. Post Export Actions: to PDF Maps Store dialog box after
Optimizing tile size may result in longer [ Launch Upload to PDF Maps Store dizlog box creating the map package. Open the
processing times. ———————= destination folder after processing
the map package.

[] Optimize tile size (slow)

Open destination folder

FUNCTIONALITY

Use Export to PDF Maps Package to generate map packages that can be directly uploaded to the PDF Maps Store,
an in-app map store for the PDF Maps app on iOS, Android, and Windows Phone. You can also generate map
packages and load them on your own devices through iTunes File Sharing or the Android file system, Dropbox, or
specify a URL to your own location. When maps are uploaded using the Upload to PDF Maps Store feature, it is put
into the Prepare for Review state on the PDF Maps Store.

All maps submitted to the PDF Maps Store are reviewed to ensure they are referenced accurately, perform as

expected, and contain appropriate content. As you plan and create your maps, be sure to keep our review and
design guidelines in mind so that you can get through the map review stage.

PREREQUISITES

While any document with a specified coordinate system can be exported as a map package using Export to PDF
Maps, you must have a PDF Maps Store vendor account to use Upload to PDF Maps.

Visit www.pdf-maps.com/vendors for more information on how to be a PDF Maps Store vendor.
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USING EXPORT TO PDF MAPS PACKAGE

Getting your maps ready for the PDF Maps app is a two part process depending on how you send or load the map
package. See the scenarios below:

Scenario 1 1. Use Export to PDF Maps to create map packages.
2. Use Upload to PDF Maps to prepare map packages and upload for
submission review.

The advantage of using Upload to PDF Maps is the ability to easily populate
details of your maps within Adobe Photoshop without having to go to the
PDF Maps vendor site.

Scenario 2 1. Use Export to PDF Maps to create map packages.
2. Go to the PDF Maps Vendor website to upload and prepare map
packages for submission review.

Scenario 3 1. Use Export to PDF Maps to create map packages.
2. Use iTunes File Sharing or the Android file system, Dropbox, or specify a
URL to transfer your map packages to your device.

This scenario doesn't upload map packages to the PDF Maps Store. It only
loads map packages to your mobile device. It is a good way to quickly test
your maps without having to go through the review process of the PDF
Maps Store.

With an open document, go to the MAPublisher tool bar and expand PDF Maps > Export to PDF Maps Package or
go to Object menu > MAPublisher > Export to PDF Maps Package.

In the Source section, choose to export all art on a specific artboard or the entire document. Choose the
appropriate MAP View to be the source for referencing. Choose from High, Medium, Low and Very low tile quality
settings. A higher Quality setting produces more tiles.

In the Destination section, choose a folder to export map packages to and specify any of the available options.

In the Export to PDF Maps Package dialog box, choose the source either as a specific artboard or all art in the
document. If multiple artboards are present, click the drop-down list and choose the appropriate artboard. In the
Destination section, specify an output folder.

In the Map Package Options section, choose a level of map quality from the Map quality drop-down (High, Good,
Medium, Low). A higher quality setting will produce more tiles in the map package. The map package file size will
be larger, but the image quality will be better. By default, the Convert to indexed color mode check box is enabled.
Note that this will not retain the full spectrum of RGB color space. It is recommended to have this option enabled.
Enabling the Optimize tile size option may result longer processing times.

In the Post Export Actions section, optionally enable the options after creating the map package. Enable the Launch
Upload to PDF Maps Store check box to open the Upload to PDF Maps Store dialog box (see next section). Enable the
Open destination folder check box to open the file browser to the location of the destination folder.
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MAP PACKAGE CONTENTS

A map package contains all of the content required to allow it to work on the PDF Maps app. When uploading a
map package to the PDF Maps Store, the ZIP file must be accompanied by all four associated files. For example, if
you have an exported map called MtOlympus, the ZIP would be called MtOlympus.zip and its four associated files
would be called MtOlympus_preview.jpg, MtOlympus_95px.jpg, MtOlympus_233px.jpg, and MtOlympus.csv. These
files must have the same name as the ZIP file and should not be renamed independently. A map package will not
get uploaded if any of the associated files are missing.

When loading a map onto your device through iTunes File Sharing or the Android file system, Dropbox, or a URL,
only the ZIP file is required.

When viewing a map package folder, it will look like the following:

E.B MtOlympus.csv
cd

? MtOlympus.zip
ﬁ MtOlympus_95px.jpg Type: JPEG image
& Dimensions: 95x 95

& MtOlympus_233pxjpg Type: JPEG image
a Dimensions: 233 x 233

ﬁ MtOlympus_preview.jpg Type: JPEG image
5 Dirmensions: 600 x 600

Map Package Contents | Description

*.csv A comma separated value file with coordinates that define spatial extent.

*zip ZIP file contains a tiles folder containing the images required to render the map in the
PDF Maps app. The ZIP also contains a thumbnail file and reference file, both of these
are required in the zip package. The zip package structure should not be altered.

* 95.jpg Small preview image; can be customized and used on vendor site.

¥ _233.jpg Large preview image; can be customized and used on vendor site.

*_preview.jpg Main preview image; can be customized, however the image size, color mode and
name should not be modified. You can create custom preview images to branding
purposes.

Note: A map package will not get uploaded if any of the map package files are missing.
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Upload to PDF Maps Store

Object > MAPublisher > Upload to PDF Maps Store or PDF Maps > Upload to PDF Maps Store

Upload to PDF Maps Store
Login to Upload Login Go to PDF Maps Store Upload
Select multiple records in a field to batch edit. Select entire rows to edit all values or to delete. Close
Status File Name Title Description Languages Publisher Published Date Pricing

1 % Americas 4zip Americas 4 Amap of eastern .S, English  Avenza 2015 - Free-

2 15} boston-east.zip boston-east An orthophoto of dewntown Boston. English Avenza 2015 Tier1-§0.99 USD

3 1) MtOlympus.zip MtOlympus A topographic map with shaded relief of Mt. Olympu... English Avenza 2015 Tier2 - 5§1.99 UsD

< >

& 14 3 @] [ Delete map package after successful upload Edit Selected. ., [

FUNCTIONALITY

Use the Upload to PDF Maps Store feature to directly upload your map package zip file to the PDF Maps Store
vendor site. This makes the process of staging your maps on the vendor site easier as you can upload multiple map
packages at once. Map details such as title, description, and price can optionally be completed in the Upload to
PDF Maps Store dialog box. You must be a registered vendor on the PDF Maps Store to use this feature, as you're
required to login through the dialog box before uploading.

USING UPLOAD TO PDF MAPS STORE

Login with your PDF Maps Store vendor account email and password. You must be logged in before you can upload
map packages for submission.

Note: To become a PDF Maps Store vendor, apply here https://mapstore.avenza.com/vendor/login.

Load maps from folder

Click the Load maps from folder button to specify a folder that contains map packages. All map packages in the
specified folder are added to the map table.

Load From Folder

. Folder: s\Public\Documents\avenzaMAaPublisher 9.6YMaps CK

« Folder is valid. Cancel

Load from CSV

Load maps and map details from a CSV file. This CSV file could be one that was manually created or one that was
exported by the Upload to PDF Maps dialog box.

Export table to CSV

Export the map details to a CSV file so that the table information can be imported and uploaded at a later time.
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Editing Map Details

Populating the map details can be done easily for multiple maps prior to upload. It is not mandatory to populate
the map details prior to upload, however, it will need to be completed on the PDF Maps Store vendor site before

submitting for review.

All available fields that can be edited include:

Title Give the map a concise, but descriptive title.

Description Write a map description that may include details about general or special map features.
Languages Choose languages that apply to the map.

Publisher Provide your company, agency or vendor name.

Published Date

A general time of when the map was published (e.g. 2015 or Jan 2015).

Pricing

Choose a pricing tier to sell the map at. Ranges from Free to Tier 77 - $249.99 USD.

Search Tags

Include descriptive keywords (space separated) to help users find the map when searching.

Primary Category

Choose a PDF Maps Store map category that pertains to the map.

Countries

Batch Edit Selected

Choose countries that the map area includes.

You can populate multiple fields that share the same map detail. To edit selected fields in a column, select multiple
fields (Ctrl + click or Shift + click) and click the Edit Selected button or right-click and choose Batch edit selected. To

batch edit an entire column, click a column heading to select the column and click the Edit Selected button.

Edit All

See all of the editable fields of one
map at once to make it easier to edit
map information. Use the navigation
controls to go to the previous or
next map.
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W][4]

oK

Filename:

Title:

Description:

Languages:

Publisher:

Published Date:

Pricing:

Search Tags:

Primary Category:

Countries:

[ \Users\MikeL \AppDatalLocal Temp\Geographic Imager|AvenzaPDF hoston-castiposton-cast.zp | | Browse...

« Filename is valid.

boston-east

An orthophoto of downtown Boston.

Available: Selected:

Afrikaans . English
Arabic L4
Chinese (Cantonese) 4
Chinese (Mandarin) v

Avenza Systems
2015
Information about when the map was published (g.g. “20107, "Dec 20117

Tier 1-$0.99 USD

Space separated list of keywords (¢.. “muskoka ontario fishing hiking)
Imagery -

Available: Selected:

Afghanistan ~
Africa »
Aland Pl
Albania v

United States of America

Cancel




UPLOADING MAPS

When you are ready to upload map packages, click the Upload button (you'll have to be logged in first). Check the
Delete map package after successful upload check box if you want to delete the files from the source folder after
the map packages are finished uploading.

When you log into the PDF Maps vendor website, the maps that were uploaded will be available and set to the
Prepare state. When you have completed all the necessary map details, you can submit the maps for review. Maps
are submitted to are reviewed by the PDF Maps team and when they are approved, are changed to the On Hold,
Ready for Sale state. Your maps can be set to For Sale at any time. Thousands of users use PDF Maps everyday and
the PDF Maps Store is a great way to sell your maps and generate revenue.

LOGOuUT

Avenza Map Store

Earnings Notifications 1 Add a New Map

=/ Select an action v Search

L Title State Updated |

Search
) MtOlympus Prepare 2015-02-18

[ boston-east Prepare 2015-02-18

Filter
) Americas_4 Prepare 2015-02-18

Show All Maps

I Remember to submit your maps to Avenza for review after you have finished preparing them. For Sale

On Hold, Ready for Sale

A purchased map may be downloaded several times by a user (for example, to load the map on different

devices). Sales numbers for maps can be found on the "Eamnings” tab. In Review

Download PDF Maps marketing materials (logos and brochures) here. Prepare For Review

Copyright © 2015, Avenza Systems Inc.  Legal Agreement  Contact Support  Help

See the PDF Maps Store help section (http://www.avenza.com/pdf-maps/support/store-help) to learn more about
map status and other details.
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Appendix 1: Technical Reference Guide

Graphic File Formats

Al
The Adobe lllustrator native postscript file format. Refer to the Adobe Illustrator User Guide for more information.

DoQ

Digital Orthophoto Quadrangle (DOQ) are geographic images from the United States Geological Survey (USGS) and
are stored in the JPG format. They can be placed by Adobe lllustrator and registered by the MAPublisher Register
Image function. DOQ are usually very large files (30 MB or more) and require extremely large amounts of RAM.

DRG

Digital Raster Graphics (DRG) are scanned images of published topographic maps from the USGS stored in TIF
format. They can be placed by Adobe lllustrator and registered by the MAPublisher Register Image function. DRG
are also usually very large files (30 MB or more) and require extremely large amounts of RAM.

EPS

The Encapsulated Post Script (EPS) file is used to transfer PostScript language artwork between applications. EPS
files are easily opened by Adobe lllustrator because the format is widely supported by most graphics programs. It
is the preferred format for export to most illustration and page-layout programs. EPS files are vector based, but can
contain embedded raster graphics and fonts.

GIF
Graphic Interchange Format (GIF) is a colour-indexed graphics format, commonly used for web pages and image file
transfer. Adobe Illustrator can export 8-bit indexed-colour or grayscale GIF.

JPEG

Joint Photographic Experts Group (JPEG or JPG) is a compression technique for raster file formats. The Digital
Orthophoto Quadrangle geographic images from the USGS are stored in this format, which can be imported by
Adobe lllustrator and registered by the MAPublisher Register Image function.

PDF / GEOSPATIAL PDF

Portable Document Format (PDF) is a standardized format developed by Adobe for use across Macintosh, Windows,
DOS, and UNIX platforms. Based on the PostScript Level 2 language, PDF supports both raster and vector graphics.
A Geospatial PDF is an Adobe Acrobat file that retains geospatial coordinates.

TIF/TIFF (GEOTIFF)

Tagged Image File Format (TIFF or TIF) is a common raster graphic file format that can be imported by Adobe
lllustrator. Many raster geographic images from GIS systems are stored in this format, which can be imported
by Adobe lllustrator and registered by the MAPublisher Register Image function. A GeoTIFF is a TIFF file with
embedded geographic information identifying its position and scale in world coordinates.

OTHERS
Please refer to the Adobe lllustrator User Guide for other graphics file formats supported by Adobe lllustrator.
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MAPublisher Import Formats

This section contains descriptions of the GIS formats supported for import by MAPublisher. Here you will find
an overview of the structure of each format, as well as information on supported format versions and elements
unique to each data type. Each file format will carry a checklist covering which core elements are supported by
MAPublisher during its import. You can also refer to the Frequently Asked Questions section in this guide for
information on any issues associated with the various file formats. Also see chapter 2 on Map Data File Formats.

AUTOCAD DRAWING (DWG) AND DRAWING EXCHANGE (DXF)

There are two formats used by AutoCAD: DXF and DWG. DXF is a CAD data file format, developed by Autodesk as
their solution for enabling data interoperability between AutoCAD and other programs. The DWG format is used for
storing two and three dimensional design data and is the internal format for the AutoCAD Computer Aided Design
package. DWG is also the common name for AutoCAD proprietary DWG technology developed by Autodesk for
their AutoCAD package.

Supported Elements Supported Geometry
Typical File Extensions *.dwg, *.dxf Aggregate No
Automated Translation Yes Circles Yes
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support No Elliptical Arc Yes
Generic Colour Support Yes Ellipses Yes
Spatial Index Never Polygon Yes
Schema Required Yes Donut Polygon Yes
3D Support Yes Point Yes
Line Yes
Text Yes

Supported Versions
Windows: Releases vrs. R12 to 2007
Mac OS X: Releases vrs. R12 to 2007.

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The
following parameters can be applied to the import:

- Group Entities - Group entities by Layer Name or Geometry.

- Hatches - Check this box if you want MAPublisher to read your hatch patterns upon import.

+ White Lines and Fills - Enabling the Import as is option will instruct MAPublisher to import the data true to the
original colour settings contained in the file. Check the Change white lines and fills to black box to import black
lines instead of the files native white lines. Check the Create black background option to incorporate a layer
containing a black background to mimic the AutoCAD environment.
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DELIMITED ASCII TEXT (CSV, TSV, TXT)

An ASCll file containing a tabular data where delimiters separate the columns and rows. Common delimiters are
commas, spaces or tabs. Microsoft Excel and many other spreadsheet programs will export data in these formats.

Supported Elements Supported Geometry
Typical File Extensions *.csv, *.tsv, *.txt Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes Yes Circular Arc No
Coordinate System Support No Elliptical Arc No
Generic Colour Support No Ellipses No
Spatial Index Never Polygon No
Schema Required Yes Donut Polygon No
Point Yes
Line No
Text No

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The
following parameters can be applied to the import:

« Axis Column - Specify which columns contain the x and y coordinates for the point data to be read in.

- Coordinate Format - Choose the formatting type of the data you wish to import (e.g. Decimal Degrees, Delimited
Degrees Minutes Seconds, Packed DMS) — formats are described in chapter 6.

- Usefirst line as header - Allows the user to enable the first line of the text file to be used as column headings.

ESRI INTERCHANGE FILE (E00)

An archive of files that describes a complete Arcinfo coverage. This is either ASCIl or compressed into a binary and is
used to transfer files between different versions of Arcinfo. It is a commonly found format for freely distributed data
such as that found at the GIS Data Depot (http.//www.geocomm.com).

A single EQO file describes a complete Arcinfo coverage. The file itself is actually an archive of several smaller files,
referred to as subfiles. Some of these subfiles have fixed names which do not vary from coverage to coverage, and
follow a predefined data format. The remainder of the subfiles contained within an EQO are the info files. These files
may contain user-defined attributes, and have names which vary from coverage to coverage.

Supported Elements Supported Geometry
Typical File Extensions *.e00 Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support Yes Elliptical Arc Yes
Spatial Index Never Ellipses No
Schema Required Yes Polygon Yes
Geometry Type Attribute e00_type Donut Polygon Yes
Point Yes
Line Yes
Text Yes

There are essentially four types of geometry defined in EQO files, which will be reproduced as layers during import:
Arcs (lines), Points, Polygons, and Text. Prior to the import process, an additional Setting can be made:

« Ticpoints layer - This option enables you to include an additional layer which will hold the registration points for the
imported data. The default is to set to Yes.
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ESRI ARCINFO GENERATE (GEN)

Esri simple ASCII storage and interchange format. There are three different types of .gen files each with of its own
syntax one for points, one for lines, and one for text geometries. This is the format exported by Arcinfo generate
command. The *.gen files are use by ArcInfo to transfer coverages to other mapping systems.

Supported Elements Supported Geometry
Typical File Extensions *.gen Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes No Circular Arc No
Coordinate System Support No Elliptical Arc No
Generic Colour Support No Ellipses No
Spatial Index Never Polygon No
Schema Required Yes Donut Polygon No
Geometry Type Attribute arcgen_geometry Point Yes

Line Yes

Text Yes

ESRI GEODATABASES

A Geodatabase is a native Esri ArcGIS data format for storing geographic data. It is a collection of geographic
datasets of various types used in ArcGIS and managed in either a file folder or a relational database. There are two
main types of geodatabases:

«  Single-User: Personal Geodatabases (extension *.mdb) and File Geodatabases (extension *.gdb)

«  Multi-User: server based geodatabases, also known as ArcSDE Geodatabases.

Supported Elements Supported Geometry
Typical File Extensions *.mdb (personal), *.gdb (file) Aggregate Yes
Automated Translation Yes Circles Yes
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support Yes Elliptical Arc Yes
Generic Colour Support No Ellipses Yes
3D Support Yes Polygon Yes
Schema Required Yes Donut Polygon Yes
Transaction Support Yes Point Yes
Enhanced Geometry Yes Line Yes
Geometry Type Attribute geodb_type Text Yes
Encoding Support Yes Raster No
Solid No
Surface No
Z value Yes
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ESRI SHAPEFILE (SHP)

The Esri Shapefile is a geospatial vector data format for geographic information systems software. It is developed
and regulated by Esri as a mostly open specification for data interoperability among Esri and other software
products. A Shapefile is a digital vector storage format for storing geometric location and associated attribute
information. This format lacks the capacity to store topological information

A single logical Shapefile consists of three physical files, each with one of the following file name extensions:
*shp: Geometric data

*shx: Index to the geometric data

*.dbf : Attributes for the geometric data

These extensions are added to the base name of the Shapefile, creating separate physical files that must all reside
in the same directory. You must select the *.shp file for import. Point, multipoint, polyline, and polygon geometric
data can be stored in *.shp files. However, a single *.shp file can contain only one type of geometry. Each entity in

a *.shp file has a corresponding entry in the *.shx index file and a corresponding row of attributes in the associated
*.dbf file. The order of the entries in each of these files is synchronized. For example, the 3rd geometric entity in the
*shp file is pointed to by the 3rd entry in the *.shx index file and has the attributes held in the 3rd row of the *.dbf.

A single Shapefile may also consist of a number of additional files, with the following file name extensions:

*sbn /*.sbx: Spatial index files for the geometric data. These two files are only generating by an Esri product
however they are not required by MAPublisher for import and will they be generated when exporting data to the
Shapefile format..

*prj: Spatial coordinate system information.

If a *.prj file exists in your Shapefile directory, holding the coordinate system information of the Shapefile, this will
automatically be read by MAPublisher on import. If your Shapefile folder does not contain a .prj file you will be
required to specify the coordinate system in order to fully utilize MAPublisher.

Supported Elements Supported Geometry
Typical File Extensions *shp (*.shx, *.dbf, *.prj) Aggregate Yes
Automated Translation Yes Circles No
User-Defined Attributes Yes Circular Arc No
Coordinate System Support Yes (if have *.prj) Elliptical Arc No
Generic Colour Support No Ellipses No
3D Support Yes Polygon Yes
Schema Required Yes Donut Polygon Yes
Transaction Support No Point Yes
Geometry Type Attribute SHAPE_GEOMETRY Line Yes
Text No
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GEOGRAPHY MARKUP LANGUAGE - SIMPLE FEATURES (GML)

GML was designed as a geographic interface language for the Geo-Web. It is currently in draft as an ISO standard
(ISO 19136). The goal of the format is to provide users with a set of abstract base objects that can be built into
working real world datasets. It uses as XML base to store geometry and feature information that can easily be
transported across the Internet.

The GML simple feature profile was created by the Open Geospatial Consortium as a restricted subset of the GML
specification. It provides a reduced geometry and metadata profile that can be shared across many GIS tasks. This
simple feature model can be used as a base to generate local application profiles for a specific work area. Since the
GML models base abstract classes, these application profiles (schemas) are required for accessing and processing
any GML datasets. Generally, GML data has a *.gml extension, and requires any application specific schema files
(*xsd). For more information on GML, and the GML simple features profile, please visit the Open Geospatial
Consortium web site: www.opengeospatial.com

Supported Elements Supported Geometry
Typical File Extensions *.gml (*xml) *.xsd Aggregate Yes
Automated Translation Varies Circles No
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support Yes Elliptical Arc No
Generic Colour Support No Ellipses No
3D Support Yes Polygon Yes
Schema Required Yes (*.xsd) Donut Polygon Yes
Transaction Support No Point Yes
Geometry Type Attribute xml_type Line Yes
Text No

GOOGLE EARTH (KML, KMZ)

KML is an XML-based language for managing the display of three-dimensional geospatial data in the programs
Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies a set of features for display. Each
feature always has a longitude and a latitude and can have other data, such as tilt, heading, and altitude. KML shares
some of the same structural grammar as GML. KML files are very often distributed as KMZ files, which are zipped
KML files with a .kmz extension. MAPublisher uses KML version 2.2 specifications for import and export.

Supported Elements Supported Geometry
Typical File Extensions *kml, *.kmz Aggregate Yes
Automated Translation Yes Circles No
User-Defined Attributes Yes Circular Arc No
Coordinate System Support Yes Elliptical Arc No
Generic Colour Support Yes Ellipses No
Spatial Index Never Polygon Yes
Schema Required No Donut Polygon Yes
3D Support Yes Point Yes
Line Yes
Text No

Prior to the import process, additional Settings can be made, which will affect how the selected KML file will import.
The following parameters can be applied to the import:

« Allow Random Colour Mode - This option allows Adobe lllustrator to generate random colour settings for the data.
- Expand Network Links - Checking this box will enable the use of network linked KML files.
«  Import KML Properties as Visible - Check this option to make KML properties visible attributes (hidden by default).
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MAPINFO INTERCHANGE FORMAT (MIF)

MIF is a published ASCII storage format used by the Maplnfo. It is used as a file format for map and database
exporting/importing in Maplnfo software products. The Maplinfo Reference Manual describes the MIF format and all
constants it uses for colour, style, symbol, and fill patterns. MaplInfo Interchange Format Files are often called MIF or
MIF/MID files.

A single logical MIF file consists of two physical files, having the following file name extensions:
*mif : Geometric data
*.mid : Attributes for the geometric data

These extensions are added to the base name of the MIF file, creating separate physical files that must all reside in
the same directory. You must select the *.mif file for import.

Each entity in a *.mif file has a row of attributes stored in an associated *.mid file. A single .mif file contains many
different types of geometry however, the associated attribute in the *.mid file must have the same number and
type of fields for each entity in the *.mif file. The order of the entries in the two files is synchronized. For example,
the second geometric entity in the *.mif file has the attributes held in the second row of the *.mid file. The number
and type of attributes associated with each entity is specified by the user. There must be at least one attribute field
in the *.mid file.

Supported Elements Supported Geometry
Typical File Extensions *mif (*.mid) Aggregate Yes
Automated Translation Yes Circles Yes
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support Yes Elliptical Arc Yes
Generic Colour Support Yes Ellipses Yes
Spatial Index Never Polygon Yes
Schema Required Yes Donut Polygon Yes
Geometry Type Attribute mif_type Point Yes
Line Yes
Text Yes

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The
following parameters can be applied to the import:

- Import as Visible Attributes - Enable this option to view the pen and brush pattern values in the imported attribute
table.

The MAPublisher MID/MIF importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded
rectangle, region (polygon), and text geometric data in *.mif files. Each geometric entity present in a *.mif file has
display properties such as pen and brush width, pattern, and colour. Supported MID/MIF properties are as follows:

MAPublisher supports the import of line weights (0-7), colours (24 bit RGB), strokes (1-71). It also supports fonts
(family, style, justification) for text. In order to use line patterns and fill patterns you must have opened or accessed
the style library equivalents. Two library files have been created, MIF - Line Styles.ai and MIF - Area Styles.ai, which
provide support for many of the standard MaplInfo pen styles (stroke patterns) and brush styles (fill patterns). These
files can be found in the Helpful Styles & Symbols folder installed with MAPublisher. Please refer to your Adobe
lllustrator User Guide for details about how to add these libraries to your Adobe lllustrator Graphic Style panel.
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MAPINFO TABLE (TAB)

TAB is a proprietary geospatial vector data format for geographic information systems software used by MaplInfo
mapping products. A minimum of two files are required for the tab format. The .DAT file which stores the attribute
data and the .TAB ASClI file which is the link between all other files and holds information about the type of data
file. The Maplinfo TAB importer is closely patterned after the Maplnfo MIF/MID reader and writer. This commonality
makes it easy to support both MIF and Maplnfo native formats in the same mapping file.

A single logical TAB file consists of a number of physical files, having the following file name extensions:

*tab: The main file for a Maplnfo table, it is associated with the appropriate dat, map, id and ind files.
*dat: Tabular data for a table in MaplInfo native format

*id: An index to a Maplnfo graphical objects (MAP) file.

*map : Contains geographic information describing map objects

*ind: An index to a MaplInfo tabular (DAT) file

These extensions are added to the base name of the TAB file, creating separate physical files that must all reside in
the same directory. You must select the *.tab file for import.

Supported Elements Supported Geometry
Typical File Extensions *tab (*.dat, *.id, *.map, *.ind)  Aggregate Yes
Automated Translation Yes Circles Yes
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support Yes Elliptical Arc Yes
Generic Colour Support Yes Ellipses Yes
Spatial Index Always Polygon Yes
Schema Required Yes Donut Polygon Yes
Geometry Type Attribute mapinfo_type Point Yes
Line Yes
Text Yes

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The
following parameters can be applied to the import:

- Import as Visible Attributes - Enable this option to view the pen and brush pattern values in the imported attribute
table

The MAPublisher TAB importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded
rectangle, region (polygon), and text geometric data in .tab files. Each geometric entity present in a *.tab file
has display properties such as pen and brush width, pattern, and colour. Supported TAB properties match those
described for MID MIF files on the previous page.

Raster TAB files cannot be imported in MAPublisher.
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MICROSTATION DESIGN (DGN)

DGN are the native files created for Bentley Systems Inc. MicroStation product. These files consist of a header,
followed by a series of elements. The header contains global information including the transformation equation
from design units to user coordinates, as well as the dimension of the elements in the file. Each element contains
standard display information, such as its colour, level, class, and style, as well as a number of attributes specific to
its element type. For example, a text element has fields for font, size, and the text string in addition to the standard
display attributes.

Supported Elements Supported Geometry
Typical File Extensions *.dgn Aggregate No
Automated Translation Yes Circles Yes
User-Defined Attributes Yes Circular Arc Yes
Coordinate System Support No Elliptical Arc Yes
Generic Colour Support Yes Ellipses Yes
Spatial Index Never Polygon Yes
Schema Required Yes Donut Polygon Yes
Geometry Type Attribute igds_type Point Yes
3D Support Yes Line Yes
Text Yes

Supported Versions
Windows: V7, V8. Mac OS X:V7,V8

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The
following parameters can be applied to the import. Note: versions V7 and V8 are supported for import, attached raster
files are ignored.

« Group Elements - Choose how you want to group the elements of the file on import. If you group the elements by
level, it may result in a large number of output files. By Level is the default.

« Coordinate Units - Choose Master or UOR (Unit of Resolution) as the coordinate units. Master is the default.

« White Lines and Fills - Enabling the Import as is option will instruct MAPublisher to import the data true to the
original colour settings contained in the file. Check the Change white lines and fills to black box to import black
lines instead of the files native white lines. Check the Create black background option to incorporate a layer
containing a black background to mimic the AutoCAD environment.

« Other - Check Drop complex chains if you want each component of a complex chain to be returned as its own
feature, otherwise all elements of the complex chain will be merged into a single linear feature.

Note: Line weight in Microstation are integer number only, as such, the Microstation export will round the Adobe
Illustrator stroke width. 0 is a valid line weight in Microstation.
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INTERNATIONAL HYDROGRAPHIC OFFICE S-57 FORMAT (000)

S-57format is intended for the exchange of digital hydrographic data between national hydrographic offices and
for its distribution to manufacturers, mariners and other data users. It is used for the supply of ENC cells (Electronic

Navigational Charts) to ECDIS (Electronic Chart Display and Information System).

The format is public, developed and maintained by the IHO (International Hydrographic Office) CHRIS working
committee (Committee on Hydrographic Requirements for Information Systems). The objects spatial geometry can
be of Point, Line or Area geometry, while object descriptions are categorized in object classes, organized in specific
attributes schemas. For a full format description, please visit http://www.iho.shom.fr/PUBLICATIONS/IHO_Download.
htm#S-57 (Appendix A in particular). An online object catalog is also available on www.s-57.com

An S-57 base file has the extension *.000, while the update files have extensions like .001,.002 and so on. It can also

be accompanied by other files:

*,000: main file

*,001: update file 1

*,002: update file 2

*,00n: update file n

files.TXT and files.JPG: ancillary text and picture files indicated in attribute definition

Update files contains only the changed (new/deleted/modified) objects and are only used as a complement
of a.000 file. Only the *.000 file is required for the import into MAPublisher. The update files will be applied at

conversion, when present. However, text and image files linked to attributes will be ignored.

Supported Elements Supported Geometry
Typical File Extensions *,000 (*.001 *.002...) Aggregate
Automated Translation Yes Circles
User-Defined Attributes No Circular Arc
Coordinate System Support Yes Elliptical Arc
Generic Colour Support No Ellipses
3D Support Yes Polygon
Schema Required N/A Donut Polygon
Transaction Support No Point
Geometry Type Attribute s57_type Line

Text

Note: Most ENC producers (private and public) publish their .000 files in encrypted formats. Only non-encrypted

files can be imported in MAPublisher (from NOAA or USACE for example).
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TIGER/LINE (RT1, BW1)

Topologically Integrated Geographic Encoding and Referencing (TIGER). TIGER is the United States Census Bureau
format for its digital database of geographic features. TIGER includes both land attributes such as roads, buildings,
rivers, and lakes, as well as areas such as counties, ZIP codes, census tracts, and census blocks. Some of the
geographic areas represented in TIGER are political areas, including counties, congressional districts, school districts,
and ZIP codes. Others are statistical areas, including Metropolitan Statistical Areas (MSA), census tracts, census block
groups, and census block. The database contains information about these features such as their location in latitude
and longitude, the name, the type of feature, address ranges for most streets, the geographic relationship to other
features, and other related information. More information on the TIGER/Line file format and data product can be
found on the U.S. Census web page at: http://www.census.gov/geo/www/tiger/

This web site contains a detailed description of the current TIGER/Line format, with an explanation of field meaning
for each feature type. A detailed description of the TIGER/Line 1998 format, with an explanation of field meaning for
each feature type, is available at: http://www.census.gov/geo/www/tiger/tiger98.pdf

Supported Elements Supported Geometry
Typical File Extensions *rt1, *bw1 Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes Yes Circular Arc No
Coordinate System Support Yes Elliptical Arc No
Generic Colour Support Yes Ellipses No
Spatial Index Never Polygon Yes
Schema Required Yes Donut Polygon Yes
Transaction Support No Point Yes
Geometry Type Attribute tiger_type Line Yes
Text No

Supported Versions: 1992, 1995, 1997, 1998, 1999, 2000, 2002

USGS SDTS (*CATD.DDF)

SDTS is the USGS robust way of transferring Earth-referenced spatial data between dissimilar computer systems with
the potential for no information loss. It is a transfer standard that embraces the philosophy of self-contained transfers,
i.e. spatial data, attribute, georeferencing, data quality report, data dictionary, and other supporting metadata all
included in the transfer. More info can be found at http://mcmcweb.er.usgs.gov/sdts/. Files in the SDTS format will
have the extension *.ddf. More information on this format can be found at: http.//mcmcweb.er.usgs.gov/sdts/

A group of *.ddf files is normally identified by the catalog file, or *CATD.DDF file, which relates the files of a single
SDTS transfer, and binds together all the files with a common prefix. Always select the SDTS file which ends in CATD,
i.e. HPO1CATD.DDF.

Supported Elements Supported Geometry
Typical File Extensions *ddf Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes No Circular Arc No
Coordinate System Support Yes Elliptical Arc No
Generic Colour Support No Ellipses No
Spatial Index Yes Polygon Yes
Schema Required N/A Donut Polygon Yes
Transaction Support No Point Yes
Geometry Type Attribute sdts_type Line Yes
Text No
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DIGITAL LINE GRAPH (DLG) (OPT)

DLG is a fixed field record that may or may not have end of line markers. The DLG file structure was designed to
accommodate all categories of spatial data represented on a conventional line map. DLG is a published ASCII format
developed by the United States Geological Survey (USGS) Federal Agency and is intended to assist in data exchange
with the National Digital Cartographic Data Base (NDCDB).

The DLG reader supports all three distinct types of DLG data:
« Large-scale DLG data (1:24,000-scale)
« Intermediate-scale DLG (1:100,000-scale)
+ Small-scale DLG data (1:2,000,000-scale)

The three scales of DLG data are physically formatted into files in one of these ways: standard, optional, and graphics
formats. MAPublisher supports both the standard and the optional DLG distribution formats; however the graphics
format is not supported. Most DLG data is distributed in the optional format. The DLG file structure was designed to
accommodate all categories of spatial data represented on a conventional line map. Node, line, and area data types
are present within the DLG format, along with linkages and attribute codes. Linkages are references to other features
within the same DLG data set, used in a variety of contexts. DLG files do not explicitly store attribute values but use a
feature coding approach in which unique feature codes are assigned to the different types of features stored within
the data set. MAPublisher will look for the extension .dlg or .opt for the input DLG files.

Supported Elements Supported Geometry
Typical File Extensions *.dlg, *.opt Aggregate No
Automated Translation Yes Circles No
User-Defined Attributes No Circular Arc No
Coordinate System Support Yes Elliptical Arc No
Generic Colour Support No Ellipses No
Spatial Index Never Polygon Yes
Schema Required No Donut Polygon Yes
Geometry Type Attribute dlg_type Point Yes
Line Yes
Text No

A1/12



MAPublisher Unicode Support

This section contains information regarding Unicode character encoding in MAPublisher. MAPublisher supports
Unicode character encoding in MAP Views, MAP Attributes, MAP Themes, and MAP Selections. MAPublisher can also
reference Adobe lllustrator layers, graphic styles and character styles using Unicode encoding.

To use Unicode character encoding you require a Unicode compliant font. Mac OS X users will have Unicode
compliant fonts installed with OS X. Windows users will require Unicode compliant fonts to render Unicode. For
more information on Unicode visit http://www.unicode.org.

The following tables display Unicode—UTF8 support in MAPublisher, for GIS data formats that are Unicode—UTF8
compliant. Unicode support for importing and exporting data is different, so for each platform two tables have
been created. For each data format there are four areas where Unicode character encoding can be used:

1. File Directory - when Unicode encoding is used in the path to where the file is located.

2. Filename - when Unicode encoding is used in the filename.

3. Attribute column name - when Unicode encoding is used in a column name for attributes.
4. Attribute value - when an attribute value contains Unicode encoding.

Windows Unicode Support (Import) Windows Unicode Support (Export)

o Attribute . . Attribute q
Data Format A it Filename Column Qugibuts Data Format . s Filename Column gugbuts
Directory Value Directory Value
Name Name
Delimited Delimited
o v \/ v \/ - \/ \/ \/ ‘/
FORMAT HAS NO FORMAT HAS NO
CADDVG v v ATTRIBUTES SADDVG v 4 ATTRIBUTES
FORMAT HAS NO FORMAT HAS NO
CADDXE v v ATTRIBUTES CADDXE v 4 ATTRIBUTES
Esri Arcinfo FORMAT HAS NO Esri Inter-
Generate \/ \/ ATTRIBUTES change File \/ \/ \/ \/
Esri ArcSDE Esri Arcinfo FORMAT HAS NO
Geodatabase \/ \/ \/ \/ Generate \/ \/ ATTRIBUTES
Esri File Esri
Geodatabase \/ \/ \/ \/ Shapefile \/ \/ ‘/ \/
Esri Inter- GML (Simple
change File \/ \/ \/ \/ Features) ‘/ \/ \/ \/
Esri Personal Maplnfo
Geodatabase v v 4 4 MIF/MID v 4 X 4
Esri
Maplinfo TA
e . v v v v apinfo TAB v v §% v
GML (Simple MicroStation FORMAT HAS NO
) v v v v Design X X ATTRIBUTES
Maplnfo KML
MIF/MID 4 4 X 4 v v v v
Maplnfo TAB \/ \/ X \/
MicroStation X X FORMAT HAS NO
Design ATTRIBUTES
KML/KMZ v v v v
FORMAT USES SIMPLE
=7 \/ \/ ASCII TEXT FOR ATTRIBUTE
NAMES AND MOST VALUES
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Mac OS X Unicode Support (Import)

File File- Attribute | Attribute
Data Format A Column Value
Directory name
Name
Delimited Text \/ \/ \/ \/
FORMAT HAS NO
CAnDRG v v ATTRIBUTES
FORMAT HAS NO
@ v v ATTRIBUTES
Esri ArcInfo FORMAT HAS NO
Generate \/ / ATTRIBUTES
e AeSDE NOT SUPPORTED ON MAC OS X
Geodatabase
G NOT SUPPORTED ON MAC 05 X
Geodatabase
Esri Inter-
change File \/ \/ \/ \/

Esri Personal
Geodatabase

NOT SUPPORTED ON MAC OS X

Esri Shapefile

v

v

v v
GML (Simple
Features) \/ \/ \/ \/
Maplinfo
MID/MIF \/ \/ X \/
Maplinfo TAB \/ / X /
MicroStation FORMAT HAS NO
Design X X ATTRIBUTES
KML/KMZ \/ \/ \/ \/
FORMAT USES SIMPLE
S57 \/ \/ ASCII TEXT FOR ATTRIBUTE

NAMES AND MOST
VALUES
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Mac OS X Unicode Support (Export)

File File- Attribute | Attribute
Data Format A Column Value
Directory name
Name
Delimited Text \/ \/ \/ \/
FORMAT HAS NO
CADDWE ATTRIBUTES
FORMAT HAS NO
CADDXE ATTRIBUTES
Esri Inter-
change File \/ \/
Esri Arcinfo FORMAT HAS NO
Generate ATTRIBUTES

Esri Shapefile

v | Vv

NEINA RSN AAE

AN R N NN NN I NE ANV

v v
ik x | v
Maplnfo TAB X \/
MicroStation FORMAT HAS NO
Design ATTRIBUTES
KML \/ \/




Windows Unicode Support
(Working with Images)

Data Format File Directory Filename File Directory Filename
(Register Image) (Register Image) (Export Image) (Export Image)

World File (.tfw) viv' N vV vk
Image Report (.irp) \/*/ \/‘ \/*/ \/’ ‘/*/ X. \/*/ X’
MapinfoTaB(tab) | v /v | vV | vTIx® vVx!
ListGeo (.Igo) \/*/ v \/*/ v \/*/ x* \/*/ v
GeoTIFF (.tif) v vt ars V!

Mac OS X Unicode Support

(Working with Images)

DACRESTIT File.Directory Fi-Iename File Directory Filename
(Register Image) (Register Image) (Export Image) (Export Image)
World File (.tfw) v'° v'° v'° Ve
Image Report (.irp) \/G \/G \/Q \/O
Maplnfo TAB (.tab) Ve Ve v Ve
ListGeo (.Igo) ‘/o ‘/o \/G \/O
GeoTIFF (.tif) Ve v Ve Ve

°Limited support
(not all combinations of Unicode
characters are supported)
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Technical Support Options / FAQ

MAPublisher support is provided free of charge to customers with a current MAPublisher Maintenance Program
(MMP) subscription. All new license and upgrade purchases include a one year MMP subscription. Customers
without a current MMP subscription may obtain support from a qualified MAPublisher technical specialist at the
rate of US$49 per incident.

TECHNICAL SUPPORT

Please consult the FAQs, the additional how-to's on the following pages as well as the following online options
before contacting Avenza technical support as your situation may be easily addressed by one of the answers
contained therein.

MAPublisher Online Resources

The Avenza Systems Inc. Website provides additional source of information to assist you in the use of MAPublisher.
The Avenza Resources are located at http://www.avenza.com/resources

- Avenza Resources Blog: tips, how-tos and news on MAPublisher and Geographic Imager software.

- Map Gallery: examples of maps created with MAPublisher.

- Styles and Symbols: a collection of styles and symbols to help make your maps look better.

«  User Forums and Frequently Asked Questions: answers to common technical questions may be
found in the Common Support Issues and FAQs category. All users with a MAPublisher license (evaluation or
permanent) can post and read topics under the General Questions for Evaluation and Licensed Users category.
Additionally, users with maintenance have access to the Maintenance Users category. There, users can find
additional information relative to software updates, etc.

« MAP Web Author APl and CSS: find advanced information on MAP Web Author API functions and CSS

support - see chapter 15 for more details.

Contacting Avenza Technical Support

Avenza offers a number of methods for direct communication with our qualified and experienced technical experts.
Please have your MAPublisher registration details handy to get prompt attention and include it in any email
correspondence. Support issues are handled on a first come, first-served basis. For non-maintenance users, Avenza
does not guarantee a response within any specified time. MAPublisher Maintenance Program subscribers receive
free and unlimited support. All others are eligible for support at the rate of US$49 per incident.

+  Hours: 9:00am to 4:00pm Eastern Standard Time

+  Email: support@avenza.com

«  Online request form: http://www.avenza.com/support/form
. Phone: +1 (416) 487-6442
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MAPUBLISHER MAINTENANCE PROGRAM (MMP)

The MAPublisher Maintenance Program is a subscription-based service plan that guarantees its members:
« unlimited priority technical support—guaranteed same business day or next business day response
« unlimited telephone support
«  free MAPublisher updates
«  free MAPublisher version upgrades
«  additional discounts and offers available to MMP members only

Your MAPublisher purchase includes a one-year membership in the MAPublisher Maintenance Program so you are
well on the way to worry-free use of MAPublisher for the first year and will be able to enjoy all the benefits of the
MMP immediately. All MAPublisher Maintenance Program subscriptions begin on the date of purchase and run for
one calendar year.

Your email address has been automatically entered in the mp-maintenance-l online email list for MMP subscribers
so that you are assured of receiving all the latest MMP news and access to all the update and upgrade files. If you
purchased your MAPublisher license from a reseller or are the end user but not the person who purchased the
software, please contact us at sales@avenza.com to ensure that we receive your email address and add you to the
MMP notification group.

Renewal

You will be notified regarding renewal options approximately six to eight weeks prior to the expiration of your
annual MMP subscription. You will be contacted a minimum of five times prior to expiration in order to ensure that
you have ample opportunity to renew or not at your discretion. You will have the option of renewing your MMP for
an additional year at the then prevailing price or canceling without penalty. Of course, if you cancel or let your MMP
lapse you will no longer be entitled to the benefits of the program as outlined above and will thus have to purchase
future upgrades at the upgrade price.

There is a grace period of approximately 30 days from the time of the MMP expiry during which you may still renew
without penalty. All post-expiration renewals will be backdated to the actual expiry date.

Lapsed Subscriptions

Failure to renew your MMP within 30 days from the expiry date will result in a lapsed MMP subscription. Lapsed
subscriptions may not be renewed and the licensee will be required to purchase support and upgrades accordingly.

Please direct all MMP questions and purchase inquiries to info@avenza.com.

WISHLIST

As either a new or experienced MAPublisher user we value your opinions on how we can improve our product.
Please let us know what functions you would like to see incorporated into future upgrades of MAPublisher.
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Memory Considerations

RAM RECOMMENDATIONS

Occasional User: 4 GB of RAM is recommended.
A graphics or GIS user who uses MAPublisher with medium sized data sets with up to 20 layers, minimal text labels,
and some low-resolution or small coverage raster images.

Power User: 8 GB or more of RAM is recommended.

A professional cartographer who uses MAPublisher daily and works with large urban data sets (including large
transportation layers) with 20 or more layers, raster based air photographs, large numbers of text labels, complex fill
patterns, etc.

RAM USAGE HINTS

Users often ask us why is so much RAM needed to operate MAPublisher. First of all, Adobe lllustrator requires a
significant amount of RAM itself in order to run smoothly. Secondly, map data sets are often large which increases
the need for RAM even further. Map data sets contain both vector and attribute data which must be stored in
memory. Since we are adding a database to Adobe lllustrator this increases the file size, which increases the

RAM requirements. MAPublisher builds a mini-GIS application inside Adobe Illustrator so that it can geo-code
information and attach data to objects. This also has some overhead.

GIS users also often ask why so much more memory is needed with MAPublisher than is with GIS software. The
graphics environment software of Adobe Illustrator loads the entire file into memory rather than just reading it
from disk, thus more RAM memory is required.

When you are importing a large number of files into Adobe Illustrator using MAPublisher, you'll notice that the
amount of available memory will decrease rapidly and your computer loses speed. This is due to the memory
management. MAPublisher reserves a fairly large amount of memory for each import-action, which is not properly
returned when the import is done or even when it is cancelled. The solution is simple: save your file, close it and
open it again. It's not even necessary to close Adobe lllustrator itself. By closing the file, the reserved memory is
properly returned.

RAM SAVING TIPS

Since a percentage of the memory is taken for attribute storage, remove any redundant or otherwise unnecessary
attribute fields from the MAP Attributes table of a layer.

Many sources of street data include paths/vectors that are segmented based on street addressing information. You
can use the MAPublisher Join Lines function to join these into single linear features based on a selected attribute
field. Reducing the number of objects (and data records) in the map file will free up memory.

Many GIS data files are large and when a series of such files is imported, you may find that the import function

starts to run more slowly. This is because scratch and memory allocations are being used up. The best solution is to
periodically save your work, quit Adobe lllustrator and then restart. This will free up the available scratch memory.
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Reduce the minimum number of Undo commands (since they all reside in memory).
Use polylined or pre-joined linear feature data sets where available.

In your GIS application, strip out the attributes you won't be using for queries or labeling before importing the data
into Adobe Illustrator.

You can set a primary and secondary scratch disk under the Adobe lllustrator preferences option in order to draw
additional storage from a partitioned or multi-drive environment.

Turn off the layer preview icon that appears to the left of each layer name in the Adobe Illustrator layers panel.

This can be done by clicking the options menu in the layers panel and then selecting small panel rows in the panel
option dialog box.
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Online Sources

For geographic information system (GIS) users, the appeal of graphics is strong and the increasing ability to discover
and share GIS across the Internet is fascinating. The Internet offers a large number of free-access GIS-related web
sites from which you can access map and information data sets. To find some information on the source listed it, use
any internet search browser such as Google to get access to the websites.

For the general public, there’s general information about countries, states, and places; simple maps of areas (e.g.,
GIF, PS format); lists and maps of Internet resources in an area. For cartographers and geography researchers, there
are cartographic/ GIS base map files (e.g., USGS Demos, DLGs, TIGER); thematic data of a geographic nature (e.g.,
census data); and complete GIS data sets (e.g., Esri Interchange Files).

FREE MAP DATA

Many sites on the Internet offer GIS data free of charge. Data is available from these and other Internet sites in a
wide variety of formats. Please consult the sections in this manual on file formats (chapter 2) to ensure that you
download usable data. Some popular sites:

«  (AST data: Center of Advanced Spatial Technologies, University of Arkansas.

- EROS Data Center: access to USGS digital datasets.

- Data.gov: home of the US government’s open data.

«  Geocommunity and GIS Data Depot: very good source of free GIS data.

«  Geoconnections/Geoconnexions: Canada Ministry of Natural Resources site.

«  Geography Network: world-wide geographic contents.

«  Geogratis: maps offered by Natural Resources Canada.

«  Geoscience Australia: Australian National Mapping Agency.

«  National Atlas of the United States: excellent data source for the United States.

. NOAA ENC Download: free download of electronic nautical charts in S-57 format (USA).

+  RobertE. Kennedy Library @ California Polytechnic State University: US based map inventory.

. United State Geological Survey: various data formats available (DLG, GeoTIFF, etc.) from the USGS website.

«  United States Fish and Wildlife Service: variety of map data in USGS DLG format.

« USACE IENCdownload: US Army Corps of Engineers, S-57 and Esri Shapefile of US waterways.

OTHER VALUABLE GEOSPATIAL RESOURCES

In some additional places on the Internet where you can find news, reviews, tips and general GIS, cartographic and
geographic information. Some popular sites:

. Directions Magazine

+  GeoCommunity

«  GISCafe

«  GIS Dictionary

+  GISLounge

+  GIS Development
+  GlSuser

+  University of Edinburgh
«  University of Florida - Geoplan Center
. US Census Bureau
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General Tips and Hints

CREATING DELIMITED XY TEXT FILES

There may be times when you wish to add a point or a series of points to your map but you do not have a GIS or
ASClI file containing these points ready for import. Provided you have the real-world coordinates for the locations
you wish to plot*, you can manually create a delimited ASCII file using a text editor (e.g. Notepad) or a spreadsheet
program (e.g. Microsoft Excel). This file can then be imported using either Import or Multiple Data Import using the
Delimited XY Text Data format.

In a text editor, one column in the file must contain the X coordinate and another must contain the Y coordinate.
Add as many additional columns as you wish containing additional information to be imported as attribute data.

If you are using a text editor, you can simply type in your data in the following format:

“Column 1 Header”,”Column 2 Header”,”Column 3 Header”...etc
“Column 1 Value 1”,”Column 2 Value 1”,”Column 3 Value 1”...etc
“Column 1 Value 2”,”Column 2 Value 2”,”Column 3 Value 2”...etc

Note that negative values for the X and Y coordinates denote west longitude and south latitude, respectively. Also
make sure to enter a carriage return using the Enter key on your keyboard after the last line of data otherwise the
last line may be ignored by MAPublisher Import or Multiple Data Import.

In a spreadsheet application, enter your point information as a table and save the file in a text format, preferably
.csv or .txt, choosing either comma or tab delimiting. The spreadsheet application will format the text automatically.

= PointsOfinterest.csv - OpenOffice.org Calc (=] E s
Eile Edit View Insert Format Tools Data Window Help x
- a8 R ¥ Kbk - D- siEZ
A20 ] hE =]
B [ c ] D E I B =
| 1 |ID Longitude Latitude PlaceName CATEGORY I
| 2 | 2 -123.13 49.3 Vancouver Aguarium aquarium
| 3| 4 -123.11 49.29 MAX Theatre at Canada Place theatre
| 4 | 5 -12312 49.28 Vancouver Art Gallery gallery =
| 5 | B -123.15 49.28 Vancouver Museum museum
| 6 | 7 -123.11 49.29/Coastal Peoples Fine Arts Gallery gallery
| 7| 8 -1231 49.27 Science World British Columbia  |science
| 8| 9 -123.15 49 28 Vancouver Maritime Museum museum
| 9 | 10 -123.12 49.29 Tourism Information Centre information
|10 11 -123.11 49.28Inuit Art Gallery Vancouver gallery
| 11| 12 -123.11 49 28 BC Sport Hall of Fame & Museum museum
|12 |
Il
|
15 -
Sheetl 1« i vl
Sheet1/1 Default STD | [* CountA=0 ||©@— & @|[100%
&

* The MAP Location Tool can be used to generate the X and Y coordinate values suitable for building ASCII Point
Files. See chapter 4 for more information.
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JOINING SDTS TABLES

The following information should be used in conjunction with the MAPublisher Join Table function.

When working with United States Geological Survey SDTS files it is necessary to join tables frequently in order

to obtain the map attribute table you require to make the map you want. This is due to the fact that SDTS data is
constructed such that the primary vector data is held separately from the various attribute tables that one might
want to use for a particular mapping purpose. The attribute table that comes as part of the vector file usually
contains a unique identifier (RCID) for each map element that is used to join it with the other data tables. For
example, a particular vector file containing the geography of rivers would contain a data column called RCID.
Various data tables containing information such as vegetation, fish counts or flow rates might be available each also
with an RCID column. The desired tables are then joined to the initial map attribute table by RCID value using the
techniques described in the previous pages.

To find the SDTS tables to join with the vector map file look for the files which have names that start with the same
character string as the name of the vector file. MAPublisher imports SDTS files that have the characters “CATD"” at the
end of the file name. A typical table to import and join with this file might be called HY01CATD.ddf.

Use the MAPublisher table importer with SDTS file type chosen to import these files. When you join layer and table,
you do the join based on the column from the layer matched to the RCID column of the table. Note that the CATD
catalog file found amongst the SDTS files explains what each table is.

ROTATING OBJECTS INDIVIDUALLY IN ADOBE ILLUSTRATOR

On some occasions you may wish to rotate selected objects about their own centres rather than as a group about

a common origin. This can be accomplished using the Adobe lllustrator Transform Each function. To use this function,
first select the objects you wish to rotate. Then go to Object > Transform > Transform Each. In the Rotate box enter a
desired rotation value and click OK. Each of the selected objects will be rotated individually about their own centres.

You may also use the #Rotation property column to individually rotate point symbols or text items based on a
specified value. See chapter 5 for guidelines on how to use this function.

GEOREFERENCING AN ADOBE ILLUSTRATOR FILE

If you are using an existing Adobe lllustrator file that was created without the use of MAPublisher and as such does
not contain any geographic parameters or attribute data, the following steps will enable you to georeference your
Adobe lllustrator file and ultimately create an attribute-rich and accurate scale and world grid structure for your
map. Please note that the steps that follow refer to functions that are outlined in more detail in the body of this user
guide. Please familiarize yourself with the main MAPublisher functions and in particular those under the MAP Views
section (see chapter 4) before proceeding.

Before beginning to georeference an Adobe lllustrator file you must be in possession of the following information:
1. The real-world scale of your data

2. Details of the coordinate system the data is in (i.e. Projection, Datum etc)

3. The X-Y coordinates of one tie-in point in the coordinate system of your data
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To determine the real-world scale of your data, use the scale bar drawn on the map for reference (measure the
page size using the Adobe lllustrator Measure tool and divide by the scale size indicated - make sure to correct for
the measurement units). If no scale bar is available, try measuring distances in page units in Adobe lllustrator and
compare with the same distance measured in real unit with a mapping or GIS software, beware that differences in
coordinate systems may affect the distance measurements.

Determining the coordinate system of the map may be difficult. If no information is provided as meta data or in the
map legend, try to compare with other maps of the same area or with traditional coordinate systems used in the
area (e.g. US State Plane zone matching a county name in the USA).

To determine the real-world tie point, find a specific location in your document for which a real-world coordinate
location is known or can be easily determined (such as known feature or grid or graticule crossing positions).
Record the location of this point in real world coordinates on a piece of paper.

When you have this information please use the following guidelines in order to georeferencing data with
MAPublisher in Adobe lllustrator.

1. Identify the registration or tie-in point in your document for which you know the X,Y or Lat,Long coordinates.

2. Determine the page position of the same point on the Adobe lllustrator page using the Info panel (Window >
Info).

You should now have the location of your tie-in point in both map and page units (e.g. -79.5, 43.5 in Lat/Long is located

at 4cm, 2cm in the document).

3. In the MAP Views panel, choose New MAP View in the panel options menu.

4. Enter a name for the MAP View.

5. Click the Specify button in the Source Coordinate System section. Choose the coordinate system that matches that
of your vector data and click OK.

6. Set the Scale to the proper scale of the map. It is important to set the scale after the coordinate system but
before you enter the map anchors.

7. Click OKin the MAP View Editor to apply the information to the new MAP View.

In the MAP Views panel, choose Specify Anchors in the panel options menu.

9. Set the Map Anchors to the value of the tie-in location in map units using the values determined earlier
(e.g. Longitude= -79.5°, 43.5°).

10. Set the Page Anchors to the value of the tie-in location in Page Units using the values determined in step 2
(e.g. X=4cm, Y=2cm). Then click OK.

11. If you have not previously done so, ensure that each layer in your Adobe Illustrator file contains only one feature
type (Point, Area, Line, Text, Legend).

12. In the MAP Views panel drag each of the layers which contain your data in to your new MAP View, ensuring that
you set the appropriate Feature Type in the Define Layer dialog box.

13. Repeat steps 1-13 for any other coordinate systems which exist in your document (such as inset maps for
example).

14. Your document is now a georeferenced MAPublisher file wherein each feature is also georeferenced and
capable of accepting attributes using MAP Attributes (see chapter 5). You can also use the MAPublisher Export
function to create a GIS file from this newly georeferenced Adobe lllustrator map.

©
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TIPS ON EXPORTING TO OTHER GIS SOFTWARE WITH MAPUBLISHER

These strategies do not focus on how to do the procedures, as these are discussed in the Export section of the MAP
Views chapter, but more on what you need to know and understand for successful export results.

First and most importantly you need to understand that the MAPublisher export was designed to export MP
imported or created data one layer and one feature at a time. Why is it important to know this? MAPublisher only
recognizes objects that have been imported by or created with its functions. If a layer was not imported with
MAPublisher or is not hosted by a designated MAP View, then MAPublisher will not allow you to export the layer.

If you have an entire layer that was not created by MAPublisher then:

1. Ensure that your layer contains only a single feature type (Point, Area, Line or Text).

2. Inthe MAP Views panel, check that you have a designated MAP View with a matching coordinate system. If you
do not, create a new MAP Views.

3. Select the layer in the MAP Views panel.

4. Drag the layer to the MAP View containing the matching coordinate system to georeference the layer.

There are also a couple of additional considerations to be aware of when exporting:

Since the current exported vector formats are GIS formats that do not support the concept of Bezier curves you
need to compensate for this. If you have Bezier curves in your Adobe lllustrator file they will not be recognized in
the GIS software. In order for these features may be represented correctly you will need to add points to these lines
in Adobe lllustrator first. Simply identify and select any objects that use Bezier curves and then select Object > Path
> Add Anchor Points. Repeat this command until the line has a sufficient number of anchor points that the shape of
your curves will not be lost on export.

Adobe lllustrator stores the origin of text that has been applied along paths differently from other text objects. We
have found the following steps to be the most successful way to get such Text exported to GIS files:

1. Create a new Adobe lllustrator layer

Select any text that has been created along paths.

Drag this text to the new Adobe Illustrator layer

Select Type > Create Outlines. The text will be converted to vector objects.

In the MAP Views panel, drag this layer back into your MAP View, specifying Area as the feature type

You can now export your Text as Area objects. Since the text is no longer text, you can no longer modify the fonts.
We recommend that you make a copy of the original text objects before you do this process. These hints on how to
transfer Adobe lllustrator files are necessary because the graphics environment handles text and curves differently
and they need some modification in order for the GIS software to represent these accurately.

VAW

DOUGLAS-PEUCKER LINE SIMPLIFICATION

The Douglas-Peucker algorithm was primarily designed to reduce the number of points required to represent a
vector line. A common problem in digital cartography and geographic information systems can occur when lines
are generated automatically from a mathematical function, which records points at a fixed interval regardless if
they are all lying along a straight line. A reduction of the number of points makes for a cleaner and more readable
cartographic line. As well in cartographic work within Adobe lllustrator the removal of points along a path can
significantly improve the speed of file redraws and reduce the overall file size.

The Douglas-Peucker Algorithm was created in Fortran 66 by David H. Douglas and Thomas K. Peucker at the
University of Ottawa in 1970-71. It was extensively tested in 1972 and was publicly communicated in the following
article: Algorithms for the Reduction of the Number of Points Required to Represent a Digitized Line or Its Caricature,
Canadian Cartographer, Vol. 10, No. 2, December 1973.
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BEZIER CURVES AND OTHER MAPUBLISHER OPERATIONS

Bezier curves are defined using four control points. Two of these are the end points of the curve, while the other
two effectively define the gradient at the end points. These two points control the shape of the curve. The curve is
actually a blend of the control points. This is a recurring theme of approximation curves; defining a curve as a blend
of the values of several control points.

Most GIS formats do not support Bezier curves when used in graphics software such as Adobe lllustrator. Typically,
curved sections of GIS data will be composed of a series of small line segments rather than an actual curve. This is
also how features imported by MAPublisher will first appear in Adobe lllustrator. Use Adobe lllustrator Object > Path
> Simplify to convert this type of feature into a Bezier curve (see chapter 8). Furthermore, Bezier curves cannot be
simplified using the MAPublisher Simplify Lines tool.

If Bezier curves are exported from Adobe lllustrator using any of the MAPublisher Export functions they will be

converted to link and node topology (i.e. the end points of the curve will simply be joined as straight lines). It is
therefore necessary to create additional points to curves to retain their true shape. This can be done globally by
using the Adobe lIllustrator Object > Path > Add Anchor Points function.

This version of MAPublisher supports Bezier curve features during the following operations:
«  Scale and Projection transformations via the MAP View Editor
«  Areaand length calculations

CREATING SYMBOLS FOR USE IN POINT STYLESHEETS

A MAPublisher Symbol Library and a National Parks Symbol Library are supplied in the Helpful Styles & Symbols
folder. You may also find that a search on the internet may be useful for finding additional libraries. If you are
required to create new symbols, the steps below will help you to quickly create symbols manually in Adobe
lllustrator.

1. Use Adobe Illustrator Tools for the manual creation of artwork that will comprise the new symbol. If you wish to
use a character that are contained in a font library, select the text character instance and click the menu
Type > Create Outlines to convert the text to vector art.

2. Open the Adobe lllustrator Symbols panel (Window > Symbols).

3. Select the artwork that will comprise the new symbol and drag it into the Adobe Illustrator Symbols panel
double-click the symbol in this panel to assign a name.

4. When Edit Stylesheet Theme is accessed for Point stylesheets, this symbol will be available in the Style column.

CREATING A MAP THEMES TEMPLATE

You can create template files with legends to automate the production of a series of similar maps. The procedure

when using MAP Themes is as follows:

1. Create a prototype map using MAP Themes to create the desired look.

2. Make a copy of your prototype map file. Delete all the layers from the file so that only the designated MAP
Themes exist.

3. Saveittoanew Adobe lllustrator template file (*.ait).
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4. Use this template file as a base for future maps as follows:
a) Make a copy of the template file.
b) Import all map layers into the template file and do any needed processing.
c¢) Inthe MAP Themes panel, assign your MAP Layers into the desired MAP Themes type.
d) Apply the MAP Themes and your new layers will be symbolized.

CREATING A MULTI-CONDITIONAL IF EXPRESSION

In Edit Expression it is possible to assign symbology to map objects by assigning an expression to the #Style
column. In the following example this is achieved by creating a multi-conditional IF statement.

In the following example, a point layer represents cities. Each point has the value “Y”, “N” or “C" in the CAPITAL
attribute column, describing whether the city is a state capital (Y), is not a state capital (N) or is a country capital (C).
There are three point symbols to assign to the type of point. In this example the following expressions can be
assigned to the #Style column of the point layer (both expressions have the same result):

Expression 1:

IF(CAPITAL ="Y", “MAP Symbol 01, IF(CAPITAL =“C", “MAP Symbol 02, “MAP Symbol 03"))

Expression 2:

IF_CASE("MAP Symbol 01", CAPITAL="C", "MAP Symbol 02", CAPITAL="N", "MAP Symbol 03")

Therefore: If the capital is “Y”, assign the symbol “MAP Symbol 01", If the capital is “C" assign the symbol “MAP Symbol
02" All other symbols assign “MAP Symbol 03"

NOTES FOR EXPORTING IMAGES

If the document colour mode is CMYK, exporting an embedded image may result in increased file size compared to
RGB mode.

If the image is linked consider the following:

1. The image will be exported in the original colour mode of the image irrespective of the current colour mode of
the document (i.e. a linked grayscale image in a CMYK document will be exported as a grayscale image, whereas
a linked RGB image in an CMYK document will be exported as a RGB image).

2. Alinked image with Alpha channels may be exported in a different colour model. For example a grayscale with
two alphas will export as an RGB or an RGB with an alpha channel will export as CMYK.

3. Linked images in CMYK mode (regardless of the color mode of the document) will export with an incorrect
result and should therefore be avoided (see chapter 12).

If the image is embedded consider the following:

1. The image will be exported in the colour mode of document (i.e. an embedded grayscale image in a CMYK
document will be exported as a CMYK image, whereas an embedded CMYK image in an RGB document will be
exported as an RGB image).

2. Embedded grayscales do not pick up the document colour model (i.e. an embedded grayscale image will be
exported as grayscale).

3. The export of embedded Bitmap images is not supported.
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Appendix 2: Coordinate Systems
Overview

In the MAPublisher application, the coordinate system option must be entered at two levels: coordinate system of
the source data (when importing GIS data) and coordinate system of the final map.

SOURCE DATA COORDINATE SYSTEM

The Source coordinate system is usually detected when the coordinate system information is available with the
GIS data being imported and when supported in the native GIS format (such as Shapefile , e00). However, in some
cases, this information is not imported because it is not supported in the original GIS format (e.g. DWG, DXF) or
when using a non-referenced Adobe lllustrator files. In that case, the coordinate system must be specified by the
user. It generally can be found from an attached metadata document, by contacting the data provider or in textual
information on the original data itself (e.g. title or legend of a scanned map).

In all cases, the source coordinate system must be known with certainty. Then only can the proper parameter
be specified in the MAPublisher interface. A wrongly specified source coordinate system would make the map data
unusable for transformations and merging with other datasets.

FINAL MAP COORDINATE SYSTEM

Most of cartographic projects are restricted in the choice of coordinate system for the final map. This parameter

is usually part of the project requirement. It is the task of the professional cartographer to analyze carefully the
situation to make the wise decision. For general purpose mapping projects (interpretive or marketing maps for
example), a more approximative selection of the coordinate systems might be acceptable. Following the request
from some of our users, who may not have a cartographic expertise, here are a list of simple considerations to take
into account before making a choice:

- Use of a Geodetic Coordinate system (angular coordinates, Lat/Long): FDH Geadetic |
« Appropriate for overlay with GPS data recorded in Lat/Long format. bilie
- WGS84 system is required to export vector data to KML format (for display it
in Google Earth, Google Maps). it
Arctic
- Use of a Projected coordinate system: el
« Appropriate for printed map (so that users can use a ruler to measure SiE e S i
distances on the map). Canada
« Required to add a scale bar. E:pfu;:gm Systems L
« Use of a particular system (within the list of projected and geodetic systems): i
- Maps that are part of a portfolio or Atlas have to comply to the same 5 Urted States
system to be consistent. b
- When a geo-referenced image (geotiff or world tiff) is to be used together oSt
with the data, it is easier to use the same coordinate system for the vector il
data as of the raster. Hinesota
« Most countries or geographic areas have published standards or usual e
way for representing the land (e.g. for road maps or meteorological maps). e el
In this case, the user should make some test with the systems listed in s -

MAPublisher. For a convenient use, coordinate systems are sorted by
continent>country>sub-division (state or county for example).
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In doubt, it is recommended to test different coordinate systems and visualize the results.

For more information on the supported coordinate systems and projections in MAPublisher, please refer to the
Avenza Projections Guide installed with MAPublisher.

Examples of appearance of the USA depending of the chosen coordinate system

Geodetic > World > WGS84 (unprojected)

] - 4 108 0 e 0 2 45

E

Projected > North America > United States > US National Atlas

% B R R E) £l .

I )
/
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The Geodetic Datasource

MAPublisher includes an extensive geodetic parameter database called the Geodetic Datasource. It contains all the
latest updates from the widely used EPSG Geodetic Parameter Dataset maintained by the Geodesy Subcommittee
of OGP (International Association of Oil and Gas producers) as well as custom systems maintained by Avenza.

In addition, the MAPublisher Geodetic Datasource supports user's custom definitions and allows for importing
external WKT (Well-Know Text) and PRJ (Esri projection file) parameter files.

Over 3500 pre-defined coordinates systems are readily available for use in most cartographic projects. Even though
the current list of systems is comprehensive, there may be instances where the end users may wish to add a brand
new coordinate system to meet their particular needs, or perhaps to duplicate and modify an existing definition to
change the units for example. A complementary Avenza Projections Guide is installed with MAPublisher. It describes
all the projections and datum shifts methods supported by MAPublisher, to assist users in the process of creating or
editing a coordinate system.

The default parameters installed with MAPublisher are stored within read-only XML database files referred to
as the Geodetic Datasource (files named geodata.xml and avenza.xsp). The base datasource files shipped with
MAPublisher are installed in the Data Source Files folder at the following location:

Windows: C:\Program Files\Avenza\MAPublisher 9\Data Source Files
Mac OS X: /Applications/Avenza/MAPublisher 9.5/MAPublisher Plug-In/Data Source Files

Custom definitions and parameters are saved or loaded from separate XML files that must always accompanied
with a file named geocalc.xsd (when not present, this file can be copied from the Data Source Files folder).

The custom and read-only entries are organized into categories and sub-folders — users may create new folders,
move entries or create short-cuts. That folder structure is saved in a view file (* xvw).

When MAPublisher is uninstalled or a newer release is installed, an option will be given to backup the custom
coordinates systems and view file (Windows only). The backup files can be found:

Windows 7/8: C:\ProgramData\Avenza\MAPublisher 9
Mac OS X:/Applications/Avenza/MAPublisher 9.5/Data Source Backup

LOAD CUSTOM COORDINATE SYSTEMS

A geodetic datasource or coordinate system database can be loaded into MAPublisher, greatly extending the
coordinate systems available for use. To load a geodetic database within MAPublisher, choose Load Custom Coordinate
Systems from the MAP Views panel options menu.

The directory containing the XML file must also contain the file geocalc.xsd. This file can be found in the directory

of the default geodata.xml file (see above). So the custom XML file can either be copied to the Data Source File

directory prior to loading, or geocalc.xsd should be copied from there to the custom XML directory.

Any additional change will be saved into the loaded xml file.
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Note: Coordinate systems may also be extracted from the input data formats (during import process).

EDIT CUSTOM COORDINATE SYSTEMS

MAPublisher includes an extensive geodetic parameter database. The contents of the Geodetic Datasource can be

browsed or

searched by using a search frame. Users can extend MAPublisher Geodetic Datasource to support an

unlimited number of custom linear and angular units, ellipsoids, datums, datum shifts, and coordinate systems.

MAPublisher Custom Coordinate Systems Editor is accessed from the MAP Views panel options menu Edit Custom
Coordinate Systems. Coordinate systems may also be edited/created from the Specify Destination Coordinate System
dialog box (opened using the Specify button in MAP Views panel and import dialog boxes), but the other geodetic
objects are only accessible through Edit Custom Coordinate Systems.

Individual entries in the geodetic data source are known as Data Source Objects. There are different types of objects
for different types of definition. Objects contained in the geodetic data source are:
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*All*: used to define the orientation of axes used and the type of units used in the system.
Angular Units: type of units for measuring rotation.

Coordinate Systems: a complete definition needed to express the context of a set of map data.
Datum Transformations: parameters to transform coordinates from one datum to another.

Ellipsoids: an ellipsoid gives a horizontal datum its size and shape. An ellipsoid does not have an origin
and cannot be used as a base model for coordinates on its own.

Envelopes: defines a geographic area of use for a particular object.

Horizontal Datums: more commonly referred to as just "datum" is the base model maps are built
on. All coordinate systems must have a datum associated with them to be related to any other map.
Without a known datum, coordinates are meaningless.

Linear Units: units for measuring straight line, Cartesian distances.

Prime Meridians: defines longitude values of meridians.



You can define new coordinate systems, make copy and modify existing objects. The custom objects are stored
in a separate xml file saved by the user. Users can also re-organize the Geodetic Datasource (default and custom
parameters) into categories and sub-folders. These changes are saved to a view file (.xvw). The view file may be
deleted to reset the Edit Custom Coordinate Systems dialog box to its default state.

3 Edit Custom Coordinate Systems n
Datasource - File contains the Datasource:  CiProgram 9.4\Data Source i
default geodetic parameter Custom Data: ~ C:\ProgramD. 0.4 1
(geodata.xml). Folder @ o DisplayName  Name Units per Degree  Abbrev  EPSGCode  ~| [ save
3 . b oA | ArcMinute ArcMinute 60 ArcMin” 5103 o~ Save/SaveAs - Save
Custom Data - File contains: > Angular Units L " ArcSecond ‘ArcSecond 3600 ArcSec 9104 S0 changes to a custom
custom eodetic > Coordinate Systems 4 Centesimal Min... Centesimal Min... 111.11111111111 9112
X 9 * Datum Transformations Y Centesimal Sec... CentesimalSec.. 1111111111111 9113 file (data to XML and
parameters. It is loaded or > Ellipsoids Y Degree Degree 1 deg 9122 view to XVW).
saved by the user. > Envelopes L Degree Degree 1 deg 9102
* Horizontal Datums 4 Gon Gon RBANRARARERERY 9106
» Linear Units \ Grad Grad LA grads 92105
Data Source Object Folders - See ———-| © PrimeMeidians L Microradian Microradian 17453.292519943 9109
I. . Y Mil_6400 Mil_6400 VTTITIITTIS 9114
ist on previous page L Minute Minute 37746707849 minute v
Add/Remove - Add and —+= |+| @ ML PR Nl I - Edit Object Buttons
remove folders and L e Add, remove, edit,
N Sear . N
categories. information or copy
Folder: Angular Units N
Search - Search for ——- objects.
Find: in | Name v @

geodetic objects. Search
in categories such as EPSG
Code, Envelope, Source
Datum, Class Type, etc.

At the top of the Edit Custom Coordinate Systems dialog box, two directory paths are listed: the geodetic data source
path and the custom data path.

Note: The geodetic data source file is protected (read-only). Any additions or modifications to coordinate systems
are stored in a separate XML file called customsystems.xml.

On the left-hand side of the dialog box is the data source object folders. To expand a folder to see its subfolders,
click the plus sign (Windows) or arrow (Mac) to the left of the category name. To see the entries at any particular
level of category, click the category itself. When an object, folder or subfolder is selected, the data source objects
list box to the right displays the information stored within each one. User defined coordinate system objects can

be organized using drag-and-drop between folders. Columns can be resized and sorted alphabetically/numerically.
Right-click on a column header to show or hide it. Entries loaded from the main geodetic data source will be shown
in black text, while entries from the custom data file will be shown in blue.

To create a new folder, click the New Folder button. A new folder will be titled "New Folder" by default and can be
renamed. Subfolders can also be created using the same method. Only user-defined categories can be deleted
using the Delete Folder button.

Changes are saved to customsystems.xml located in:
Windows 7/8: C:\ProgramData\Avenza\MAPublisher 9
Mac OS: Applications/Avenza/MAPublisher 9.5/MAPublisher Plug-In/Data Source Files

The default XVW file (folder structure) is saved to customview.xvw, located in:

Windows 7/8: C:\ProgramData\Avenza\MAPublisher 9
Mac OS X: Applications/Avenza/MAPublisher 9.5/MAPublisher Plug-In/
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CREATE NEW DATA SOURCE OBJECTS

In the Edit Custom Coordinate Systems dialog box, click the New Object button [*] to create a new data source
object. When creating new data source objects, the identification information and definition parameters need to be
completed. Complete this information in the respective Identification and Definition tabs.

The Identification tab is used to name the object and associate identification codes with it (if applicable). It is
important to enter an appropriate name for the object. The Remarks field can be used to add notes on a definition
and is optional. The Identifiers list may be used to add identifying codes for an object that may come from other
databases. The GC code is a unique identifier assigned by Geographic Imager and should not be altered. To enter
additional codes use the space below it.

The Definition tab is used to define the parameters of an object. Each object has parameters unique to it. Refer to the
list below when creating new objects.

Note:

*All*

Refer to the Avenza Projections Guide for more information on supported projections and their parameters
as well as supported datum transformations methods.

For coordinate points, specify the coordinate point dimensions in either 2D or 3D. For Geodetic and Projected
Coordinate Points, the Longitude and Latitude style of units must be entered for all 2D Dimensional Points. The
Longitude, Latitude and Ellipsoid Height style of units must be entered for 3D Dimensional Points.

Identfication | Definiton

Abbreviation

Units Per Degree 1

Angular Units

- Cartesian Point Style Editor Ex ¢ Geodetic Point Style Editor < || e Projected Paint Style Editor B
Identficaton | Definiton Identiication | Defiition Identfiaton | Defintion

x Dimensions Dimensions
Label[x @n CE
Units| Meter - | ) Longitude East

¥ Label| Geodetic longitude Label Eastng
Label v Units|Degree @ Unis|meter @
Units| Meter © Latitude Nrth

z Label Geodetic attude Label Northing
Label[z Units|Degree @ Unis|meter @
Urits|veter (1)

ok Cancel ok Cancel ok Cancel
@ Angular Unit Editor

For angular units, enter a conversion for the new unit in terms of the scientific

T3 Angular Unit Editor

Identficaton | Defiition

Name New Angular Unit
Remarks

Tdentfers [ |-gyer Code

GC 4bAd0c-bfs6-11e3-8253-6b43468¢f18

ok Can
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standard Degrees. The Abbreviation is used to identify the unit within the
application interface (Example: The abbreviation for degrees is "deg").



3 Geodetic Coordinate System Editor
Identificaion | Definion
Envelope |World -| &
pont Style
Datum

Vertical Reference

Identification | Definition

- Projected Coordinate System Editor L ||

Envelope [Workd (1)
Point Style o | &9

Geodetic -] @

ok Cancel
- Datum Transformation Editor B
Identification | Definiton
Envelope | orld .| @
Source
Target .| &
Method | Molodensky -
Parameter Value Units
b 0
] 0
! 0 pe
ok Cancel
3 Ellipsoid Editor “
Identfication | Defiition
Semi-tajor Axis
value|0
Units &
Semi-tinor Axis
value|o
Units &
Tnverse Flattening
Value 1e+32
[ tnverse Fiattening Definitive
oK Cancel

Coordinate Systems

For Coordinate Systems, select an Envelope defining the appropriate area

of use. If you are unsure of the appropriate envelope, you can leave it set to
the default World envelope. The Point Style is how you will select the style
of linear units for your system. For most projected systems, you will want to
select "Projected point in (units)". Then select the Geodetic model that using
the appropriate datum for your system. When you select the appropriate
projection for your system, the parameters needed to define the system will
appear in the table below. Enter the needed parameters and define the units
each parameter is specified in.

Datum Transformations

For Datum Shifts, select an Envelope (appropriate geographic area of use),
Source, Target and Method. If you are unsure of a more specific envelope, leave
it set to the default "World" Envelope. The Source and Target fields are used

to specify the two geodetic models the Transformation is valid for. The Method
specifies the necessary parameters to define a particular datum transformation.
With the proper method selected, enter the appropriate parameters for

your datum transformation. Be sure to define the appropriate units for each
parameter by clicking the Units button.

Ellipsoids

For Ellipsoids you must enter the parameters for the Semi-Major Axis and Semi-
Minor Axis (often noted as "a" and "b" respectively) define the linear units the
axes are specified in by selecting a predefined unit in the appropriate fields.
The Inverse Flattening (often noted as "1/f") will automatically calculate in

the field below. Alternately, you can make the Inverse Flattening definitive by
enabling the check box at the bottom. You can then manually enter the Inverse
Flattening rather than the Semi-Minor Axis parameter.
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3 Envelope Editor
Identfication | Defiition
[] Specty Extents Points

Foint style

Minimum Point

Maximum Point

Longitude 0

Height o

Cancel

L3 Horizontal Datum Editor “
Identfication | Defiition
Elipsoid (1)
Prime Merician (1)
oK Cancel
- Linear Unit Editor < |
Identification | Defiition
Abbreviation
Urits Per Meter |1
oK Cancel
- Prime Meridian Editor “
Identification | Defiition
Longitude
Value[o
Units| .||

Cancel
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Envelopes

For Envelopes, specify the extents of the envelope (it is not required but
recommended). If the Specify Extents Points check box is checked, it is required to
enter the minimum and maximum points of the envelope and the point style the
value represent.

Horizontal Datums
For Horizontal datums you must select the Ellipsoid the datum is based on, as well

as the prime meridian used.

Linear Units

For Linear units, enter a conversion for the new unit in terms of the scientific
standard Meters. The Abbreviation is used to identify the unit within the
application interface (Example: The Abbreviation for Meters is "m")

Prime Meridians
For Prime Meridians you must enter the longitude value of the Prime Meridian

and the angular unit that value is in.



EDIT OBJECTS

To edit a custom or user-defined object, click the Edit Object button [Z]. Edits may be made in the respective object
editor dialog box. Alternatively, double-click an object to open the editor dialog box. When a data source object
belonging to the master data set is selected, the Edit Object button [#] is disabled (because these objects are read-
only). To modify an original object, create a copy of the object first then edit it.

DELETE OBJECTS

When a data source object belonging to the master data set is selected, the Delete Object button @ is disabled.
Only user-defined objects can be deleted.

COPY OBJECTS

Any object can be copied. To create a copy of an object, select an object and click the Copy Object button [&]. A
dialog box will appear with "Copy of:" preceding the object name in the Name box.

MOVE OBJECTS

Any user defined object can be moved. Drag-and-drop an object from the Data Source Objects List to a Data Source
Object Folder. A dialog box will prompt you to move the object or to create a shortcut to it.

LOAD CUSTOM COORDINATE SYSTEM DEFINITIONS

In some instances, the coordinate system of an image is not listed in the geodetic data source or the reference file
format does not support the coordinate system. In such cases, it may be useful to load custom coordinate system
definitions. In the Geographic Imager panel options menu, click Load Custom Coordinate System. MAPublisher can use
the following coordinate system file formats: WKT definitions (.wkt), MapInfo MAP files (.map), Mapinfo TAB files
(.tab) and ESRI projection files (.prj).

When a new coordinate system definition is loaded, it automatically replaces the source coordinate system of the
currently selected image. To transform the image to the loaded coordinate system, open another referenced file
and then load the coordinate system to that file. In the Transform dialog box, choose the Same As option to make
the destination coordinate system identical to the image of the loaded coordinate system.

When a coordinate system definition is loaded, it is added to the geodetic data source but not saved. If the loaded
file matches an existing definition, the original definition will be used and the loaded definition will not be added.
All new definitions are located at the top level of the appropriate category in the Coordinate Systems folder list (in
either Geodetic or Projected). Before exiting Adobe Photoshop, be sure to save your geodetic data source if you
wish to use the coordinate system definition again.
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Appendix 3: MAPublisher How-To’s For Legacy Users

Legend Functionality in MAP Themes

Users of MAPublisher 6 or earlier should consult the following pages for information on how to perform common
legacy MAPublisher tasks in MAPublisher 8.4 and newer.

BUILDING COLOUR RAMPS TO CREATE STYLES

You can enhance the look of your maps by using colour ramps, rather than random colours, for your area and line

styles. A possible use for this would be in the creation of relief maps.

Determine the number of new graduated styles you wish to create.

Create two rectangles with the Rectangle Tool aligned vertically, one at the top of the page, the other at the base.

Colour the first (top) and last (bottom) elements with two end colours for the ramp.

Choose Object > Blend > Blend Options.

Choose Specified Steps from the list. Enter the value you determined in the first step minus two. Click OK.

Select the two rectangles. Choose Object > Blend > Make. The legend elements will be blended between the two

end colours.

7. Choose Object > Expand, then choose Object > Ungroup. This ungroups the art so that the new styles can be
added to the Graphic Styles panel and be used in the MAP Themes.

S

ASSIGNING INCREMENTAL VALUES TO STYLES

It is very straightforward to assign styles to values for stylesheets based on Equal to expressions. The following
examples can be used as a basis for new stylesheets, providing the functionality which was previously available in
the Unique Occurrences option in Auto Assign Legend Info.

Example 1 (Rule 1 assigned first listed value and first style):

1. Create the first Equal to rule, using the first listed style, and an expression based on the first listed value in a
specified attribute column, i.e. Style A assigned to Column X = "Value 1”.

2. Click the Add button. The second rule will be automatically assigned an incremental expression, i.e. Style B
assigned to Column X = "Value 2.

3. Keep clicking the Add button until all the values or styles have been used.

Example 2 (Rule 1 assigned first listed value and third style):

1. Create the first Equal to rule, using the first listed style, and an expression based on the third listed value in a
specified attribute column, i.e. Style C assigned to Column X ="Value 1”.

2. Click the Add button. The second rule will be automatically assigned the first unused style, i.e. Style A assigned
to Column X = "Value 2".

3. Keep clicking the Add button. Assignments will be incremental, but will not include the third style again, i.e.
Style B assigned to Column X ="Value 3”; Style D assigned to Column X = "Value 4”; etc
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CREATING STYLE RULES BASED ON MULTIBLE ATTRIBUTE COLUMNS

Assign Legend Info previously provided options to assign legend criteria to legend elements based on values in
multiple attribute columns. This functionality can be achieved in the Edit Stylesheet Theme dialog box. Toggle to
the Advanced mode to compose advanced expressions.

The following are some examples of multi-column expressions in a world countries stylesheet (using a string type
column named CONTINENT and an integer type column named POPULATION).

CONTINENT=*Africa” AND POPULATION<1000000
Result: only African countries with populations less than one million are assigned the selected style.

CONTINENT=“Africa” OR POPULATION<1000000
Result: all African countries and all countries with populations less than one million are assigned the selected style.

CONTAINS(CONTINENT,“America” AND POPULATION>1000000
Result: only countries in North and South America with populations more than one million are assigned the selected style.

CONTINENT=*“Europe” AND POPULATION>1000000 OR CONTINENT=*Asia” AND POPULATION>10000000
Result: countries in Europe with populations more than one million and countries in Asia with populations more than ten
million are assigned the selected style.

Copy and Paste

The MAP Copy/Paste function was removed in MAPublisher version 7. You can now achieve the same functionality
via Adobe lllustrator native Copy/Paste tools.

Use Edit > Copy or Edit > Cut to copy art.

Deselect the art.

Select the destination layer in the Layers panel

Use Edit > Paste in Front or Edit > Paste in Back to paste the art into the new layer at its previous location.

N

« When pasting to layers which already contain an attribute structure, the destination layer must have an attribute
schema which matches the source layer (only attributes in common will be transferred).

« When pasting to layers which contain no attribute structure, the destination layer will be assigned the same
attribute schema as the source layer.

« The destination layer can be contained in any MAP View as required.

- The destination layer must be of a matching feature type as the source layer.

- Pasted data will always maintain its attributes. If you paste into a non-map layer, drag this layer into a MAP View,
then recreate the schema, attributes will be populated appropriately.
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Grid and Scalebar Operations

EDITING CUSTOM ART

Manually editing type (position, font, colour, etc) is not possible on Grids and Scale Bars in their default grouped
state. Manual editing is possible but objects must be first expanded (choose Object > Expand). Note that this will
negate any opportunity to subsequently edit the art using MAPublisher editing tools.

If you require a different design to be used for your Grid or Scale Bar, or wish to change any parameter without
generating a new version, simply select the Grid or Scale Bar and choose Object > Edit Grid or Scale Bar. This will
re-open the Grids and Graticules or Scale Bar dialog box with the current parameters of the object for subsequent
editing. Editing the style of text (text colour, font, alignment, etc) used in the Grid or Scale Bar can be achieved by
modifying the properties of the style in the Character Styles panel.

Use the bounding box of the generated grid or scale bar (choose View > Show Bounding Box) to resize. Resizing scale
bars horizontally will add or remove intervals from the bar(s). Resizing scale bars vertically will adjust the width of
the bar(s). Resizing grids horizontally or vertically will add or remove component cells in the grid.

EXPORTING GRIDS

To export a grid you must first expand the object (choose Object > Expand), then move it to an Area layer.
Alternatively expand your grid, move the legend layer to the [Non-MAP layers] category, then move it back into the
MAP View specifying the feature type as Area.

MISSING DATA IN GRIDS ON PROJECTED MAP VIEWS

Certain projections may cause incomplete grids and graticules to be drawn. Such issues may occur if the MAP View
is in a polar projection or the extents of the data cross the 180 degree west/east meridian.

If the generation of a grid/graticule causes blank or incomplete results, the following workflow should be used:
Reproject the MAP View to a standard Lat/Long projection (e.g. NAD27 Lat/Long, Degrees).

Generate your grid or graticules on this MAP View.

Expand the object (choose Object > Expand).

Create a new Area layer in the MAP View. Drag the expanded grid to this new layer.

Reproject the MAP View back to the original projection.

nuhwnN =
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Legacy Text Conversion
Opening legacy files, you may be prompted to update text (legacy text conversion).

Only text objects that are associated to attributes are required to be updated. For other text with no attributes, you
do not necessarily need to update.

Legacy Text Conversion

MAPublisher has detected that this document contains legacy Tllustrator text art. Tlustrator will not
recognize such text as true text art until that art is converted, and MAPublisher will not display attributes
for legacy text art.

If you decide not to convert the text at this time and instead opt to convert it manually at a later time, be

aware that Ilustrator's legacy text conversion process does NOT preserve attributes for converted text
art.

All textart - Choose this option to convert all text
. Update
to the Adobe lllustrator current version.

——*® Alltextart

MAPublisher text art only - Choose this option to
convert only the MAPublisher text (on MAP
layers)

MaPublisher text art only

——e () Nothing

Nothing - Choose this option if no conversion is
necessary
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Appendix 4: Helpful Styles and Symbols Files

The Helpful Styles & Symbols folder is found in the following locations:

Windows 7/8: C:\Users\Public\Public Documents\Avenza\MAPublisher 9.5\Helpful Styles & Symbols
Mac OS X: Applications/Avenza/MAPublisher 9.5/Helpful Styles & Symbols

Helpful Styles & Symbols > MAP Graphic Styles

This folder contains eight sets of graphic styles for areas and lines:

MAP - Area Effects.ai A set of area gradients

MAP - Area Patterns.ai A set of black and patterns for areas

MAP - Area Solid Colors.ai A set of solid colors for areas

MAP - Line Styles.ai A set of line styles

Format specific styles

DGN - Line Styles.ai A set of MicroStation DGN line styles 1-7

MIF - Area Styles.ai A set of MapInfo MIF/MID area styles 1-71
MIF - Line Styles.ai A set of MapInfo MIF/MID line styles 1-77
S57 - Line and Area Styles.ai A set of S-57 specific styles for lines and areas

Helpful Styles & Symbols > MAP Swatches
This folder contains two sets of swatches:
MAP - Color Groups and Gradients.ai A set color groups and gradient swatches

MAP - Patterns.ai A set of various swatch patterns

Helpful Styles & Symbols > MAP Symbols

This folder contains nine symbol sets of categorized symbols:

MAP - Symbols.ai A set of useful map symbols

KML - Symbols.ai A set of Google Earth symbols used with KML points
S57 - Symbols.ai A set of S-57 specific symbols

LabelPro Arrowheads.ai A set of arrowheads used with MAP LabelPro
Aeronautical Symbols.ai A set of aeronautical point symbols

Bank Symbols.ai A set of symbols from major world banks
North Arrows.ai A set of north arrow symbols

Park Symbols.ai A set of U.S. National Parks Service symbols
Subway Symbols.ai A set of symbols from major subway lines
Transit Symbols.ai A set of symbols from major transit systems
Weather Symbols.ai A set of weather-related point symbols
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Helpful Styles & Symbols > S-57 Symbolization

The S-57 Symbolization folder contains two templates with a series of MAP Theme stylesheets linking S-57
imported features to appropriate nautical symbols and graphic styles inspired from the International Hydrographic
Office S-4 publication (previously M-4) (Regulations of the IHO for international (INT) charts and charts specifications
of the IHO). Graphic styles and symbol names are mostly based on the S-57 naming conventions. The basic template
allow users to quickly apply styles to the imported data. The advanced template is more detailed to help users learn
the format and make use of the data.

Subway Symbols.ai Adobe lllustrator template with detailed MAP Themes for use with S-57 data
S57_Basic_Template.ait  Adobe lllustrator template with simplified MAP Themes for use with S-57data
US5FL12M Sample ENC file in S-57 format (chart of Tampa Bay, courtesy of NOAA®)

How to use S-57 templates:
«  Open S-57_Basic_Template.ait or S-57_Basic_Template.ait and import S-57 data.
«  Inthe MAP Themes panel, double-click a stylesheet theme to see its settings.
«  For depth sounding labels, use attribute values with the Label Features - Use sounding style option for
points labels. To round the depth values according to hydrographic standards, use the expression
provided in the Expression Library (see chapter 5 on MAP Attributes and chapter 10 on Labeling)

Note: This representation is non-exhaustive and meant to assist users with limited knowledge of the S-57 format

to interpret the data contents more easily. The created map must not be used for navigation, unless further
processing is supervised by a trained hydrographer.

More Helpful Styles & Symbols on Avenza.com

For even more styles and symbols, visit http://www.avenza.com/resources/styles-symbols.
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